WAN : Protocoles X.25

Traduction entre X.25 et TCP

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

XOT (X.25 au-dessus de TCP) est conçu par Cisco Systems, et est détaillé dans le Request For Comments (RFC) 1613, pour transporter le X.25 au-dessus des Internet IP. Ceci permet des paquets de X.25 à envoyer au-dessus d'un réseau du Transmission Control Protocol/Internet Protocol (TCP/IP) au lieu d'une procédure de Link Access, lien équilibré (de LAPB). XOT est une méthode d'envoyer des paquets de X.25 au-dessus des Internet IP par l'encapsulation du niveau de paquet de X.25 dans des paquets TCP.

Ce document présente une configuration d'échantillon qui illustre ces deux traductions :

  • Protocole TCP (Transmission Control Protocol) à la traduction de X.25.

  • X.25 à la traduction de TCP.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Cette traduction exige l'ensemble de fonctionnalités de l'édition Enterprise, qui est seulement pris en charge sur les Plateformes 26xx de routeur de Cisco et en haut.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/14216/x25_tcptrans1.gif

Comme affiché ici, des liens dos à dos sont utilisés entre les Routeurs 1 et 2 et entre les routeur 2 et 3.

Configurations

Ce document utilise les configurations suivantes :

  • Router1

  • Router2

  • Routeur3

Remarque: Nous avons tronqué les configurations suivantes pour afficher les informations pertinentes.

Router1
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname Router1
!
interface Serial0
 description DCE connection to s1 Router2
 ip address 10.0.0.6 255.255.255.252
 no ip mroute-cache
 clockrate 56000
!
ip route 192.168.7.0 255.255.255.0 10.0.0.5                                             

Router2
version 12.1
service timestamps debug datetime msec                                                  
service timestamps log datetime msec
!
hostname Router2
!
x25 routing
!
interface Loopback0
 ip address 192.168.7.1 255.255.255.0
!
interface Serial0
 description DCE connection to s1 Router3
 encapsulation x25 dce
 no ip mroute-cache
 clockrate 64000
!
interface Serial1
 description DTE connection to s0 Router1
 ip address 10.0.0.5 255.255.255.252
!
x25 route 123 interface Serial0
!
translate tcp 192.168.7.2 x25 123
translate x25 345 tcp 10.0.0.6

Routeur3
Router3#show running-config
Building configuration...
 
Current configuration:
!
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
hostname Router3
!
ip subnet-zero
!
x25 routing
!
interface Serial1
 description DTE connection to s0 Router2
 encapsulation x25
 x25 address 123
!
x25 route 345 interface Serial1                                                         

Vérifiez

Utilisez les commandes suivantes de tester que votre réseau fonctionne correctement :

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • show debug — te permet d'afficher l'un grand choix mettent au point les informations, ou d'exercer des activités spécifiques de dépannage.

  • telnet 192.168.7.2 — se connecte aux systèmes informatiques sur l'Internet en mode guidage.

  • la protection 345 — se connecte vous en fonction à une PROTECTION.

  • show x25 vc — affiche des informations au sujet des circuits virtuels commutés par active (SVC), et circuits virtuels permanents (PVCs) dans le mode d'exécution privilégié.

Le résultat présenté dans les tests ci-dessous est un résultat d'écrire ces commandes sur les périphériques affichés dans le schéma de réseau ci-dessus. Cette sortie prouve que le réseau fonctionne correctement.

Test 1 : TCP à la traduction de X.25

Dans ce test, nous exécutons une session de telnet de Router1 à l'adresse IP du Router2 :

  1. Telnet 192.168.7.2 de Router1.

    Remarque: Cette adresse appartient au réseau 192.168.7.0 /24 dans le Router2. Cette adresse ne doit pas n'être assignée à aucun autre système dans le réseau.

  2. Le Router2 fait un TCP à la traduction de X.25 afin d'atteindre Routeur3. La sortie est affichée ci-dessous.

Router2#show debug 
   TCP: 
     TCP special event debugging is on 
   X.29 PAD: 
     X25 PAD debugging is on 
   X.25: 
     X.25 special event debugging is on 
   Protocol translation: 
     Protocol Translation debugging is on 
   Router2#
 
Router1#telnet 192.168.7.2 
   Trying 192.168.7.2 ... Open 
   Trying 123...Open 
    User Access Verification 
    Password: 
   Router3>

Router2# 
   *Mar  1 01:50:28.759: TCP0: state was LISTEN -> SYNRCVD [23 -> 10.0.0.6(11007)]    
   *Mar  1 01:50:28.763: TCB00499CAC setting property TCP_TOS (11) C0094 
   *Mar  1 01:50:28.767: tcppad2: fork started 
   *Mar  1 01:50:28.767: TCP: sending SYN, seq 3338770911, ack 4026886977    
   *Mar  1 01:50:28.771: TCP2: Connection to 10.0.0.6:11007, advertising MSS 1460 
   *Mar  1 01:50:28.775: TCP2: Connection to 10.0.0.6:11007, received MSS 556, MSS is 556 
   *Mar  1 01:50:28.791: TCP2: state was SYNRCVD -> ESTAB [23 -> 10.0.0.6(11007)]    
   *Mar  1 01:50:28.803: pad_open_connection: found a valid route 
   *Mar  1 01:50:28.807: Serial0: X.25 O R1 Call (11) 8 lci 1 
   *Mar  1 01:50:28.811: From (0):  To (3): 123 
   *Mar  1 01:50:28.811: Facilities: (0) 
   *Mar  1 01:50:28.815: Call User Data (4): 0x01000000 (pad)    
   *Mar  1 01:50:28.827: Serial0: X.25 I R1 Call Confirm (5) 8 lci 1 
   *Mar  1 01:50:28.831: From (0):  To (0): 
   *Mar  1 01:50:28.835: Facilities: (0) 
   *Mar  1 01:50:28.835: PAD2: Call completed 
   *Mar  1 01:50:28.839: PAD2: Control packet received. 
   *Mar  1 01:50:28.851: PAD2: Input X29 packet type 4 (Read X.3 param) len 1 
   *Mar  1 01:50:28.855: PAD2: Output X29 packet type 0 (Parameter indication) len 45 
       1:1, 2:1, 3:2, 4:1, 5:0, 6:0, 7:4, 
       8:0, 9:0, 10:0, 11:14, 12:0, 13:0, 14:0, 15:0, 
       16:127, 17:21, 18:18, 19:0, 20:0, 21:0, 22:0, 
   *Mar  1 01:50:28.879: PAD2: Control packet received. 
   *Mar  1 01:50:28.883: PAD2: Input X29 packet type 6 (Set and Read) len 9 
       2:0, 4:1, 15:0, 7:21, 
   *Mar  1 01:50:28.887: tcppad2: Sending WILL ECHO 
   *Mar  1 01:50:28.891: PAD2: Output X29 packet type 0 (Parameter indication) len 9 
       2:0, 4:1, 15:0, 7:21,

Router2#show x25 vc
   SVC 1, State: D1, Interface: Serial0 
     Started 00:00:25, last input 00:00:22, output 00:00:22  
  Line: 2 vty 0 Location: Host: 10.0.0.6    
      connected to 123 PAD <--> X25  
  Window size input: 2, output: 2 
     Packet size input: 128, output: 128 
     PS: 5  PR: 4  ACK: 4  Remote PR: 5 RCNT: 0 RNR: no 
     P/D state timeouts: 0  timer (secs): 0 
     data bytes 57/62 packets 5/4 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0 
   Router2# 

Test 2 : X.25 à la traduction de TCP

Dans ce test, nous commençons un assembleur de paquet/session de démonteur (PROTECTION) à partir de Routeur3 à l'adresse de X.25 du Router2 :

  1. Faites une PROTECTION à 345 de Routeur3.

  2. Le Router2 fait un X.25 à la traduction de TCP afin d'atteindre Router1. La sortie est affichée ci-dessous.

Router2#show debug 
   TCP: 
     TCP special event debugging is on 
   X.29 PAD: 
     X25 PAD debugging is on 
   X.25: 
     X.25 special event debugging is on 
   Protocol translation: 
     Protocol Translation debugging is on 
   Router2# 

Router3#pad 345 
   Trying 345...Open 
   Trying 10.0.0.6 ... Open 
    User Access Verification 
    Password: CCCC 
   Router1> 
      
Router2# 
   *Mar  1 01:51:31.475: Serial0: X.25 I R1 Call (12) 8 lci 1024 
   *Mar  1 01:51:31.479: From (3): 123 To (3): 345 
   *Mar  1 01:51:31.483: Facilities: (0) 
   *Mar  1 01:51:31.483: Call User Data (4): 0x01000000 (pad)    
   *Mar  1 01:51:31.487: PAD: translate call to 345 
   *Mar  1 01:51:31.491: Call User Data (4): 0x01000000 (pad)    
   *Mar  1 01:51:31.495: PAD: Creating proto translation on tty2 for vc 1024    
   *Mar  1 01:51:31.499: Serial0: X.25 O R1 Call Confirm (5) 8 lci 1024 
   *Mar  1 01:51:31.503: From (0):  To (0): 
   *Mar  1 01:51:31.503: Facilities: (0) 
   *Mar  1 01:51:31.507: PAD2: Call completed 
   *Mar  1 01:51:31.511: padtcp2: fork started 
   *Mar  1 01:51:31.515: PAD2: Output X29 packet type 4 (Read X.3 param) len 1 
   *Mar  1 01:51:31.523: TCB0049E7A4 created 
   *Mar  1 01:51:31.523: TCB0049E7A4 setting property TCP_TOS (11) 49C853    
   *Mar  1 01:51:31.527: TCB0049E7A4 bound to UNKNOWN.44034 
   *Mar  1 01:51:31.531: PAD2: Control packet received. 
   *Mar  1 01:51:31.531: TCP: sending SYN, seq 3401534831, ack 0 
   *Mar  1 01:51:31.535: TCP2: Connection to 10.0.0.6:23, advertising MSS 1460 
   *Mar  1 01:51:31.539: TCP2: state was CLOSED -> SYNSENT [44034 -> 10.0.0.6(23)]    
   *Mar  1 01:51:31.559: TCP2: state was SYNSENT -> ESTAB [44034 -> 10.0.0.6(23)]    
   *Mar  1 01:51:31.563: TCP2: Connection to 10.0.0.6:23, received MSS 1460, MSS is 1460 
   *Mar  1 01:51:31.567: TCB0049E7A4 connected to 10.0.0.6.23 
   *Mar  1 01:51:31.571: PAD2: Input X29 packet type 0 (Parameter indication) len 45 
       1:1, 2:1, 3:2, 4:1, 5:0, 6:0, 7:4, 
       8:0, 9:0, 10:0, 11:14, 12:0, 13:0, 14:0, 15:0, 
       16:127, 17:21, 18:18, 19:0, 20:0, 21:0, 22:0, 
   *Mar  1 01:51:31.583: PAD2: Setting ParamsIn, length 44 
   *Mar  1 01:51:31.587: PAD2: Output X29 packet type 6 (Set and Read) len 9 
       2:0, 4:1, 15:0, 7:21, 
   *Mar  1 01:51:31.599: PADTCP2: Telnet received WILL ECHO (1) 
   *Mar  1 01:51:31.599: PAD2: Control packet received. 
   *Mar  1 01:51:31.607: PADTCP2: Telnet received DO TTY-TYPE (24) 
   *Mar  1 01:51:31.611: PAD2: Output X29 packet type 6 (Set and Read) len 3 2:0, 
   *Mar  1 01:51:31.619: PAD2: Input 
   *Mar  1 01:51:31.619: PAD2: Control packet received.X29 packet type 0 
       (Parameter indication) len 9 2:0, 4:1, 15:0, 7:21, 
   *Mar  1 01:51:31.627: PAD2: Setting ParamsIn, length 8 
   *Mar  1 01:51:31.631: PAD2: Input X29 packet type 0 (Parameter indication) len 3 2:0, 
   *Mar  1 01:51:31.635: PAD2: Setting ParamsIn, length 2 
   *Mar  1 01:51:31.643: PADTCP2: Telnet received DONT TTY-LOCATION (23) 
   *Mar  1 01:51:31.647: PADTCP2: Telnet received DONT TTY-SPEED (32) 
   Router2#  

Router2#show x25 vc 
   SVC 1024,  State: D1,  Interface: Serial0 
     Started 00:00:10, last input 00:00:07, output 00:00:05  
  Line: 2   vty 0    Location:  Host: 123    
     123 connected to 345 PAD <--> X25  
  Window size input: 2, output: 2 
     Packet size input: 128, output: 128 
     PS: 1  PR: 6  ACK: 6  Remote PR: 1  RCNT: 0  RNR: no 
     P/D state timeouts: 0  timer (secs): 0 
     data bytes 3057/60 packets 33/6 Resets 0/0 RNRs 0/0 REJs 0/0 INTs 0/0    
   Router2# 
   Router2# 

Avant d'émettre des commandes de débogage, référez-vous aux informations importantes sur des commandes de debug.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 14216