WAN : Protocoles X.25

Configuration d'un routeur en tant que PAD pour XOT pour un hôte asynchrone

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document présente une configuration d'échantillon dans laquelle un serveur distant se connecte au X.25 au-dessus d'un réseau de Protocole TCP (Transmission Control Protocol) sur une ligne commutée du réseau téléphonique public commuté (PSTN). L'hôte n'envoie ou reçoit aucun paquet de X.25. Cependant, le routeur distant qu'il connecte agit en tant qu'assembleur de paquet de X.25/démonteur (PROTECTION) et encapsule et désencapsule des paquets de X.25 pour l'hôte.

Remarque: Ceci désigné sous le nom « de la protection inverse », pendant que l'appel X.25 peut seulement être établi du périphérique X.25 (serveur) à l'hôte asynchrone, pas vice versa. La protection en avant exige une configuration différente.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les améliorations à la fonctionnalité liée à la protection que nous pouvons les utiliser dans le service de traduction de Conversion de protocole ont été introduites dans la version de logiciel 11.2 de Cisco IOSÝ.

Les Plateformes suivantes prennent en charge les améliorations de PROTECTION :

  • Routeurs de la gamme Cisco 2500

  • Routeurs de gamme Cisco 26xx

  • Routeurs de gamme Cisco 36xx

  • Cisco 4000 Routeurs

  • Cisco 4500 Routeurs

  • Cisco 4700 Routeurs

  • Routeurs de gamme Cisco AS5200

  • Routeurs de la gamme Cisco 7000

  • Routeurs de la gamme Cisco 7200

  • Routeurs de la gamme Cisco 7500

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Informations générales

La PROTECTION au-dessus du Protocole XOT (X.25 over TCP) active des appels de PROTECTION aux destinations qui ne sont pas accessibles au-dessus des interfaces physiques de X.25, mais au-dessus des tunnels de TCP. Cette fonction active des appels de PROTECTION provenant d'un routeur sur une liaison IP pour atteindre un périphérique de X.25. La PROTECTION au-dessus de XOT permet également aux connexions entrantes XOT d'une liaison IP d'être reçues comme connexions de PROTECTION ou de Conversion de protocole sur le routeur local.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/14188/netdiag1.jpg

Configurations

Ce document utilise les configurations suivantes :

Routeur distant
Current configuration:
!
version 12.0
 service pad from-xot                   

!---used for allowing incoming xot to pad connection

 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
!
!OPTIONAL
x29 profile default 2:0, 4:1, 15:0, 7:21 

!---apply customized x29 profile as default to all incoming connections

!
hostname Remote
!
memory-size iomem 25
 ip subnet-zero
 no ip domain-lookup
!
x25 routing
!
interface Serial0
 ip address 10.10.100.2 255.255.255.0
 no ip directed-broadcast
!
interface Serial1
 ip address 10.10.175.1 255.255.255.0
 no ip directed-broadcast
!
interface FastEthernet0
 ip address 10.10.10.42 255.255.255.0
 no ip directed-broadcast
 half-duplex
!
ip classless
 no ip http server
!
x25 route ^100 xot 10.10.100.1
 x25 host remote 250                 
!---map the x25 address of 25099 to the router's
hostname
!
line con 0
 no exec
 exec-timeout 0 0
 transport input none
line aux 0                     

!---to async host

 no exec
 modem InOut
 rotary 99                   

!---enable reverse PAD

 transport input pad
 flowcontrol hardware
line vty 0 4
 login local
!

Routeur principal
Current configuration:
!
version 12.0
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
!
hostname Main
!
!
memory-size iomem 25
 ip subnet-zero
 no ip domain-lookup
!
x25 routing
!
!
!
interface Serial0
 ip address 10.10.100.1 255.255.255.0
 no ip directed-broadcast
 clockrate 800000
!
interface Serial1
 no ip directed-broadcast
 encapsulation x25 dce
 x25 address 150
 clockrate 56000
!
interface FastEthernet0
 no ip address
 no ip directed-broadcast
 half-duplex
!
ip classless
 no ip http server
!
x25 route ^250 xot 10.10.100.2
 x25 route ^100 interface Serial1
!
line con 0
 transport input none
 line aux 0
 line vty 0 4
 login local
!
no scheduler allocate
end

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Dépannage des commandes

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Remarque: Avant d'émettre des commandes de débogage, référez-vous aux informations importantes sur des commandes de debug.

  • événements de debug x25 — Affiche des informations au sujet de tout le trafic de X.25 ou d'une classe de services spécifique de X.25.

  • debug pad — Affiche des messages de débogage pour toutes les connexions de PROTECTION.

La sortie de débogage suivante est affichée pour un appel réussi de X.25 du serveur à l'hôte. Nous avons exécuté ces commandes de débogage en fonction sur le routeur distant.

Remote#debug x25 events
Remote#debug pad
WORKING CALL
2d01h: pad_ctxt_up: id 808D6F18, reason 80742B9C (event 0, impetus 10)
2d01h: [10.10.100.1,11042/10.10.100.2,1998]: XOT I P/Inactive Call (20) 8
lci 1
2d01h:   From (5): 10006 To (5): 25099
2d01h:   Facilities: (6)
2d01h:     Packet sizes: 128 128
2d01h:     Window sizes: 2 2
2d01h:   Call User Data (4): 0x01000000 (pad)
2d01h: PAD: incoming call to 25099 on line 5 CUD length 4
2d01h: PAD: Creating TTY daemon on tty5 for vc 1
2d01h: [10.10.100.1,11042/10.10.100.2,1998]: XOT O P3 Call Confirm (5) 8
lci 1
2d01h:   From (0):  To (0):
2d01h:   Facilities: (0)
2d01h: PAD5: Call completed
2d01h: PAD5: Output X29 packet type 4 (Read X.3 param) len 1
2d01h: PAD5: Control packet received.
2d01h: PAD5: Input X29 packet type 0 (Parameter indication) len 45
1:1, 2:1, 3:2, 4:0, 5:0, 6:5, 7:2,
8:0, 9:0, 10:0, 11:14, 12:1, 13:4, 14:0, 15:1,
16:8, 17:24, 18:18, 19:2, 20:255, 21:7, 22:0,
2d01h: PAD5: Setting ParamsIn, length 44
2d01h: PAD5: Output X29 packet type 6 (Set and Read) len 9 2:0, 4:1,
15:0,7:21,
2d01h: PAD5: Control packet received.
2d01h: PAD5: Input X29 packet type 0 (Parameter indication) len 9 2:0,
4:1, 15:0, 7:21,

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 14188