Sécurité et VPN : Négociation IPSec/protocoles IKE

Configuration du chiffrement CET avec un tunnel GRE

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Cisco a annoncé la fin de la vie pour la technologie de cryptage de Cisco. Le pour en savoir plus, voient s'il vous plaît l'annonce de fin de ventes.


Contenu


Introduction

Pour configurer le cryptage de la technologie de cryptage de Cisco (CET) avec un tunnel, vous devez configurer le cryptage sur l'interface du tunnel. Supplémentaire, vous devez configurer le cryptage sur l'interface physique cette des têtes vers la destination certaine du tunnel.

Remarque: Le cryptage CET est maintenant fin de vie. IPSec est la structure de chiffrement recommandée pour le transfert.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/14120/13.gif

Remarques sur les diagrammes de réseau

  • 8.8.8.8, derrière r3-4k, et 7.7.7.4, derrière R6-2500, sont des stations d'extrémité. Quand ils se cinglent, le trafic passe par le tunnel.

  • Le tunnel d'Encapsulation de routage générique (GRE) est configuré avec des interfaces de bouclage comme source du tunnel et destination.

  • Le trafic par le tunnel est également chiffré. L'implémentation de cette caractéristique exige de cela de chiffrer le trafic du tunnel, le crypto map doit être relié à l'interface de tunnel et à l'interface sortante physique.

Configurations

Ce document utilise les configurations suivantes :

r3-4k
hostname r3-4k
  !
  crypto public-key r6-2500 02014544
   F3681B5D 32372A19 0C0CCC4B E707F829 D882CF30 A9B4DBE3 E1911E9C F6A9E162 
   732558DF A20FEFAD 2ACC400E 8DDB10B1 3566FA3A E55A9BBE 00916AAD 20A0C75C
   quit
  !
  crypto map my_crypto_map 10
   set algorithm 40-bit-des
   set peer r6-2500
   match address 128
  !
  interface Loopback0
   ip address 1.1.6.1 255.255.255.0
  !
  interface Tunnel0
   ip address 5.5.5.1 255.255.255.0
   tunnel source Loopback0
   tunnel destination 2.2.6.3
   crypto map my_crypto_map
  !
    interface Ethernet0
   ip address 1.1.1.1 255.255.255.0
   description inside interface
   media-type 10BaseT
   crypto map my_crypto_map
  !
  !
  interface Serial0
   encapsulation frame-relay
   no ip route-cache
  !
  interface Serial0.1 point-to-point
  description outside interface
   ip address 8.8.8.1 255.255.255.0
   frame-relay interface-dlci 100   
  !
  !ip classless
  ip route 0.0.0.0 0.0.0.0 1.1.1.2
  ip route 7.0.0.0 255.0.0.0 5.5.5.2
  
  access-list 128 permit gre host 1.1.6.1 host 2.2.6.3
  !

R1-AGS
!
  hostname R1-AGS
  !
  interface Ethernet0
   ip address 1.1.1.2 255.255.255.0
  !
  interface Serial1
   ip address 2.2.5.2 255.255.255.0
  !
  ip classless
  ip route 1.0.0.0 255.0.0.0 1.1.1.1
  ip route 2.0.0.0 255.0.0.0 2.2.5.3

R6-2500
hostname R6-2500
  !
  crypto public-key r3-4k 04D6265A
   512A7D84 43C348B7 959D2FE2 3122B285 FDA2A362 7272A835 84D03134 DB160DE1 
   27CA2D24 D6C23EFE 3BE25A95 D62EA30B 0F2C3BA8 9AB6DB82 D8127238 266AC987
   quit
  ! 
  crypto map my_crypto_map 10
   set algorithm 40-bit-des
   set peer r3-4k
   match address 128
  !
  interface Loopback0
   ip address 2.2.6.3 255.255.255.0
  !
  interface Tunnel0
   ip address 5.5.5.2 255.255.255.0
   tunnel source Loopback0
   tunnel destination 1.1.6.1
   crypto map my_crypto_map
  !
  interface Ethernet 0
  description inside interface
   ip address 7.7.7.3 255.255.255.0
  !
  interface Serial0
  description outside interface
   ip address 2.2.5.3 255.255.255.0
   crypto map my_crypto_map
  !
  ip classless
  ip route 0.0.0.0 0.0.0.0 2.2.5.2
  ip route 7.0.0.0 255.0.0.0 7.7.7.0
  ip route 8.0.0.0 255.0.0.0 5.5.5.1
  !
  access-list 128 permit gre host 2.2.6.3 host 1.1.6.1

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 14120