Voix : Digital CCS

VoIP avec signalisation CCS (Common Channel Signaling)

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu

CCS
CAS

Introduction

Ce document montre les configurations nécessaires pour les deux Routeurs dans ce document pour communiquer par l'intermédiaire de la voix sur ip (VoIP) et du Protocole CCS (Common Channel Signaling) au-dessus d'un PRI numérique.

Il est important de noter que dans cette configuration, les deux Routeurs sont dos à dos connecté au-dessus d'un segment IP. Dans la plupart des topologies cependant, les routeurs activés par la voix peuvent exister n'importe où. Habituellement, les Routeurs de Voix sont connectés par l'intermédiaire de la Connectivité de RÉSEAU LOCAL à d'autres Routeurs qui sont connectés au WAN. Il est important noter ce parce que si vos Routeurs de Voix ne sont pas connectés au-dessus d'une ligne louée, toutes les commandes de configuration de connectivité WAN sont configurées sur ces Routeurs qui sont connectés au WAN, et pas sur les Routeurs de Voix, car elles sont dans les configurations dans ce document.

Tandis qu'un routeur de Cisco 3640 et un routeur de Cisco AS5300 sont utilisés dans cet exemple de configuration, ces configurations peuvent également être utilisées pour des Routeurs de gamme Cisco 2600.

Conditions préalables

Conditions requises

Avant que vous puissiez configurer votre routeur de Cisco pour utiliser le VoIP, il est le meilleur si vous comprenez les concepts des caractéristiques de Qualité de service (QoS) en logiciel de ½ du ¿  de Cisco IOSïÂ. Pour se renseigner plus sur des caractéristiques de QoS, référez-vous à la Mise en file d'attente, le trafic formant, et filtrage et la Signalisation QoS de la page de QoS de Cisco IOS sur Cisco.com.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Routeurs de gammes Cisco 2600 et 3640

  • Cisco AS5300

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Signalisation T1 : CAS et CCS

La signalisation dans le monde de téléphonie fournit des fonctions telles que diriger et annoncer l'état de ligne, alertant des périphériques quand un appel essaye de se connecter, et acheminement et des informations d'adressage.

Il y a deux types différents d'informations de signalisation dans le monde de t1 :

  • CCS

  • Signalisation CAS (Channel Associated Signaling)

CCS

CCS est la transmission des informations de signalisation hors de la bande de l'information. La forme la plus notable et la plus très utilisée de ce type de signalisation est le RNIS. Un inconvénient à l'utilisation d'un PRI RNIS est la suppression d'un DS0, ou canal vocal. Dans ce cas, pour signaler l'utilisation. Par conséquent, un t1 aurait vingt-trois DS0s, ou canaux B pour des données d'utilisateur, et un DS0, ou canal D pour la signalisation. Il est possible de contrôler plusieurs PRIs avec un canal D simple avec chacun utilisant non la signalisation associée par installation (NFAS). Par conséquent, vous pouvez configurer l'autre PRIs dans le groupe NFAS pour utiliser chacun des vingt-quatre DS0s comme canaux B. L'utilisation de la signalisation PRI assure les vitesses de connexion possibles maximum, particulièrement avec l'arrivée des Modems 56K. Ceci illustre la capacité de canal clair du RNIS.

Un autre inconvénient d'utiliser CCS (comme vu dans le schéma de réseau) est que le PBX a besoin d'une carte numérique de T1 PRI, qui est plus chère qu'une carte de signalisation E&M. Une carte de signalisation E&M est utilisée dans le même schéma de réseau si vous exécutez CAS entre l'AS5300 et le PBX.

CAS

CAS est la transmission des informations de signalisation dans la bande de l'information, ou signalisation d'intrabande. Ceci signifie que les signaux vocaux voyagent sur les mêmes circuits que l'état de ligne, l'adresse, et les signaux d'alerte. Pendant qu'il y a vingt-quatre canaux sur un plein t1 rayent, CAS intercale des paquets de signalisation dans des paquets vocaux. Par conséquent, il y a de pleins vingt-quatre canaux aux utiliser pour la Voix.

Les divers types de signalisation de CAS sont disponibles dans le monde de t1. Les formes les plus communes de la signalisation de CAS sont loopstart, groundstart, et signalisation E&M. Le plus grand inconvénient de la signalisation de CAS est que le réseau emploie des bits des paquets IP de l'information, tels que des paquets vocaux, pour remplir des fonctions de signalisation. La signalisation de CAS désigné ainsi souvent sous le nom de la signalisation de revêtu d'une robe-bit.

CAS n'est pas le choix optimal quand on tente de réaliser les vitesses de connexion plus élevées possible avec des Modems. La plupart des Modems peuvent s'ajuster à la qualité du signal et encore donner les connexions fiables ultra-rapides. Cependant, l'utilisation des Modems 56K sur CAS raye des vitesses d'arrêters la connexion par presque 2 K dans la direction en aval de transmission par joncteur réseau qui utilise la signalisation de CAS.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/14079/voip_pri_cookbook_topo.gif

Configurations

Ce document utilise les configurations suivantes :

Cisco 3640 San Jose
sanjose3640A#show run
Building configuration...
 
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3640
!
logging buffered 60000 debugging
enable password cisco
!
no ip subnet-zero
!
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 3/0/0
 operation 4-wire
!
voice-port 3/0/1
 operation 4-wire
!
voice-port 3/1/0
!
voice-port 3/1/1
!
dial-peer voice 1 pots     

!--- More on dial peers.

 destination-pattern 4552468
 port 1/0/1
!
dial-peer voice 2 voip
 destination-pattern 3006
 session target ipv4:10.2.1.2
!
dial-peer voice 3 pots
 destination-pattern 5551234
 port 1/0/0
!
dial-peer voice 4 voip
 destination-pattern 4005
 fax-rate 9600
 session target ipv4:10.2.1.2
!
interface Ethernet0/0
 ip address 10.2.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial2/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no fair-queue
 clockrate 64000
!
interface Serial2/1
 no ip address
 no ip directed-broadcast
 shutdown
 clockrate 38000
!
interface Serial2/2
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial2/3
 no ip address
 no ip directed-broadcast
 shutdown
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end

Cisco AS5300 Raleigh
AS5300#show run
Building configuration...
 
Current configuration:
!
version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname AS5300
!
boot system flash c5300-js-mz_113-6_na2.bin
enable password cisco
!
isdn switch-type primary-dms100
!
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 clock source internal
!
controller T1 2
 clock source internal
!
controller T1 3
 clock source internal
!
!
dial-peer voice 1 voip           

!--- More on dial peers.

 destination-pattern 4552468
 session target ipv4:10.2.1.1
!
dial-peer voice 2 pots
 destination-pattern 3...
 direct-inward-dial
 port 0:D
 prefix 3
!
dial-peer voice 4 pots
 destination-pattern 4...
 direct-inward-dial
 port 0:D
 prefix 4
!
dial-peer voice 3 voip
 destination-pattern 5551234
 fax-rate 9600
 session target ipv4:10.2.1.1
!
!
voice-port 0:D
!
interface Ethernet0
 ip address 10.2.1.2 255.255.255.0
!
interface Serial0:23
 no ip address
 isdn switch-type primary-dms100
 isdn tei-negotiation first-call
 isdn incoming-voice modem
 no cdp enable
!
interface FastEthernet0
 no ip address
 shutdown
!
ip classless
!
logging buffered 60000 debugging
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Dépannage des commandes

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Remarque: Avant d'émettre des commandes de débogage, référez-vous aux informations importantes sur des commandes de debug.

  • debug voip ccapi inout — Utilisé pour tracer le chemin d'exécution par l'API de contrôle d'appel, qui sert d'interface entre l'application de session d'appel et le logiciel sous-jacent de réseau-particularité. Vous pouvez utiliser la sortie de cette commande de comprendre comment des appels sont traités par le routeur.

  • debug vpm all — Utilisé pour activer le tout les mettez au point les commandes de vpm : debug vpm spi, debug vpm signal et debug vpm dsp.

    Remarque: Ceci mettent au point génère beaucoup de sortie.

  • show call active voice — Utilisé pour afficher le contenu de la table d'appel actif, qui affiche tous les appels actuellement s'est connecté par le routeur.

  • show call history voice — Utilisé pour afficher la table d'historique d'appel. La table d'historique d'appel contient une liste de tous les appels connectés par ce routeur dans la commande de temps décroissante puisque le VoIP a été activé. Vous pouvez afficher des sous-ensembles de la table d'historique d'appel à l'aide des mots clé spécifiques.

  • show voice port — Utilisé pour afficher les informations de configuration au sujet d'un port vocal spécifique.


Informations connexes


Document ID: 14079