IP : Integrated Intermediate System-to-Intermediate System (IS-IS)

Configuration du protocole IS-IS pour IP sur routeurs Cisco

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

L'objectif de ce document est d'expliquer la configuration de base du Intermediate System-to-Intermediate System (IS-IS) pour IP sur les routeurs Cisco. En plus de la configuration, comment surveiller les diverses informations IS-IS est expliquée, comme les informations indiquées d'élection de système intermédiaire (DIS) et les informations de base de données IS-IS.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations dans ce document sont basées sur la version de logiciel 12.1(5)T9 de Ý de Cisco IOS.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configuration d'échantillon IS-IS

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Afin d'activer l'IS-IS pour l'IP sur un routeur de Cisco et le faire permuter les informations de routage avec d'autres routeurs activés IS-IS, vous devez effectuer ces deux tâches :

  • Activez le processus IS-IS et assignez la zone

  • IS-IS d'enable pour le Routage IP sur une interface

D'autres tâches de configuration sont facultatives, toutefois les deux tâches ci-dessus sont exigées. Pour plus d'informations sur des tâches facultatives de configuration, référez-vous à configurer l'IS-IS intégré.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/13795/is-is-ip-config.jpg

Configurations

Ce document utilise les configurations suivantes :

Les configurations d'échantillon ci-dessous configurent tous les Routeurs dans la topologie ci-dessus avec ces paramètres :

  • Zone 49.0001

  • Routeurs du niveau 1 (L1) et du niveau 2 (L2) (c'est le par défaut sauf indication contraire)

  • Aucun paramètres optionnels

  • Exécutant l'IS-IS pour l'IP seulement

  • Le bouclage relie (des bouclages ne sont annoncés par l'IS-IS, pas l'IS-IS activés)

Routeur 1
!
interface Loopback0
ip address 172.16.1.1 255.255.255.255

!--- Creates loopback interface and assigns
!--- IP address to interface Loopback0.

!
interface Ethernet0
ip address 172.16.12.1 255.255.255.0
ip router isis 


!--- Assigns IP address to interface Ethernet0 
!--- and enables IS-IS for IP on the interface.

!
router isis
passive-interface Loopback0
net 49.0001.1720.1600.1001.00
!

!--- Enables the IS-IS process on the router, 
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router.

Routeur 2
!
interface Loopback0
ip address 172.16.2.2 255.255.255.255

!--- Creates loopback interface and assigns 
!--- IP address to interface Loopback0.

!
Interface Ethernet0
ip address 172.16.12.2 255.255.255.0
ip router isis

!--- Assigns IP address to interface Ethernet0 
!--- and enables IS-IS for IP on the interface.

!
Interface Serial0
ip address 172.16.23.1 255.255.255.252
ip router isis

!--- Assigns IP address to interface Serial0 
!--- and enables IS-IS for IP on the interface.

!
router isis 
passive-interface Loopback0
net 49.0001.1720.1600.2002.00
!

!--- Enables the IS-IS process on the router,
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router. 

Routeur 3
!
interface Loopback0
ip address 172.16.3.3 255.255.255.255 

!--- Creates loopback interface 
!--- and assigns IP address to 
!--- interface Loopback0.

!
Interface Serial0
ip address 172.16.23.2 255.255.255.252
ip router Isis

!--- Assigns IP address to 
!--- interface Serial0 and enables 
!--- IS-IS for IP on the interface.

!
router isis 
passive-interface Loopback0
net 49.0001.1234.1600.2231.00
!

!--- Enables the IS-IS process on the router, 
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router.

Supervision d'IS-IS

Il y a beaucoup de commandes show disponibles pour surveiller l'état d'IS-IS sur un routeur de Cisco. Ce document explique certaines des commandes plus fondamentales basées sur les configurations de routeur ci-dessus.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Contiguïtés de supervision d'IS-IS

Utilisez la commande neighbor de show clns d'afficher les contiguïtés pour un routeur spécifique. C'est la sortie de cette commande du routeur 1 (R1) et du Router2 (R2) :

R1# show clns neighbor
System Id   Interface  SNPA            State  Holdtime  Type Protocol
R2          Et0        0000.0c47.b947  Up     24        L1L2 ISIS
    
R2# show clns neighbor
System Id  Interface  SNPA             State  Holdtime  Type Protocol
R1         Et0        0000.0c09.9fea   Up     24        L1L2 ISIS
R3         Se0        *HDLC*           Up     28        L1L2 ISIS

Dans l'exemple ci-dessus, R1 identifie R2 sur son interface E0 avec le type de contiguïté étant L1L2. Puisque R1 et R2 sont configurés avec des configurations par défaut, ils envoient et reçoivent les hellos L1 et L2.

R2 identifie R1 sur son interface E0, et Routeur3 (R3) sur son interface S0. La même explication comme ci-dessus est vrai pour le type de contiguïté.

Puisque R1 et R2 sont sur la même interface Ethernet, il y ont un DIS pour L1 et L2. Vous pouvez vérifier ceci utilisant la commande de <int> de show clns interface sur le routeur 1, comme affiché ci-dessous :

R1# show clns interface ethernet 0
Ethernet0 is up, line protocol is up
  Checksums enabled, MTU 1497, Encapsulation SAP
  Routing Protocol: ISIS
    Circuit Type: level-1-2
    Interface number 0x0, local circuit ID 0x1
    Level-1 Metric: 10, Priority: 64, Circuit ID: R2.01
    Number of active level-1 adjacencies: 1
    Level-2 Metric: 10, Priority: 64, Circuit ID: R2.01
    Number of active level-2 adjacencies: 1
    Next ISIS LAN Level-1 Hello in 5 seconds
    Next ISIS LAN Level-2 Hello in 1 seconds

Dans la sortie ci-dessus, R2 est le DIS. C'est le R2 (DIS) qui génère le paquet d'État de lien de pseudonode (LSP) et est dénoté avec un LSP-ID différent de zéro - R2.01

Puisque la mesure/priorité sont identique pour les deux Routeurs dans L1/L2, le tie-break pour le DIS est les points les plus élevés de sous-réseau d'adresse de la connexion (SNPA) sur le segment de RÉSEAU LOCAL. L'adresse SNPA se rapporte à l'adresse de la liaison de données, et est dans ce cas l'adresse MAC. L'autre exemple des adresses de la liaison de données serait des adresses et DLCI en relais de trame de X.25.

Notez que le DIS est élu pour les deux niveaux, et qu'aucun DIS de sauvegarde n'existe, comme avec le Protocole OSPF (Open Shortest Path First), qui a un routeur de secours désigné (DR).

Quelques autres points d'intérêt de la sortie ci-dessus incluent :

  • Type de circuit : L1L2

  • Les mesures L1 et L2 et les priorités sont aux valeurs par défaut : 10 et 64

  • Contiguïtés L1 et L2 : 1 (de point de vue R1 sur l'interface Ethernet - c'est R2 seulement)

  • Hellos de RÉSEAU LOCAL IS-IS pour L1 et L2

  • Maximum Transmission Unit (MTU) : 1497. C'est parce que l'en-tête IS-IS d'interconnexion de systèmes ouverts (OSI) est encapsulée à l'intérieur 3 d'une en-tête de l'octet 802.2.

Surveillance de la base de données IS-IS

La commande de show isis database (détail) affiche le contenu de la base de données IS-IS. C'est la sortie de cette commande une fois émise sur R2. Puisque l'IS-IS est un protocole d'état de lien, la base de données d'état de lien devrait être identique pour n'importe quel routeur dans la même zone.

R2# show isis database
ISIS Level-1 Link State Database:
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime    ATT/P/OL
R1.00-00      0x0000008B   0x6843        55              0/0/0
R2.00-00    * 0x00000083   0x276E        77              0/0/0
R2.01-00    * 0x00000004   0x34E1        57              0/0/0
R3.00-00      0x00000086   0xF30E        84              0/0/0
ISIS Level-2 Link State Database:
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime    ATT/P/OL
R1.00-00      0x00000092   0x34B2        41              0/0/0
R2.00-00    * 0x0000008A   0x7A59        115             0/0/0
R2.01-00    * 0x00000004   0xC3DA        50              0/0/0
R3.00-00      0x0000008F   0x0766        112             0/0/0

Il y a quelques choses à noter dans la sortie ci-dessus. D'abord, au sujet du LSP-ID :

Le LSP-ID, R1.00-00, peut être décomposé en trois sections : R1/00/00

  • R1 = ID système

  • 00 = valeur différente de zéro pour le pseudonode. L'avis R2.01-00 est le LSP pseudonode.

  • 00 = nombre de fragment. Dans ce cas, il y a seulement des nombres de fragment de 00, qui indique que toute l'adaptation de données dans ce fragment LSP, et il n'y avait aucun besoin de créer plus de fragments. S'il y avait eu les informations qui ne se sont pas insérées dans le premier LSP, l'IS-IS aurait créé plus de fragments LSP, tels que 01, 02, et ainsi de suite.

* dénote les LSP qui ont été générés par ce routeur, le routeur que la commande show a été émise en fonction. En outre, puisque ce routeur est un routeur L1 et L2, il contient une base de données L1 et L2.

Vous pouvez également regarder une particularité LSP et employer le mot clé de détail pour afficher plus d'informations. Un exemple de ceci est affiché ici :

R2# show isis database R2.00-00 detail
ISIS Level-1 LSP R2.00-00
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
R2.00-00    * 0x00000093   0x077E        71            0/0/0
  Area Address: 49.0001
  NLPID:        0xCC
  Hostname: R2
  IP Address:   172.16.2.2 
  Metric: 10         IP 172.16.12.0 255.255.255.0
  Metric: 0          IP 172.16.2.2 255.255.255.255
  Metric: 10         IP 172.16.23.0 255.255.255.252
  Metric: 10         IS R2.01
  Metric: 10         IS R3.00
ISIS Level-2 LSP R2.00-00
LSPID         LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
R2.00-00    * 0x0000009A   0x5A69        103           0/0/0
  Area Address: 49.0001
  NLPID:        0xCC
  Hostname: R2
  IP Address:   172.16.2.2
  Metric: 10         IS R2.01
  Metric: 10         IS R3.00
  Metric: 10         IP 172.16.23.0 255.255.255.252
  Metric: 10         IP 172.16.1.1 255.255.255.255
  Metric: 10         IP 172.16.3.3 255.255.255.255
  Metric: 0          IP 172.16.2.2 255.255.255.255
  Metric: 10         IP 172.16.12.0 255.255.255.0

La sortie ci-dessus prouve que l'adresse de bouclage de ce routeur est annoncée avec une valeur de 0. C'est parce que le bouclage est annoncé avec une commande passive-interface sous le processus IS-IS de routeur, et l'interface de bouclage par lui-même n'est pas activée pour l'IS-IS. Tous autres préfixes IP ont une valeur de 10, qui est le coût par défaut sur les interfaces exécutant l'IS-IS.

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 13795