IP : Protocole HSRP (Hot Standby Router Protocol)

Présentation et configuration de la commande ip unnumbered

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document explique le concept d'IP non numéroté et fournit plusieurs exemples de configuration pour référence. La commande de configuration ip unnumbered vous permet d'activer le traitement d'IP sur une interface série sans lui attribuer une adresse IP explicite. L'interface d'ip non numéroté peut « emprunter » l'adresse IP d'une autre interface déjà configurée sur le routeur, qui économise de l'espace réseau et d'adresse.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Qu'est-ce qu'une interface non numérotée ?

Considérez le réseau représenté ci-dessous. Le routeur A a une interface série S0 et une interface Ethernet E0.

/image/gif/paws/13786/20a_new.gif

L'interface Ethernet 0 du routeur A peut être configurée avec une adresse IP comme illustré ci-dessous :

interface Ethernet0
ip address 172.16.10.254 255.255.255.0

Logiquement, pour activer l'IP sur l'interface S0, vous devriez configurer une adresse IP unique dessus. Cependant, il est également possible d'activer l'IP sur l'interface série et de l'apporter sans lui attribuer une adresse IP unique. Ceci est fait en empruntant une adresse IP déjà configurée sur une d'autres interfaces du routeur. Pour faire ceci, la commande de mode interface ip unnumbered est utilisée comme illustré ci-dessous.

interface Serial 0
ip unnumbered Ethernet 0

La commande de mode interface <number> de <type> d'ip unnumbered emprunte l'adresse IP de l'interface spécifiée à l'interface sur laquelle la commande a été configurée. L'utilisation de la commande ip unnumbered a pour conséquence le partage de l'adresse IP par deux interfaces. Ainsi, dans notre exemple, l'adresse IP qui a été configuré sur l'interface Ethernet est également attribuée à l'interface série et les deux interfaces impliquées fonctionnent normalement. Ceci peut être vérifié avec le résultat de la commande show ip interface brief, comme illustré ci-dessous :

RouterA# show ip interface brief 

Interface    IP-Address      OK?    Method   Status   Protocol
Ethernet0    172.16.10.254   YES    manual   up       up
Serial0      172.16.10.254   YES    manual   up       up

Comme vous pouvez le voir dans le résultat de la commande show ip interface brief ci-dessus, l'interface série a une adresse IP identique à celle de l'interface Ethernet et les deux interfaces sont entièrement fonctionnelles. L'interface qui emprunte son adresse à une autre des interfaces fonctionnelles du routeur est appelée « interface non numérotée ». Dans notre exemple, Serial 0 est l'interface non numérotée.

Le seul vrai inconvénient dont souffre l'interface non numérotée est qu'elle est indisponible pour les tests et la gestion à distance. Rappelez-vous également que l'interface non numérotée doit emprunter son adresse à une interface qui est en service. Si l'interface non numérotée indique une interface qui n'est pas fonctionnelle (c'est-à-dire, qui n'affiche pas « Interface status UP », « Protocol UP »), l'interface non numérotée ne fonctionne pas. C'est précisément pourquoi il est recommandé que le point d'interface non numérotée indique une interface de bouclage puisque les bouclages n'échouent pas. En conclusion, souvenez-vous que la commande ip unnumbered fonctionne uniquement sur les interfaces point à point. Quand vous configurez la commande sur l'interface à accès multiples (c'est-à-dire, Ethernet) ou l'interface de bouclage, les messages suivants sont affichés :

RouterA(config)# int e0 
RouterA(config-if)# ip unnumbered serial 0 
Point-to-point (non-multi-access) interfaces only 
RouterA(config-if)# ip unnumbered loopback 0 
Point-to-point (non-multi-access) interfaces only  

IP et IP non numéroté

Sur un routeur Cisco, chaque interface connectée à un segment réseau doit appartenir à un seul sous-réseau. Les routeurs directement connectés ont des interfaces qui se connectent au même segment réseau et qui sont attribuées à des adresses IP du même sous-réseau. Si un routeur doit envoyer des données à un réseau qui n'est pas directement connecté, il regarde dans sa table de routage et transfère le paquet au prochain saut directement connecté en direction de la destination. S'il n'y a aucune route dans la table de routage, le routeur transfère le paquet à sa passerelle de dernier recours. Quand un routeur qui est directement connecté à la destination finale reçoit le paquet, il livre le paquet directement à l'hôte d'extrémité.

La table de routage IP contient des routes de sous-réseau ou des routes de réseau principal. Chaque route a une ou plusieurs adresses du prochain saut directement attachées. Des routes de sous-réseau sont regroupées ou récapitulées par défaut aux frontières du réseau principal afin de réduire la taille de la table de routage.

Remarque: Le modèle d'agrégation abordé ci-dessus assume un protocole de routage de vecteur de distance traditionnel tel que le Protocole d'informations de routage (RIP) ou l'Interior Gateway Routing Protocol (IGRP).

Supposons que nous attribuons des adresses IP aux interfaces d'un routeur en utilisant un réseau de classe B qui a été divisé en sous-réseaux avec huit bits de sous-réseautage. Chaque interface requiert un seul sous-réseau. Bien que chaque connexion série point à point ait seulement deux points d'extrémité à adresser, si nous attribuons un sous-réseau entier à chaque interface série, nous utilisons 254 adresses disponibles pour chaque interface où seules deux adresses sont nécessaires. Si nous utilisons l'ip non numérotée sur chaque interface série, nous économisons de l'espace d'adresse ; l'adresse d'une interface LAN « est empruntée » et utilisée comme adresse source pour des mises à jour et des paquets de routage provenant de l'interface série. De cette façon, l'espace d'adresse est économisé. L'IP non numéroté n'a de sens que pour les liaisons point à point.

Un routeur recevant une mise à jour du routage installe l'adresse source de la mise à jour du routage comme prochain saut dans sa table de routage. Normalement, le prochain saut est un nœud de réseau directement connecté. Ce n'est plus le cas si nous utilisons l'IP non numéroté parce que chaque interface série « emprunte » son adresse IP à une interface LAN différente, chacun dans un sous-réseau différent et probablement dans un réseau principal différent. Quand l'IP non numéroté est configuré, les routes acquises via l'interface d'IP non numérotée ont pour prochain saut l'interface et non l'adresse source de la mise à jour de routage. Ainsi nous évitons un problème d'adresse non valide du prochain saut parce que la source de la mise à jour de routage provenant d'un prochain saut n'est pas directement connecté.

Exemples de configuration

Remarque: Les informations dans ces exemples de configuration sont basées sur la version de logiciel de½ du¿Â du Cisco IOSï 12.2(10b) et ont été testées sur le Routeurs de la gamme Cisco 2500.

Observons quatre exemples de configuration différents pour un IP non numéroté.

Remarque: Nous aurions pu utiliser des interfaces de bouclage au lieu d'interfaces Ethernet.

Même réseau principal, sous-réseaux différents

La Figure 1 montre que des deux côtés de la liaison série nous avons le même réseau principal avec des sous-réseaux différents.

Figure 1 - Diagramme de réseau

20a.gif

Routeur 1.1.1.1 Routeur 2.2.2.2
Current configuration:

interface Ethernet0
 ip address 171.68.178.196 255.255.255.192 

interface Serial0
 ip unnumbered Ethernet0

router igrp 10
 network 171.68.0.0 

Current configuration:

interface Ethernet 0
 ip address 171.68.179.1 255.255.255.192
 
interface Serial 0
 ip unnumbered Ethernet0 

router igrp 10
 network 171.68.0.0 

Router 1.1.1.1# show ip route

     171.68.0.0/26 is subnetted, 3 subnets
I       171.68.179.0 [100/8976] via 171.68.179.1, 00:00:02, Serial0
C       171.68.178.192 is directly connected, Ethernet0
I       171.68.0.0 [100/8976] via 171.68.179.1, 00:00:02, Serial0

Router 1.1.1.1# ping 171.68.179.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 171.68.179.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/30/32 ms


Router 2.2.2.2# show ip route

     171.68.0.0/26 is subnetted, 3 subnets
C       171.68.179.0 is directly connected, Ethernet0
I       171.68.178.192 [100/8976] via 171.68.178.196, 00:00:02, Serial0
I       171.68.0.0 [100/8976] via 171.68.178.196, 00:00:02, Serial0
     
Router 2.2.2.2# ping 171.68.178.196

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms

Les informations de route au sujet des sous-réseaux sont correctement mises à jour dans ce scénario.

Réseaux principaux différents, aucun sous-réseau

La Figure 2 montre que des deux côtés de la liaison série nous avons différents réseaux principaux et aucun sous-réseau.

Figure 2 - Diagramme de réseau

/image/gif/paws/13786/20b.gif

Routeur 1.1.1.1 Routeur 2.2.2.2
Current configuration:

interface Ethernet0
 ip address 171.68.178.196 255.255.0.0 

interface Serial0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 171.68.0.0 
Current configuration:

interface Ethernet 0
 ip address 172.68.1.1 255.255.0.0 

interface Serial 0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 172.68.0.0

Router 1.1.1.1# show ip route

C    171.68.0.0/16 is directly connected, Ethernet0
I    172.68.0.0/16 [100/8976] via 172.68.1.1, 00:01:26, Serial0

Router 1.1.1.1# ping 172.68.1.1

Sending 5, 100-byte ICMP Echos to 172.68.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms


Router 2.2.2.2# show ip route

I    171.68.0.0/16 [100/8976] via 171.68.178.196, 00:00:21, Serial0
C    172.68.0.0/16 is directly connected, Ethernet0

Router 2.2.2.2# ping 171.68.178.196

Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/32 ms

Réseau principal avec sous-réseau, réseau principal sans sous-réseau

La Figure 3 montre que d'un côté de la liaison série nous avons un réseau principal avec un sous-réseau, et de l'autre côté un réseau principal sans sous-réseau.

Figure 3 - Diagramme de réseau

/image/gif/paws/13786/20c.gif

Routeur 1.1.1.1 Routeur 2.2.2.2
Current configuration:

interface Ethernet0
 ip address 171.68.178.196 255.255.255.192

interface Serial0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 171.68.0.0 
Current configuration:

interface Ethernet 0
 ip address 172.68.1.1 255.255.0.0

interface Serial 0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 172.68.0.0

Router 1.1.1.1# show ip route

     171.68.0.0/26 is subnetted, 1 subnets
C       171.68.178.192 is directly connected, Ethernet0
I    172.68.0.0/16 [100/8976] via 172.68.1.1, 00:00:03, Serial0

Router 1.1.1.1# ping 172.68.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.68.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/31/32 ms


Router 2.2.2.2# show ip route

     171.68.0.0/16 is variably subnetted, 2 subnets, 2 masks
I       171.68.178.192/32 [100/8976] via 171.68.178.196, 00:00:48, Serial0
I       171.68.0.0/16 [100/8976] via 171.68.178.196, 00:00:48, Serial0
C    172.68.0.0/16 is directly connected, Ethernet0

Router 2.2.2.2# ping 171.68.178.196

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/32 ms

Remarque: Avec un version antérieure à la version 11.0(2) de logiciel Cisco IOS, vous devez mettre une route statique pour le réseau principal 171.68.0.0/16 dans le routeur 2.2.2.2.

Dans ce scénario, les informations de sous-réseau sont perdues puisqu'elles sont traitées en tant que route hôte. Dans le logiciel Cisco IOS versions 11.0(2) et ultérieures, l'Interior Gateway Routing Protocol (IGRP) et le Protocole d'informations de routage (RIP) résolvent ce problème en envoyant la route récapitulative pour le réseau principale à travers les liaisons point à point non numérotées.

Deux réseaux principaux différents et leurs sous-réseaux respectifs

La Figure 4 montre que sur les deux côtés de la liaison série nous avons deux réseaux principaux différents avec des sous-réseaux respectifs.

Figure 4 - Diagramme de réseau

/image/gif/paws/13786/20d.gif

Routeur 1.1.1.1 Routeur 2.2.2.2
Current configuration:

interface Ethernet0
 ip address 171.68.178.196 255.255.255.192 

interface Serial0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 171.68.0.0
Current configuration:

interface Ethernet 0
 ip address 172.68.1.1 255.255.255.192 
 
interface Serial 0
 ip unnumbered Ethernet0 
 
router igrp 10
 network 172.68.0.0 

Router 1.1.1.1# show ip route

     171.68.0.0/26 is subnetted, 1 subnets
C       171.68.178.192 is directly connected, Ethernet0
     172.68.0.0/16 is variably subnetted, 2 subnets, 2 masks
I       172.68.0.0/16 [100/8976] via 172.68.1.1, 00:00:02, Serial0
I       172.68.1.0/32 [100/8976] via 172.68.1.1, 00:00:02, Serial0

Router 1.1.1.1# ping 172.68.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.68.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/81/280 ms


Router 2.2.2.2# show ip route

     171.68.0.0/16 is variably subnetted, 2 subnets, 2 masks
I       171.68.178.192/32 [100/8976] via 171.68.178.196, 00:00:22, Serial0
I       171.68.0.0/16 [100/8976] via 171.68.178.196, 00:00:22, Serial0
     172.68.0.0/26 is subnetted, 1 subnets
C       172.68.1.0 is directly connected, Ethernet0

Router 2.2.2.2# ping 171.68.178.196

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/31/32 ms

Remarque: Dans les versions de logiciel Cisco IOS antérieures à la version 11.0(2), vous devez mettre une route statique pour le réseau principal 171.68.0.0/16 dans le routeur 2.2.2.2 et 172.68.0.0/16 dans le routeur 1.1.1.1.

Dans ce scénario, les informations de sous-réseau sont perdues puisqu'elles sont traitées en tant que route hôte. Dans le logiciel Cisco IOS versions 11.0(2) et ultérieures, IGRP et RIP résolvent ce problème en envoyant la route récapitulative pour le réseau principal à travers les liaisons point à point non numérotées.


Informations connexes


Document ID: 13786