IP : Protocole HSRP (Hot Standby Router Protocol)

Partage de charge avec HSRP

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document donne un exemple de configuration du protocole Hot Standby Router Protocol (HSRP) afin de tirer profit de plusieurs chemins vers une destination donnée.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Théorie générale

Le protocole HSRP est souvent utilisé pour améliorer la résilience dans les réseaux, mais cela peut entraîner une diminution de l'efficacité du réseau. L'exemple de ce document comporte deux chemins reliant le réseau des hôtes au réseau des serveurs. Pour la redondance, le HSRP fonctionne entre R1 et R2, l'un ou l'autre pouvant être routeur actif et devenir « propriétaire » de l'adresse IP virtuelle de HSRP. Le deuxième routeur devient le routeur de réserve, et devient routeur actif uniquement si le routeur actif actuel s'arrête. Pour plus d'informations sur les routeurs actifs et les routeurs de réserve, consultez Comment utiliser les commandes standby preempt et standby track.

L'adresse de la passerelle par défaut des hôtes leur est attribuée en tant qu'adresse IP virtuelle HSRP. Quand les hôtes doivent transmettre des paquets au réseau du serveur, ils les transmettent à leur passerelle par défaut, ou à n'importe quel routeur actif. Dans la mesure où un seul routeur est actif, les paquets émanant des hôtes vers les serveurs traversent seulement un des deux chemins disponibles.

Remarque: Selon la façon dont vous configurez R3, les paquets qui reviennent des serveurs vers les hôtes peuvent ou non utiliser les deux chemins de retour. En outre, les paquets qui reviennent des serveurs vers les hôtes n'ont pas besoin de passer par le routeur actif.

Afin d'utiliser les deux chemins du réseau des hôtes vers le réseau des serveurs, vous pouvez configurer le Multigroup HSRP (MHSRP) entre R1 et R2. En fait, R1 est configuré avec deux groupes HSRP (par exemple, groupe 1 et groupe 2) et R2 est également configuré avec les mêmes groupes HSRP. Pour le groupe 1, R1 est le routeur actif et R2 est le routeur de réserve. Pour le groupe 2, R2 est le routeur actif et R1 est le routeur de réserve. Vous configurez ensuite la moitié des passerelles par défaut des hôtes avec l'adresse IP virtuelle du groupe 1 HSRP, et l'autre moitié des passerelles par défaut des hôtes avec l'adresse IP virtuelle du groupe 2 HSRP.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/13781/7a.gif

Configurations

Ce document utilise les configurations suivantes :

Configuration R1 MHSRP
Current configuration:

interface Ethernet0
        ip address 171.16.6.5 255.255.255.0

        standby 1 preempt
        standby 1 ip 171.16.6.100
        standby 1 track Serial0
        standby 2 preempt
        standby 2 ip 171.16.6.200
        standby 2 track serial 0
        standby 2 priority 95

Configuration R2 MHSRP
Current configuration:

interface Ethernet0
       ip address 171.16.6.6 255.255.255.0
       standby 1 preempt
       standby 1 ip 171.16.6.100
       standby 1 track Serial0
       standby 1 priority 95
       standby 2 preempt
       standby 2 ip 171.16.6.200
       standby 2 track serial 0

Dans ces configurations, remarquez que lorsque les deux routeurs commencent à exécuter le HSRP, R1 a une priorité par défaut de 100 pour le groupe 1 et une priorité de 95 pour le groupe 2. R2 a une priorité par défaut de 100 pour le groupe 2 et une priorité de 95 pour le groupe 1. R1 est donc le routeur actif pour le groupe 1 et R2 le routeur actif pour le groupe 2. Cet exemple montre que vous pouvez accomplir le partage de charge avec MHSRP. Pour cela, vous devez cependant utiliser la priorité et l'anticipation HSRP. HSRP n'a aucun effet sur le trafic de retour. Le chemin emprunté par le trafic de retour dépend du protocole de routage configuré sur le routeur.

Remarque: Quand les commandes standby priority valeur et standby preempt sont configurées, il est obligatoire de mentionner explicitement le numéro de groupe. S'il n'est pas mentionné, la valeur par défaut est 0. Le numéro de groupe par défaut est 0.

Remarque importante

Plusieurs contrôleurs Ethernet (Lance et QUICC) de produits bas de gamme ne peuvent avoir qu'une seule adresse de contrôle d'accès au support (MAC) de monodiffusion dans leur filtre d'adresse. Ces plates-formes n'autorisent qu'un seul groupe HSRP et elles modifient l'adresse d'interface en adresse MAC virtuelle HSRP quand le groupe devient actif. Le partage de charge sur des plates-formes ayant cette limitation n'est pas possible avec HSRP. La commande use-bia a été introduite pour contourner les problèmes qui se produisent quand vous exécutez HSRP sur des produits bas de gamme. Par exemple, si vous exécutez HSRP et DECNet sur les mêmes interfaces, des problèmes se produisent, car DECnet et HSRP tentent de modifier l'adresse MAC. Avec la commande use-bia, vous pouvez configurer HSRP pour utiliser l'adresse MAC créée par le processus de DECnet. Cependant, sachez que l'utilisation de la commande use-bia présente quelques inconvénients, par exemple :

  • Quand un routeur devient actif, l'adresse IP virtuelle est déplacée vers une adresse MAC différente. Le nouveau routeur actif envoie une réponse gratuite du protocole de résolution d'adresse (ARP) mais toutes les implémentations d'hôte ne gèrent pas correctement l'ARP gratuit.

  • La configuration de use-bia interrompt le proxy ARP. Un routeur de secours ne peut pas couvrir la base de données ARP du proxy perdu d'un routeur défaillant.

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 13781