IP : Protocole HSRP (Hot Standby Router Protocol)

Comment utiliser les commandes standby preempt et standby track

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document décrit la manière dont les commandes standby preempt et standby track fonctionnent ensemble ainsi que l'utilisation de chacune.

La commande standby preempt donne la priorité au routeur de protocole Cisco HSRP (Hot Standby Router Protocol) pour que ce dernier devienne actif immédiatement. La priorité est d'abord déterminée par la valeur de priorité configurée puis par l'adresse IP. Dans chaque cas, une valeur plus élevée a une plus priorité plus grande. Quand un routeur d'une certaine priorité acquiert un routeur de moins grande priorité, le routeur envoie un message « Coup ». Quand un routeur actif de basse priorité reçoit un message « Coup » ou un message « Hello » depuis un routeur actif de plus grande priorité, le statut du routeur change en « Speak » et un message « Resign » est envoyé.

La commande standby track vous permet de spécifier une autre interface sur le routeur pour surveiller le processus HSRP, en vue de modifier la priorité HSRP pour un groupe donné. Si le protocole de ligne de l'interface spécifiée échoue, la priorité HSRP est réduite. Ainsi, un autre routeur HSRP de priorité plus élevée peut devenir le routeur actif si standby preempt est activé.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Version de logiciel 12.2(10b) de Ý de Cisco IOS

  • Routeurs Cisco 2503

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

Ce diagramme est un exemple qui décrit l'utilisation conjointe des commandes standby preempt et standby track.

6a.gif

Exemples de configuration

Dans le diagramme de réseau, HSRP est configuré de cette manière :

  • R1 est le routeur actif et suit l'état de l'interface R1 série 0. Quand R1 est le routeur actif, tout le trafic des hôtes (hôtes 1, 2 et 3) vers les serveurs est routé via R1.

  • R2 est le routeur actif et suit l'état de l'interface R2 série 1.

  • Si R1 l'interface de l'interface série 0 descend, le hsrp priority R1 est diminué de 10. en ce moment que le hsrp priority R2 est le supérieur à R1, et R2 succède en tant que routeur actif. Quand R2 devient le routeur actif, tout le trafic des hôtes vers les serveurs est routé via R2.

Remarque: La passerelle par défaut pour les hôtes 1, 2, et 3 est configurée avec l'adresse IP virtuelle de HSRP (171.16.6.100, dans ce cas). Par exemple, un protocole de routage RIP est configuré sur les routeurs pour activer la connectivité entre les hôtes et les serveurs.

Voici la configuration de chaque routeur :

Routeur 1 (Cisco 2503)
interface Ethernet0 
ip address 171.16.6.5 255.255.255.0

!--- Assigns an IP address to the interface.

no ip redirects 
standby 1 ip 171.16.6.100

!--- Assigns a standby group and standby IP address

standby 1 priority 105

!--- Assign a priority (105 in this case) to the router interface (e0)
!--- for a particular group number (1). The default is 100.

standby 1 preempt

!--- Allows the router to become the active router when the priority 
!--- is higher than all other HSRP-configured routers in the hot standby group. 
!--- If you do not use the standby preempt command in the configuration 
!--- for a router, that router does not become the active router, even if 
!--- the priority is higher than all other routers. 

standby 1 track Serial0

!--- Indicates that HSRP tracks Serial0 interface. 
!--- The interface priority can also be configured, which indicates the 
!--- amount by which the router priority decreases when 
!--- the interface goes down. The default is 10.

interface Serial0 
ip address 171.16.2.5 255.255.255.0

Routeur 2 (Cisco 2503)
interface Ethernet0
ip address 171.16.6.6 255.255.255.0

!--- Assigns an IP address to the interface.

no ip redirects
standby 1 ip

!--- Indicates the hot standby group. Here the IP address of the virtual router 
!--- is not configured. See the note after this table.

standby 1 preempt

!--- Allows the router to become the active router when the priority 
!--- is higher than all other HSRP-configured routers in the hot standby group. 
!--- If you do not use the standby preempt command in the configuration 
!--- for a router, that router does not become the active router, even if 
!--- the priority is higher than all other routers. 

standby 1 track Serial1

!--- Indicates that HSRP tracks Serial1 interface. 
!--- The interface priority can also be configured, which indicates the 
!--- amount by which the router priority decreases when 
!--- the interface goes down. The default is 10.
!--- The priority is also not configured and hence the default 
!--- priority value of 100 is applied.

interface Serial1
ip address 171.16.7.6 255.255.255.0

Remarque: R2 ne dispose pas d'une adresse IP de veille configurée. L'objectif consiste à démontrer qu'il s'agit d'une configuration valide. Quand R1 et R2 échangent des messages HSRP « Hello », R2 retient l'adresse IP de veille de R1. La configuration de R2 avec une adresse IP de veille (identique à celle de R1) constitue également une configuration valide.

R1# show standby
Ethernet0 - Group 1
Local state is Active, priority 105, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.458
Virtual IP address is 171.16.6.100 configured
Active router is local
Standby router is 171.16.6.6 expires in 8.428
Virtual mac address is 0000.0c07.ac01
2 state changes, last state change 02:09:49
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 1 up:
Interface    Decrement  State
Serial0         10      Up
 
R2# show standby
Ethernet0 - Group 1
Local state is Standby, priority 100, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.814
Virtual IP address is 171.16.6.100
Active router is 171.16.6.5, priority 105 expires in 9.896
Standby router is local
3 state changes, last state change 00:10:21
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 1 up:
Interface   Decrement  State
Serial1        10      Up

Bien que R2 n'ait pas de priorité HSRP configurée, la sortie affiche la priorité R2 comme étant la valeur HSRP par défaut, c'est-à-dire 100. La sortie des deux routeurs indique que les routeurs suivent l'état de l'interface de série 0. R1 est actif et R2 en veille. Au final, les deux routeurs sont configurés avec la commande standby preempt.

Que se produit-il si l'interface R1 série 0 tombe en panne ? La sortie de la commande show standby se présente ainsi :

R1# show standby
Ethernet0 - Group 1
Local state is Standby, priority 95 (confgd 105), may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 2.670
Virtual IP address is 171.16.6.100 configured
Active router is 171.16.6.6, priority 100 expires in 8.596
Standby router is local
4 state changes, last state change 00:01:45
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 0 up:
Interface    Decrement  State
Serial0         10      Down
   
R2# show standby
Ethernet0 - Group 1
Local state is Active, priority 100, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 0.810
Virtual IP address is 171.16.6.100
Active router is local
Standby router is 171.16.6.5 expires in 9.028
Virtual mac address is 0000.0c07.ac01
4 state changes, last state change 00:01:38
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 1 up:
Interface   Decrement  State
Serial1        10      Up

Avis dans la sortie que le hsrp priority de R1 est réduit de 10 — à 95. Cette modification augmente de 100 la priorité de R2. Alors que R2 était configuré pour le standby preempt et que sa priorité s'est accrue, il est devenu le routeur actif et R1 s'est mis en veille. Maintenant, si l'interface R1 série 0 est de nouveau opérationnelle, la priorité de R1 repasse à 105. Dans une telle situation, R1 prévaut et redevient le routeur actif HSRP.

Remarque: Si le standby preempt n'est pas configuré sur R2, R2 n'envoie pas de message "Coup" à R1, ce qui aurait fait passer R2 en routeur actif. R1 reste alors actif.

Observez par exemple la configuration suivante :

standby priority 120
standby track serial 0
standby track serial 1

Une priorité HSRP de 120 est configurée avec la commande standby priority et HSRP est configuré pour suivre l'état des interfaces série 0 et série 1. Puisqu'aucune valeur de décrément n'est spécifiée avec la commande standby track, la priorité HSRP est décrémentée de la valeur par défaut, 10, lorsque l'interface tombe en panne. Au départ, les deux interfaces sont disponibles et la priorité HSRP de l'interface est de 120, comme le montre la sortie de la commande show standby :

R1# show standby
Ethernet0 - Group 1
  Local state is Active, priority 120, may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 1.034
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:00:04
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 2 up:
    Interface                  Decrement  State
    Serial0                       10      Up
    Serial1                       10      Up
R1#

Désormais, l'interface Serial0 est désactivée.

R1#
1w0d: %LINK-3-UPDOWN: Interface Serial0, changed state to down
1w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
R1#

Ceci réduit le hsrp priority de 10 — de 120 à une valeur de 110. Vous pouvez utiliser la commande show standby pour effectuer la vérification suivante :

R1# show standby
Ethernet0 - Group 1
  Local state is Active, priority 110 (confgd 120), may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 2.544
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:00:48
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 1 up:
    Interface                  Decrement  State
    Serial0                       10      Down  (line protocol down)
    Serial1                       10      Up
R1#

Ensuite, le deuxième a dépisté l'interface — L'interface série 1 — est réduite :

R1#
1w0d: %LINK-3-UPDOWN: Interface Serial1, changed state to down
1w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, changed state to down
R1#

Ceci réduit de nouveau le hsrp priority de 10 — de 110 à une valeur de 100. Vous pouvez utiliser la commande show standby pour effectuer la vérification suivante :

R1# show standby
Ethernet0 - Group 1
  Local state is Active, priority 100 (confgd 120), may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 1.846
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:01:06
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 0 up:
    Interface                  Decrement  State
    Serial0                       10      Down  (line protocol down)
    Serial1                       10      Down  (line protocol down)
R1#

Lorsque l'une des interfaces (série 0 ou série 1) tombe en panne, la priorité passe à 110. Lorsque ces deux interfaces suivies (série 0 et série 1) tombent en panne, la priorité passe à 100.

Remarque: Dans certaines versions plus anciennes de Cisco IOS, le décrément de priorité HSRP n'est pas cumulatif si vous ne définissez pas explicitement la valeur de décrément avec la commande standby track. Référez-vous au bogue Cisco ayant l'ID CSCdp72834 (clients enregistrés uniquement) pour plus d'informations.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 13780