IP : Traduction d'adresses de réseau (NAT)

Pools NAT et sous-réseau zéro

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document discute comment les groupes de Traduction d'adresses de réseau (NAT) sont sujets à des règles de sous-réseau zéro juste comme toutes les autres adresses IP.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Théorie générale

Quand vous configurez un groupe NAT tels que les adresses dans le groupe font partie de sous-réseau zéro, la traduction NAT échoue.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir plus d'informations sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés uniquement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/13777/7a.gif

Dans cet exemple de configuration, le périphérique interne a un default route du routeur NAT. Le périphérique externe a une artère statique à une adresse à laquelle le périphérique interne est traduit. Le routeur NAT a cette configuration NAT :

ip nat pool test 171.68.1.1 171.68.1.10 netmask  255.255.240.0
ip nat inside source list 7 pool test 

interface s 0
ip address 171.16.4.6 255.255.255.0
ip nat inside

interface s 1
ip address 171.16.6.6 255.255.255.0
ip nat outside

access-list 7 permit host 171.16.4.4

Notez que les adresses dans le test NAT de groupe sont des adresses de sous-réseau zéro. Le ping du périphérique interne au périphérique externe échoue parce qu'aucune traduction ne se produit. Si vous exécutez la commande de debug ip nat sur le routeur NAT, elle indique ces messages :

NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5

Remarque: Le « (a) » dans la sortie de débogage signifie que la traduction a manqué après qu'acheminement produit.

Remarque: Afin d'éviter ce problème, configurez la commande d'ip subnet-zero dans le routeur NAT. La commande est activée par défaut dans la version de logiciel 12.0 de½ du¿Â du Cisco IOSïÂ. Dans des versions logicielles plus tôt de Cisco IOS, il n'est pas activé par défaut. Si le NAT n'est pas configuré correctement une fois utilisé avec PAT, alors la traduction NAT peut échouer. Ce sont les codes de panne de traduction NAT :

 A = Inside to outside fails after routing
 B = Outside to inside fails before routing
 C = Outside to inside fails after routing 
 D = Helpered fails 
 L = Internally generated packet fails 
 E = Inside to outside fails after routing

Informations connexes


Document ID: 13777