IP : Traduction d'adresses de réseau (NAT)

Exemple de configuration à l'aide de la commande ip nat outside source static

18 juin 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (21 avril 2016) | Commentaires


Contenu


Introduction

Ce document fournit un exemple de configuration avec l'utilisation de la commande ip nat outside source static et comporte une brève description de ce qui arrive au paquet IP pendant le processus NAT. Considérez la topologie du réseau dans ce document comme exemple.

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

Voyez la section « de l'information relative » de ce document pour de plus amples informations.

Composants utilisés

Les informations dans ce document sont basées sur le Routeurs de la gamme Cisco 2500 sur la version de logiciel 12.2(27) de ½ du ¿  de Cisco IOSïÂ.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous présente les informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez le Command Lookup Tool (clients enregistrés uniquement) pour rechercher les informations supplémentaires sur les commandes que ce document utilise.

Diagramme du réseau

Ce document utilise cette configuration du réseau.

http://www.cisco.com/c/dam/en/us/support/docs/ip/network-address-translation-nat/13773-2a.gif

Lorsque vous émettez un ping à partir de l'interface Loopback1 du routeur 2514W vers l'interface Loopback0 du routeur 2501E, voici ce qui se produit :

Sur l'interface externe (S1) du routeur 2514X, le paquet ping apparaît avec l'adresse source (SA) 172.16.89.32 et l'adresse de destination (DA) 171.68.1.1. NAT traduit l'adresse source (SA) à l'adresse locale extérieure 171.68.16.5 (selon la commande ip nat outside source staticconfigurée sur le routeur 2514X). Le routeur 2514X vérifie alors dans sa table de routage qu'il existe une route vers l'adresse 171.68.1.1. Si la route n'existe pas, le routeur 2514X rejette le paquet. Dans ce cas, le routeur 2514X a un routage vers 171.68.1.1 via la route statique vers 171.68.1.0. Il transmet le paquet à la destination. Le routeur 2501E voit le paquet sur son interface entrante (E0) avec l'adresse source (SA) 171.68.16.5, et l'adresse de destination (DA) 171.68.1.1. Il répond en envoyant une réponse d'écho d'Internet Control Message Protocol (ICMP) à 171.68.16.5. S'il n'a pas de route, il rejette le paquet. Dans ce cas, la route par défaut est attribuée. Par conséquent, il envoie un paquet de réponse au routeur 2514X en utilisant l'adresse source (SA) 171.68.1.1, et l'adresse de destination (DA) 171.68.16.5. Le routeur 2514X voit le paquet et vérifie qu'une route vers l'adresse 171.68.16.5 existe. S'il n'en a pas, il répond avec une réponse d'ICMP inaccessible. Dans ce cas, il dispose d'une route vers 171.68.16.5 (à cause de la route statique). Il traduit donc de nouveau le paquet vers l'adresse 172.16.89.32 et lui transmet à l'extérieur de son interface externe (S1).

Configurations

Ce document utilise les configurations suivantes :

Routeur 2514W
hostname 2514W 
! 


!--- Output suppressed.

interface Loopback1 
 ip address 172.16.89.32 255.255.255.0 
! 
interface Ethernet1 
 no ip address 
 no ip mroute-cache 
! 
interface Serial0 
 ip address 172.16.191.254 255.255.255.252 
 no ip mroute-cache 
! 

!--- Output suppressed.

ip classless 
ip route 0.0.0.0 0.0.0.0 172.16.191.253 

!--- Default route to forward packets to 2514X.

!


!--- Output suppressed.

Routeur 2514X
hostname 2514X 
! 


!--- Output suppressed.

ip nat outside source static 172.16.89.32 171.68.16.5 

!--- Outside local address.

! 


!--- Output suppressed.

interface Ethernet1 
 ip address 171.68.192.202 255.255.255.0 
 ip nat inside 

!--- Defines Ethernet 1 as a NAT inside interface.

 no ip mroute-cache 
 no ip route-cache 
! 
interface Serial1 
 ip address 172.16.191.253 255.255.255.252 
 no ip route-cache 
 ip nat outside 

!--- Defines Serial 1 as a NAT outside interface.

 clockrate 2000000 



! 


!--- Output suppressed.

ip classless  
ip route 171.68.1.0 255.255.255.0 171.68.192.201 
ip route 171.68.16.0 255.255.255.0 172.16.191.254 

!--- Static routes for reaching the loopback interfaces


!--- on 2514E and 2514W.

!


!--- Output suppressed.

Routeur 2501E
hostname rp-2501E 
! 


!--- Output suppressed.

interface Loopback0 
 ip address 171.68.1.1 255.255.255.0 
! 
interface Ethernet0 
 ip address 171.68.192.201 255.255.255.0 
! 


!--- Output suppressed.

ip classless 
ip route 0.0.0.0 0.0.0.0 171.68.192.202 

!--- Default route to forward packets to 2514X.

!


!--- Output suppressed.

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Utilisez la commande show ip nat translations pour contrôler la traduction des entrées, comme dans la sortie ci-dessous.

2514X#show ip nat translations
Pro Inside global      Inside local       Outside local      Outside global
--- ---                ---                171.68.16.5        172.16.89.32
2514X#

Dépannez

Cet exemple utilise le débogage de traduction NAT et le débogage de paquet IP pour expliquer le processus NAT.

Remarque: Puisque les commandes de débogage produisent une importante quantité de sortie, utilisez-les seulement quand le trafic sur le réseau IP est faible afin que l'autre activité sur le système ne soit pas compromise.

Remarque: Référez-vous aux informations importantes sur les commandes de débogage avant d'utiliser les commandes de débogage.

Cette sortie est le résultat de l'exécution simultanée des commandes debug ip packet et debug ip nat sur le routeur 2514X, tout en envoyant un ping à partir de l'adresse de l'interface Loopback1 du routeur 2514W loopback1 (172.16.89.32) sur l'adresse de l'interface Loopback0 2501E (171.68.1.1)

Cette sortie montre le premier paquet arrivant sur l'interface extérieure du routeur 2514X. L'adresse source 172.16.89.32 est traduite vers l'adresse 171.68.16.5. Le paquet ICMP est transmis à la destination à l'extérieur de l'interface Ethernet1.

5d17h: NAT: s=172.16.89.32->171.68.16.5, d=171.68.1.1 [171]
5d17h: IP: tableid=0, s=171.68.16.5 (Serial0), d=171.68.1.1 (Ethernet0), routed
via RIB
5d17h: IP: s=171.68.16.5 (Serial0), d=171.68.1.1 (Ethernet0), g=171.68.192.201,
len 100, forward
5d17h:     ICMP type=8, code=0

Cette sortie montre le paquet de retour provenant de 171.68.1.1 avec l'adresse de destination 171.68.16.5, qui est ensuite traduite vers l'adresse 172.16.89.32. Le paquet ICMP obtenu est transmis à l'extérieur de l'interface Serial1.

5d17h: IP: tableid=0, s=171.68.1.1 (Ethernet0), d=171.68.16.5 (Serial0), routed
via RIB
5d17h: NAT: s=171.68.1.1, d=171.68.16.5->172.16.89.32 [171]
5d17h: IP: s=171.68.1.1 (Ethernet0), d=172.16.89.32 (Serial0), g=172.16.191.254,
 len 100, forward
5d17h:     ICMP type=0, code=0

L'échange des paquets ICMP continue. Le processus NAT pour cette sortie de débogage est identique à la sortie précédente.

5d17h: NAT: s=172.16.89.32->171.68.16.5, d=171.68.1.1 [172]
5d17h: IP: tableid=0, s=171.68.16.5 (Serial0), d=171.68.1.1 (Ethernet0), routed
via RIB
5d17h: IP: s=171.68.16.5 (Serial0), d=171.68.1.1 (Ethernet0), g=171.68.192.201,
len 100, forward
5d17h:     ICMP type=8, code=0
5d17h: IP: tableid=0, s=171.68.1.1 (Ethernet0), d=171.68.16.5 (Serial0), routed
via RIB
5d17h: NAT: s=171.68.1.1, d=171.68.16.5->172.16.89.32 [172]
5d17h: IP: s=171.68.1.1 (Ethernet0), d=172.16.89.32 (Serial0), g=172.16.191.254,
 len 100, forward
5d17h:     ICMP type=0, code=0
5d17h: NAT: s=172.16.89.32->171.68.16.5, d=171.68.1.1 [173]
5d17h: IP: tableid=0, s=171.68.16.5 (Serial0), d=171.68.1.1 (Ethernet0), routed
via RIB
5d17h: IP: s=171.68.16.5 (Serial0), d=171.68.1.1 (Ethernet0), g=171.68.192.201,
len 100, forward
5d17h:     ICMP type=8, code=0
5d17h: IP: tableid=0, s=171.68.1.1 (Ethernet0), d=171.68.16.5 (Serial0), routed
via RIB
5d17h: NAT: s=171.68.1.1, d=171.68.16.5->172.16.89.32 [173]
5d17h: IP: s=171.68.1.1 (Ethernet0), d=172.16.89.32 (Serial0), g=172.16.191.254,
 len 100, forward
5d17h:     ICMP type=0, code=0
5d17h: NAT: s=172.16.89.32->171.68.16.5, d=171.68.1.1 [174]
5d17h: IP: tableid=0, s=171.68.16.5 (Serial0), d=171.68.1.1 (Ethernet0), routed
via RIB
5d17h: IP: s=171.68.16.5 (Serial0), d=171.68.1.1 (Ethernet0), g=171.68.192.201,
len 100, forward
5d17h:     ICMP type=8, code=0
5d17h: IP: tableid=0, s=171.68.1.1 (Ethernet0), d=171.68.16.5 (Serial0), routed
via RIB
5d17h: NAT: s=171.68.1.1, d=171.68.16.5->172.16.89.32 [174]
5d17h: IP: s=171.68.1.1 (Ethernet0), d=172.16.89.32 (Serial0), g=172.16.191.254,
 len 100, forward
5d17h:     ICMP type=0, code=0
5d17h: NAT: s=172.16.89.32->171.68.16.5, d=171.68.1.1 [175]
5d17h: IP: tableid=0, s=171.68.16.5 (Serial0), d=171.68.1.1 (Ethernet0), routed
via RIB
5d17h: IP: s=171.68.16.5 (Serial0), d=171.68.1.1 (Ethernet0), g=171.68.192.201,
len 100, forward
5d17h:     ICMP type=8, code=0
5d17h: IP: tableid=0, s=171.68.1.1 (Ethernet0), d=171.68.16.5 (Serial0), routed
via RIB
5d17h: NAT: s=171.68.1.1, d=171.68.16.5->172.16.89.32 [175]
5d17h: IP: s=171.68.1.1 (Ethernet0), d=172.16.89.32 (Serial0), g=172.16.191.254,
 len 100, forward
5d17h:     ICMP type=0, code=0

Résumé

Quand le paquet se déplace de l'extérieur vers l'intérieur, la traduction se produit dans un premier temps, puis la table de routage est examinée pour vérifier que la destination existe. Quand le paquet se déplace de l'extérieur vers l'intérieur, la table de routage est examinée dans un premier temps pour vérifier que la destination existe, et la traduction se produit ensuite. Référez-vous à la commande NAT d'opération pour de plus amples informations.

Il est important de noter quelle partie du paquet IP est traduite quand on utilise chacune des commandes dont parle ce document. Ce tableau contient des directives :

Commande Action
Commande statique ip nat outside source
  • Traduit la source des paquets IP se déplaçant de l'extérieur vers l'intérieur.
  • Traduit la destination des paquets IP se déplaçant de l'intérieur vers l'extérieur.
Commande statique ip nat inside source
  • Traduit la source des paquets IP se déplaçant de l'intérieur vers l'extérieur.
  • Traduit la destination des paquets IP se déplaçant de l'extérieur vers l'intérieur.

Ces directives indiquent qu'il existe plus d'une manière de traduire un paquet. Selon vos besoins spécifiques, vous devriez déterminer la manière de définir les interfaces NAT (intérieures ou extérieures) ainsi que le contenu des tables de routage avant ou après traduction. Gardez à l'esprit que la partie du paquet traduit dépend de la direction que le paquet dans laquelle il se déplace et de la manière dont vous configurez la traduction NAT.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 13773