IP : Protocole BGP (Border Gateway Protocol)

Comment utiliser HSRP pour assurer la redondance dans un réseau BGP multihébergé

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document décrit comment fournir la redondance dans un réseau multirésident de Border Gateway Protocol (BGP) où vous avez des connexions à deux fournisseurs d'accès Internet distincts (ISP). En cas d'une panne de connectivité vers un ISP, le trafic est rerouté dynamiquement par l'autre ISP avec la commande BGP set as-path {tag | prepend as-path-string} et le Hot Standby Router Protocol (HSRP).

Conditions préalables

Conditions requises

Les lecteurs de ce document devraient avoir connaissance des sujets suivants :

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

L'objectif de la configuration dans ce document est de réaliser cette politique réseau :

  • Tout le trafic sortant originaire des hôtes sur le réseau 192.168.21.0/24 et destiné à l'Internet doit être conduit par R1 à ISP-A. Cependant, si ce lien échoue ou R1 échoue, tout le trafic sortant doit être rerouté par R2 à l'ISP B (et puis à l'Internet) sans intervention manuelle.

  • Tout le trafic d'arrivée destiné à un Autonomous System, AS 100, de l'Internet doit être conduit par R1. Au cas où le lien d'ISP-A à R1 échouerait, le trafic d'arrivée doit automatiquement être rerouté par l'ISP B à R2.

Ces conditions requises peuvent être rencontrées deux Technologies : BGP et HSRP.

Le premier objectif d'un chemin de sortie entièrement redondant peut être réalisé avec le HSRP. Typiquement les PC n'ont pas la capacité pour collecter et permuter les informations de routage. L'adresse IP de la passerelle par défaut est statiquement configurée sur un PC et si le routeur de passerelle descend, le PC perd la Connectivité à n'importe quel périphérique au delà de son segment de réseau local. C'est le cas même si une passerelle alternative existe. Le HSRP a été conçu pour répondre à ces exigences. Référez-vous au pour en savoir plus de fonctionnalités et caractéristiques de HSRP.

Le deuxième objectif peut être atteint avec le set as-path BGP ajoutent la commande au début, qui permet au BGP pour propager un plus long PENDANT QUE chemin (par ajouter son propre numéro de système autonome au début plus d'une fois) par le R2 au lien d'ISP B pour le préfixe 192.168.21.0/24. Ainsi, tous trafiquent destiné à 192.168.21.0/24 qui est livré de l'extérieur de l'AS 100 prend le plus court PENDANT QUE chemin par l'ISP-A au lien R1. Si le chemin primaire (ISP-A à R1) échoue, tout le trafic prend le plus long PENDANT QUE le chemin (ISP B à R2) afin d'atteindre le réseau 192.168.21.0/24. Afin d'apprendre plus au sujet du set as-path BGP ajoutent la commande au début, se rapportent au diagramme d'attribut as_path dans le document d'études de cas de BGP.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau affichée ici :

Dans ce diagramme, le routeur 1 (R1) et le Router2 (R2) sont dans l'AS 100, qui a le BGP externe (eBGP) scrutant avec ISP-A (EN TANT QUE 300) et ISP B (EN TANT QUE 400) respectivement. Le routeur 6 (R6) est une partie de EN TANT QUE 600, qui a l'eBGP scrutant avec ISP-A et ISP B. R1. R2 a l'iBGP scrutant, qui est nécessaire pour assurer le routage optimal. Par exemple, quand vous essayez d'atteindre EN TANT QUE 400 routes internes, R1 n'utilise pas le chemin plus long plus d'EN TANT QUE 300. R1 en avant le trafic à R2 à la place.

R1 et R2 sont également configurés pour le HSRP au-dessus d'un segment commun d'Ethernets. Les hôtes sur le même segment d'Ethernets ont un default route ces points vers l'adresse IP de réserve 192.168.21.10 de HSRP.

hsrp_bgp-01.gif

Configurations

R1
Current configuration

hostname R1
!
interface serial 0
ip address 192.168.31.1 255.255.255.0
!
interface Ethernet1
  ip address 192.168.21.1 255.255.255.0
  standby 1 priority 105
  standby 1 preempt delay minimum 60
  standby 1 ip 192.168.21.10
  standby 1 track Serial0

!--- The 
standby track serial command tracks the state of 
!--- the Serial0 interface and brings down the  
!--- priority of standby group 1, if the interface goes down.
!--- The 
standby preempt delay minimum 60 command makes sure that 
!--- R1 preempts and takes over as active router again. This command also ensures that
!--- the router waits 60 seconds before doing so in order to give BGP time enough
!--- to converge and populate the routing table. This avoids
!--- traffic being sent to R1 before it is ready to forward it.

!
!
router bgp 100
  no synchronization
  network 192.168.21.0
  neighbor 192.168.21.2 remote-as 100
  neighbor 192.168.21.2 next-hop-self
  neighbor 192.168.31.3 remote-as 300
  no auto-summary
!

R2
Current configuration:  

hostname  R2 
!
interface serial 0  
ip address 192.168.42.2 255.255.255.0  
!
interface Ethernet1  
 ip address 192.168.21.2 255.255.255.0  
 standby 1 priority 100  
 standby 1 preempt  
 standby 1 ip 192.168.21.10  
! 
!  
router bgp 100  
 no synchronization  
 network 192.168.21.0   
 neighbor 192.168.21.1 remote-as 100  
 neighbor 192.168.21.1 next-hop-self  
 neighbor 192.168.42.4 remote-as 400  
 neighbor 192.168.42.4 route-map foo out 

!--- It appends AS 100 to the BGP updates sent to AS 400 
!--- in order to make it a backup for the ISP-A to R1 path.

 no auto-summary  
!  
access-list 1 permit 192.168.21.0  
route-map foo permit 10  
 match ip address 1  
 set as-path prepend 100  

end

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Quand vous configurez la Redondance dans n'importe quel réseau, vous devez considérer deux choses :

  • La création d'un chemin redondant pour des paquets allant d'un réseau local à un réseau de destination.

  • La création d'un chemin redondant pour des paquets revenant d'une destination à un réseau local.

Paquets allant du réseau local vers la destination

Dans cet exemple, le réseau local est 192.168.21.0/24. Le routeur R1 et R2 exécutent le HSRP sur le segment d'Ethernets connecté pour relier Ethernet1. R1 est configuré en tant que routeur actif de HSRP avec un standby priority de 105, et R2 est configuré avec un standby priority de 100. La commande de la piste Serial0 (s0) du standby 1 sur R1 permet au processus de HSRP pour surveiller cette interface. Si l'état d'interface descend, le hsrp priority est réduit. Quand la ligne protocole de l'interface s0 descend, le hsrp priority est réduit à 95 (la valeur par défaut par laquelle la priorité est réduite est 10). Ceci fait l'autre routeur de HSRP, R2, ont une haute priorité (une priorité de 100). R2 va bien au routeur actif de HSRP et attire le trafic destiné à l'adresse 192.169.21.10 de HSRP actif.

Émettez la commande de show standby afin de voir le routeur HSRP actif quand l'interface s0 sur R1 est en hausse :

R1#show standby 
   Ethernet1 - Group 1 
     Local state is Active, priority 105, may preempt 
     Hellotime 3 sec, holdtime 10 sec 
     Next hello sent in 0.338 
     Virtual IP address is 192.168.21.10 configured 
     Active router is local 
     Standby router is 192.168.21.2 expires in 8.280 
     Virtual mac address is 0000.0c07.ac01 
     13 state changes, last state change 00:46:10 
     IP redundancy name is "hsrp-Et0-1"(default) 
     Priority tracking 1 interface, 1 up: 
     Interface                    Decrement   State 
     Serial0                          10      Up 

R2#show standby 
   Ethernet1 - Group 1
     State is Standby
     56 state changes, last state change 00:05:13
     Virtual IP address is 192.168.21.10
     Active virtual MAC address is 0000.0c07.ac01
     Local virtual MAC address is 0000.0c07.ac01 (default)
     Hello time 3 sec, hold time 10 sec
     Next hello sent in 1.964 secs
     Preemption enabled
     Active router is 192.168.21.1, priority 105 (expires in 9.148 sec)
     Standby router is local
     Priority 100 (default 100)
     IP redundancy name is "hsrp-Et0-1" (default)

R1#show standby ethernet 1 brief
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active addr     Standby addr    Group addr
Et1         1   105  P Active   local           192.168.21.2    192.168.21.10
R1#

R2#show standby ethernet 1 brief
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active          Standby         Virtual IP
Et1         1   100  P Standby  192.168.21.1    local           192.168.21.10
R2#

La commande de show standby affiche R1 en tant que routeur HSRP actif en raison de la haute priorité de 105. Puisque R1 est le routeur actif, R1 possède l'adresse IP de réserve 192.168.21.10. Tout le trafic IP de l'hôte configuré avec la passerelle par défaut aux artères de 192.168.21.10 par R1.

Si vous réduisez l'interface s0 sur le routeur R1, le routeur actif de HSRP change puisque le HSRP sur R1 est configuré avec la commande de l'interface série 0 de standby track. Quand le protocole d'interface de l'interface série 0 descend, le HSRP réduit la priorité de R1 de 10 (par défaut) à 95. R1 change son état au « standby ». R2 succède en tant que routeur actif, et possède ainsi l'adresse IP de réserve 192.168.21.10. En conséquence, tout le trafic destiné des hôtes dans les 192.168.21.0/24 artères de segment trafiquent par R2. Le débogage et la sortie de commande show confirme la même chose.

R1(config)# interface s0 
R1(config-if)# shut 
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Active         -> Speak 
 %LINK-5-CHANGED: Interface Serial0, changed state to administratively down 
 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down 
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Speak  -> Standby 
 %LINK-3-UPDOWN: Interface Serial0, changed state to down: 
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Active       -> Speak 
 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down 
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Speak  -> Standby 

Notez que R1 va bien à un routeur de réserve.

Si R2 entre dans l'état active, alors vous voyez la sortie semblable à ceci :

R2# 
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Standby        -> Active 

Si vous exécutez la commande de show standby sur R1 et R2, observez les standby priority après que l'interface s0 aille vers le bas sur R1 :

R1#show standby
Ethernet1 - Group 1
  Local state is Standby, priority 95 (confgd 105), may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 0.808
  Virtual IP address is 192.168.21.10 configured
  Active router is 192.168.21.2, priority 100 expires in 9.008
  Standby router is local
  15 state changes, last state change 00:00:40
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 1 interface, 0 up:
    Interface               Decrement   State
    Serial0                      10     Down  (administratively down)
R1#
 
R2#show standby
Ethernet1 - Group 1
  State is Active
    57 state changes, last state change 00:00:33
  Virtual IP address is 192.168.21.10
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (bia)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.648 secs
  Preemption enabled
  Active router is local
  Standby router is 192.168.21.1, priority 95 (expires in 7.096 sec)
  Priority 100 (default 100)
  IP redundancy name is "hsrp-Et0-1" (default)
R2#

R2#

R1#sh standby ethernet 1 brief
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active addr     Standby addr    Group addr
Et0         1   95   P Standby  192.168.21.2    local           192.168.21.10
R1# 

R2#sh standby ethernet 1 brief
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active          Standby         Virtual IP
Et0         1   100  P Active   local           192.168.21.1    192.168.21.10
R2#

Notez que le standby priority R1 a réduit de 105 à 95, et R2 est devenu le routeur actif.

Résumé

En cas d'une panne de connectivité entre ISP-A et R1, le HSRP réduit la priorité du groupe de veille sur R1. R1 va d'un état active à un état de réserve. R2 va d'un état de réserve à un état active. L'adresse IP de réserve 192.168.21.10 devient active sur R2, et héberge envoyer le trafic à l'utilisation R2 d'Internet et à l'ISP B, fournissant une voie de déroutement pour le trafic sortant.

Pour plus d'informations sur la commande de standby track de HSRP, référez-vous à comment utiliser les commandes de standby preempt et de standby track.

Paquets provenant la destination vers le réseau local

Selon la politique réseau définie dans la section Informations générales, puisqu'ISP-A est votre chemin primaire et l'ISP B est le chemin de sauvegarde pour le trafic étant livré vers 192.168.21.0/24 (pour des raisons telles qu'une plus grande connexion de bande passante vers ISP-A), vous pouvez ajouter votre propre numéro de système autonome dans les mises à jour BGP annoncées vers l'ISP B dans R2 pour faire PENDANT QUE le chemin à travers l'ISP B semblent plus long. Afin de faire ceci, configurez un mappage de route pour le voisin 192.168.42.4 BGP. Dans ce mappage de route, ajoutez vos propres moyens COMME avec le set as-path ajoutez la commande au début. Appliquez ce route-map aux mises à jour sortantes au voisin 192.168.42.4.

Remarque: Dans la production, vous devez ajouter le numéro de système autonome plus d'une fois pour s'assurer que l'artère annoncée devient moins préférée.

C'est la table BGP dans R6 pour le réseau 192.168.21.0 quand la Connectivité BGP entre R1 à ISP-A et R2 à l'ISP B est en hausse :

R6#
show ip bgp 192.168.21.0
BGP routing table entry for 192.168.21.0/24, version 30 
Paths: (2 available, best #1) 
  Advertised to non peer-group peers: 
    192.168.64.4 
  300 100 
    192.168.63.3 from 192.168.63.3 (10.5.5.5) 
      Origin IGP, localpref 100, valid, external, best, ref 2 
  400 100 100 
    192.168.64.4 from 192.168.64.4 (192.168.64.4) 
      Origin IGP, localpref 100, valid, external

Le BGP sélectionne le meilleur chemin comme COMME {300 100} par ISP-A parce qu'il a un plus petit COMME longueur de chemin en comparaison du COMME chemin {400 100 100} de l'ISP B. La raison là est une tout plus longue QUE la longueur de chemin de l'ISP B est en raison de CAR le chemin ajoutent la configuration au début dans R2.

Quand la Connectivité se casse entre R1 et ISP-A, R6 doit choisir la voie de déroutement par l'ISP B pour atteindre le réseau 192.168.21.0/24 dans l'AS 100 :

R1(config)#interface s0 
R1(config-if)#shut 
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down 

C'est la table BGP dans R6 pour le réseau 192.168.21.0/24 :

R6#show ip bgp 192.168.21.0 
BGP routing table entry for 192.168.21.0/24, version 31 
Paths: (1 available, best #1) 
  Advertised to non peer-group peers: 
    192.168.63.3 
  400 100 100 
    192.168.64.4 from 192.168.64.4 (192.168.64.4) 
      Origin IGP, localpref 100, valid, external, best

Référez-vous à la configuration d'échantillon pour le BGP avec deux fournisseurs de services différents (hébergement multiple) pour plus d'informations sur des configurations BGP dans un réseau multihomed.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.


Informations connexes


Document ID: 13768