IP : Protocole BGP (Border Gateway Protocol)

Partage de charge avec BGP en environnement mono et multihébergé : Exemples de configuration

19 octobre 2014 - Traduction automatique
Autres versions: PDFpdf | Anglais (19 septembre 2014) | Commentaires


Contenu


Introduction

Le partage de charge permet au routeur de distribuer le trafic sortant et entrant parmi plusieurs chemins. Les chemins sont dérivés statiquement ou avec des protocoles dynamiques, comme :

  • Protocole d'informations de routage (RIP)

  • Enhanced Interior Gateway Routing Protocol (EIGRP)

  • Protocole Open Shortest Path First (OSPF)

  • Interior Gateway Routing Protocol (IGRP)

Par défaut, le Border Gateway Protocol (BGP) sélectionne seulement un meilleur chemin simple et n'exécute pas l'équilibrage de charge. Ce document montre comment exécuter le partage de charge dans différents scénarios avec l'utilisation de BGP. Pour des informations supplémentaires sur l'équilibrage de charge, reportez-vous à Comment fonctionne l'équilibrage de charge ?.

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Partage de charge avec l'adresse de bouclage en tant que voisin BGP

Ce scénario montre comment réaliser le partage de charge quand il y a de multiples liaisons (jusqu'à un maximum de six) à coût égal. Les liaisons se terminent en un routeur dans un système local autonome (AS) et en un autre routeur dans un AS distant dans un environnement à résidence unique. Le diagramme de réseau sert d'exemple.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Cette section utilise cette configuration du réseau :

/image/gif/paws/13762/40a.gif

Configurations

Cette section utilise ces configurations :

RouterA
interface loopback 0
 ip address 1.1.1.1 255.255.255.0

interface serial 0
 ip address 160.20.20.1 255.255.255.0
 no ip route-cache
  
interface serial 1
 ip address 150.10.10.1 255.255.255.0
 no ip route-cache
  
router bgp 11
neighbor 2.2.2.2 remote-as 10
neighbor 2.2.2.2 update-source loopback 0

!--- Use the IP address of the loopback interface for TCP connections.

neighbor 2.2.2.2 ebgp-multihop

!--- You must configure ebgp-multihop whenever the external BGP (eBGP)
!--- connections are not on the same network address.


router eigrp 12
network 1.0.0.0
network 150.10.0.0
network 160.20.0.0
no auto-summary

RouterB
interface loopback 0
 ip address 2.2.2.2 255.255.255.0

interface serial 0
 ip address 160.20.20.2 255.255.255.0
 no ip route-cache

interface serial 1
 ip address 150.10.10.2 255.255.255.0
 no ip route-cache

router bgp 10
neighbor 1.1.1.1 remote-as 11
neighbor 1.1.1.1 update-source loopback 0

!--- Use the IP address of the loopback interface for TCP connections.


neighbor 1.1.1.1 ebgp-multihop

!--- You must configure ebgp-multihop whenever the eBGP connections
!--- are not on the same network address.

router eigrp 12
network 2.0.0.0
network 150.10.0.0
network 160.20.0.0
no auto-summary

Remarque: Vous pouvez utiliser des routes statiques au lieu d'un protocole de routage afin d'introduire deux voies d'accès à coût égal pour atteindre la destination. Dans ce cas, le protocole de routage est EIGRP.

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

La sortie de la commande show ip route montre que chacun des deux chemins vers le réseau 2.2.2.0 sont appris par l'intermédiaire d'EIGRP. La sortie de la commande traceroute indique que la charge est distribuée entre deux liaisons de série. Dans ce scénario, le partage de charge se produit sur une base par paquet. Vous pouvez lancer la commande ip route-cache sur les interfaces de série pour faire le partage de charge sur une base par destination. Vous pouvez également configurer l'équilibrage de charge par paquet et par destination avec Cisco Express Forwarding. Pour plus d'informations sur la façon de configurer Cisco Express Forwarding, reportez-vous à Configuration de Cisco Express Forwarding.

RouterA# show ip route

!--- Output suppressed.

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
     2.0.0.0/24 is subnetted, 1 subnets
D       2.2.2.0 [90/2297856] via 150.10.10.2, 00:00:45, Serial1
                [90/2297856] via 160.20.20.2, 00:00:45, Serial0
     160.20.0.0/24 is subnetted, 1 subnets
C       160.20.20.0 is directly connected, Serial0
     150.10.0.0/24 is subnetted, 1 subnets
C       150.10.10.0 is directly connected, Serial1

RouterA# traceroute 2.2.2.2 

Type escape sequence to abort.
Tracing the route to 2.2.2.2

1 160.20.20.2 16 msec
    150.10.10.2 8 msec *

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Partage de charge en cas de double-résidence vers un fournisseur de services Internet (ISP) par un routeur local simple

Ce scénario montre comment réaliser le partage de charge quand plusieurs liaisons existent entre un AS distant et un AS local. Ces liaisons terminent en un routeur sur l'AS local et des routeurs multiples sur un AS distant dans un environnement BGP à résidence simple. Le diagramme de réseau est un exemple d'un tel réseau.

Cet exemple de configuration utilise la commande maximum-paths. Par défaut, BGP choisit un meilleur chemin parmi de possibles voies d'accès à coût égal qui sont ont apprises d'un AS. Cependant, vous pouvez changer le nombre maximal de voies d'accès à coût égal parallèles qui sont permises. Afin d'apporter cette modification, intégrez la commande maximum-paths dans la configuration de BGP. Utilisez un chiffre entre 1 et 6 pour l'argument chemins.

Diagramme du réseau

Cette section utilise cette configuration du réseau :

40b.gif

Configurations

Cette section utilise ces configurations :

RouterA
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Serial 0
 ip address 160.20.20.1 255.255.255.0
!
!  
interface Serial 1
 ip address 150.10.10.1 255.255.255.0
!
! 
router bgp 11
neighbor 160.20.20.2 remote-as 10
neighbor 150.10.10.2 remote-as 10
network 1.0.0.0
maximum-paths 2

!--- This command specifies the maximum number of paths
!--- to install in the routing table for the specific destination.

RouterB
interface Ethernet0 
 ip address 2.2.2.1 255.255.255.0
!
interface Serial 0
 ip address 160.20.20.2 255.255.255.0
!
!
router bgp 10
neighbor 160.20.20.1 remote-as 11
network 2.0.0.0
auto-summary

RouterC
interface Ethernet0 
 ip address 2.2.2.2 255.255.255.0
!
interface Serial 1
 ip address 150.10.10.2 255.255.255.0
!
!
router bgp 10
neighbor 150.10.10.1 remote-as 11
network 2.0.0.0 
auto-summary

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

La sortie de la commande show ip route montre que chacun des deux chemins vers le réseau 2.2.2.0 sont appris par l'intermédiaire de BGP. La sortie de la commande traceroute indique que la charge est distribuée entre deux liaisons de série. Dans ce scénario, le partage de charge se produit sur une base par destination. La commande show ip bgp donne les entrées valides pour le réseau 2.0.0.0.

RouterA# show ip route

!--- Output suppressed.

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
B    2.0.0.0/8 [20/0] via 150.10.10.2, 00:04:23
               [20/0] via 160.20.20.2, 00:04:01
     160.20.0.0/24 is subnetted, 1 subnets
C       160.20.20.0 is directly connected, Serial0
     150.10.0.0/24 is subnetted, 1 subnets
C       150.10.10.0 is directly connected, Serial1
 
RouterA# traceroute 2.2.2.2 

Type escape sequence to abort.
Tracing the route to 2.2.2.2

1 160.20.20.2 16 msec
    150.10.10.2 8 msec * 

RouterA# show ip bgp

BGP table version is 3, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete 
	
Network 	Next Hop 	Metric 	LocPrf 	Weight Path    
*> 1.0.0.0 	0.0.0.0 	        	0 	32768  i    
*> 2.0.0.0 	160.20.20.2  0 			0 	10 i    
*               150.10.10.2  0 			0 	10 i

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Partage de charge en cas de double-résidence vers un ISP par plusieurs routeurs locaux

Ce scénario montre comment réaliser le partage de charge quand il y a des plusieurs connexions sur le même ISP par plusieurs routeurs locaux. Les deux homologues d'eBGP se terminent par deux routeurs locaux distincts. L'Équilibrage de charge sur les deux liaisons n'est pas possible parce que BGP choisit le meilleur chemin simple appris de l'eBGP et BGP interne (iBGP)parmi les réseaux. Le partage de charge parmi plusieurs chemins vers l'AS 10 est la deuxième meilleure option. Avec ce type de partage de charge, le trafic vers des réseaux spécifiques, sur la base de stratégies prédéfinies, circule par les deux liaisons. En outre, chaque liaison agit en tant que solution de secours pour l'autre liaison, au cas l'une d'entre elles ne marcherait pas.

Pour simplifier, supposez que la stratégie de routage BGP pour l'AS 11 soit :

  • AS 11 accepte les routes locales de l'AS 10, conjointement avec un défaut pour le reste des routes Internet.

  • La stratégie de trafic sortant est :

    • Tout trafic qui se destine à Internet depuis R101 sort par la liaison R101-R103.

    • Si la liaison R101-R103 ne marche pas, alors tout le trafic vers Internet depuis R101 passe par R102 vers l'AS 10.

    • De même, tout trafic qui se destine à Internet depuis R102 passe par la liaison R102-R104.

    • Si la liaison R102-R104 ne marche pas, alors tout le trafic vers Internet depuis R102 passe par R101 vers l'AS 10.

  • La stratégie de trafic entrant est :

    • Le trafic qui est destiné au réseau 192.168.11.0/24 depuis Internet devrait provenir de la liaison R103-R101.

    • Le trafic qui est destiné au réseau 192.168.12.0/24 depuis Internet devrait provenir de la liaison R104-R102.

    • Si une liaison vers l'AS 10 ne marche pas, alors l'autre liaison devrait réacheminer le trafic qui se destine à tous les réseaux vers l'AS 11 depuis Internet.

Afin de réaliser ceci, 192.168.11.0 est annoncé de R101 à R103 avec un AS_PATH plus court que celui annoncé de R102 à R104. L'AS 10 trouve le meilleur chemin par la liaison R103-R101. De même, 192.168.12.0 est annoncé avec un chemin plus court à travers la liaison R102-R104. L'AS 10 préfère la liaison R104-R102 pour le trafic qui est lié à 192.168.12.0 dans l'AS 11.

Pour le trafic sortant, BGP détermine le meilleur chemin sur la base des routes qui sont ont apprises à travers eBGP. Ces routes sont préférables aux routes apprises par l'iBGP. Ainsi, R101 apprend 10.10.34.0 de R103 par l'eBGP et de R102 par l'iBGP. Le chemin externe est sélectionné en priorité sur le chemin interne. Ainsi, si vous regardez la table BGP dans la configuration R101 , la route vers 10.10.34.0 se ferait par la liaison R101-R103, avec le prochain saut 10.10.13.3. Sur R102, la route vers 10.10.34.0 passerait par la liaison R102-R104, avec le prochain saut 10.10.24.4. Ceci permet le partage de charge pour le trafic qui se destine à 10.10.34.0. Un raisonnement semblable s'applique aux routes par défaut sur R101 et R102. Pour plus d'informations sur les critères de sélection de chemin par BGP, reportez-vous à l'Algorithme de sélection du meilleur chemin BGP.

Diagramme du réseau

Cette section utilise cette configuration du réseau :

40c.gif

Configurations

Cette section utilise ces configurations :

R101
hostname R101

!
interface Ethernet0/0
 ip address 192.168.11.1 255.255.255.0 secondary
 ip address 192.168.12.1 255.255.255.0
!
interface Serial8/0
 ip address 10.10.13.1 255.255.255.0
!
router bgp 11
 no synchronization
 bgp log-neighbor-changes
 network 192.168.11.0
 network 192.168.12.0
 neighbor 10.10.13.3 remote-as 10
 neighbor 10.10.13.3 route-map R101-103-MAP out

!--- The AS_PATH is increased for 192.168.12.0.

 neighbor 192.168.12.2 remote-as 11
 neighbor 192.168.12.2 next-hop-self
 maximum-paths 2
 no auto-summary
!
access-list 1 permit 192.168.12.0
access-list 2 permit 192.168.11.0
route-map R101-103-MAP permit 10
 match ip address 1
 set as-path prepend 11 11 11
!         
route-map R101-103-MAP permit 20
 match ip address 2

R102
hostname R102
!

interface Ethernet0/0
 ip address 192.168.11.2 255.255.255.0 secondary
 ip address 192.168.12.2 255.255.255.0
!
interface Serial8/0
 ip address 10.10.24.2 255.255.255.0
!
router bgp 11
 no synchronization
 bgp log-neighbor-changes
 network 192.168.11.0
 network 192.168.12.0
 neighbor 10.10.24.4 remote-as 10
 neighbor 10.10.24.4 route-map R102-104-MAP out

!--- The AS_PATH is increased for 192.168.11.0.

 neighbor 192.168.12.1 remote-as 11
 neighbor 192.168.12.1 next-hop-self
 no auto-summary
!
access-list 1 permit 192.168.11.0
access-list 2 permit 192.168.12.0
route-map R102-104-MAP permit 10
 match ip address 1
 set as-path prepend 11 11 11
!         
route-map R102-104-MAP permit 20
 match ip address 2
!

R103
hostname R103
!
interface Ethernet0/0
 ip address 10.10.34.3 255.255.255.0
!
interface Serial8/0
 ip address 10.10.13.3 255.255.255.0
!
router bgp 10
no synchronization
 bgp log-neighbor-changes
 network 10.10.34.0 mask 255.255.255.0
 neighbor 10.10.13.1 remote-as 11
 neighbor 10.10.13.1 default-originate
 neighbor 10.10.34.4 remote-as 10
 neighbor 10.10.34.4 next-hop-self
 no auto-summary
 !

R104
hostname R104
!

interface Ethernet0/0
 ip address 10.10.34.4 255.255.255.0

!
interface Serial8/0
 ip address 10.10.24.4 255.255.255.0
!
router bgp 10
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.10.24.2 remote-as 11
 neighbor 10.10.24.2 default-originate
 neighbor 10.10.34.3 remote-as 10
 neighbor 10.10.34.3 next-hop-self
 no auto-summary
!

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Vérification quand les deux liaisons entre l'AS 11 et l'AS 10 sont activées

Vérification du trafic sortant

Remarque: Le signe plus grand que (>) dans la sortie de commande show ip bgp représente le meilleur chemin à utiliser pour ce réseau parmi les divers chemins possibles. Reportez-vous à l'Algorithme de sélection du meilleur chemin BGP pour plus d'informations.

La table BGP dans R101 montre que le meilleur chemin pour tout le trafic sortant vers Internet est la liaison R101-R103. La sortie de commande show ip route confirme les routes dans la table de routage.

R101# show ip bgp

BGP table version is 5, local router ID is 192.168.12.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
* i0.0.0.0          192.168.12.2                  100      0 10 i
*>                  10.10.13.3                             0 10 i  
!--- This is the next hop of R103.

* i10.10.34.0/24    192.168.12.2                  100      0 10 i
*>                  10.10.13.3               0             0 10 i  
!--- This is the next hop of R103.

* i192.168.11.0     192.168.12.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i
* i192.168.12.0     192.168.12.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i

R101# show ip route

!--- Output suppressed.

Gateway of last resort is 10.10.13.3 to network 0.0.0.0

C    192.168.12.0/24 is directly connected, Ethernet0/0
C    192.168.11.0/24 is directly connected, Ethernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.13.0 is directly connected, Serial8/0
B       10.10.34.0 [20/0] via 10.10.13.3, 00:08:53 
!--- This is the next hop of R103.

B*   0.0.0.0/0 [20/0] via 10.10.13.3, 00:08:53     
!--- This is the next hop of R103.

Voici les tables BGP et de routage pour R102. Selon la stratégie, R102 devrait acheminer tout le trafic vers l'AS 10 à travers la liaison R102-R104 :

R102# show ip bgp

BGP table version is 7, local router ID is 192.168.12.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 0.0.0.0          10.10.24.4                             0 10 i   
!--- This is the next hop of R104.

* i                 192.168.12.1                  100      0 10 i
*> 10.10.34.0/24    10.10.24.4                             0 10 i   
!--- This is the next hop of R104.

* i                 192.168.12.1             0    100      0 10 i
* i192.168.11.0     192.168.12.1             0    100      0 i
*>                  0.0.0.0                  0         32768 i
* i192.168.12.0     192.168.12.1             0    100      0 i
*>                  0.0.0.0                  0         32768 i

R102# show ip route

!--- Output suppressed.

Gateway of last resort is 10.10.24.4 to network 0.0.0.0

C    192.168.12.0/24 is directly connected, Ethernet0/0
C    192.168.11.0/24 is directly connected, Ethernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.24.0 is directly connected, Serial8/0
B       10.10.34.0 [20/0] via 10.10.24.4, 00:11:21   
!--- This is the next hop of R104.

B*   0.0.0.0/0 [20/0] via 10.10.24.4, 00:11:21       
!--- This is the next hop of R104.

Vérification du trafic entrant d'AS 10 à AS 11

Les réseaux 192.168.11.0 et 192.168.12.0 appartiennent à EN TANT QUE 11. selon la stratégie, l'AS 11 devrait préférer le lien R103-R101 pour le trafic qui est destiné au réseau 192.168.11.0 et au lien R104-R102 pour le trafic qui est destiné au réseau 192.168.12.0.

R103# show ip bgp

BGP table version is 4, local router ID is 10.10.34.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.10.34.0/24    0.0.0.0                  0         32768 i
*> 192.168.11.0     10.10.13.1               0             0 11 i             
!--- The next hop is R101.

*  192.168.12.0     10.10.13.1               0             0 11 11 11 11 i   
*>i                 10.10.34.4               0    100      0 11 i             
!--- The next hop is R104.


R103# show ip route

!--- Output suppressed.

Gateway of last resort is not set

B    192.168.12.0/24 [200/0] via 10.10.34.4, 00:04:46  
!--- The next hop is R104.

B    192.168.11.0/24 [20/0] via 10.10.13.1, 00:04:46   
!--- The next hop is R101.

     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.13.0 is directly connected, Serial8/0
C       10.10.34.0 is directly connected, Ethernet0/0

Le meilleur chemin pour le réseau 192.168.11.0 sur R103 est par le lien R103-R101, et le meilleur chemin pour le réseau 192.168.12.0 est par R104 à EN TANT QUE 11. dans ce cas, la longueur de plus court chemin détermine le meilleur chemin.

De même, sur R104, BGP et la table de routage ressemble à ceci :

R104# show ip bgp

BGP table version is 13, local router ID is 10.10.34.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i10.10.34.0/24    10.10.34.3               0    100      0 i
*>i192.168.11.0     10.10.34.3               0    100      0 11 i
*                   10.10.24.2               0             0 11 11 11 11 i
*> 192.168.12.0     10.10.24.2               0             0 11 i

R104# show ip route

!--- Output suppressed.

Gateway of last resort is not set

B    192.168.12.0/24 [20/0] via 10.10.24.2, 00:49:06    
!--- The next hop is R102.

B    192.168.11.0/24 [200/0] via 10.10.34.3, 00:07:36   
!--- The next hop is R103.

     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.24.0 is directly connected, Serial8/0
C       10.10.34.0 is directly connected, Ethernet0/0

Vérification quand la liaison R101-R103 ne marche pas

Quand la liaison R101-R103 ne marche pas, tout le trafic devrait être réacheminé par R102. Ce schéma illustre cette modification :

40d.gif

Fermez la liaison R103-R101 sur R103 afin de simuler cette situation.

R103(config)# interface serial 8/0
R103(config-if)# shutdown

*May 1 00:52:33.379: %BGP-5-ADJCHANGE: neighbor 10.10.13.1 Down Interface flap  
*May 1 00:52:35.311: %LINK-5-CHANGED: Interface Serial8/0, changed state to 
 administratively down
*May 1 00:52:36.127: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial8/0, changed 
 state to down

Vérifiez la route sortante vers l'AS 10.

R101# show ip bgp

BGP table version is 17, local router ID is 192.168.12.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i0.0.0.0          192.168.12.2                  100      0 10 i   
!--- This is the next hop of R102.

*>i10.10.34.0/24    192.168.12.2                  100      0 10 i   
!--- This is the next hop of R102.

* i192.168.11.0     192.168.12.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i
* i192.168.12.0     192.168.12.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i

R101# show ip route

!--- Output suppressed.

Gateway of last resort is 192.168.12.2 to network 0.0.0.0

C    192.168.12.0/24 is directly connected, Ethernet0/0
C    192.168.11.0/24 is directly connected, Ethernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
B       10.10.34.0 [200/0] via 192.168.12.2, 00:01:34
B*   0.0.0.0/0 [200/0] via 192.168.12.2, 00:01:34      
!--- All outbound traffic goes through R102.

     
R102# show ip route

!--- Output suppressed.

Gateway of last resort is 10.10.24.4 to network 0.0.0.0

C    192.168.12.0/24 is directly connected, Ethernet0/0
C    192.168.11.0/24 is directly connected, Ethernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.24.0 is directly connected, Serial8/0
B       10.10.34.0 [20/0] via 10.10.24.4, 00:13:22
B*   0.0.0.0/0 [20/0] via 10.10.24.4, 00:55:22         
!--- All outbound traffic on R102 goes through R104.

Vérifiez la route de trafic entrant quand R101-R103 est désactivé.

R103# show ip bgp

BGP table version is 6, local router ID is 10.10.34.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.10.34.0/24    0.0.0.0                  0         32768 i
*>i192.168.11.0     10.10.34.4               0    100      0 11 11 11 11 i
*>i192.168.12.0     10.10.34.4               0    100      0 11 i

R103# show ip route

!--- Output suppressed.

Gateway of last resort is not set

B    192.168.12.0/24 [200/0] via 10.10.34.4, 00:14:55      
!--- The next hop is R104.

B    192.168.11.0/24 [200/0] via 10.10.34.4, 00:05:46      
!--- The next hop is R104.

     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.34.0 is directly connected, Ethernet0/0

Sur R104, le trafic pour 192.168.11.0 et 192.168.12.0 passe par la liaison R104-R102.

R104# show ip route

!--- Output suppressed.

Gateway of last resort is not set

B    192.168.12.0/24 [20/0] via 10.10.24.2, 00:58:35    
!--- The next hop is R102.

B    192.168.11.0/24 [20/0] via 10.10.24.2, 00:07:57    
!--- The next hop is R102.

     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.24.0 is directly connected, Serial8/0
C       10.10.34.0 is directly connected, Ethernet0/0

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Partage de charge en cas de multihébergement par deux ISP via un seul routeur local

Dans ce scénario, l'équilibrage de charge n'est pas une option dans un environnement à résidences multiples, ainsi vous pouvez seulement faire le partage de charge. Vous ne pouvez pas faire l'équilibrage de charge parce que BGP sélectionne seulement un meilleur chemin simple vers une destination parmi les routes BGP qui sont apprises de différents AS. L'idée est de définir une meilleure métrique pour les routes dans la gamme de 1.0.0.0 à 128.0.0.0 qui sont ont apprises de l'ISP (A) et une meilleure métrique pour le reste des routes qui sont ont apprises de l'ISP (B). Le diagramme de réseau est un exemple.

Reportez-vous à l'exemple de configuration pour BGP avec deux fournisseurs de service différents (multi-résidence) pour des informations supplémentaires.

Diagramme du réseau

Cette section utilise cette configuration du réseau :

40e.gif

Configurations

Cette section utilise ces configurations :

RouterA
interface Serial 0
 ip address 160.20.20.1 255.255.255.0
 no ip route-cache
    
interface Serial 1
 ip address 150.10.10.1 255.255.255.0
 no ip route-cache
   
router bgp 11
neighbor 160.20.20.2 remote-as 10
neighbor 160.20.20.2 route-map UPDATES-1 in

!--- This allows only the networks up to 128.0.0.0.

neighbor 150.10.10.2 remote-as 12
neighbor 150.10.10.2 route-map UPDATES-2 in

!--- This allows anything above the 128.0.0.0 network.

auto-summary
  
route-map UPDATES-1 permit 10
match ip address 1
set weight 100
 
route-map UPDATES-1 permit 20
match ip address 2
  
route-map UPDATES-2 permit 10
match ip address 1
  
route-map UPDATES-2 permit 20
match ip address 2
set weight 100
  
access-list 1 permit 0.0.0.0  127.255.255.255
access-list 2 deny 0.0.0.0 127.255.255.255
access-list 2 permit any

RouterB
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
int loopback 1
 ip address 170.16.6.5 255.255.255.0
 
interface Serial 0
 ip address 160.20.20.2 255.255.255.0
 no ip route-cache
  
router bgp 10
neighbor 160.20.20.1 remote-as 11
network 2.0.0.0
network 170.16.0.0
auto-summary

RouterC
interface Loopback0 
 ip address 170.16.6.6 255.255.255.0
 
interface Loopback1 
 ip address 2.2.2.1 255.255.255.0
  
interface Serial 1
 ip address 150.10.10.2 255.255.255.0
 no ip route-cache
  
router bgp 12
neighbor 150.10.10.1 remote-as 11
network 2.0.0.0 
network 170.16.0.0
auto-summary

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

La sortie de la commande show ip route et la sortie de la commande traceroute montrent que tout réseau inférieur à 128.0.0.0 sort du RouteurA par 160.20.20.2. Cette route est le prochain saut hors de l'interface de série 0. Le reste des réseaux sortent par 150.10.10.2, qui est le prochain saut hors de la interface de série 1.

RouterA# show ip route

!--- Output suppressed.

Gateway of last resort is not set
B 	170.16.0.0/16 [20/0] via 150.10.10.2, 00:43:43		 
!--- This is the next hop out through serial 1.

B 	2.0.0.0/8 [20/0] via 160.20.20.2, 00:43:43			 
!--- This is the next hop out through serial 0.

    160.20.0.0/24 is subnetted, 1 subnets
C 		160.20.20.0 is directly connected, Serial0
    150.10.0.0/24 is subnetted, 1 subnets
C 		150.10.10.0 is directly connected, Serial1

RouterA# show ip bgp

BGP table version is 3, local router ID is 160.20.20.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
 Network Next Hop Metric LocPrf Weight Path
   Network          Next Hop            Metric LocPrf Weight Path
*  2.0.0.0          150.10.10.2              0             0 12 i
*>                  160.20.20.2              0           100 10 i
*  170.16.0.0       160.20.20.2              0             0 10 i
*>                  150.10.10.2              0           100 12 i
  
RouterA# traceroute  2.2.2.2

Type escape sequence to abort.
Tracing the route to 2.2.2.2 

1   160.20.20.2 16 msec * 16 msec 

RouterA# traceroute  170.16.6.6

Type escape sequence to abort.
Tracing the route to 170.16.6.6

1   150.10.10.2 4 msec * 4 msec

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Partage de charge en cas de multirésidence vers deux ISP par plusieurs routeurs locaux

L'équilibrage de charge n'est pas possible dans un environnement à résidences multiples avec deux ISP. BGP sélectionne seulement le meilleur chemin simple vers une destination parmi les chemins BGP qui sont appris de différents AS, ce qui rend l'équilibrage de charge impossible. Cependant, le partage de charge est possible dans de tels réseaux BGP multi-résidences. Sur la base de stratégies prédéterminées, le flux de trafic est contrôlé avec différents attributs BGP.

Cette section aborde la configuration multi-résidences qui est le plus fréquemment utilisée. La configuration montre comment réaliser le partage de charge. Voyez le diagramme de réseau dans lequel la multi-résidences de l'AS 100 permet la fiabilité et le partage de charge.

Remarque: Les adresses IP de cet exemple suivent des normes RFC 1918 pour l'espace d'adressage privé et ne sont pas routables sur Internet.leavingcisco.com

Pour simplifier, supposez que la stratégie de routage BGP pour l'AS 100 est :

  • L'AS 100 accepte les routes locales des deux fournisseurs, conjointement avec une par défaut pour le reste des routes Internet.

  • La stratégie de trafic sortant est :

    • Le trafic qui se destine à l'AS 300 passe par la liaison R1-ISP(A).

    • Le trafic qui se destine à l'AS 400 passe par la liaison R2-ISP(B).

    • Tout autre trafic devrait préférer la route par défaut 0.0.0.0 par la liaison R1-ISP(A).

    • Si la liaison R1-ISP(A) ne marche pas, tout le trafic devra passer par la liaison R2-ISP(B).

  • La stratégie de trafic entrant est :

    • Le trafic qui est destiné au réseau 10.10.10.0/24 d'Internet devrait provenir de la liaison ISP(A)-R1.

    • Le trafic qui est destiné au réseau 10.10.20.0/24 d'Internet devrait provenir de la liaison ISP(B)-R2.

    • Si un ISP échoue, l'autre ISP devrait réacheminer le trafic vers l'AS 100 d'Internet pour tous les réseaux.

Diagramme du réseau

Cette section utilise cette configuration du réseau :

40f.gif

Configurations

Cette section utilise ces configurations :

R2
interface Ethernet0
 ip address 192.168.21.2 255.255.255.0
 !
interface Serial0
  ip address 192.168.42.2 255.255.255.0  
router bgp 100  
 no synchronization  
 bgp log-neighbor-changes  

!--- The next two lines announce the networks to BGP peers.

 network 10.10.10.0 mask 255.255.255.0  
 network 10.10.20.0 mask 255.255.255.0  

!--- The next line configures iBGP on R1.
 
  neighbor 192.168.21.1 remote-as 100  
  neighbor 192.168.21.1 next-hop-self  

!--- The next line configures eBGP with ISP(B).
 
 neighbor 192.168.42.4 remote-as 400  

!--- This is the incoming policy route map for the application 
!--- of attributes to specific routes.
 
 neighbor 192.168.42.4 route-map AS-400-INCOMING in  

!--- This is the outgoing policy route map for the application 
!--- of attributes to specific routes.
 
 neighbor 192.168.42.4 route-map AS-400-OUTGOING out  
 no auto-summary  
!  
!  

!--- This line sets the AS path access list.
!--- The line permits all routes within the routing domain of the provider.

ip as-path access-list 1 permit ^400$  
!  

!--- These two lines set the access list.
 
access-list 10 permit 10.10.10.0 0.0.0.255  
access-list 20 permit 10.10.20.0 0.0.0.255  

!--- The next three lines configure LOCAL_PREF for routes 
!--- that match AS path access list 1.
 
route-map AS-400-INCOMING permit 10  
 match as-path 1  
 set local-preference 150  

!--- Here, the route map prepends AS 100 to BGP updates for networks 
!--- that are permitted by access list 10.
 
route-map AS-400-OUTGOING permit 10  
 match ip address 10  
 set as-path prepend 100  

!--- This line announces the network that is permitted by
!--- access list 20 without any changes in BGP attributes.
 
route-map AS-400-OUTGOING permit 20  
 match ip address 20

R1
interface Serial0/0   
 ip address 192.168.31.1 255.255.255.0  
!  
interface Ethernet1/0  
 ip address 192.168.21.1 255.255.255.0  
!  
router bgp 100  
 no synchronization  
 bgp log-neighbor-changes  
 network 10.10.10.0 mask 255.255.255.0  
 network 10.10.20.0 mask 255.255.255.0
   
!--- IBGP peering with R2 
neighbor 192.168.21.2 remote-as 100  
neighbor 192.168.21.2 next-hop-self  
! 

!--- This line sets eBGP peering with ISP(A).
 
neighbor 192.168.31.3 remote-as 300  
!  

!--- This is the incoming policy route map for the application 
!--- of attributes to specific routes.
 
 neighbor 192.168.31.3 route-map AS-300-INCOMING in  
!  

!--- This is the outgoing policy route map for the application 
!--- of attributes to specific routes.
 
neighbor 192.168.31.3 route-map AS-300-OUTGOING out  
 no auto-summary  
  

!--- This line sets the AS path access list.
!--- The line permits all routes within the routing domain of the provider.

ip as-path access-list 1 permit ^300$  
!  

!--- These two lines set the IP access list.

access-list 10 permit 10.10.20.0 0.0.0.255  
access-list 20 permit 10.10.10.0 0.0.0.255  


!--- The next three lines configure LOCAL_PREF for routes that match 
!--- AS path access list 1.
 
route-map AS-300-INCOMING permit 10  
 match as-path 1  
 set local-preference 200  
!  

!--- Here, the route map prepends AS 100 to BGP updates for networks 
!--- that are permitted by access list 10.
 
route-map AS-300-OUTGOING permit 10  
 match ip address 10  
 set as-path prepend 100  
!  

!--- This line announces the network that is permitted 
!--- by access list 20 without any changes in BGP attributes.
 
route-map AS-300-OUTGOING permit 20  
 match ip address 20  
!

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Lancez la commande show ip bgp afin de vérifier que la stratégie sortie/entrée fonctionne.

Remarque: Le signe plus grand que (>) dans la sortie show ip bgp représente le meilleur chemin à utiliser pour ce réseau parmi les divers chemins possibles. Reportez-vous à l'Algorithme de sélection du meilleur chemin BGP pour plus d'informations.

R1# show ip bgp

BGP table version is 6, local router ID is 192.168.31.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

BGP table version is 6, local router ID is 192.168.31.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

Network          Next Hop            Metric LocPrf Weight Path
*> 0.0.0.0          192.168.31.3                  200      0 300 i

!--- This line shows that the default route 0.0.0.0/0 is preferred 
!--- through AS 300, ISP(A).

* i10.10.10.0/24    192.168.21.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i
* i10.10.20.0/24    192.168.21.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i
*> 30.30.30.0/24    192.168.31.3             0    200      0 300 i
*>i40.40.40.0/24    192.168.21.2             0    150      0 400 i

!--- The route to network 30.30.30.0/24 (AS 300) is preferred 
!--- through the R1-ISP(A) link.
!--- The route to network 40.40.40.0/24 (AS 400) is preferred 
!--- through the R2-ISP(B) link.

Maintenant, regardez la sortie show ip bgp sur R2 :

R2# show ip bgp 

BGP table version is 8, local router ID is 192.168.42.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*  0.0.0.0          192.168.42.4                  150      0 400 i  
*>i                 192.168.21.1                  200      0 300 i

!--- This line shows that the default route 0.0.0.0/0 is preferred
!--- through AS 300, through the R2-ISP(B) link.

*> 10.10.10.0/24    0.0.0.0                  0         32768 i
* i                 192.168.21.1             0    100      0 i
*> 10.10.20.0/24    0.0.0.0                  0         32768 i
* i                 192.168.21.1             0    100      0 i
*>i30.30.30.0/24    192.168.21.1             0    200      0 300 i 
*> 40.40.40.0/24    192.168.42.4             0    150      0 400 i

!--- The route to network 30.30.30.0/24 (AS 300) is preferred 
!--- through the R1-ISP(A) link.
!--- The route to network 40.40.40.0/24 (AS 400) is preferred 
!--- through the R2-ISP(B) link.

Lancez la commande show ip bgp sur le routeur 6 afin d'observer la stratégie d'entrée pour les réseaux 10.10.10.0/24 et 10.10.20.0/24 :

R6# show ip bgp

BGP table version is 15, local router ID is 192.168.64.6
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.10.10.0/24    192.168.63.3                           0 300 100 100 i

!--- This line shows that network 10.10.10.0/24 is routed through AS 300
!--- with the ISP(A)-R1 link.

*                   192.168.64.4                           0 400 100 100 100 i
*  10.10.20.0/24    192.168.63.3                           0 300 100 100 i
*>                  192.168.64.4                           0 400 100 i

!--- This line shows that network 10.10.20.0/24 is routed through AS 400
!--- with the ISP(B)-R2 link.

*> 30.30.30.0/24    192.168.63.3             0             0 300 i
*> 40.40.40.0/24    192.168.64.4             0             0 400 i

Fermez la liaison R1-ISP(A) sur R1 et observez la table BGP. Attendez-vous à ce que tout le trafic vers Internet soit acheminé par la liaison R2-ISP(B) :

R1(config)# interface serial 0/0
R1(config-if)# shutdown
 
*May  2 19:00:47.377: %BGP-5-ADJCHANGE: neighbor 192.168.31.3 Down Interface flap 
*May  2 19:00:48.277: %LINK-5-CHANGED: Interface Serial0/0, changed state to 
 administratively  down 
*May 23 12:00:51.255: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed 
 state to down 

R1# show ip bgp 

BGP table version is 12, local router ID is 192.168.31.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i0.0.0.0          192.168.21.2                  150      0 400 i  

!--- The best default path is now through the R2-ISP(B) link.

* i10.10.10.0/24    192.168.21.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i
* i10.10.20.0/24    192.168.21.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i
*>i40.40.40.0/24    192.168.21.2             0    150      0 400 i

R2# show ip bgp 

BGP table version is 14, local router ID is 192.168.42.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 0.0.0.0          192.168.42.4                  150      0 400 i  

!--- The best default route is now through ISP(B) with a 
!--- local preference of 150.

* i10.10.10.0/24    192.168.21.1             0    100      0 i
*>                  0.0.0.0                  0         32768 i
* i10.10.20.0/24    192.168.21.1             0    100      0 i
*>                  0.0.0.0                  0         32768 i
*> 40.40.40.0/24    192.168.42.4             0    150      0 400 i

Regardez la route pour le réseau 10.10.10.0/24 dans le routeur 6 :

R6# show ip bgp 

BGP table version is 14, local router ID is 192.168.64.6
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.10.10.0/24    192.168.64.4                           0 400 100 100 i  

!--- Network 10.10.10.0 is reachable through ISP(B), which announced
!--- the network with AS path prepend.
 
*> 10.10.20.0/24    192.168.64.4                           0 400 100 i
*> 30.30.30.0/24    192.168.63.3             0             0 300 i
*> 40.40.40.0/24    192.168.64.4             0             0 400 i

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 13762