IP : Protocole BGP (Border Gateway Protocol)

Configuration de la fonction BGP Local-AS

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document explique la caractéristique de local-as de Protocole BGP (Border Gateway Protocol), qui était d'abord disponible dans la version de logiciel 12.0(5)S de Ý de Cisco IOS.

La caractéristique de local-as permet à un routeur pour sembler être un membre d'un deuxième système autonome (AS), en plus de son vrai AS. Cette caractéristique peut seulement être utilisée pour de véritables pairs d'eBGP. Vous ne pouvez pas utiliser cette caractéristique pour deux pairs qui sont des membres de sous-titre-âne différent de confédération.

Conditions préalables

Conditions requises

Ce document exige une compréhension du protocole de routage BGP et de ses exécutions. Référez-vous aux études de cas de BGP.

Composants utilisés

Les informations dans ce document appliquent aux ces le logiciel et les versions de matériel.

  • Version du logiciel Cisco IOS 12.2(28)

  • Routeurs de la gamme Cisco 2500

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Syntaxe de commande

Cette liste affiche la syntaxe des commandes que les configurations dans cette utilisation de document.

Le local-as ne peut pas être personnalisé pour différents pairs à un groupe de homologues.

Le local-as ne peut pas avoir le numéro de système autonome de protocole BGP de gens du pays ou le numéro de système autonome du pair distant.

La commande de local-as est valide seulement si le pair est un véritable pair d'eBGP. Cela ne fonctionne pas pour deux pairs dans le sous-titre-âne différent dans une confédération.

Référez-vous au guide de référence des commandes BGP pour des informations supplémentaires sur des commandes BGP.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

La caractéristique de local-as est utile s'ISP-A achète l'ISP B, mais les clients du l'ISP-b ne veulent pas ne modifier aucunes organisations ou configuration scrutantes. La caractéristique de local-as permet à des Routeurs dans l'ISP B pour aller bien à des membres des ISP-a AS. En même temps, ces Routeurs semblent à leurs clients retenir leur numéro de système autonome d'ISP B.

Dans la figure 1, ISP-A n'a pas encore acheté l'ISP B. Dans la figure 2, ISP-A a acheté l'ISP B, et l'ISP B utilise la caractéristique de local-as.

Dans la figure 2, l'ISP B appartient à l'AS 100, et à l'ISP-C à EN TANT QUE 300. En scrutant avec ISP-C, utilisations d'ISP B EN TANT QUE 200 en tant que son numéro de système autonome avec l'utilisation de la commande du local-as 200 du voisin ISP-C. Dans les mises à jour envoyées de l'ISP B à ISP-C, l'AS_SEQUENCE dans l'attribut as_path contient "200 100". Le "200" est ajouté au début par l'ISP B dû à la commande du local-as 200 configurée pour ISP-C.

Normalement un ISP-A/B combiné renumérote les Routeurs dans l'ISP B pour faire partie d'AS 100. Ce qui s'ISP-C est la modification incapable ses configurations d'eBGP avec l'ISP B ? Avant la caractéristique de local-as, l'ISP-A/B combiné doit mettre à jour deux numéros de système autonome. La commande de local-as permet à ISP-A/B pour être physiquement un COMME tandis qu'elle semble être l'âne deux à ISP-C.

Configurez

Cette section vous présente les informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Afin de trouver des informations complémentaires sur les commandes que ce document utilise, veuillez utiliser le Command Lookup Tool (clients enregistrés seulement).

Diagrammes du réseau

Ce document utilise ces configurations réseau.

Figure 1

/image/gif/paws/13761/39a.gif

Figure 2

/image/gif/paws/13761/39b.gif

Configurations

Ce document utilise les configurations suivantes.

ISP B (AS 100, local-as 200)
hostname ISP-B
! 
interface serial 0 
ip address 192.168.1.1 255.255.255.252 
! 
interface ethernet 0 
ip address 192.168.4.1 255.255.255.0 
! 
router bgp 100 

!--- Note the AS number 100. This is the AS number of ISP-A, which is now
!--- used by all routers in ISP-B after its acquisition by ISP-A.

 neighbor 192.168.1.2 remote-as 300 

!--- Defines the e-BGP connection to ISP-C.

 neighbor 192.168.1.2 local-as 200 

!--- This command makes the remote router in ISP-C to see this
!--- router as belonging to AS 200 instead of AS 100. 
!--- This also make this router to prepend AS 200 in 
!--- all updates to ISP-C.

network 192.168.4.0
! 
!

ISP-C (EN TANT QUE 300)
hostname ISP-C
! 
interface serial 1 
ip address 192.168.1.2 255.255.255.252 
! 
interface ethernet 0 
ip address 192.168.9.1 255.255.255.0 
! 
router bgp 300 
 neighbor 192.168.1.1 remote-as 200

!--- Defines the e-BGP connection to ISP-B.


!--- Note AS is 200 and not AS 100.
 
 network 192.168.9.0 
! 
!

Vérifiez

Cette section fournit des informations que vous pouvez employer pour confirmer votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Référez-vous au guide de référence des commandes BGP afin de se renseigner plus sur les commandes show utilisées dans cette section.

Visualisez la table de routage BGP pour voir comment la commande de local-as a changé l'AS_PATH. Ce que vous observez est cet ISP B ajoute au début EN TANT QUE 200 aux mises à jour aux lesquelles sont envoyés et reçus d'ISP-C. En outre, notez que l'ISP B est dans le numéro de système autonome 100.

ISP-B# 
show ip bgp summary

  BGP router identifier 192.168.4.1, local AS number 100 
  BGP table version is 3, main routing table version 3 
  2 network entries and 2 paths using 266 bytes of memory 
  2 BGP path attribute entries using 104 bytes of memory 
  1 BGP AS-PATH entries using 24 bytes of memory 
  0 BGP route-map cache entries using 0 bytes of memory 
  0 BGP filter-list cache entries using 0 bytes of memory 
  BGP activity 2/6 prefixes, 2/0 paths, scan interval 15  secs 

  Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd 
  192.168.1.2     4   300      29      29        3    0    0 00:25:19       1

Dans cette sortie, notez qu'ISP-C voit l'ISP B en tant qu'élément de EN TANT QUE 200.

ISP-C# show ip bgp summary 
  BGP table version is 3, main routing table version 3 
  2 network entries (2/6 paths) using 480 bytes of memory 
  2 BGP path attribute entries using 192 bytes of memory 
  0 BGP route-map cache entries using 0 bytes of memory 
  0 BGP filter-list cache entries using 0 bytes of memory 

  Neighbor        V    AS MsgRcvd MsgSent  TblVer InQ OutQ   Up/Down  State/PfxRcd 
  192.168.1.1     4   200      34      34       3   0    0  00:30:19   1

La note dans cette sortie que l'ISP B ajoute "200" au début aux artères a appris d'ISP-C.

ISP-B# 
show ip bgp

  BGP table version is 3, local router ID is 192.168.4.1 
  Status codes: s suppressed, d damped, h history, * valid, > best, i - internal 
  Origin codes: i - IGP, e - EGP, ? - incomplete 

  Network          Next Hop            Metric LocPrf  Weight   Path 
  *> 192.168.4.0      0.0.0.0               0          32768   i 
  *> 192.168.9.0      192.168.1.2           0              0   200 300 i

Notez qu'ISP-C voit des artères d'ISP B avec un AS_PATH de "200 100".

ISP-C# show ip bgp 
  BGP table version is 3, local router ID is 192.168.1.2 
  Status codes: s suppressed, d damped, h history, * valid, > best, i - internal 
  Origin codes: i - IGP, e - EGP, ? - incomplete 

  Network          Next Hop          Metric LocPrf  Weight Path 
  *> 192.168.4.0      192.168.1.1         0              0 200 100 i 
  *> 192.168.9.0      0.0.0.0             0          32768 i

Ces commandes affichent les valeurs configurées de local-as dans leur sortie :

ISP-B# show ip bgp neighbors 192.168.1.2
BGP neighbor is 192.168.1.2,  remote AS 300,  local AS 200, external link
  BGP version 4, remote router ID 192.168.9.1
  BGP state = Established, up for 00:22:42
  Last read 00:00:42, hold time is 180, keepalive interval is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(old & new)
    Address family IPv4 Unicast: advertised and received
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
                         Sent       Rcvd
    Opens:                  1          1
    Notifications:          0          0
    Updates:                2          1
    Keepalives:            25         25
    Route Refresh:          0          1
    Total:                 28         28
  Default minimum time between advertisement runs is 30 seconds

! Output Suppressed

Dépannez

La commande de debug ip bgp updates affiche les préfixes reçus avec ses attributs du voisin. Cette sortie prouve que le préfixe 192.168.4.0/24 est reçu avec COMME LE CHEMIN 200, 100.

ISP-C#
*May 10 12:45:14.947: BGP(0): 192.168.1.1 computing updates, afi 0, neighbor ver
sion 0, table version 5, starting at 0.0.0.0
*May 10 12:45:14.947: BGP(0): 192.168.1.1 send UPDATE (format) 192.168.9.0/24, n
ext 192.168.1.2, metric 0, path
*May 10 12:45:14.947: BGP(0): 192.168.1.1 1 updates enqueued (average=52, maximu
m=52)
*May 10 12:45:14.947: BGP(0): 192.168.1.1 update run completed, afi 0, ran for 0
ms, neighbor version 0, start version 5, throttled to 5
*May 10 12:45:14.947: BGP: 192.168.1.1 initial update completed
*May 10 12:45:15.259: BGP(0): 192.168.1.1 rcvd UPDATE w/ attr: nexthop 192.168.1
.1, origin i, metric 0, path 200 100
ISP-C#
*May 10 12:45:15.259: BGP(0): 192.168.1.1 rcvd 192.168.4.0/24
*May 10 12:45:15.279: BGP(0): Revise route installing 192.168.4.0/24 -> 192.168.
1.1 to main IP table
ISP-C#

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 13761