IP : Protocole BGP (Border Gateway Protocol)

BGP Policy Accounting et fonctions de comptabilisation de l'interface de sortie de BGP Policy Accounting

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

La caractéristique de la comptabilité de stratégie de Protocole BGP (Border Gateway Protocol) (PA) te permet pour expliquer le trafic IP différentiel en assignant des compteurs basés sur la liste, le numéro de système autonome, et/ou l'AS_PATH de la communauté sur a par base d'interface d'entrée.

La comptabilité d'interface de sortie PA BGP introduit plusieurs extensions pour activer la PA BGP sur une interface de sortie et pour inclure la comptabilité basée sur une adresse source pour des les deux le trafic d'entrée et sortie sur une interface. Des compteurs basés sur des paramètres tels que la liste de la communauté, le numéro de système autonome, ou le chemin d'Autonomous System sont assignés pour identifier le trafic IP.

Conditions préalables

Conditions requises

Avant que vous utilisiez la caractéristique PA BGP, activez le Technologie Cisco Express Forwarding (CEF) ou le Cisco Express Forwarding distribué (dCEF) sur le routeur.

Composants utilisés

La caractéristique PA BGP est d'abord prise en charge en les Plateformes suivantes qui prennent en charge la Cisco IOS version 12.0(9)S.

  • Cisco 7200, 7500, et Routeurs de gamme 12000

Le nombre de Plateformes qui prennent en charge cette caractéristique dans la Cisco IOS version 12.2(13)T est beaucoup plus grand. Les Plateformes incluent :

  • 1400, 1600, 1700, 2600, 3600, 7100, 7200, 7500, AS5300, AS5350, AS5400, AS5800, AS5850, ICS7750, IGX 8400 URM, MGX 8850, uBR7200.

La comptabilité d'interface de sortie PA BGP a été ajoutée dans 12.0(22)S et a introduit la première fois en tant que nouvelle caractéristique dans 12.3(4)T. Il y a beaucoup de Plateformes de Cisco qui prennent en charge cette caractéristique.

Remarque: Pour obtenir les informations mises à jour concernant le soutien de plate-forme de cette caractéristique, l'accès Cisco comportent le navigateur II (clients enregistrés seulement).

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Théorie générale

Cette caractéristique était d'abord disponible sur la version de logiciel 12.0(9)S ED de½ du¿Â du Cisco IOSïÂ. Pour que la fonctionnalité de comptabilisation stratégique fonctionne, vous devez activer le BGP et le CEF/dCEF sur le routeur.

Utilisant la comptabilité de stratégie BGP, vous pouvez expliquer le trafic (et appliquer la facturation) selon l'artère qu'elle traverse. Par exemple, vous pouvez expliquer le trafic qui est domestique conduit, international, terrestre, ou le satellite. De cette façon, vous pouvez identifier et expliquer tout le trafic sur une base de par-client.

Cette caractéristique tire profit de la commande de table-map BGP, qui classifie les préfixes qu'elle met dans la table de routage selon la liste de la communauté, numéro de système autonome, AS_PATH, et ainsi de suite. Basé sur ce critère de correspondance, la pratique comptable BGP place un nombre de position (actuellement 1 64) d'une table de comptabilité associée avec chaque interface. Chaque position représente une Classification du trafic, qui permet le trafic IP à expliquer différentiel par la liste, le numéro de système autonome, ou l'AS_PATH de la communauté par interface d'entrée.

Le pour en savoir plus, se rapportent au BGP Policy Accounting.

Remarque: La PA BGP mesure et classifie le trafic IP à la laquelle est envoyé, ou reçu de, différents pairs. La PA était précédemment disponible sur une interface d'entrée seulement.

La fonctionnalité de comptabilisation d'interface de sortie de BGP Policy Accounting introduit plusieurs extensions pour activer la PA BGP sur une interface de sortie et pour inclure la comptabilité basée sur une adresse source pour des les deux le trafic d'entrée et sortie sur une interface. Des compteurs basés sur des paramètres tels que la liste de la communauté, le numéro de système autonome, ou le chemin d'Autonomous System sont assignés pour identifier le trafic IP. La comptabilité d'interface de sortie a été ajoutée dans la Cisco IOS version 12.0(22)S.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Configurer le BGP Policy Accounting

  1. Spécifiez les communautés dans les listes de la communauté (ou définissez les listes AS_PATH) qui classifient le trafic pour la comptabilité.

    ip community-list 30 permit 100:190
      ip community-list 40 permit 100:198
      ip community-list 50 permit 100:197
      ip community-list 60 permit 100:296
      ip community-list 70 permit 100:201
      !
  2. Définissez un route-map aux listes du match community et placez les nombres appropriés de position.

    route-map set_bucket permit 10
    match community 30
    set traffic-index 2
    !
    route-map set_bucket permit 20
    match community 40
    set traffic-index 3
    !
    route-map set_bucket permit 30
    match community 50
    set traffic-index 4
    !
    route-map set_bucket permit 40
    match community 60
    set traffic-index 5
    !
    route-map set_bucket permit 50
    match community 70
    set traffic-index 6 
  3. Utilisez la commande de table-map sous le BGP de modifier le nombre de position quand la table de Routage IP est mise à jour avec des artères apprises du BGP.

    router bgp 110
      table-map set_bucket
      network 15.1.1.0 mask 255.255.255.0
      neighbor 14.1.1.1 remote-as 100
      !
      ip classless
      ip bgp-community new-format 
  4. Activez la fonctionnalité de comptabilisation stratégique sur l'interface d'entrée connectée au client.

    interface POS7/0
      ip address 15.1.1.2 255.255.255.0
      no ip directed-broadcast
      bgp-policy accounting
      no keepalive
      crc 32
      clock source internal

Configurer la comptabilité d'interface de sortie de BGP Policy Accounting

La configuration de la comptabilité d'interface de sortie PA BGP est très semblable à la PA BGP. Les premiers en trois étapes décrits dans la section précédente sont exactement identiques. La seule modification est dans la commande de traçabilité de bgp-policy qui est utilisée pour activer la caractéristique PA sur l'interface. Dans l'exemple au-dessous du BGP LA PA est activée sur l'interface 7/0 de POS. Les critères PA est basés sur l'adresse source du trafic de sortie

interface POS7/0
 ip address 10.15.1.2 255.255.255.0
 bgp-policy accounting output source
 no keepalive
 crc 32
 clock source internal

commandes show qui surveillent la comptabilité de stratégie

Pour examiner quel préfixe est assigné auquel position et auquel la communauté (ou les communautés), utilisent le show ip cef et les commandes de show ip bgp.

Router# show ip cef 196.240.5.0 detail
196.240.5.0/24, version 21, cached adjacency to POS7/2
0 packets, 0 bytes, traffic_index 4
  via 14.1.1.1, 0 dependencies, recursive
   next hop 14.1.1.1, POS7/2 via 14.1.1.0/30
   valid cached adjacency

Router# show ip bgp 196.240.5.0
BGP routing table entry for 196.240.5.0/24, version 2
Paths: (1 available, best #1)
  Not advertised to any peer
  100
    14.1.1.1 from 14.1.1.1 (32.32.32.32)
      Origin IGP, metric 0, localpref 100, valid, external, best
      Community: 100:197

Pour regarder des statistiques de trafic de par-interface, utilisez la commande de show cef interface policy-statistics.

LC-Slot7# show cef interface policy-statistics
:
POS7/0 is up (if_number 8)
Bucket    Packets               Bytes

1          0                      0
2          0                      0
3          50                     5000
4          100                    10000
5          100                    10000
6          10                     1000
7          0                      0
8          0                      0

Informations connexes


Document ID: 13760