IP : Protocole BGP (Border Gateway Protocol)

Exemple de configuration de la suppression de numéros AS privés dans BGP

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document montre des exemples de configuration pour la suppression des numéros de système autonome (AS) privés lors de l'envoi de mises à jour eBGP. Les numéros de système autonome peuvent appartenir à l'une de deux catégories : privé et public. Comme les adresses IP publiques et privées, vous ne pouvez pas diffuser des numéros de système autonome privés sur Internet. La plage de numéros de système autonome publics s'étend entre 1 et 64511; celle des numéros de système autonome privés, entre 64512 et 65535. Vous pouvez utiliser des numéros de système autonome privés pour diviser des systèmes autonomes volumineux en plusieurs petits systèmes autonomes connectés par eBGP. En outre, si vous êtes connecté à un seul FSI, celui-ci peut assigner des numéros de système autonome privés afin d'économiser les numéros de système autonome publics. Cependant, vous devez supprimer ces numéros de système autonome privés avant que vous envoyiez les mises à jour au maillage BGP global (Internet).

Remarque: L'attribution des numéros de système autonome privés n'est pas recommandée si vous vous connectez aux ISP de multiple. Des numéros de système autonome privés peuvent être utilisés si le réseau client se connecte à un ISP simple (ou choisissez autoguidé ou dual-homed).

Référez-vous à retirer les numéros de système autonome privés dans le BGP pour plus d'informations sur les numéros de système autonome privés.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations dans ce document appliquent aux ces le logiciel et les versions de matériel :

  • Version de logiciel 12.2(27) de Ý de Cisco IOS

  • Cisco 2501 et Routeur Cisco 2503

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise les numéros de système autonome publics d'une configuration réseau en laquelle utilise Routeur3 le numéro de système autonome privé 65000, et d'utilisation du routeur 1 et du Router2 EN TANT QUE 1 et EN TANT QUE 5 respectivement.

Le Router2 est dans le nuage de fournisseur de services avec le routeur 1 (s'exécutant EN TANT QUE 1) et Routeur3 (s'exécutant EN TANT QUE 65000) en tant que ses clients.

/image/gif/paws/13758/36-1.gif

Envoyez et recevez les mises à jour

Cette procédure explique la séquence d'opérations qui se produisent quand annonce Routeur3 un réseau (10.0.0.0/24 dans ce cas).

  1. Annonce Routeur3 le réseau 10.0.0.0/24 avec COMME attribut de chemin 65000 au Router2.

  2. Le Router2 reçoit la mise à jour de Routeur3 et fait une entrée pour le réseau 10.0.0.0 /24 dans sa table de routage avec le prochain saut comme 172.16.0.1 (interface série S0 sur le routeur 3).

  3. Le Router2 (périphérique de fournisseur de services), une fois configuré avec la commande voisine de remove-private-as de 192.168.0.2, décolle le numéro de système autonome privé et construit un nouveau paquet de mise à jour avec son propre numéro de système autonome en tant que COMME attribut de chemin pour le réseau 10.0.0.0/24 et envoie la même chose au routeur 1 qui est dans AS1.

  4. Le routeur 1 reçoit la mise à jour d'eBGP pour le réseau 10.0.0.0/24 et fait une entrée dans sa table de routage avec le prochain saut comme 192.168.0.1 (interface série S1 sur le routeur 2). COMME attribut de chemin pour ce réseau comme vu sur le routeur 1 est EN TANT QUE 5 (routeur 2). Ainsi, les numéros de système autonome privés sont empêchés d'entrer dans les tables BGP de l'Internet.

Configurations

Ce document utilise les configurations suivantes :

Routeur 3
Current configuration :
!
interface Ethernet0
 ip address 10.0.0.1 255.255.255.0
!
interface Serial0
 ip address 172.16.0.1 255.255.255.0
!
router bgp 65000
 network 10.0.0.0 mask 255.255.255.0
 neighbor 172.16.0.2 remote-as 5

!--- Configures Router 2 as an eBGP neighbor in public AS 5. 

!
end

Routeur 2
Current configuration :
!
!
interface Ethernet0
 ip address 172.30.1.1 255.255.0.0
!
interface Serial0
 ip address 172.16.0.2 255.255.255.0
!
interface Serial1
 ip address 192.168.0.1 255.255.255.0
!
router bgp 5
 network 172.30.0.0
 network 192.168.0.0
 neighbor 172.16.0.1 remote-as 65000

!--- Configures Router 3 as an eBGP neighbor in private AS 65000.

 neighbor 192.168.0.2 remote-as 1

!--- Configures Router 1 as an eBGP neighbor in public AS 1. 

 neighbor 192.168.0.2 remove-private-AS

!--- Removes the private AS numbers from outgoing eBGP updates.

!
!
end

Routeur 1
Current configuration :
!
version 12.2
!
!
interface Serial0
 ip address 192.168.0.2 255.255.255.0
 !
router bgp 1
 neighbor 192.168.0.1 remote-as 5

!--- Configures Router 2 as an eBGP neighbor in public AS 5.

!
end

Format de POINT d'Autonomous System

Cet exemple explique comment convertir le numéro de système autonome plus grand que 65535 en Autonomous System 4-Byte (format ASDOT).

Avant configuration ASDOT

Router#show run | beg router 
router bgp 131280
no synchronization 
bgp log-neighbor-changes 
no auto-summary 

Configuration ASDOT

Router(config-router)#bgp asnotation dot 
Router(config-router)#end 

Après configuration

Router#show run | beg router bgp 
router bgp 2.208  <== 
no synchronization 
bgp asnotation dot 
bgp log-neighbor-changes 
no auto-summary ! 

Vérifiez

Cette section fournit des informations que vous pouvez employer pour confirmer votre configuration fonctionne correctement.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Les messages de débogage pris avec la commande de debug ip bgp updates sur l'exposition du routeur 1 que la mise à jour pour le réseau 10.0.0.0/24 reçu du Router2 (192.68.0.1) a COMME attribut de chemin 5 qui est le numéro de système autonome de Router2. La commande de show ip bgp sur le Router2 et le routeur 1 illustrent également la même chose.

Router1#
1w1d: %BGP-5-ADJCHANGE: neighbor 192.168.0.1 Up
1w1d: BGP(0): 192.168.0.1 computing updates, afi 0, 
       neighbor version 0, table version 1, starting at 0.0.0.0
1w1d: BGP(0): 192.168.0.1 update run completed, afi 0, 
       ran for 0ms, neighbor version 0, start version 1, throttled to 1
1w1d: BGP: 192.168.0.1 initial update completed
1w1d: BGP(0): 192.168.0.1 rcvd UPDATE w/ attr: nexthop 
       192.168.0.1, origin i, path 5
1w1d: BGP(0): 192.168.0.1 rcvd 10.0.0.0/24
1w1d: BGP(0): Revise route installing 10.0.0.0/24 -> 192.168.0.1 
      to main IP table
1w1d: BGP(0): 192.168.0.1 computing updates, afi 0, neighbor 
      version 1, table version 2, starting at 0.0.0.0
1w1d: BGP(0): 192.168.0.1 update run completed, afi 0, ran for 0ms,
      neighbor version 1, start version 2, throttled to 2

Router2#show ip bgp
BGP table version is 3, local router ID is 192.168.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
    Network         Next Hop      Metric  LocPrf Weight   Path
 *> 10.0.0.0/24     172.16.0.2         0              0   65000 i
 *> 172.30.0.0      0.0.0.0            0         32768    i
 

Router1#show ip bgp
BGP table version is 19, local router ID is 192.168.0.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
    Network          Next Hop      Metric  LocPrf  Weight  Path
 *> 10.0.0.0/24      192.168.0.1                        0  5 i
 *> 172.30.0.0       192.168.0.1        0               0  5 i

La table BGP du Router2 prouve que le réseau 10.0.0.0 provient de EN TANT QUE 65000. La table BGP du routeur 1 affiche que le même réseau provient de EN TANT QUE 5. C'est en raison de la commande voisine de remove-private-as de 192.168.0.2 sur le Router2, qui décolle le numéro de système autonome privé et empêche les numéros de système autonome privés d'atteindre l'Internet. Pour cette raison, EN TANT QUE 1 (le routeur 1) a un affichage cohérent de EN TANT QUE 5 en tant qu'étant le créateur du réseau 10.0.0.0/24.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 13758