IP : Protocole BGP (Border Gateway Protocol)

Exemple de configuration d'iBGP et d'eBGP avec ou sans adresse de boucle

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (19 décembre 2015) | Commentaires


Contenu


Introduction

Le BGP est un Exterior Gateway Protocol (EGP), utilisé pour exécuter le routage d'interdomain dans les réseaux TCP/IP. Un routeur BGP doit établir une connexion (sur le port TCP 179) à chacun des pairs BGP avant que des mises à jour BGP puissent être échangées. La session BGP entre deux pairs BGP est dite une session de BGP externe (eBGP) si les pairs BGP sont dans de différents systèmes autonomes (AS). Une session BGP entre deux pairs BGP est dite une session de BGP interne (iBGP) si les pairs BGP sont dans les m?mes systèmes autonomes.

Par défaut, le rapport de partenariat est établi utilisant l'adresse IP de l'interface la plus proche du routeur de pair. Cependant, utilisant la commande de neighbor update-source, n'importe quelle interface opérationnelle, y compris l'interface de bouclage, peut être spécifiée pour être utilisée pour établir des connexions TCP. Cette méthode de scruter utilisant une interface de bouclage est utile puisqu'elle ne réduira pas la session BGP quand il y a des plusieurs chemins entre les pairs BGP, qui auraient autrement en démolissant la session BGP si l'interface physique utilisée pour établir la session descend. En plus de cela, il permet également les Routeurs exécutant le BGP avec de plusieurs liens entre eux pour équilibrer la charge au-dessus des chemins disponibles.

Les configurations d'échantillon dans ce document sont pour l'iBGP et l'eBGP, chacun des deux avec et sans des adresses de bouclage.

Remarque: Vous pouvez utiliser ces configurations pour établir des relations voisines. Référez-vous utilisant le protocole BGP pour le routage d'Interdomain pour des configurations plus complexes.

Conditions préalables

Conditions requises

Avant que vous tentiez cette configuration, assurez-vous que vous répondez à cette exigence :

  • La connaissance des protocoles BGP

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques. Les sorties de commande affichées dans ce document ont été prises des Routeurs de gamme 2500 exécutant la version 12.2(24a) de½ du¿Â IOSïÂ.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section contient les exemples suivants de configuration :

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/13751-23a.gif

configuration d'iBGP

Dans cette configuration, les deux Routeurs sont dedans EN TANT QUE 400.

R1-AGS R6-2500
Current configuration:

!-- Output suppressed.

interface Serial1
 ip address 10.10.10.1 255.255.255.0
!
router bgp 400

!--- Enables BGP for the autonomous
!--- system 400.

 neighbor 10.10.10.2 remote-as 400
 
!--- Specifies a neighbor 10.10.10.2
 !--- in the remote AS 400, making
 !--- this an iBGP connection.  
!-- Output suppressed.

end
Current configuration:

!-- Output suppressed.

interface Serial0
ip address 10.10.10.2 255.255.255.0
!
router bgp 400
 neighbor 10.10.10.1 remote-as 400

!-- Output suppressed.

end

configuration d'eBGP

Dans cette configuration, le routeur R1-AGS est dedans PENDANT QUE 300 et routeur R6-2500 est dedans EN TANT QUE 400.

R1-AGS R6-2500
Current configuration:

!-- Output suppressed

interface Serial1
 ip address 10.10.10.1 255.255.255.0
!
router bgp 300

!--- Enables BGP for the autonomous
!--- system 300.

 neighbor 10.10.10.2 remote-as 400
 
!--- Specifies a neighbor 10.10.10.2
 !--- in the remote AS 400, making
 !--- this an eBGP connection.


!-- Output suppressed.

end
Current configuration:

!-- Output suppressed.

interface Serial0
ip address 10.10.10.2 255.255.255.0
!
router bgp 400
 neighbor 10.10.10.1 remote-as 300

!-- Output suppressed.

end

Des pairs doivent être directement connectés en utilisant l'eBGP. S'ils ne sont pas directement connectés, la commande de neighbor ebgp-multihop doit être utilisée et un chemin à travers un IGP ou une artère statique pour atteindre le pair doit exister pour que les Routeurs établissent des relations voisines. Dans la configuration ci-dessus, le routeur R1-AGS appartient à EN TANT QUE 300 tandis que le routeur R6-2500 appartient à EN TANT QUE 400.

configuration d'iBGP avec une adresse de bouclage

Vous pouvez configurer l'iBGP utilisant une adresse de bouclage (ou toute autre interface opérationnelle) suivant les indications de cette section.

R1-AGS R6-2500
Current configuration:


!-- Output suppressed.

interface Loopback0
  ip address 1.1.1.1 255.255.255.255
 !
 interface Serial1
  ip address 10.10.10.1 255.255.255.0
 !
 router bgp 300
  neighbor 2.2.2.2 remote-as 300
  neighbor 2.2.2.2 update-source Loopback0
  
!--- This command specifies that the TCP
  !--- connection with the specified external
  !--- peer should be established using the
  !--- address on the loopback interface.

 !
 ip route 2.2.2.2 255.255.255.255 10.10.10.2
 
!--- This static route ensures that the 
 !--- remote peer address used for peering
 !--- is reachable.
!-- Output suppressed.

end
Current configuration:


!-- Output suppressed.

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0
 ip address 10.10.10.2 255.255.255.0
!
router bgp 300
 neighbor 1.1.1.1 remote-as 300
 neighbor 1.1.1.1 update-source Loopback0
!
ip route 1.1.1.1 255.255.255.255 10.10.10.1

!-- Output suppressed.

end

configuration d'eBGP avec une adresse de bouclage

Vous pouvez également configurer l'eBGP utilisant une adresse de bouclage (ou toute autre interface opérationnelle) suivant les indications de cette section. Des interfaces de bouclage sont utilisées de cette manière pour garantir l'accessibilité dans les réseaux avec des plusieurs chemins suivant les indications du chargement partageant utilisant l'adresse de bouclage comme section voisine BGP de chargement partageant avec le BGP dans les environnements monos et multihébergés : Configurations d'échantillon.

R1-AGS R6-2500
Current configuration:


!-- Output suppressed.


interface Loopback0
  ip address 1.1.1.1 255.255.255.255
 !
 interface Serial1
  ip address 10.10.10.1 255.255.255.0
 !
 router bgp 300
  neighbor 2.2.2.2 remote-as 400
  neighbor 2.2.2.2 ebgp-multihop 2
 
 !--- This command changes the ttl value in 
  !--- order to allow the packet to reach the 
  !--- external BGP peer which is not directly
  !--- connected or is using an interface other
  !--- than the directly connected interface.

  neighbor 2.2.2.2 update-source Loopback0
  
!--- This command specifies that the TCP
  !--- connection with the external BGP
  !--- peer should be established using the
  !--- address on the loopback interface.
 !

 ip route 2.2.2.2 255.255.255.255 10.10.10.2

 !--- This static route ensures that the 
 !--- remote peer address used for peering
 !--- is reachable.


!-- Output suppressed.


end
Current configuration:


!-- Output suppressed.


interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0
 ip address 10.10.10.2 255.255.255.0
!
router bgp 400
 neighbor 1.1.1.1 remote-as 300
 neighbor 1.1.1.1 ebgp-multihop 2
 neighbor 1.1.1.1 update-source Loopback0
!
ip route 1.1.1.1 255.255.255.255 10.10.10.1


!-- Output suppressed.


end

Vérifiez

Ces sections fournissent des informations que vous pouvez employer pour confirmer vos configurations fonctionnez correctement. certaines commandes show sont prises en charge par l'outil Interpréteur de sortie, qui vous permet d'afficher une analyse de la sortie de la commande show.

Vérifiez la configuration d'iBGP

Utilisez la commande de show ip bgp neighbors d'afficher des informations sur le TCP et les connexions de Protocole BGP (Border Gateway Protocol) et de les vérifier si le pair BGP est établi. La sortie de la commande de show ip bgp neighbors ci-dessous affiche l'état BGP en tant que « établi », qui indique que le rapport de partenariat BGP a été établi avec succès.

R1-AGS# show ip bgp neighbors | include BGP
BGP neighbor is 10.10.10.2,  remote AS 400, internal link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:04:20
  BGP table version 1, neighbor version 1
R1-AGS#

La commande de show ip bgp neighbors a été utilisée ci-dessus avec le modificateur | incluez le BGP. Ceci rend la sortie plus accessible en lecture en filtrant la la sortie de commande et en affichant les éléments pertinents seulement.

En outre, la commande de show ip bgp summary peut également être utilisée pour afficher le statut de toutes les connexions BGP, comme affiché ci-dessous.

R1-AGS(9)# show ip bgp summary
BGP router identifier 10.1.1.2, local AS number 400	
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.10.10.2      4   400       3       3        1    0    0 00:00:26        0

Vérifiez la configuration d'eBGP

Utilisez la commande de show ip bgp neighbors d'afficher des informations sur le TCP et les connexions de Protocole BGP (Border Gateway Protocol) et de les vérifier si le pair BGP est établi. La sortie de la commande de show ip bgp neighbors ci-dessous affiche l'état BGP en tant que « établi », qui indique que le rapport de partenariat BGP a été établi avec succès.

R1-AGS# show ip bgp neighbors | include BGP
BGP neighbor is 10.10.10.2,  remote AS 400, external link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:00:17
  BGP table version 1, neighbor version 1

En outre, la commande de show ip bgp summary peut également être utilisée pour afficher le statut de toutes les connexions BGP, comme affiché ci-dessous.

R1-AGS(9)# show ip bgp summary
BGP router identifier 10.10.10.1, local AS number 300
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.10.10.2      4   400       3       3        1    0    0 00:00:26        0

Vérifiez la configuration d'iBGP avec une adresse de bouclage

Utilisez la commande de show ip bgp neighbors d'afficher des informations sur le TCP et les connexions de Protocole BGP (Border Gateway Protocol) et de les vérifier si le pair BGP est établi. La sortie de la commande de show ip bgp neighbors ci-dessous affiche l'état BGP en tant que « établi », qui indique que le rapport de partenariat BGP a été établi avec succès.

R1-AGS# show ip bgp neighbors | include BGP
BGP neighbor is 2.2.2.2,  remote AS 300, internal link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:00:28
  BGP table version 1, neighbor version 1
R1-AGS#

En outre, la commande de show ip bgp summary peut également être utilisée pour afficher le statut de toutes les connexions BGP, comme affiché ci-dessous.

R1-AGS(9)# show ip bgp summary
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4   400       3       3        1    0    0 00:00:26        0

Vérifiez la configuration d'eBGP avec une adresse de bouclage

Utilisez la commande de show ip bgp neighbors d'afficher des informations sur le TCP et les connexions de Protocole BGP (Border Gateway Protocol) et de les vérifier si le pair BGP est établi. La sortie de la commande de show ip bgp neighbors ci-dessous affiche l'état BGP en tant que « établi », qui indique que le rapport de partenariat BGP a été établi avec succès.

R1-AGS# show ip bgp neighbors | include BGP
BGP neighbor is 2.2.2.2,  remote AS 400, external link
  BGP version 4, remote router ID 2.2.2.2
  BGP state = Established, up for 00:00:16
  BGP table version 1, neighbor version 1
  External BGP neighbor may be up to 2 hops away.

En outre, la commande de show ip bgp summary peut également être utilisée pour afficher le statut de toutes les connexions BGP, comme affiché ci-dessous.

R1-AGS(9)# show ip bgp summary
BGP router identifier 1.1.1.1, local AS number 300
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4   400       3       3        1    0    0 00:00:26        0

Dépannez

Référez-vous à pourquoi faites le basculeur de voisins BGP entre l'inactif, connectez, et des états active ? et dépannage du BGP pour information l'information de dépannage.


Informations connexes


Document ID: 13751