Commutation multiprotocole par étiquette (MPLS) : MPLS

Configuration d'une ingénierie de trafic MPLS de base à l'aide du protocole IS-IS

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Cet exemple de configuration montre comment mettre en œuvre l'ingénierie de trafic (TE) sur un réseau existant de commutation multiprotocole par étiquette (MPLS) utilisant Frame Relay et Intermediate System-to-Intermediate System (IS-IS). Dans cet exemple, deux tunnels dynamiques (configurés automatiquement par des commutateurs-routeurs d'étiquettes [LSR]) et deux tunnels utilisant des trajectoires explicites ont été mis en œuvre.

TE est un nom générique qui correspond à l'utilisation de différentes Technologies d'optimiser l'utilisation d'une capacité et d'une topologie données de circuit principal.

MPLS TE fournit une manière d'intégrer des capacités TE (comme ceux utilisés sur des protocoles de couche 2 comme l'atmosphère) dans les protocoles de la couche 3 (IP). MPLS TE emploie une extension aux protocoles existants (RSVP Protocol [RSVP], IS-IS, protocole OSPF [OSPF]) pour calculer et établir les tunnels unidirectionnels qui sont placés selon la contrainte de réseau. La circulation est tracée sur les différents tunnels selon leur destination.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Versions de logiciel 12.0(11)S et 12.1(3a)T de Cisco IOSÝ

  • Routeurs de Cisco 3600

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Composants fonctionnels

Composant Description
Interfaces de tunnel IP Couche 2 : Une interface de tunnel MPLS est la tête d'un chemin commuté par étiquette (LSP). Il est configuré avec un ensemble des besoins en matière de ressources, tels que la bande passante et la priorité. Couche 3 : L'interface de tunnel LSP est la tête de réseau d'une liaison virtuelle unidirectionnelle à la destination de tunnel.
RSVP avec l'extension TE Le RSVP est utilisé pour établir et mettre à jour des tunnels LSP basés sur le chemin calculé utilisant des messages de CHEMIN et RESV. La spécification de protocole de RSVP a été étendue de sorte que les messages RESV distribuent également les informations d'étiquette.
IGP d'état de lien (IS-IS ou OSPF avec l'extension TE) Utilisé pour inonder la topologie et les informations de ressource du module de gestion de lien. L'IS-IS utilise de nouvelles Type-Longueur-valeurs (TLVs) et l'OSPF utilise des annonces d'État de lien du type 10 (également appelées Opaque LSAs).
Module de calcul de chemin MPLS TE Fonctionne à la tête LSP seulement et détermine un chemin utilisant les informations de la base de données d'état de lien.
Module de gestion de lien MPLS TE À chaque saut LSP, ce module exécute l'admission d'appel de lien sur les messages de signalisation de RSVP, et la comptabilité de la topologie et des informations de ressource à inonder par OSPF ou IS-IS.
Expédition de commutation par étiquette Mécanisme de transfert de base MPLS basé sur des étiquettes.

Configurez

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant.

/image/gif/paws/13737/mplsteisis1.gif

Configurations

Guide de configurations rapide

Cette procédure peut être utilisée pour exécuter une configuration rapide. Pour plus d'informations détaillées, référez-vous à l'Ingénierie de trafic MPLS et aux améliorations.

  1. Installez votre réseau avec la configuration habituelle (dans ce cas, le Relais de trames est utilisé).

    Remarque: Il est obligatoire d'installer une interface de bouclage avec un masque IP de 32 bits.

    Cette adresse est utilisée pour l'installation du réseau MPLS et du TE par le protocole de routage. Cette adresse de bouclage doit être accessible par l'intermédiaire de la table de routage globale.

  2. Installez un protocole de routage pour le réseau MPLS. Ce doit être un protocole de routage à état de liens (IS-IS ou OSPF). Dans le mode de configuration de protocole de routage, entrez :

    • Pour l'IS-IS :

      metric-style wide (or metric-style both) 
      mpls traffic-eng router-id LoopbackN 
      mpls traffic-eng [level-1 | level-2 |]
    • Pour l'OSPF :

      mpls traffic-eng area X 
      mpls traffic-eng router-id LoopbackN (must have a 255.255.255.255 mask)
  3. Enable MPLS TE. Entrez dans l'ip cef (ou l'ip cef distribué si disponible afin d'améliorer la représentation) en mode de configuration générale. Activez MPLS (IP de balise-commutation) sur chaque interface intéressée. Entrez dans le tunnel d'Ingénierie de trafic MPLS pour activer MPLS TE, aussi bien que le RSVP pour des tunnels de la zéro-bande passante TE.

  4. Activez le RSVP en entrant dans l'ip rsvp bandwidth XXX sur chaque interface intéressée pour les tunnels différents de zéro de bande passante.

  5. Tunnels d'installation à utiliser pour TE. Il y a beaucoup d'options qui peuvent être configurées pour le tunnel MPLS TE, mais la commande de tunnel mode mpls traffic-eng est obligatoire. La commande de tunnel mpls traffic-eng autoroute announce annonce la présence du tunnel par le protocole de routage.

Remarque: N'oubliez pas d'utiliser le loopbackN d'ip unnumbered pour l'adresse IP des interfaces de tunnel.

Cette configuration d'échantillon affiche deux tunnels dynamiques avec la bande passante différente (et les priorités) qui vont du routeur de Pescara au routeur de Pesaro, et deux tunnels qui utilisent un chemin explicite qui va de Pesaro à Pescara.

Fichier de configuration

Seulement les éléments pertinents des fichiers de configuration sont inclus. Les commandes utilisées pour activer le MPLS sont imprimées en italiques, alors que les commandes spécifiques à TE (RSVP y compris) sont en gras.

Pesaro
Current configuration:
 !
 version 12.1
 !
 hostname Pesaro
 !
 ip cef
 mpls traffic-eng tunnels
 !
 interface Loopback0
  ip address 10.10.10.6 255.255.255.255
  ip router isis 
 !
 interface Tunnel158
  ip unnumbered Loopback0
  tunnel destination 10.10.10.4
  tunnel mode mpls traffic-eng
  tunnel mpls traffic-eng autoroute announce
  tunnel mpls traffic-eng priority 2 2
  tunnel mpls traffic-eng bandwidth 158
  tunnel mpls traffic-eng path-option 1 explicit name low
 !
 interface Tunnel159
  ip unnumbered Loopback0
  tunnel destination 10.10.10.4
  tunnel mode mpls traffic-eng
  tunnel mpls traffic-eng autoroute announce
  tunnel mpls traffic-eng priority 4 4
  tunnel mpls traffic-eng bandwidth 159
  tunnel mpls traffic-eng path-option 1 explicit name straight
 !

 interface Serial0/0
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/0.1 point-to-point
  bandwidth 512
  ip address 10.1.1.22 255.255.255.252
  ip router isis 
  tag-switching ip
  mpls traffic-eng tunnels 
  frame-relay interface-dlci 603   
  ip rsvp bandwidth 512 512
 !
 router isis 
  net 49.0001.0000.0000.0006.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 !
 ip classless
 !
 ip explicit-path name low enable
  next-address 10.1.1.21 
  next-address 10.1.1.10 
  next-address 10.1.1.1 
  next-address 10.1.1.14 
 !
 ip explicit-path name straight enable
  next-address 10.1.1.21 
  next-address 10.1.1.5 
  next-address 10.1.1.14 
 !
 end

Pescara
Current configuration:
 !
 version 12.0
 !
 hostname Pescara
 !

 ip cef
 !
 mpls traffic-eng tunnels
 !
 interface Loopback0
  ip address 10.10.10.4 255.255.255.255
  ip router isis 
 !
 interface Tunnel1
  ip unnumbered Loopback0

  tunnel destination 10.10.10.6
  tunnel mode mpls traffic-eng
  tunnel mpls traffic-eng autoroute announce
  tunnel mpls traffic-eng priority 5 5
  tunnel mpls traffic-eng bandwidth 25
  tunnel mpls traffic-eng path-option 2 dynamic
 !
 interface Tunnel3
  ip unnumbered Loopback0

  tunnel destination 10.10.10.6
  tunnel mode mpls traffic-eng
  tunnel mpls traffic-eng autoroute announce
  tunnel mpls traffic-eng priority 6 6
  tunnel mpls traffic-eng bandwidth  69
  tunnel mpls traffic-eng path-option 1 dynamic
 !

 interface Serial0/1
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/1.1 point-to-point
  bandwidth 512
  ip address 10.1.1.14 255.255.255.252

  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 401   
  ip rsvp bandwidth 512 512
 !
 router isis 
  net 49.0001.0000.0000.0004.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 end

Pomerol
Current configuration:

 version 12.0
 !
 hostname Pomerol
 !
 ip cef
 !
 mpls traffic-eng tunnels
!
 interface Loopback0
  ip address 10.10.10.3 255.255.255.255
  ip router isis 
 !
 interface Serial0/1
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/1.1 point-to-point
  bandwidth 512
  ip address 10.1.1.6 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
   frame-relay interface-dlci 301   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/1.2 point-to-point
  bandwidth 512
  ip address 10.1.1.9 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 302   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/1.3 point-to-point
  bandwidth 512
  ip address 10.1.1.21 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 306   
  ip rsvp bandwidth 512 512
 !
 router isis 
  net 49.0001.0000.0000.0003.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 ip classless
 !
 end

Pulligny
Current configuration:
 !
 version 12.1
 !
 hostname Pulligny
 !
 ip cef
 !
 mpls traffic-eng tunnels
 !
 interface Loopback0
  ip address 10.10.10.2 255.255.255.255
 !
 interface Serial0/1
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/1.1 point-to-point
  bandwidth 512
  ip address 10.1.1.2 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 201   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/1.2 point-to-point
  bandwidth 512
  ip address 10.1.1.10 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 203   
  ip rsvp bandwidth 512 512
 !
 router isis 
  passive-interface Loopback0
  net 49.0001.0000.0000.0002.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 ip classless
 !
 end

Pauillac
!
 version 12.1
 !
 hostname pauillac
 !
 ip cef
 mpls traffic-eng tunnels
 !
 interface Loopback0
  ip address 10.10.10.1 255.255.255.255
  ip router isis 
 !
 interface Serial0/0
  no ip address
  encapsulation frame-relay
 !
 interface Serial0/0.1 point-to-point
  bandwidth 512
  ip address 10.1.1.1 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 102   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/0.2 point-to-point
  bandwidth 512
  ip address 10.1.1.5 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 103   
  ip rsvp bandwidth 512 512
 !
 interface Serial0/0.3 point-to-point
  bandwidth 512
  ip address 10.1.1.13 255.255.255.252
  ip router isis 
  mpls traffic-eng tunnels
  tag-switching ip
  frame-relay interface-dlci 104   
  ip rsvp bandwidth 512 512
 !
 router isis 
  net 49.0001.0000.0000.0001.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
 !
 ip classless
 !
 end

Vérifiez

Commandes show

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

  • brief de show mpls traffic-eng tunnels

  • nom Pesaro_t158 de show mpls traffic-eng tunnels

  • show ip rsvp interface

  • bande passante 75 de 10.10.10.6 de destination de show mpls traffic-eng topology path

D'autres commandes utiles (non illustrées ici) incluent :

  • show isis mpls traffic-eng advertisements

  • affichez l'expédition-table de balise-commutation

  • show ip cef

  • show mpls traffic-eng tunnels summary

Exemple de sortie avec show

Sur n'importe quel LSR, vous pouvez utiliser le show mpls traffic-eng tunnels pour vérifier l'existence et l'état des tunnels. Par exemple, sur Pesaro, vous voyez un total de quatre tunnels, deux qui arrivent chez Pesaro (Pescara_t1 et T3) et deux qui commencent à partir de Pesaro (t158 et t159) :

Pesaro#show mpls traffic-eng tunnels brief 
Signaling Summary:
    LSP Tunnels Process:            running
    RSVP Process:                   running
    Forwarding:                     enabled
    Periodic reoptimization:        every 3600 seconds, next in 606 seconds
TUNNEL NAME                      DESTINATION      UP IF     DOWN IF   STATE/PROT
Pesaro_t158                      10.10.10.4       -         Se0/0.1   up/up
Pesaro_t159                      10.10.10.4       -         Se0/0.1   up/up     
Pescara_t1                       10.10.10.6       Se0/0.1   -         up/up     
Pescara_t3                       10.10.10.6       Se0/0.1   -         up/up     
Displayed 2 (of 2) heads, 0 (of 0) midpoints,2 (of 2) tails

C'est ce qui est vu tandis que sur un routeur moyen :

Pulligny#show mpls traffic-eng tunnels brief 
Signaling Summary:
    LSP Tunnels Process:            running
    RSVP Process:                   running
    Forwarding:                     enabled
    Periodic reoptimization:        every 3600 seconds, next in 406 seconds
TUNNEL NAME                      DESTINATION      UP IF     DOWN IF   STATE/PROT
Pescara_t3                       10.10.10.6       Se0/1.1   Se0/1.2   up/up
Pesaro_t158                      10.10.10.4       Se0/1.2   Se0/1.1   up/up
Displayed 0 (of 0) heads, 2 (of 2) midpoints, 0 (of 0) tails

La configuration détaillée de n'importe quel tunnel peut être vue utilisant ceci :

Pesaro#show mpls traffic-eng tunnels name Pesaro_t158

Name: Pesaro_t158                         (Tunnel158) Destination: 10.10.10.4
  Status:
    Admin: up         Oper: up     Path: valid       Signaling: connected

    path option 1, type explicit low (Basis for Setup, path weight 40)

  Config Parameters:
    Bandwidth:  158      kbps  Priority: 2  2   Affinity: 0x0/0xFFFF
    AutoRoute:  enabled   LockDown: disabled    

  InLabel  :  - 
  OutLabel : Serial0/0.1, 17
  RSVP Signaling Info:
       Src 10.10.10.6, Dst 10.10.10.4, Tun_Id 158, Tun_Instance 1601
    RSVP Path Info:
      My Address: 10.10.10.6   
      Explicit Route: 10.1.1.21 10.1.1.10 10.1.1.1 10.1.1.14 
 10.10.10.4 
      Record   Route:  NONE
      Tspec: ave rate=158 kbits, burst=8000 bytes, peak rate=158 kbits
    RSVP Resv Info:
      Record   Route:  NONE
      Fspec: ave rate=158 kbits, burst=8000 bytes, peak rate=4294967 kbits
  History:
    Current LSP:
      Uptime: 3 hours, 33 minutes
      Selection: reoptimation
    Prior LSP:
      ID: path option 1 [1600]
      Removal Trigger: configuration changed

Dans ce cas, le chemin est explicite et spécifié dans le message de RSVP (le champ qui porte le chemin est également connu comme objet de route explicite [ERO]). Si ce chemin ne peut pas être suivi, l'engine MPLS TE utilise la prochaine option de chemin, qui peut être une autre route explicite ou une artère dynamique.

Les informations spécifiques de RSVP sont disponibles utilisant des commandes standard de RSVP. Dans cette sortie, il y a deux réservations faites sur Pulligny, un par Pesaro_t158 (158K) et l'autre par Pescara_t3 (69k).

Pulligny#show ip rsvp interface
interface    allocated  i/f max  flow max pct UDP  IP   UDP_IP   UDP M/C 
Se0/1        0M         0M       0M       0   0    0    0        0       
Se0/1.1      158K       512K     512K     30  0    1    0        0 
Se0/1.2      69K        512K     512K     13  0    1    0        0

Si vous voulez connaître quel chemin TE est utilisé pour une destination particulière (et une bande passante particulière) sans créer un tunnel, vous pouvez utiliser cette commande :

Remarque: Veuillez noter que cette commande est enveloppée à une deuxième ligne pour des raisons spatiales.

Pescara#show mpls traffic-eng topology path destination 
                          10.10.10.6 bandwidth 75
Query Parameters:
  Destination: 10.10.10.6
    Bandwidth: 75
   Priorities: 0 (setup), 0 (hold)
     Affinity: 0x0 (value), 0xFFFFFFFF (mask)
Query Results:
  Min Bandwidth Along Path: 385 (kbps)
  Max Bandwidth Along Path: 512 (kbps)
  Hop  0: 10.1.1.14      : affinity 00000000, bandwidth 512 (kbps)
  Hop  1: 10.1.1.5       : affinity 00000000, bandwidth 385 (kbps)
  Hop  2: 10.1.1.21      : affinity 00000000, bandwidth 512 (kbps)
  Hop  3: 10.10.10.6

Si le réseau fait la propagation d'IP TTL (référez-vous à la propagation d'ip ttl de MPLS), émettez une commande traceroute et voyez que le chemin suivi est le tunnel et que les artères de tunnel selon ce qui est configuré :

Pescara#traceroute 10.10.10.6

Type escape sequence to abort.
Tracing the route to 10.10.10.6

  1 10.1.1.13 [MPLS: Label 29 Exp 0] 540 msec 312 msec 448 msec
  2 10.1.1.2 [MPLS: Label 27 Exp 0] 260 msec 276 msec 556 msec
  3 10.1.1.9 [MPLS: Label 29 Exp 0] 228 msec 244 msec 228 msec
  4 10.1.1.22 112 msec *  104 msec

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 13737