Commutation multiprotocole par étiquette (MPLS) : MPLS

Configuration d'un VPN MPLS de base à l'aide du protocole OSPF

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document indique comment configurer un réseau de base de commutation multiprotocole par étiquette (MPLS). Référez-vous aux exemples et au TechNotes de configuration sur la page de support MPLS pour plus d'informations sur la façon configurer des sujets avancés tels que VPN ou ingénierie de trafic (TE).

Conditions préalables

Conditions requises

Cisco recommande que vous soyez au courant du fonctionnement de base du MPLS. Référez-vous à l'aperçu multiprotocole de commutation par étiquette pour un aperçu de MPLS.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Versions de logiciel 12.2(28) de Cisco IOSÝ

  • Routeurs de Cisco 3600

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Mécanisme

Un réseau MPLS est généralement un réseau fédérateur consisté en les Routeurs MPLS-activés appelés les Routeurs de commutateur d'étiquette (LSR). Généralement, le réseau se compose d'un noyau LSR avec une périphérie LSR qui applique des étiquettes aux paquets.

C'est le mécanisme d'installation d'un réseau MPLS :

  1. Des tables de routage du LSRs différent sont calculées avec un Protocole IGP (Interior Gateway Protocol). Un protocole de routage à état de liens, tel que le Protocole OSPF (Open Shortest Path First) ou le Protocole IS-IS (Intermediate System-to-Intermediate System), est exigé si vous prévoyez de déployer MPLS TE.

  2. Un protocole de distribution d'étiquette (LDP) annonce les attaches entre les artères et les étiquettes. Ces attaches sont vérifiées contre la table de routage. Si l'artère (préfixe/masque et prochain saut) apprise du LDP apparie l'artère apprise de l'IGP dans la table de routage, une entrée est créée dans l'étiquette cette les bases d'informations de forwards (LFIB) sur le LSR.

Le LSR utilise ce mécanisme de transfert :

  1. Une fois une périphérie LSR reçoit un paquet non étiqueté, la table de Cisco Express Forwarding est vérifiée et une étiquette est imposée au paquet si nécessaire. Ce LSR s'appelle le d'entrée LSR.

  2. Sur l'arrivée d'un paquet étiqueté à l'interface d'arrivée d'un noyau LSR, le LFIB fournit l'interface sortante et la nouvelle étiquette qui est associée avec le paquet sortant.

  3. Le routeur avant le dernier LSR (le saut pénultième) saute l'étiquette et transmet le paquet sans étiquette. Le dernier saut s'appelle le de sortie LSR.

Ce diagramme montre cette configuration réseau :

/image/gif/paws/13736/1b.gif

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Dans les informations complémentaires de découverte des FO de commande sur les commandes utilisées dans ce document, utilisez le Command Lookup Tool (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/13736/1a.gif

Guide de configuration rapide

Utilisez cette procédure comme guide de configuration rapide.

  1. Installez votre réseau comme d'habitude. Le MPLS a besoin d'une connexion IP standard afin d'établir les bases avancées.

  2. Assurez-vous que les travaux de protocole de routage (OSPF ou IS-IS) correctement. Ces commandes sont imprimées en italiques dans les configurations dans la section suivante.

  3. Activez l'ip cef, parce que de meilleures représentations utilisent l'ip cef distribué si disponibles, dans le mode de configuration générale. Ceci est affiché en gras dans les configurations dans la section suivante.

  4. Activez l'IP de MPLS, ou l'IP de balise-commutation sur des versions logicielles plus anciennes de Cisco IOS, en mode de configuration générale et dans chaque interface, suivant les indications de gras dans les configurations dans la section suivante. Même lorsque la commande d'IP de MPLS est utilisée, la sortie courante d'exposition peut encore afficher la commande comme IP de balise-commutation dans des quelques versions logicielles de Cisco IOS, suivant les indications des configurations dans la section suivante.

    Remarque: Le LSRs doit avoir () des interfaces de bouclage avec un masque d'adresse de 32 bits et ces interfaces doivent être accessibles avec la table globale de Routage IP.

Configurations

Ce document utilise les configurations suivantes :

Pomerol

!
version 12.2

!
hostname Pomerol
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.3 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.21 255.255.255.252
 tag-switching ip
!
interface Serial3/0
 ip address 10.1.1.6 255.255.255.252
 tag-switching ip
!
interface Serial4/0
 ip address 10.1.1.9 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
! 
ip classless
!
end

Pulligny

!
version 12.2
!
hostname Pulligny
!
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.2 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.2 255.255.255.252
 tag-switching ip
!
interface Serial3/0
 ip address 10.1.1.10 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

Pauillac
!
version 12.2
!
hostname Pauillac
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.13 255.255.255.252
 tag-switching ip
!
interface Serial3/0
 ip address 10.1.1.17 255.255.255.252
 tag-switching ip
!
interface Serial4/0
 ip address 10.1.1.1 255.255.255.252
 tag-switching ip
!
interface Serial5/0
 ip address 10.1.1.5 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

Pescara
!
version 12.2
!
hostname Pescara
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.4 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.14 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

Pesaro
!
version 12.2
!
hostname Pesaro
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.6 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.22 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

Pérouse
!
version 12.2
!
hostname Perugia
!
ip subnet-zero
!
ip cef
!
interface Loopback0
 ip address 10.10.10.5 255.255.255.255
!
interface Serial2/0
 ip address 10.1.1.18 255.255.255.252
 tag-switching ip
!
router ospf 10
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 9
!
ip classless
!
end

Vérifiez

Cette section fournit des informations qui vous permettront de vérifier que votre configuration fonctionne correctement.

Les commandes utilisées dans le MPLS de base configurant utilisant la configuration d'échantillon IS-IS s'appliquent également.

Afin d'illustrer cette configuration d'échantillon, regardez une destination particulière, par exemple 10.10.10.4, sur le Pomerol LSR.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • show ip route — Utilisé pour vérifier l'artère IP pour ce destination in la table de Routage IP :

    Pomerol#show ip route 10.10.10.4
    Routing entry for 10.10.10.4/32
      Known via "ospf 10", distance 110, metric 129, type intra area
      Last update from 10.1.1.5 on Serial3/0, 17:29:23 ago
      Routing Descriptor Blocks:
      * 10.1.1.5, from 10.10.10.4, 17:29:23 ago, via Serial3/0
          Route metric is 129, traffic share count is 1
    
  • show mpls forwarding-table — Utilisé pour vérifier la table d'expédition MPLS, qui est l'équivalent de commutation par étiquette de la table de Routage IP pour le Routage IP standard. Il contient les étiquettes d'arrivée et sortantes et les descriptions des paquets.

    Pomerol#show mpls forwarding-table 
    Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
    tag    tag or VC   or Tunnel Id      switched   interface
    16     Pop tag     10.1.1.12/30      636        Se3/0      point2point
    17     Pop tag     10.10.10.1/32     0          Se3/0      point2point
    18     21          10.10.10.4/32     0          Se3/0      point2point
    19     Pop tag     10.1.1.0/30       0          Se4/0      point2point
           Pop tag     10.1.1.0/30       0          Se3/0      point2point
    20     Pop tag     10.10.10.6/32     612        Se2/0      point2point
    21     Pop tag     10.1.1.16/30      0          Se3/0      point2point
    22     16          10.10.10.5/32     0          Se3/0      point2point
    23     Pop tag     10.10.10.2/32     0          Se4/0      point2point
  • détail de show mpls forwarding-table — Utilisé pour voir des détails de table d'expédition MPLS :

    Pomerol#show mpls forwarding-table 10.10.10.4 32 detail
    Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
    tag    tag or VC   or Tunnel Id      switched   interface
    18     21          10.10.10.4/32     0          Se3/0      point2point
            MAC/Encaps=4/8, MRU=1500, Tag Stack{21}
            0F008847 00015000
            No output feature configured
        Per-packet load-sharing
  • le show mpls ldp bindings ou les attaches de TDP de balise-commutation d'exposition (basées sur quelle version logicielle de Cisco IOS vous utilisation) — utilisée pour voir les attaches d'étiquette a associé avec une destination particulière. Les attaches locales aussi bien que distantes peuvent être vues.

    Pomerol#show tag-switching tdp bindings 10.10.10.4 32
      tib entry: 10.10.10.4/32, rev 14
            local binding:  tag: 18
            remote binding: tsr: 10.10.10.1:0, tag: 21
            remote binding: tsr: 10.10.10.2:0, tag: 23
            remote binding: tsr: 10.10.10.6:612, tag: 20 
    
    

    Notez que des étiquettes pour chaque classe d'expédition sont établies à chaque LSR, même si elles ne sont pas sur le chemin (le plus court) préféré. Dans ce cas, un paquet destiné à 10.10.10.4/32 peut aller par 10.10.10.1 (avec étiquette 21) ou par 10.10.10.2 (avec étiquette 23). Le LSR choisit la première solution parce qu'il est le plus court. Cette décision est prise avec la table standard de Routage IP, qui dans ce cas, est construite avec l'OSPF.

  • détail de show ip cef — Utilisé au contrôle que Cisco Express Forwarding fonctionne correctement et que des balises sont permuté correctement :

    Pomerol#show ip cef 10.10.10.4 detail
    10.10.10.4/32, version 37, cached adjacency to Serial3/0
    0 packets, 0 bytes
      tag information set
        local tag: 18
        fast tag rewrite with Se3/0, point2point, tags imposed: {21}
      via 10.1.1.5, Serial3/0, 0 dependencies
        next hop 10.1.1.5, Serial3/0
        valid cached adjacency
        tag rewrite with Se3/0, point2point, tags imposed: {21}
    

Dépannez

Référez-vous au dépannage MPLS pour les informations sur la façon dont dépanner le MPLS.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 13736