Commutation multiprotocole par étiquette (MPLS) : MPLS

Configuration d'un VPN MPLS de base à l'aide du protocole IS-IS

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Cet exemple de configuration montre comment configurer un réseau de commutation multiprotocole par étiquette (MPLS) pour d'autres tâches telles que le réseau privé virtuel (VPN) ou l'ingénierie de trafic (voir plus d'exemples de configuration sur la page de support de MPLS).

Conditions préalables

Conditions requises

Avant d'essayer cette configuration, veuillez vous assurer que vous remplissez les conditions préalables suivantes :

  • Afin d'implémenter le MPLS, vous avez besoin d'un routeur de Cisco 2600 ou plus tard.

  • Choisissez le Cisco IOS requis avec le MPLS utilisant le conseiller de logiciel (clients enregistrés seulement).

  • Vérifiez la RAM supplémentaire et la mémoire flash requises exécuter le MPLS dans les Routeurs. Les cartes d'interface WAN (WIC), WIC-1T et WIC-2T, peuvent être utilisées.

Composants utilisés

Les informations dans ce document sont basées sur les versions de logiciel et de matériel ci-dessous.

  • Cisco 3640, Cisco 3660, Cisco 4500, et Routeur Cisco 2610

  • La version de logiciel 12.2(6h) de Cisco IOSÝ s'exécute sur tous les Routeurs

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Théorie générale

Un réseau MPLS est généralement un réseau fédérateur consisté en les Routeurs MPLS-activés appelés les Routeurs de commutateur d'étiquette (LSR). Généralement, le réseau se compose d'un noyau LSR avec une périphérie LSR responsable d'appliquer des étiquettes aux paquets.

Le mécanisme d'installation d'un réseau MPLS est le suivant.

  • Des tables de routage du LSRs différent sont calculées utilisant un Protocole IGP (Interior Gateway Protocol). Un protocole de routage à état de liens tel que le Protocole OSPF (Open Shortest Path First) ou le Protocole IS-IS (Intermediate System-to-Intermediate System) est exigé si vous allez déployer l'Ingénierie de trafic MPLS.

  • Un protocole de distribution d'étiquette (LDP) annonce les attaches entre les artères et les étiquettes. Ces attaches sont vérifiées contre la table de routage. Si l'artère (préfixe/masque et prochain saut) apprise par l'intermédiaire du LDP apparie l'artère apprise par l'intermédiaire de l'IGP dans la table de routage, une entrée est créée dans les Forwarding Information Base d'étiquette (LFIB) sur le LSR.

Le LSR utilise le mécanisme de transfert suivant.

  • Une fois une périphérie LSR reçoit un paquet non étiqueté, la table d'express forwarding de Cisco est vérifiée et une étiquette est imposée au paquet si nécessaire. Ce LSR s'appelle le d'entrée LSR.

  • Sur l'arrivée d'un paquet étiqueté à l'interface entrante d'un noyau LSR, le LFIB fournit l'interface sortante et la nouvelle étiquette qui seront associées avec le paquet sortant.

  • Le routeur avant le dernier LSR (le saut pénultième) saute l'étiquette et transmet le paquet sans étiquette. Le dernier saut s'appelle le de sortie LSR.

Le diagramme suivant montre cette configuration réseau.

/image/gif/paws/13735/1b.gif

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/13735/1a.gif

Configurations

Ce document utilise les configurations suivantes :

Guide de configuration rapide

Terminez-vous ces étapes pour configurer le MPLS :

  1. Installez votre réseau comme d'habitude (le MPLS a besoin d'une connexion IP standard afin d'établir les bases avancées).

  2. Assurez-vous que le protocole de routage (OSPF ou IS-IS) fonctionne correctement. Ces commandes sont affichées en italique dans les configurations dans cette section.

  3. Utilisez la commande d'ip cef (pour de meilleures représentations, utilisez la commande distribuée d'ip cef si disponible) en mode de configuration générale (affiché en gras dans les configurations dans cette section) d'activer.

  4. Utilisez la commande d'IP de MPLS (ou la commande d'IP de balise-commutation sur des versions logicielles plus anciennes de Cisco IOS) en mode de configuration générale et dans chaque interface (affichée en gras dans les configurations dans cette section) d'activer.

    Remarque:  Le LSRs doit avoir () des interfaces de bouclage avec un masque d'adresse de 32 bits.

Pomerol
Current configuration:
!
version 12.2
!
hostname Pomerol
!
ip cef

!--- Enables Cisco Express Forwarding globally.

!
interface Loopback0
 ip address 10.10.10.3 255.255.255.255
 ip router isis 

!--- Assigns an IP address to interface loopback0 
!--- and enables IS-IS for IP on the interface.

!
interface Serial0/0
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 ip address 10.1.1.6 255.255.255.252
 ip router isis   
 tag-switching ip

!--- Enables dynamic Label Switching of 
!--- IPv4 packets on an interface.

 frame-relay interface-dlci 301   
!
interface Serial0/0.2 point-to-point
 ip address 10.1.1.9 255.255.255.252
 ip router isis  
 tag-switching ip
 frame-relay interface-dlci 303   
!
interface Serial0/0.3 point-to-point
 ip address 10.1.1.21 255.255.255.252
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 306   
!
router isis  
 net 49.0001.0000.0000.0003.00
 is-type level-1
!
ip classless
!
end

Pulligny
Current configuration:
!
version 12.1
!
hostname Pulligny
!
ip cef
!
interface Loopback0
 ip address 10.10.10.2 255.255.255.255
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 ip address 10.1.1.2 255.255.255.252
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 201   
!
interface Serial0/0.2 point-to-point
 ip address 10.1.1.10 255.255.255.252
 ip router isis 
tag-switching ip
 frame-relay interface-dlci 203   
!
router isis
 redistribute static ip
 passive-interface Loopback0
 net 49.0001.0000.0000.0002.00
 is-type level-1

!--- Enables the IS-IS process on the router,
!--- makes loopback interface passive 
!--- (does not send IS-IS packets on interface), 
!--- and assigns area and system ID to router.

!
ip classless
!
end

Pauillac
Current configuration : 2366 bytes
!
version 12.1
!
hostname pauillac
!
ip cef
!
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
 ip router isis
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 ip address 10.1.1.1 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 102   
!
interface Serial0/0.2 point-to-point
 ip address 10.1.1.5 255.255.255.252
 ip access-group 150 out
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 103   
!
interface Serial0/0.3 point-to-point
 bandwidth 512
 ip address 10.1.1.13 255.255.255.252
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 104   
!
interface Serial0/0.4 point-to-point
 ip address 10.1.1.17 255.255.255.252
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 105
!
!
router isis
 net 49.0001.0000.0000.0001.00
 is-type level-1
!
ip classless
!
end

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • affichez le voisin de TDP de balise-commutation

  • affichez les attaches de TDP de balise-commutation

  • affichez l'expédition-table de balise-commutation

  • affichez le détail de l'expédition-table a.b.c.d de balise-commutation

  • traceroute a.b.c.d

Une liste exhaustive de commandes est incluse dans la référence de commandes MPLS. D'autres exemples de commande show sont décrits en configurant le MPLS de base utilisant l'OSPF.

Exemple de sortie

Cette sortie se concentre sur le LDP. Le LDP actuellement mis en application dans l'IOS est le Protocole TDP (protocole de distribution de balise), qui contient quelques extensions de propre à Cisco, mais il soit utilisé avec le LDP, le protocole officiel IETF pour la distribution d'étiquette. Le Protocole TDP sera remplacé par LDP à l'avenir.

Vous pouvez employer le TDP de balise-commutation d'exposition * commande afin de vérifier l'état de Protocole TDP. Vous pouvez voir des voisins avec la commande neighbor de TDP de balise-commutation d'exposition.

Pulligny# show tag-switching tdp discovery
Local TDP Identifier:    
	10.10.10.2:0
TDP Discovery Sources:    
  Interfaces:
 Serial0/0.1: xmit/recv            
   TDP Id: 10.10.10.1:0
 Serial0/0.2: xmit/recv
   TDP Id: 10.10.10.3:0

!--- Ensure you are able to ping this IP address
!--- If not, check whether a route exists in the routing table

Pulligny# show tag-switching tdp neighbor 
Peer TDP Ident: 10.10.10.1:0; Local TDP Ident 10.10.10.2:0
        TCP connection: 10.10.10.1.711 - 10.10.10.2.11001
        State: Oper; PIEs sent/rcvd: 27907/27925; ; Downstream
        Up time: 2w2d
        TDP discovery sources:
          Serial0/0.1
        Addresses bound to peer TDP Ident:
          10.1.1.1        10.1.1.13       10.1.1.17       10.10.10.1      
          10.1.1.5        10.200.28.89    
Peer TDP Ident: 10.10.10.3:0; Local TDP Ident 10.10.10.2:0
        TCP connection: 10.10.10.3.11001 - 10.10.10.2.711
        State: Oper; PIEs sent/rcvd: 22893/22874; ; Downstream
        Up time: 1w6d
        TDP discovery sources:
          Serial0/0.2
        Addresses bound to peer TDP Ident:
          10.200.28.91    10.1.1.6        10.1.1.9        10.1.1.21       
          10.10.10.3

Vous pouvez utiliser les attaches de TDP de balise-commutation d'exposition commandez afin de visualiser les attaches établies entre les étiquettes et les artères.

Pulligny# show tag-switching tdp bindings 
(...)
  tib entry: 10.10.10.4/32, rev 22
        local binding:  tag: 21
        remote binding: tsr: 10.10.10.1:0, tag: 22
        remote binding: tsr: 10.10.10.3:0, tag: 25
  tib entry: 10.10.10.6/32, rev 51
        local binding:  tag: 23
        remote binding: tsr: 10.10.10.3:0, tag: 18
        remote binding: tsr: 10.10.10.1:0, tag: 20
(...)

Vous pouvez employer la commande d'expédition-table de balise-commutation d'exposition afin de voir quelles attaches sont utilisées pour construire le LFIB.

Pulligny# show tag-switching forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface 
16     Pop tag     10.1.1.4/30       0          Se0/0.2    point2point       
       Pop tag     10.1.1.4/30       0          Se0/0.1    point2point
17     Pop tag     10.1.1.20/30      0          Se0/0.2    point2point
18     Pop tag     10.10.10.3/32     0          Se0/0.2    point2point
19     Pop tag     10.10.10.1/32     0          Se0/0.1    point2point
20     Pop tag     10.1.1.12/30      0          Se0/0.1    point2point
21     Pop tag     10.1.1.16/30      0          Se0/0.1    point2point
22     20          10.10.10.5/32     0          Se0/0.1    point2point
23     22          10.10.10.6/32     0          Se0/0.2    point2point
24     22          10.10.10.4/32     0          Se0/0.1    point2point

Vous pouvez utiliser la commande de détail de 10.10.10.4 d'expédition-table de balise-commutation d'exposition de visualiser les détails d'une destination donnée.

Pulligny# show tag-switching forwarding-table 10.10.10.4 detail 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
21     22          10.10.10.4/32     12103      Se0/0.1    point2point  
        MAC/Encaps=4/8, MTU=1500, Tag Stack{22}
        30918847 00016000
    Per-packet load-sharing

Vous pouvez également utiliser la commande traceroute, si le réseau fait la propagation d'IP TTL, de visualiser les sauts. Référez-vous à la commutation par étiquette multiprotocole sur des Routeurs de Cisco pour plus d'informations sur la commande de propagation d'ip ttl de MPLS.

Pesaro# traceroute 10.10.10.4

Type escape sequence to abort.
Tracing the route to 10.10.10.4

  1 10.1.1.21 [MPLS: Label 25 Exp 0] 296 msec 256 msec 244 msec
  2 10.1.1.5 [MPLS: Label 22 Exp 0] 212 msec 392 msec 352 msec
  3 10.1.1.14 436 msec *  268 msec

Remarque: L'exp 0 apparaît dans la sortie si le champ expérimental est utilisé pour le Qualité de service (QoS).

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 13735