Commutation multiprotocole par étiquette (MPLS) : MPLS

Configuration d'un VPN MPLS de base avec RIP côté client

30 juillet 2013 - Traduction automatique
Autres versions: PDFpdf | Anglais (16 novembre 2007) | Commentaires


Contenu


Introduction

Cet exemple de configuration montre un réseau privé virtuel (VPN) de commutation multiprotocole par étiquette (MPLS) lorsque le protocole d'information de routage (RIP) est présent du côté du client.

La caractéristique VPN, une fois utilisée avec le MPLS, permet à plusieurs sites pour interconnecter d'une manière transparente par un fournisseur de services. Un réseau du fournisseur de service peut prendre en charge plusieurs VPN d'IP différents. Chaque IP VPN apparaît comme réseau privé, séparé de tous autres réseaux. Chaque site dans un VPN envoie des paquets IP à d'autres sites dans le même VPN.

Chaque VPN est associé avec un ou plusieurs VPN de routage ou instances de transmission (VRF). UN VRF se compose d'une table de Routage IP, d'une table dérivée de Technologie Cisco Express Forwarding (CEF), et d'un ensemble d'interfaces qui utilisent la table d'expédition.

Le routeur conserve un routage distinct et la table CEF pour chaque VRF. Ceci empêche les informations d'être envoyé en dehors du VPN et permet le même sous-réseau à utiliser dans plusieurs VPN sans poser des problèmes d'adresse IP en double.

Le routeur utilisant le Protocole BGP (Border Gateway Protocol) distribue les informations de routage VPN utilisant les communautés BGP étendues.

Pour plus d'informations sur la propagation des mises à jour par un VPN voir les communautés cibles de la route VPN, la distribution BGP des informations de routage VPN, et le MPLS expédiant des sections dans des réseaux privés virtuels MPLS.

Conditions préalables

Conditions requises

Aucune condition préalable spécifique n'est requise pour ce document.

Composants utilisés

Nous avons développé et avons testé cette configuration utilisant le logiciel et les versions de matériel ci-dessous :

  • Routeurs de PE : La fonctionnalité VPN MPLS réside dans les Routeurs de PE. Utilisez le navigateur de caractéristique II (clients enregistrés seulement) pour déterminer quelles combinaisons de matériel et de logiciel vous pouvez utiliser.

  • Routeurs de la CE : Utilisez n'importe quel routeur capable permuter les informations de routage avec son routeur PE.

  • Routeurs et Commutateurs P : Dans ce document, des Commutateurs ATM tels que le MSR, le BPX et les MGX ont été utilisés. Cependant, parce que le document se concentre sur la caractéristique MPLS VPN nous pourrions également avoir utilisé la trame en fonction MPLS au centre avec des Routeurs, tels que le Cisco 12000.

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Description du réseau

Nous avons installé un circuit principal standard atmosphère MPLS utilisant la région 0 de Protocole OSPF (Open Shortest Path First) comme Protocole IGP (Interior Gateway Protocol). Nous avons configuré deux VPN différents utilisant ce circuit principal. Les premières utilisations VPN DÉCHIRENT en tant que son Customer Edge au protocole de routage du Provider Edge (CE-PE) ; l'autre VPN utilise le BGP en tant que son protocole de routage PE-CE. Nous avons configuré de diverses artères de bouclage et de charge statique sur les Routeurs de la CE pour simuler la présence d'autres Routeurs et réseaux.

Remarque: Le BGP doit être utilisé comme IGP VPN entre les Routeurs de PE, puisque l'utilisation des communautés BGP étendues est la seule manière de transporter les informations de routage pour le VPN entre les Routeurs de PE.

Remarque: Un réseau atmosphère a été utilisé comme réseau fédérateur pour faire cette configuration. Cette configuration s'applique aux protocoles atmosphère (et autre). Les Routeurs de PE doivent pouvoir s'atteindre utilisant le réseau MPLS pour que la configuration du VPN fonctionne.

Conventions

Les lettres ci-dessous représentent les différents types des Routeurs et de Commutateurs utilisés :

  • P : Le principal routeur du fournisseur

  • PE : Routeur de la périphérie du fournisseur

  • CE : Routeur de la périphérie du client

  • C : Le routeur du client

Une configuration typique illustrant ces conventions est affichée dans le diagramme ci-dessous :

/image/gif/paws/13732/mpls_vpn_rip_mplsvpn.gif

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Procédure de configuration

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document. La documentation Cisco IOS trouvée dans des réseaux privés virtuels MPLS décrit également cette procédure de configuration.

Remarque: Pour trouver les informations complémentaires sur les commandes utilisées dans ce document, utilisez l'utilitaire de recherche de commande IOS (les clients enregistrés seulement)

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

/image/gif/paws/13732/mpls_vpn_rip_mv_rip.gif

Partie I

Les étapes ci-dessous vous aideront à configurer correctement.

Activez la commande d'ip cef. Si à l'aide d'un routeur de Cisco 7500, assurez-vous que la commande distribuée d'ip cef est activée, où disponible, pour améliorer des représentations sur le PE, une fois que le MPLS est installé.

  1. Créez un VRF pour chaque VPN utilisant le vrf d'IP [routage VPN | commande de forwarding instance name]. Tout en créant les vrf, soyez sûr à :

    • Spécifiez le moteur de distinction de route correct utilisé pour ce VPN utilisant la commande ci-dessous. Le distinguisher est utilisé pour étendre l'adresse IP et te permet pour l'identifier à quel VPN il appartient.

      rd [VPN route distinguisher]
      
    • Installez les propriétés d'importation et d'exportation pour les communautés BGP étendues utilisant la commande ci-dessous. Ces propriétés sont utilisées pour filtrer le processus d'importation et d'exportation.

      route-target {export | import | both} [target VPN extended community] 
      
  2. Configurez les détails de transfert pour les interfaces respectives utilisant la commande d'ip vrf forwarding [nom de la table] et souvenez-vous pour installer l'adresse IP après.

  3. Selon le protocole de routage PE-CE utilisé, faites un ou plusieurs de ce qui suit :

    • Configurez les artères statiques comme suit :

      ip route vrf vrf-name prefix mask [next-hop-address] [interface {interface-number}] 
      
    • Configurez le RIP utilisant la commande suivante :

      address-family ipv4 vrf [VPN routing | forwarding instance name] 
      

      Une fois que vous vous êtes terminé une ou chacun des deux étapes ci-dessus, sélectionnez les commandes normales de configuration RIP.

      Remarque: Ces commandes s'appliquent seulement aux interfaces de transfert du VRF en cours. Redistribuez le BGP correct dans le RIP et souvenez-vous pour spécifier la mesure utilisée.

    • Déclarez les informations sur les voisins BGP.

    • Configurez l'OSPF utilisant la nouvelle commande IOS :

      router ospf process-id vrf [VPN routing | forwarding instance name] 
      

    Remarque: Cette commande s'applique seulement aux interfaces de transfert pour le VRF en cours. Redistribuez les informations de routage correctes BGP dans l'OSPF et spécifiez la mesure utilisée. Une fois le processus OSPF à un VRF est complet, même si le processus OSPF n'est pas spécifié dans la ligne de commande, cet ID de processus est toujours utilisé pour ce VRF particulier.

Partie II

Configurez le BGP entre les Routeurs de PE. Il y a plusieurs façons de configurer BGP, comme utiliser les méthodes de réflecteur de route ou de confédération. La méthode affichée ici est configuration de voisinage directe. Il est le plus simple et moins l'extensible.

  1. Déclarez les différents voisins.

  2. Entrez dans le vrf d'ipv4 d'address-family [routage VPN | commande de forwarding instance name] pour chaque VPN actuel à ce routeur PE. Effectuez une ou plusieurs des étapes suivantes, selon les besoins :

    • Redistribuez les informations de routage statiques.

    • Redistribuez les informations de routage de RIP.

    • Redistribuez les informations de routage OSPF.

    • Activez le voisinage BGP avec les routeurs de la CE.

  3. Entrez le mode d'address-family vpnv4 et :

    • Activez les voisins.

    • Spécifiez que la communauté étendue doit être utilisée. Ceci est obligatoire.

Exemples de configuration

Dans la configuration d'Alcalzaba, des lignes spécifiques à la configuration du VPN sont affichées en gras.

Alcazaba
!
ip vrf vrf101
 rd 1:101
 route-target export 1:101
 route-target import 1:101
!
ip cef
!
interface Loopback0
 ip address 223.0.0.3 255.255.255.255
!
interface Ethernet1/1
 ip vrf forwarding vrf101
 ip address 150.150.0.1 255.255.255.0
!
interface ATM3/0
 no ip address
 no ip mroute-cache
 no ATM ilmi-keepalive
 PVC qsaal 0/5 qsaal
 PVC ilmi 0/16 ilmi
 !
!
interface ATM3/0.1 tag-switching
 ip address 10.0.0.17 255.255.255.252
 tag-switching ATM vpi 2-4
 tag-switching ip
!
interface ATM4/0
 no ip address
 no ATM ilmi-keepalive
!
interface ATM4/0.1 tag-switching
 ip address 10.0.0.13 255.255.255.252
 tag-switching ATM vpi 2-4
 tag-switching ip 
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 223.0.0.3 0.0.0.0 area 0
!
router rip
 version 2
 !
 address-family ipv4 vrf vrf101
 version 2
 redistribute bgp 1 metric 0
 network 150.150.0.0
 no auto-summary
 exit-address-family
!
router bgp 1
 no synchronization
 neighbor 125.2.2.2 remote-as 1
 neighbor 125.2.2.2 update-source Loopback0
 neighbor 223.0.0.21 remote-as 1
 neighbor 223.0.0.21 update-source Loopback0
 no auto-summary
 !
 address-family ipv4 vrf vrf101
 redistribute rip
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 125.2.2.2 activate
 neighbor 125.2.2.2 send-community extended
 neighbor 223.0.0.21 activate
 neighbor 223.0.0.21 send-community extended
 no auto-summary
 exit-address-family
!

Kozel
!
ip vrf vrf101
 rd 1:101
 route-target export 1:101
 route-target import 1:101
!
ip cef
!
interface Loopback0
 ip address 223.0.0.21 255.255.255.255
!
interface Ethernet1/1
 ip vrf forwarding vrf101
 ip address 200.200.0.1 255.255.255.0
!
interface ATM4/0
 no ip address
 no ATM scrambling cell-payload
 no ATM ilmi-keepalive
 PVC qsaal 0/5 qsaal     
 PVC ilmi 0/16 ilmi
!
interface ATM4/0.1 tag-switching
 ip address 10.0.0.6 255.255.255.252
 tag-switching ATM vpi 2-4
 tag-switching ip
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 0
 network 223.0.0.21 0.0.0.0 area 0
!
router rip
 version 2
 !
 address-family ipv4 vrf vrf101
 version 2
 redistribute bgp 1 metric 1
 network 200.200.0.0
 no auto-summary
 exit-address-family
!
router bgp 1
 no synchronization
 neighbor 125.2.2.2 remote-as 1
 neighbor 125.2.2.2 update-source Loopback0
 neighbor 223.0.0.3 remote-as 1
 neighbor 223.0.0.3 update-source Loopback0
 no auto-summary
 !
 address-family ipv4 vrf vrf101
 redistribute rip
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 125.2.2.2 activate
 neighbor 125.2.2.2 send-community extended
 neighbor 223.0.0.3 activate
 neighbor 223.0.0.3 send-community extended
 no auto-summary
 exit-address-family
!

La Médina
Current configuration:
!
ip vrf vrf101
 rd 1:101
 route-target export 1:101
 route-target import 1:101
ip cef
!
interface Loopback1
 ip vrf forwarding vrf101
 ip address 11.2.2.2 255.255.255.252
!
interface ATM2/0
 no ip address
 no ATM ilmi-keepalive
!
interface ATM2/0.66 tag-switching
 ip address 125.1.4.2 255.255.255.252
 tag-switching ip
!
interface Ethernet1/1
 ip vrf forwarding vrf101
 ip address 11.3.3.1 255.255.255.252
!
router ospf 1
 
 network 125.1.4.0 0.0.0.3 area 0
 network 125.2.2.2 0.0.0.0 area 0
!
router rip
 version 2
 network 11.0.0.0
 !
 address-family ipv4 vrf vrf101
 version 2
 redistribute bgp 1 metric 1
 network 11.0.0.0
 no auto-summary
 exit-address-family
!
router bgp 1
 no synchronization
 neighbor 223.0.0.3 remote-as 1
 neighbor 223.0.0.3 update-source Loopback0
 neighbor 223.0.0.21 remote-as 1
 neighbor 223.0.0.21 update-source Loopback0
 !
 address-family ipv4 vrf vrf101
 redistribute connected
 redistribute static
 redistribute rip
 default-information originate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 223.0.0.3 activate
 neighbor 223.0.0.3 send-community extended
 neighbor 223.0.0.21 activate
 neighbor 223.0.0.21 send-community extended
 exit-address-family
!

Rapide
Current configuration:


!
interface Loopback0
 ip address 223.0.0.12 255.255.255.255
!         
interface Loopback2
 ip address 7.7.7.7 255.255.255.0
!
interface FastEthernet0/1
 ip address 150.150.0.2 255.255.255.0
 duplex auto
 speed auto
!
router rip
 version 2
 redistribute static
 network 7.0.0.0
 network 10.0.0.0
 network 150.150.0.0
 no auto-summary
!
ip route 158.0.0.0 255.0.0.0 Null0
!

Damme
!
interface Loopback1
 ip address 6.6.6.6 255.0.0.0
!
interface FastEthernet0/0
 ip address 10.200.10.14 255.255.252.0
 duplex auto
 speed autoa
!
router bgp 158
 no synchronization
 network 6.0.0.0
 network 10.200.0.0 mask 255.255.252.0
 neighbor 10.200.10.3 remote-as 1
 no auto-summary
!

Pivrnec
Current configuration:
!
interface Loopback0
 ip address 223.0.0.22 255.255.255.255
!
interface Loopback1
 ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/1
 ip address 200.200.0.2 255.255.255.0
 duplex auto
 speed auto
!
router rip
 version 2
 redistribute static
 network 6.0.0.0
 network 200.200.0.0
 no auto-summary
!
ip route 69.0.0.0 255.0.0.0 Null0
!

Guilder
!
interface Loopback2
 ip address 150.150.0.1 255.255.0.0
!
interface Ethernet0/2
 ip address 201.201.201.2 255.255.255.252
!
router bgp 69
 no synchronization
 network 7.7.7.0 mask 255.255.0.0
 network 150.150.0.0
 network 201.201.201.0 mask 255.255.255.252
 redistribute connected
 neighbor 201.201.201.1 remote-as 1
 no auto-summary
!

Purkmister
Current configuration:
!
interface Loopback0
 ip address 11.5.5.5 255.255.255.252
!
interface FastEthernet0/1
 ip address 11.3.3.2 255.255.255.252
 duplex auto
 speed auto
!
router rip
 version 2
 network 11.0.0.0
!

Commandes debug et show

Avant d'utiliser les commandes debug, référez-vous à la section Informations importantes sur les commandes Debug. des commandes de Routage-particularité sont répertoriées ici :

  • vrf de show ip rip database - Affiche les informations contenues dans la base de données RIP pour un VRF particulier.

  • vrf de show ip bgp vpnv4 - Les informations d'adresse des affichages VPN de la table BGP.

  • show ip route vrf - Affiche la table de Routage IP associée avec un VRF.

  • show ip route - Affiche toutes les artères statiques IP, ou ceux installées utilisant la fonction de téléchargement d'artère d'Authentification, autorisation et comptabilité (AAA).

Certaines commandes show sont prises en charge par l'outil d'Output Interpreter (clients enregistrés seulement), qui te permet pour visualiser une analyse de sortie de commande show.

Sur un routeur PE, la méthode de routage PE-CE telle que le RIP, le BGP, ou la charge statique, et les mises à jour BGP PE-PE indiquent la table de routage utilisée pour un VRF particulier. Vous pouvez afficher les informations de RIP pour un VRF particulier comme suit :

Alcazaba# show ip rip database vrf vrf101
 0.0.0.0/0 auto-summary  
 0.0.0.0/0
 [2] via 150.150.0.2, 00:00:12, Ethernet1/1
 6.0.0.0/8 auto-summary
 6.6.6.6/32 redistributed
 [1] via 223.0.0.21,
 7.0.0.0/8 auto-summary
 7.7.7.0/24
 [1] via 150.150.0.2, 00:00:12, Ethernet1/1 
 10.0.0.0/8 auto-summary
 10.0.0.0/8 redistributed
 [1] via 125.2.2.2,
 10.0.0.0/16
 [1] via 150.150.0.2, 00:00:12, Ethernet1/1 
 10.200.8.0/22
 [1] via 150.150.0.2, 00:00:12, Ethernet1/1 
 11.0.0.0/8 auto-summary
 11.0.0.4/30 redistributed
 [1] via 125.2.2.2,
 11.1.1.0/30 redistributed
 [1] via 125.2.2.2,
 11.3.3.0/30 redistributed
 [1] via 125.2.2.2,
 11.5.5.4/30 redistributed
 [1] via 125.2.2.2,
 69.0.0.0/8 auto-summary
 69.0.0.0/8 redistributed
 [1] via 223.0.0.21,
 150.150.0.0/16 auto-summary
 150.150.0.0/24 directly connected, Ethernet1/1
 158.0.0.0/8
 [1] via 150.150.0.2, 00:00:17, Ethernet1/1
 200.200.0.0/24 auto-summary 
 200.200.0.0/24 redistributed 
 [1] via 223.0.0.21,

Vous pouvez afficher les informations BGP pour un VRF particulier utilisant la commande de vrf de show ip bgp vpnv4. Les résultats PE-PE du BGP interne (iBGP) sont indiqués par un I dans la sortie ci-dessous.

Alcazaba# show ip bgp vpnv4 vrf vrf101 
   BGP table version is 46, local router ID is 223.0.0.3 
   Status codes: s suppressed, d damped, h history, * valid, best, i - internal    
   Origin codes: i - IGP, e - EGP, ? - incomplete  
 Network Next Hop Metric LocPrf Weight Path 
   Route Distinguisher: 1:101 (default for vrf vrf101) 
   *i6.6.6.6/32 223.0.0.21 1 100 0 ? 
   * 7.7.7.0/24 150.150.0.2 1 32768 ? 
   * 10.0.0.0/16 150.150.0.2 1 32768 ? 
   * 10.200.8.0/22 150.150.0.2 1 32768 ? 
   *i11.2.2.0/30 125.2.2.2 0 100 0 ? 
   *i11.3.3.0/30 125.2.2.2 0 100 0 ? 
   *i11.5.5.4/30 125.2.2.2 1 100 0 ? 
   *i69.0.0.0 223.0.0.21 1 100 0 ? 
   * 150.150.0.0/24 0.0.0.0 0 32768 ? 
   * 158.0.0.0/8 150.150.0.2 1 32768 ? 
   *i200.200.0.0 223.0.0.21 0 100 0 ?

Vérifiez la table de routage globale pour un VRF sur le PE et les Routeurs de la CE. Ces vrf devraient s'assortir. Pour le routeur PE, vous devez spécifier le VRF utilisant la commande de show ip route vrf :

Alcazaba# show ip route vrf vrf101
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP   
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
   i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, IA - ISIS inter area    
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route
    Gateway of last resort is not set
   B 69.0.0.0/8 [200/1] via 223.0.0.21, 00:11:03
   B 200.200.0.0/24 [200/0] via 223.0.0.21, 00:11:03
    6.0.0.0/32 is subnetted, 1 subnets
   B 6.6.6.6 [200/1] via 223.0.0.21, 00:11:03 
    7.0.0.0/24 is subnetted, 1 subnets
   R 7.7.7.0 [120/1] via 150.150.0.2, 00:00:05, Ethernet1/1 
    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
   R 10.0.0.0/16 [120/1] via 150.150.0.2, 00:00:05, Ethernet1/1 
   R 10.200.8.0/22 [120/1] via 150.150.0.2, 00:00:05, Ethernet1/1 
    11.0.0.0/30 is subnetted, 3 subnets
   B 11.3.3.0 [200/0] via 125.2.2.2, 00:07:05
   B 11.2.2.0 [200/0] via 125.2.2.2, 00:07:05
   B 11.5.5.4 [200/1] via 125.2.2.2, 00:07:05
    150.150.0.0/24 is subnetted, 1 subnets
   C 150.150.0.0 is directly connected, Ethernet1/1
   R 158.0.0.0/8 [120/1] via 150.150.0.2, 00:00:06, Ethernet1/1

La commande équivalente sur Pivrnec est la commande de show ip route, puisque pour chaque routeur de client (et Customer Edge) c'est la table de routage standard.

Pivrnec# show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP  
  D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
  N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
  E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
  i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, IA - ISIS inter area  
  * - candidate default, U - per-user static route, o - ODR 
  P - periodic downloaded static route Gateway of last resort is not 
  set S 69.0.0.0/8 is directly connected, Null0 
  223.0.0.0/32 is subnetted, 1 subnets 
 C 223.0.0.22 is directly connected, Loopback0 
 C 200.200.0.0/24 is directly connected, FastEthernet0/1 
  6.0.0.0/32 is subnetted, 1 subnets 
 C 6.6.6.6 is directly connected, Loopback1 
  7.0.0.0/24 is subnetted, 1 subnets 
 R 7.7.7.0 [120/1] via 200.200.0.1, 00:00:23, FastEthernet0/1 
  10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks 
 R 10.0.0.0/16 [120/1] via 200.200.0.1, 00:00:23, FastEthernet0/1 
 R 10.200.8.0/22 [120/1] via 200.200.0.1, 00:00:24, FastEthernet0/1 
  11.0.0.0/30 is subnetted, 3 subnets 
 R 11.3.3.0 [120/1] via 200.200.0.1, 00:00:24, FastEthernet0/1 
 R 11.2.2.0 [120/1] via 200.200.0.1, 00:00:25, FastEthernet0/1 
 R 11.5.5.4 [120/1] via 200.200.0.1, 00:00:25, FastEthernet0/1 
  150.150.0.0/24 is subnetted, 1 subnets 
 R 150.150.0.0 [120/1] via 200.200.0.1, 00:00:25, FastEthernet0/1 
 R 158.0.0.0/8 [120/1] via 200.200.0.1, 00:00:25, FastEthernet0/1

Mpls label

Vérifiez la pile d'étiquette utilisée pour n'importe quelle artère comme suit :

Alcazaba# show tag-switching forwarding-table vrf vrf101 11.5.5.5 detail    
   Local Outgoing Prefix Bytes tag Outgoing Next Hop
   tag tag or VC or Tunnel Id switched interface
   None 2/91 11.5.5.4/30 0 AT4/0.1 point2point
    MAC/Encaps=4/12, MTU=4466, Tag Stack{2/91(vcd=69) 37} 
    00458847 0004500000025000

Vous pouvez utiliser les commandes normales pour visualiser les allocations de balise avec les relations d'identifiant et d'indentifiant de canal virtuel de chemin virtuel (VPI/VCI) suivant les indications de la façon dépanner le MPLS VPN.

Superposer d'adresse

Vous pouvez utiliser la même adresse dans différents VPN sans gêner d'autres VPN. Dans cet exemple, l'adresse de 6.6.6.6 est connectée deux fois, à Pivrnec dans le VPN 101 et à Damme dans le VPN 102. Nous pouvons vérifier ceci utilisant la commande ping sur un site et la commande de debug ip icmp sur l'autre site.

Guilder# ping 6.6.6.6
   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
   !!!!!
   Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms

Damme# debug ip icmp
   ICMP packet debugging is on
   6d22h: ICMP: echo reply sent, src 6.6.6.6, DST 201.201.201.2
   6d22h: ICMP: echo reply sent, src 6.6.6.6, DST 201.201.201.2
   6d22h: ICMP: echo reply sent, src 6.6.6.6, DST 201.201.201.2
   6d22h: ICMP: echo reply sent, src 6.6.6.6, DST 201.201.201.2
   6d22h: ICMP: echo reply sent, src 6.6.6.6, DST 201.201.201.2

Exemple de sortie de débogage

Référez-vous à l'écoulement de paquet dans un environnement MPLS VPN pour voir la sortie témoin utilisant la même configuration.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 13732