Commutation multiprotocole par étiquette (MPLS) : MPLS

Exemple de configuration d'ingénierie du trafic MPLS de base à l'aide de la configuration OSPF

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit un exemple de configuration pour mettre en oeuvre l'ingénierie de trafic (TE) sur un réseau existant de commutation multiprotocole par étiquette (MPLS) utilisant le Frame Relay et l'Open Shortest Path First (OSPF). Notre exemple met en oeuvre deux tunnels dynamiques (configurés automatiquement par des commutateurs-routeurs d'étiquettes d'afflux [LSR]) et deux tunnels utilisant des trajectoires explicites.

TE est un nom générique correspondant à l'utilisation de différentes Technologies d'optimiser l'utilisation d'une capacité et d'une topologie données de circuit principal.

MPLS TE fournit une manière d'intégrer des capacités TE (comme ceux utilisés sur des protocoles de couche 2 comme l'atmosphère) dans les protocoles de la couche 3 (IP). MPLS TE emploie une extension aux protocoles existants (Protocole IS-IS (Intermediate System-to-Intermediate System), Protocole RSVP (Resource Reservation Protocol), OSPF) pour calculer et établir les tunnels unidirectionnels qui sont placés selon la contrainte de réseau. La circulation est tracée sur les différents tunnels selon leur destination.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations de ce document sont basées sur les versions de logiciel et matériel suivantes :

  • Versions de logiciel 12.0(11)S et 12.1(3a)T de½ du¿Â du Cisco IOSïÂ

  • Routeurs de Cisco 3600

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Composants fonctionnels

Le tableau suivant décrit les composants fonctionnels de cet exemple de configuration :

Composant Description
Interfaces de tunnel IP Couche 2 : une interface de tunnel MPLS est la tête d'un chemin commuté par étiquette (LSP). Il est configuré avec un ensemble des besoins en matière de ressources, tels que la bande passante et la priorité. Couche 3 : l'interface de tunnel LSP est la tête de réseau d'une liaison virtuelle unidirectionnelle à la destination de tunnel.
RSVP avec l'extension TE Le RSVP est utilisé pour établir et mettre à jour des tunnels LSP basés sur le chemin calculé des messages utilisant de CHEMIN et de RSVP réservation (RESV). La spécification de protocole de RSVP a été étendue de sorte que les messages RESV distribuent également les informations d'étiquette.
Protocole IGP (Interior Gateway Protocol) d'État de lien [IS-IS ou OSPF avec l'extension TE] Utilisé pour inonder la topologie et les informations de ressource du module de gestion de lien. L'IS-IS utilise de nouvelles Type-Longueur-valeurs (TLVs) ; L'OSPF utilise des annonces d'État de lien du type 10 (également appelées Opaque LSAs).
Module de calcul de chemin MPLS TE Fonctionne à la tête LSP seulement et détermine un chemin utilisant les informations de la base de données d'état de lien.
Module de gestion de lien MPLS TE À chaque saut LSP, ce module exécute l'admission d'appel de lien sur les messages de signalisation de RSVP, et la comptabilité de la topologie et des informations de ressource à inonder par OSPF ou IS-IS.
Expédition de commutation par étiquette Mécanisme de transfert de base MPLS basé sur des étiquettes.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/13731/mplsteisis1.gif

Guide de configuration rapide

Vous pouvez employer les étapes suivantes pour exécuter une configuration rapide. Référez-vous à l'Ingénierie de trafic MPLS et aux améliorations pour plus d'informations détaillées.

  1. Installez votre réseau avec la configuration habituelle. (Dans ce cas, nous avons utilisé le Relais de trames.)

    Remarque: Il est obligatoire d'installer une interface de bouclage avec un masque IP de 32 bits. Cette adresse sera utilisée pour l'installation du réseau MPLS et du TE par le protocole de routage. Cette adresse de bouclage doit être accessible par l'intermédiaire de la table de routage globale.

  2. Installez un protocole de routage pour le réseau MPLS. Ce doit être un protocole de routage à état de liens (IS-IS ou OSPF). Dans le mode de configuration de protocole de routage, sélectionnez les commandes suivantes :

    • Pour l'IS-IS :

      metric-style [wide | both]
      mpls traffic-eng router-id LoopbackN 
      mpls traffic-eng [level-1 | level-2 |]
      
    • Pour l'OSPF :

      mpls traffic-eng area X 
      mpls traffic-eng router-id LoopbackN (must have a 255.255.255.255 mask)
  3. Enable MPLS TE. Entrez dans l'ip cef (ou l'ip cef distribué si disponible afin d'améliorer la représentation) en mode de configuration générale. Activez MPLS (IP de balise-commutation) sur chaque interface intéressée. Entrez dans le tunnel d'Ingénierie de trafic MPLS pour activer MPLS TE, aussi bien que le RSVP pour des tunnels de la zéro-bande passante TE.

  4. Activez le RSVP en entrant dans l'ip rsvp bandwidth XXX sur chaque interface intéressée pour les tunnels différents de zéro de bande passante.

  5. Tunnels d'installation à utiliser pour TE. Il y a beaucoup d'options qui peuvent être configurées pour le tunnel MPLS TE, mais la commande de tunnel mode mpls traffic-eng est obligatoire. La commande de tunnel mpls traffic-eng autoroute announce annonce la présence du tunnel par le protocole de routage.

    Remarque: N'oubliez pas d'utiliser le loopbackN d'ip unnumbered pour l'adresse IP des interfaces de tunnel.

    Cette configuration affiche deux tunnels dynamiques (Pescara_t1 et Pescara_t3) avec la bande passante différente (et les priorités) allant du routeur de Pescara au routeur de Pesaro, et deux tunnels (Pesaro_t158 et Pesaro_t159) utilisant un chemin explicite allant de Pesaro à Pescara.

Fichiers de configuration

Ce document utilise les configurations présentées ci-dessous. Seulement les éléments pertinents des fichiers de configuration sont inclus. Les commandes utilisées pour activer le MPLS sont en texte bleu ; les commandes spécifiques à TE (RSVP y compris) sont en texte en gras.

Pesaro
Current configuration:

!

version 12.1

!

hostname Pesaro

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.6 255.255.255.255

!

interface Tunnel158

 ip unnumbered Loopback0

 tunnel destination 10.10.10.4

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng priority 2 2

 tunnel mpls traffic-eng bandwidth 158

 tunnel mpls traffic-eng path-option 1 explicit name low

!

interface Tunnel159

 ip unnumbered Loopback0

 tunnel destination 10.10.10.4

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng priority 4 4

 tunnel mpls traffic-eng bandwidth 159

 tunnel mpls traffic-eng path-option 1 explicit name straight

!

interface Serial0/0

 no ip address

 encapsulation frame-relay

!

interface Serial0/0.1 point-to-point

 bandwidth 512

 ip address 10.1.1.22 255.255.255.252

 
tag-switching ip


 mpls traffic-eng tunnels 

 frame-relay interface-dlci 603   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

ip classless

!

ip explicit-path name low enable

 next-address 10.1.1.21 

 next-address 10.1.1.10 

 next-address 10.1.1.1 

 next-address 10.1.1.14 

!

ip explicit-path name straight enable

 next-address 10.1.1.21 

 next-address 10.1.1.5 

 next-address 10.1.1.14 

!

end

Pescara
Current configuration:

!

version 12.0

!

hostname Pescara

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.4 255.255.255.255

!

interface Tunnel1

 ip unnumbered Loopback0

 no ip directed-broadcast

 tunnel destination 10.10.10.6

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng priority 5 5

 tunnel mpls traffic-eng bandwidth 25

 tunnel mpls traffic-eng path-option 2 dynamic

!

interface Tunnel3

 ip unnumbered Loopback0

 no ip directed-broadcast

 tunnel destination 10.10.10.6

 tunnel mode mpls traffic-eng

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng priority 6 6

 tunnel mpls traffic-eng bandwidth  69

 tunnel mpls traffic-eng path-option 1 dynamic

!

interface Serial0/1

 no ip address

 encapsulation frame-relay

!

interface Serial0/1.1 point-to-point

 bandwidth 512

 ip address 10.1.1.14 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 401   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

end

Pomerol
Current configuration:



version 12.0

!

hostname Pomerol

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.3 255.255.255.255

!

interface Serial0/1

 no ip address

 encapsulation frame-relay

!

interface Serial0/1.1 point-to-point

 bandwidth 512

 ip address 10.1.1.6 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 301   

 ip rsvp bandwidth 512 512

!

interface Serial0/1.2 point-to-point

 bandwidth 512

 ip address 10.1.1.9 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 302   

 ip rsvp bandwidth 512 512

!

interface Serial0/1.3 point-to-point

 bandwidth 512

 ip address 10.1.1.21 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 306   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

ip classless

!

end

Pulligny
Current configuration:

!

version 12.1

!

hostname Pulligny

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.2 255.255.255.255

!

interface Serial0/1

 no ip address

 encapsulation frame-relay

!

interface Serial0/1.1 point-to-point

 bandwidth 512

 ip address 10.1.1.2 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 201   

 ip rsvp bandwidth 512 512

!

interface Serial0/1.2 point-to-point

 bandwidth 512

 ip address 10.1.1.10 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 203   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

ip classless

!

end

Pauillac
!

version 12.1

!

hostname pauillac

!


ip cef


!

mpls traffic-eng tunnels

!

interface Loopback0

 ip address 10.10.10.1 255.255.255.255

!

interface Serial0/0

 no ip address

 encapsulation frame-relay

!

interface Serial0/0.1 point-to-point

 bandwidth 512

 ip address 10.1.1.1 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 102   

 ip rsvp bandwidth 512 512

!

interface Serial0/0.2 point-to-point

 bandwidth 512

 ip address 10.1.1.5 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 103   

 ip rsvp bandwidth 512 512

!

interface Serial0/0.3 point-to-point

 bandwidth 512

 ip address 10.1.1.13 255.255.255.252

 mpls traffic-eng tunnels

 
tag-switching ip


 frame-relay interface-dlci 104   

 ip rsvp bandwidth 512 512

!

router ospf 9

 network 10.1.1.0 0.0.0.255 area 9

 network 10.10.10.0 0.0.0.255 area 9

 mpls traffic-eng area 9

 mpls traffic-eng router-id Loopback0

!

ip classless

!

end

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Des commandes show générales sont illustrées en configurant l'ingénierie du trafic de base MPLS utilisant l'IS-IS. Les commandes suivantes sont spécifiques à MPLS TE avec l'OSPF et sont illustrées ci-dessous :

  • lien de show ip ospf mpls traffic-eng

  • show ip ospf database opaque-area

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Exemple de sortie de la commande show

Vous pouvez utiliser la commande de lien de show ip ospf mpls traffic-eng de voir ce qui sera annoncé par OSPF à un routeur donné. Les caractéristiques de RSVP sont affichées dans ci-dessous gras, indiquant la bande passante qui peut être réservée, qui est annoncé et utilisé. Vous pouvez voir la bande passante utilisée par Pescara_t1 (à priorité 5) et à Pescara_t3 (à priorité 6).

Pesaro# show ip ospf mpls traffic-eng link 

  OSPF Router with ID (10.10.10.61) (Process ID 9)

  Area 9 has 1 MPLS TE links. Area instance is 3.

  Links in hash bucket 48.
    Link is associated with fragment 0. Link instance is 3 
      Link connected to Point-to-Point network
      Link ID : 10.10.10.3 Pomerol
      Interface Address : 10.1.1.22
      Neighbor Address : 10.1.1.21
      Admin Metric : 195
      Maximum bandwidth : 64000
      Maximum reservable bandwidth : 64000
      Number of Priority : 8
      Priority 0 : 64000       Priority 1 : 64000     
      Priority 2 : 64000       Priority 3 : 64000     
      Priority 4 : 64000       Priority 5 : 32000     
      Priority 6 : 24000       Priority 7 : 24000   
      Affinity Bit : 0x0

La commande de show ip ospf database peut être retenue au type 10 LSAs et affiche la base de données qui est utilisée par le processus MPLS TE pour calculer la meilleure route (pour TE) pour les tunnels dynamiques (Pescara_t1 et Pescara_t3 dans cet exemple). Ceci peut être vu dans la sortie partielle suivante :

Pesaro# show ip ospf database opaque-area 

  OSPF Router with ID (10.10.10.61) (Process ID 9)

  Type-10 Opaque Link Area Link States (Area 9)

  LS age: 397
  Options: (No TOS-capability, DC)
  LS Type: Opaque Area Link
  Link State ID: 1.0.0.0
  Opaque Type: 1
  Opaque ID: 0
  Advertising Router: 10.10.10.1
  LS Seq Number: 80000003
  Checksum: 0x12C9
  Length: 132
  Fragment number : 0

    MPLS TE router ID : 10.10.10.1 Pauillac

    Link connected to Point-to-Point network
      Link ID : 10.10.10.3
      Interface Address : 10.1.1.5
      Neighbor Address : 10.1.1.6
      Admin Metric : 195
      Maximum bandwidth : 64000
      Maximum reservable bandwidth : 48125
      Number of Priority : 8
      Priority 0 : 48125       Priority 1 : 48125     
      Priority 2 : 48125       Priority 3 : 48125     
      Priority 4 : 48125       Priority 5 : 16125     
      Priority 6 : 8125        Priority 7 : 8125      
      Affinity Bit : 0x0

    Number of Links : 1
  LS age: 339
  Options: (No TOS-capability, DC)
  LS Type: Opaque Area Link
  Link State ID: 1.0.0.0
  Opaque Type: 1
  Opaque ID: 0
  Advertising Router: 10.10.10.2
  LS Seq Number: 80000001
  Checksum: 0x80A7
  Length: 132
  Fragment number : 0

    MPLS TE router ID : 10.10.10.2 Pulligny

    Link connected to Point-to-Point network
      Link ID : 10.10.10.1
      Interface Address : 10.1.1.2
      Neighbor Address : 10.1.1.1
      Admin Metric : 195
      Maximum bandwidth : 64000
      Maximum reservable bandwidth : 64000
      Number of Priority : 8
      Priority 0 : 64000       Priority 1 : 64000     
      Priority 2 : 64000       Priority 3 : 64000     
      Priority 4 : 64000       Priority 5 : 64000     
      Priority 6 : 64000       Priority 7 : 64000     
      Affinity Bit : 0x0

    Number of Links : 1

 LS age: 249
  Options: (No TOS-capability, DC)
  LS Type: Opaque Area Link
  Link State ID: 1.0.0.0
  Opaque Type: 1
  Opaque ID: 0
  Advertising Router: 10.10.10.3
  LS Seq Number: 80000004
  Checksum: 0x3DDC
  Length: 132
  Fragment number : 0

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.


Informations connexes


Document ID: 13731