IP : Protocole RIP (Routing Information Protocol)

Exemple de configuration d'extensions déclenchées en RIP :

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document affiche des configurations d'échantillon utilisant la commande de configuration d'interface d'ip rip triggered.

Les extensions déclenchées au Protocole RIP (Routing Information Protocol) augmentent l'efficacité sur le Point à point, des liaisons série. Cette caractéristique est prise en charge sur toutes les Plateformes exécutant la version de logiciel 12.0(1)T et ultérieures de Cisco IOSÝ. Les extensions déclenchées aident à éviter deux problèmes courants avec employer le RIP pour se connecter à un WAN :

  • La radiodiffusion périodique par le RIP peut empêcher les circuits BLÊMES d'être fermés.

  • Même sur les liens fixes et point par point, le temps système des transmissions de RIP périodique peut sérieusement interrompre le transfert des données normal.

Pour activer cette caractéristique, utilisez la commande de configuration d'interface d'ip rip triggered les des deux les côtés du lien. Voyez les configurations ci-dessous pour un exemple.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

/image/gif/paws/13720/51a.gif

Configurations

Ce document utilise les configurations présentées ci-dessous.

S3-3640
interface Serial1/0 
  ip address 172.16.1.1 255.255.255.0
  ip rip triggered
 ! 
 router rip
  network 172.16.0.0 

S3-3620
interface Loopback8
 ip address 172.19.1.1 255.255.255.0
!
interface Ethernet0/3
 ip address 172.18.1.1 255.255.255.0
!
interface Serial1/0
 ip address 172.16.1.2 255.255.255.0
 ip rip triggered
!
router rip
 network 172.16.0.0
 network 172.18.0.0
 network 172.19.0.0

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Des artères apprises par une interface qui est configurée avec l'ip rip triggered est affichées comme entrée permanente dans la base de données RIP et la table de routage.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • show ip route - Affiche l'état actuel de la table de routage.

  • show ip rip database - Entrées récapitulatives d'adresse d'affichages dans les entrées de base de données de routage de RIP si des artères appropriées sont récapitulées basées sur une adresse récapitulative.

S3-3640#show ip route
C       172.16.1.0/24 is directly connected, Serial1/0
R    172.19.0.0/16 [120/1] via 172.16.1.2, Serial1/0
R    172.18.0.0/16 [120/1] via 172.16.1.2, Serial1/0

S3-3640#show ip rip database
172.18.0.0/16    auto-summary
172.18.0.0/16
    [1] via 172.16.1.2, 00:02:44 (permanent), Serial1/0
	* Triggered Routes:
     - [1] via 172.16.1.2, Serial1/0
172.19.0.0/16    auto-summary
172.19.0.0/16
    [1] via 172.16.1.2, 00:02:45 (permanent),Serial1/0
  	* Triggered Routes:
     - [1] via 172.16.1.2, Serial1/0

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Dépannage des commandes

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Remarque: Avant d'exécuter les commandes debug, référez-vous à la section Informations importantes sur les commandes Debug.

  • événements de debug ip rip - Affiche des informations sur des transactions de routage de RIP.

S3-3640#debug ip rip events
RIP: received v1 triggered request from 172.16.1.2 on Serial1/0
RIP: start retransmit timer of 172.16.1.2
RIP: received v1 triggered ack from 172.16.1.2 on Serial1/0
RIP: Stopped retrans timer for 172.16.1.2
RIP: sending v1 ack to 172.16.1.2 via Serial1/0 (172.16.1.1),

Conclusion

Quand vous permettez aux extensions déclenchées DE DÉCHIRER, conduisant des mises à jour sont transmis sur le WAN seulement si un des événements suivants se produit :

  • Le routeur reçoit une demande spécifique d'une mise à jour de routage, qui cause la pleine base de données d'être envoyée.

  • Les informations d'une autre interface modifient la base de données de routage, qui cause seulement les dernières modifications d'être envoyées.

  • L'interface est soulevée ou descend, qui cause une base de données partielle d'être envoyée.

  • Le routeur est mis sous tension pour la première fois pour s'assurer qu'au moins une mise à jour est envoyée, qui cause la pleine base de données d'être envoyée.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 13720