IP : Protocole OSPF (Open Shortest Path First)

Configurations initiales d'OSPF sur sous-interfaces de relais de trame

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit des exemples de configurations pour Open Shortest Path First (OSPF) sur des sous-interfaces Frame Relay.

Conditions préalables

Conditions requises

Avant que vous tentiez cette configuration, assurez-vous que vous répondez à ces exigences :

  • Une compréhension de base de Relais de trames et de configuration OSPF

Référez-vous à configurer l'OSPF et à configurer et à dépannage de Frame Relay le pour en savoir plus.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Routeur Cisco 2503

  • Version de logiciel de½ du¿Â du Cisco IOSï 12.3(3) sur les deux Routeurs

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Informations générales

Afin de configurer et dépanner l'OSPF au-dessus d'un réseau, vous devez avoir une bonne compréhension de la topologie du réseau sous-jacente. Le mécanisme voisin de détection, l'élection du routeur indiqué (DR) et du routeur de secours désigné (BDR), et l'inondation de mise à jour dépendent de lui. La topologie sous-jacente de la couche 2 peut être l'une de ces derniers :

  • Accès multiple avec diffusion (par exemple, Ethernets) — Un réseau de diffusion est un qui permet l'émission ou les paquets de multidiffusion à envoyer au-dessus du réseau et par conséquent de chaque périphérique capables communiquer directement avec chaque autre périphérique dans le segment. Un réseau multi-accès est un réseau qui connecte plus de deux périphériques. Référez-vous aux configurations initiales pour l'OSPF au-dessus du pour en savoir plus de supports de diffusion.

  • Point à point (tel que des liaisons série avec contrôle de liaison de données point par point et de haut niveau (PPP/HDLC)) — les réseaux point par point permettent également l'émission ou les paquets de multidiffusion à envoyer au-dessus du réseau, et ces réseaux connectent seulement deux périphériques sur le segment. Référez-vous aux configurations initiales pour l'OSPF au-dessus d'un pour en savoir plus de lien point par point.

  • Non-émission à plusieurs accès (NBMA), comme le Relais de trames — ces réseaux ne prennent en charge pas des émissions ou des Multidiffusions, mais peuvent connecter plus que des périphériques et sont à plusieurs accès en nature. Référez-vous aux configurations initiales pour l'OSPF au-dessus du pour en savoir plus de liaisons de non annonce.

  • Point-à-multipoint — C'est une collection de liens point par point entre de divers périphériques sur un segment. Ces réseaux permettent également l'émission ou les paquets de multidiffusion à envoyer au-dessus du réseau. Ces réseaux peuvent représenter le segment à plusieurs accès en tant que plusieurs liens point par point qui connectent tous les périphériques sur le segment.

Quand l'OSPF est exécuté sur un réseau, deux importants événements se produisent avant que les informations de routage soient permutées :

  • Des voisins sont découverts utilisant des paquets HELLO multicasts.

  • Le DR et les BDR sont choisis pour que chaque réseau multi-accès optimise le processus de création de contiguïté. Tous les Routeurs dans ce segment devraient pouvoir communiquer directement avec le DR et le BDR pour la contiguïté appropriée (dans le cas d'un réseau, d'un DR et d'un BDR point par point ne soyez pas nécessaire puisqu'il y a seulement deux Routeurs dans le segment, et par conséquent l'élection n'a pas lieu).

Pour une détection voisine réussie sur un segment, le réseau doit permettre des émissions ou des paquets de multidiffusion à envoyer.

Dans la topologie de la couche 2 d'accès multiple avec diffusion, des émissions sont prises en charge ; donc, un routeur qui exécute l'OSPF peut découvrir des voisins OSPF automatiquement et élit n'importe quel routeur comme DR et BDR puisque n'importe quel périphérique peut parler à tous autres Routeurs dans ce segment de diffusion.

En topologie point à point, des voisins sont découverts automatiquement puisque des voisins sont directement connectés entre eux par un lien point par point, et l'émission ou les paquets de multidiffusion sont expédiés au-dessus du réseau ; cependant, le DR et le choix de BDR n'a pas lieu comme expliqué plus tôt.

Dans une topologie de réseau NBMA, qui est en soi nonbroadcast, des voisins ne sont pas découverts automatiquement. Les essais OSPF pour élire un DR et un BDR dus à la nature à plusieurs accès du réseau, mais l'élection échoue puisque des voisins ne sont pas découverts. Des voisins doivent être configurés manuellement pour surmonter ces problèmes. En outre, la configuration supplémentaire est nécessaire dans une topologie de hub and spoke pour s'assurer que les routeurs concentrateur, qui ont la Connectivité avec chaque autre routeur en étoile, sont élus comme DR et BDR. Alternativement, vous pouvez changer la configuration sur l'interface NBMA pour faire l'OSPF croire que c'est un autre type de réseau qui n'a pas ces problèmes.

La configuration correcte est nécessaire pour le bon fonctionnement de l'OSPF.

Les sous-interfaces de relais de trame peuvent fonctionner en deux modes :

  • Point à point — Quand une sous-interface point par point de Relais de trames est configurée, la sous-interface émule un réseau point par point et l'OSPF le traite comme type de réseau point par point.

  • Multipoint — Quand une sous-interface multipoint de Relais de trames est configurée, l'OSPF traite cette sous-interface comme type de réseau NBMA.

Le logiciel de Cisco IOS utilise la commande d'ip ospf network de permettre l'OSPF de passage de flexibilité sur une interface dans les modes différents :

ip ospf network {émission | non-émission | {point-à-multipoint [non-émission] | Point à point}}

La section de configurer de ce document contient des configurations d'échantillon pour l'OSPF au-dessus des sous-interfaces point par point de Relais de trames, OSPF au-dessus des sous-interfaces multipoints de Relais de trames avec l'émission, non-émission, et réseaux point-à-multipoint.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau affichée ici :

/image/gif/paws/13693/22a.gif

Configurations

Ce document utilise les configurations affichées dans cette section.

Configuration point par point

R4-2503
interface Loopback0
      ip address 3.3.3.3 255.255.255.255
     !
     interface Serial0
      no ip address
      encapsulation frame-relay
     
!--- To enable Frame Relay encapsulation
 
     
!--- on the interface.


      no keepalive
     !
     interface Serial0.1 point-to-point
     
!--- The subinterface is configured to
 
     
!--- function as a point-to-point link
 
     
!--- with this command.

      ip address 1.1.1.2 255.255.255.0
      frame-relay interface-dlci 16   
     
!--- To assign a data-link connection identifier
 
     
!--- (DLCI) to a specified Frame Relay subinterface.

     
!--- Without this command,  all the DLCIs are assigned
 
     
!--- to the physical interface.

     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
     !

R1-2503
interface Loopback0
      ip address 2.2.2.2 255.255.255.255
     !
     interface Serial0
      no ip address
      encapsulation frame-relay
     
!--- To enable Frame Relay encapsulation on
 
     
!--- the interface.

      no keepalive
      clockrate 2000000
     !
     interface Serial0.1 point-to-point
     
!--- The subinterface is configured to function
 
     
!--- as a point-to-point link with this command.

      ip address 1.1.1.1 255.255.255.0
      frame-relay interface-dlci 16  
     
!--- To assign a data-link connection identifier
 
     
!--- (DLCI) to a specified Frame Relay subinterface.
 
     
!--- Without this command, all the DLCIs are
 
     
!--- assigned to the physical interface.
 
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
     !

Conseils de vérification pour la configuration point par point

Les commandes tracées les grandes lignes ici sont utiles pour la vérification :

Les sorties de ces commandes sont affichées ici :

R4-2503# show ip ospf neighbor
      
     Neighbor ID  Pri   State      Dead Time   Address   Interface
     2.2.2.2        1   FULL/  -   00:00:33    1.1.1.1   Serial0.1

Remarque: Dans cette sortie, l'état des voisins OSPF est affiché en tant que « COMPLÈTEMENT/- », mais l'état DR et BDR n'est pas indiqué. C'est parce qu'il n'y a aucun DR et choix de BDR sur un lien point par point.

R4-2503# show ip ospf interface s0 
     %OSPF: OSPF not enabled on Serial0

R4-2503# show ip ospf interface s0.1
     Serial0.1 is up, line protocol is up 
       Internet Address 1.1.1.2/24, Area 0 
       Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_POINT, Cost: 64
       Transmit Delay is 1 sec, State POINT_TO_POINT,
       Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
         oob-resync timeout 40
         Hello due in 00:00:09
	   Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 1, maximum is 1
       Last flood scan time is 0 msec, maximum is 0 msec	 
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 2.2.2.2
       Suppress hello for 0 neighbor(s)
	   
R1-2503# show ip ospf neighbor
      
     Neighbor ID   Pri   State      Dead Time   Address  Interface
     3.3.3.3         1   FULL/  -   00:00:37    1.1.1.2  Serial0.1 

R1-2503# show ip ospf interface s0
     %OSPF: OSPF not enabled on Serial0
     
R1-2503# show ip ospf interface s0.1
     Serial0.1 is up, line protocol is up 
       Internet Address 1.1.1.1/24, Area 0 
       Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 64
       Transmit Delay is 1 sec, State POINT_TO_POINT,
       Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
         oob-resync timeout 40
         Hello due in 00:00:03
	   Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 1, maximum is 1
       Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 3.3.3.3
       Suppress hello for 0 neighbor(s)

Configuration multipoint avec le réseau de diffusion

Dans cette configuration, le type de réseau est changé pour annoncer avec la commande d'émission d'ip ospf network. Maintenant, le réseau NBMA est visualisé comme réseau d'accès multiple avec diffusion où le DR et le choix de BDR a lieu. Les commandes de carte de Relais de trames sont également placées d'expédier des adresses d'émission.

R4-2503
interface Loopback0
      ip address 3.3.3.3 255.255.255.255
     !
     interface Serial0
      no ip address
      encapsulation frame-relay
      no keepalive
     !
     interface Serial0.2 multipoint
     
!--- The subinterface is treated as a multipoint link.
 
      ip address 1.1.1.2 255.255.255.0
      ip ospf network broadcast
     
!--- This command is used to define the network
 
     
!--- type as broadcast. The network type is defined
 
     
!--- on non-broadcast networks so as to not configur
 
	    
!--- the neighbors explicitly.

      frame-relay map ip 1.1.1.1 16 broadcast
     
!--- To define the mapping between a destination
 
     
!--- protocol address and the data-link connection
 
     
!--- identifier (DLCI) used to connect to the
 
     
!--- destination address. The broadcast keyword
 
     
!--- is used to forward broadcasts and multicasts
 
     
!--- to this address.

     !
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
     !

R1-2503
interface Loopback0
     ip address 2.2.2.2 255.255.255.255
     !
     !         
     interface Serial0
      no ip address
      encapsulation frame-relay
      no keepalive
      clockrate 2000000
     !
     interface Serial0.2 multipoint
     
!--- The subinterface is treated as a multipoint link.
 
      ip address 1.1.1.1 255.255.255.0
      ip ospf network broadcast
     
!--- This command is used to define the network
 
     
!--- type as broadcast. The network type is defined
 
     
!--- on non-broadcast networks so as not configure
 
     
!--- the neighbors explicitly.

      frame-relay map ip 1.1.1.2 16 broadcast
     
!--- To define the mapping between a
 
     
!--- destination protocol address and the data-link
 
     
!--- connection identifier (DLCI) used to connect
 
     
!--- to the destination address.  The broadcast
 
     
!--- keyword is used to forward broadcasts and multicasts

     
!--- to this address.

     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
     !

Remarque: Si une sous-interface est aussi point par point configuré, la même sous-interface ne peut pas être réaffectée qu'une sous-interface multipoint à moins que le routeur soit rechargé. Dans ce cas, une sous-interface différente est utilisée pour la configuration multipoint.

Conseils de vérification pour la configuration multipoint avec le réseau de diffusion

R4-2503# show ip ospf neighbor      
     Neighbor ID   Pri   State      Dead Time   Address   Interface
     2.2.2.2         1   FULL/BDR   00:00:32    1.1.1.1   Serial 0.2
     
R4-2503# show ip ospf interface s0
     %OSPF: OSPF not enabled on Serial0
     
R4-2503# show ip ospf interface s0.2
     Serial0.2 is up, line protocol is up 
       Internet Address 1.1.1.2/24, Area 0 
       Process ID 1, Router ID 3.3.3.3, Network Type BROADCAST, Cost: 64
       Transmit Delay is 1 sec, State DR, Priority 1
       Designated Router (ID) 3.3.3.3, Interface address 1.1.1.2
       Backup Designated router (ID) 2.2.2.2, Interface address 1.1.1.1
       Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
          oob-resync timeout 40         
          Hello due in 00:00:05
     Index 1/1, flood queue length 0
     Next 0x0(0)/0x0(0)
     Last flood scan length is 1, maximum is 1
     Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 2.2.2.2  (Backup Designated Router)
       Suppress hello for 0 neighbor(s)	   
R1-2503# show ip ospf neighbor
      
     Neighbor ID   Pri   State     Dead Time   Address   Interface
     3.3.3.3         1   FULL/DR   00:00:35    1.1.1.2   Serial0.2
     
R1-2503# show ip ospf interface s0
     %OSPF: OSPF not enabled on Serial0
     
R1-2503# show ip ospf interface s0.2
     Serial0.2 is up, line protocol is up 
       Internet Address 1.1.1.1/24, Area 0 
       Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 64
       Transmit Delay is 1 sec, State BDR, Priority 1
       Designated Router (ID) 3.3.3.3, Interface address 1.1.1.2
       Backup Designated router (ID) 2.2.2.2, Interface address 1.1.1.1
       Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
          oob-resync timeout 40         
          Hello due in 00:00:01
      Index 1/1, flood queue length 0     
       Next 0x0(0)/0x0(0)     
       Last flood scan length is 1, maximum is 1     
       Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 3.3.3.3  (Designated Router)
       Suppress hello for 0 neighbor(s)

Configuration multipoint avec le réseau de non-diffusion

Dans cette configuration, le réseau est la non-émission, qui ne permet pas des voisins à découvrir automatiquement. La commande neighbor est utilisée de configurer manuellement des voisins OSPF. Cependant, cette commande est nécessaire seulement avec des versions de logiciel de Cisco IOS plus tôt que 10.0. Comme solution alternative, émettez la commande d'ip ospf network de changer le type de réseau par défaut (voyez la configuration multipoint avec l'exemple de configuration réseau de réseau de diffusion). Référez-vous « en évitant le jeu rouleau-tambour et la commande neighbor à la section sur NBMA » de pour en savoir plus de guide de conception OSPF. Le DR et les BDR sont élus en raison de la nature à plusieurs accès.

R4-2503
interface Loopback0
      ip address 3.3.3.3 255.255.255.255
     !
     interface Serial0
      no ip address
      encapsulation frame-relay
      no keepalive
     !
     interface Serial0.2 multipoint
      ip address 1.1.1.2 255.255.255.0
      frame-relay map ip 1.1.1.1 16 broadcast
      ip ospf priority 2
      
!--- This command assigns a higher priority for this router on this interface,
      !--- so that it gets elected as the DR. In case of a Hub and Spoke topology,
      !--- the hub should be elected as the DR as it has connectivity to all the spokes.
 
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
     !

R1-2503
interface Loopback0
      ip address 2.2.2.2 255.255.255.255
     !
     interface Serial0
      no ip address
      encapsulation frame-relay
      no keepalive
      clockrate 2000000
     !
     interface Serial0.2 multipoint
      ip address 1.1.1.1 255.255.255.0
      frame-relay map ip 1.1.1.2 16 broadcast
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
      neighbor 1.1.1.2 

     
!--- Used to manually configure neighbors.

     

Conseils de vérification pour la configuration multipoint avec le réseau de non-diffusion

R4-2503# show ip ospf neighbor
      
     Neighbor ID   Pri   State      Dead Time   Address   Interface
     2.2.2.2         1   FULL/BDR   00:01:56    1.1.1.1   Serial0.2
     
R4-2503# show ip ospf interface s0
     %OSPF: OSPF not enabled on Serial0
     
R4-2503# show ip ospf interface s0.2
     Serial0.2 is up, line protocol is up 
       Internet Address 1.1.1.2/24, Area 0 
       Process ID 1, Router ID 3.3.3.3, Network Type NON_BROADCAST, Cost: 64
       Transmit Delay is 1 sec, State DR,Priority 2
       Designated Router (ID) 3.3.3.3, Interface address 1.1.1.2
       Backup Designated router (ID) 2.2.2.2, Interface address 1.1.1.1
       Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
          oob-resync timeout 40         
          Hello due in 00:00:25
       Index 1/1, flood queue length 0     
        Next 0x0(0)/0x0(0)     
        Last flood scan length is 1, maximum is 1     
        Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 2.2.2.2  (Backup Designated Router)
       Suppress hello for 0 neighbor(s)	   
R1-2503# show ip ospf neighbor
      
     Neighbor ID   Pri   State      Dead Time   Address   Interface
     3.3.3.3         2   FULL/DR    00:01:52    1.1.1.2   Serial0.2
     
R1-2503# show ip ospf interface s0
     %OSPF: OSPF not enabled on Serial0
     
R1-2503# show ip ospf interface s0.2
     Serial0.2 is up, line protocol is up 
       Internet Address 1.1.1.1/24, Area 0 
       Process ID 1, Router ID 2.2.2.2, Network Type NON_BROADCAST, Cost: 64
       Transmit Delay is 1 sec, State BDR, Priority 1
       Designated Router (ID) 3.3.3.3, Interface address 1.1.1.2
       Backup Designated router (ID) 2.2.2.2, Interface address 1.1.1.1
       Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
          oob-resync timeout 40         
          Hello due in 00:00:01
       Index 1/1, flood queue length 0     Next 0x0(0)/0x0(0)     
       Last flood scan length is 1, maximum is 1
       Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 3.3.3.3  (Designated Router)
       Suppress hello for 0 neighbor(s)

Configuration multipoint avec le réseau point-à-multipoint

Dans cette configuration, le type de réseau est changé avec la commande point-à-multipoint d'ip ospf network de fonctionner comme collection de liens point par point. Des voisins sont découverts automatiquement et le DR et le choix de BDR n'a pas lieu.

R4-2503
interface Loopback0
      ip address 3.3.3.3 255.255.255.255
     !
     interface Serial0
      no ip address
      encapsulation frame-relay
      no keepalive
     !
     interface Serial0.2 multipoint
      ip address 1.1.1.2 255.255.255.0
      ip ospf network point-to-multipoint
     
!--- To configure an interface as
!--- point-to-multipoint for non-broadcast media.
 
     
     frame-relay map ip 1.1.1.1 16 broadcast
     !
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
     !

R1-2503
interface Loopback0
      ip address 2.2.2.2 255.255.255.255
     !
     interface Serial0
      no ip address
      encapsulation frame-relay
      no keepalive
      clockrate 2000000
     !
     interface Serial0.2 multipoint
      ip address 1.1.1.1 255.255.255.0
      ip ospf network point-to-multipoint
     
!--- To configure an interface as
 
     
!--- point-to-multipoint for non-broadcast media.

     frame-relay map ip 1.1.1.2 16 broadcast
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
     !

Conseils de vérification pour la configuration multipoint avec le réseau point-à-multipoint

R4-2503# show ip ospf neighbor
      
     Neighbor ID   Pri   State      Dead Time   Address   Interface
     2.2.2.2         1   FULL/  -   00:01:58    1.1.1.1   Serial0.2
     
R4-2503# show ip ospf interface s0
   %OSPF: OSPF not enabled on Serial0
     
R4-2503# show ip ospf interface s0.2
     Serial2.1 is up, line protocol is up 
       Internet Address 1.1.1.2/24, Area 0 
       Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_MULTIPOINT, Cost: 64
       Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
       Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
          oob-resync timeout 40         
          Hello due in 00:00:07
      Index 1/1, flood queue length 0     
      Next 0x0(0)/0x0(0)     
      Last flood scan length is 1, maximum is 2     
      Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 2.2.2.2
       Suppress hello for 0 neighbor(s)
	   
R1-2503# show ip ospf neighbor
      
     Neighbor ID   Pri   State      Dead Time   Address   Interface
     3.3.3.3         1   FULL/  -   00:01:49    1.1.1.2   Serial0.2
     
R1-2503# show ip ospf interface s0 
     %OSPF: OSPF not enabled on Serial0
     
R1-2503# show ip ospf interface s0.2
     Serial0.2 is up, line protocol is up 
       Internet Address 1.1.1.1/24, Area 0 
       Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_MULTIPOINT, Cost: 64
       Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
       Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
          oob-resync timeout 40         
          Hello due in 00:00:00
        Index 1/1, flood queue length 0     
        Next 0x0(0)/0x0(0)     
        Last flood scan length is 1, maximum is 2     
        Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 3.3.3.3
       Suppress hello for 0 neighbor(s)

Vérifiez

Afin de vérifier vos configurations, utilisez les paragraphes fournis dans la section de configurer de ce document.

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Avant que vous dépanniez toutes les questions liées au voisin OSPF sur un réseau NBMA, il est important de se souvenir qu'un réseau NBMA peut être configuré dans ces modes de fonctionnement avec la commande d'ip ospf network :

  • Point à point

  • Point-à-multipoint

  • Émission

  • NBMA

Bonjour et des intervalles morts de chaque mode sont décrits dans cette table :

Type de réseau Intervalle entre deux paquets Hello (sec) Intervalle mort (sec)
Point à point 10 40
Point-à-multipoint 30 120
Émission 10 40
Non-émission 30 120

Quand l'OSPF est configuré sur une interface physique (par exemple, interface S0) non d'une technologie d'accès multiple avec diffusion telle que le Relais de trames, le type de réseau par défaut de NON_BROADCAST est assigné. Quand l'OSPF est configuré sur des sous-interfaces point par point, le type d'interface par défaut de POINT_TO_POINT est assigné. Quand l'OSPF est configuré sur des sous-interfaces multipoints, le type d'interface par défaut de NON_BROADCAST est assigné.

Quand le réseau NBMA se compose d'une combinaison d'examen médical et d'interfaces logiques (sous-interfaces) sur différents Routeurs, les différents types de réseau OSPF entrés dans les lisent. Bonjour les non-concordances sont susceptibles de se produire en pareil cas ; en conséquence, des contiguïtés OSPF ne sont pas formées.

Référez-vous aux problèmes avec exécuter l'OSPF en mode NBMA au-dessus de Relais de trames et dépanner l'OSPF pour plus d'informations sur la façon dépanner l'OSPF.


Informations connexes


Document ID: 13693