IP : Protocole OSPF (Open Shortest Path First)

Configurations initiales d'OSPF sur support de non-diffusion

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Sur les médias non destinés à la radiodiffusion tels que le Frame Relay, X.25, ATM, et le Switched Multimegabit Data Service (SMDS), l'OSPF peut fonctionner dans deux modes :

  • NBMA : simule un modèle de diffusion en élisant un routeur indiqué (DR) et un routeur de secours désigné (BDR). Il y a deux manières de simuler un modèle de diffusion sur un réseau NBMA : définissez le type de réseau comme émission avec le commande secondaire d'interface de diffusion d'ip ospf network ou configurez les déclarations de voisinage utilisant la commande de router ospf.

  • Point-à-mutipoint : traite le réseau de non-diffusion comme collection de liens point par point en configurant la commande point-à-multipoint d'ip ospf network.

Vous devez définir le type de réseau sur des réseaux de non-diffusion pour éviter de configurer des déclarations de voisinage. Sont ci-dessous les configurations d'échantillon pour l'OSPF au-dessus des liaisons de non annonce. Utilisez la commande de show ip ospf interface de vérifier le type de réseau d'une interface exécutant l'OSPF et le show ip ospf neighbor de commande est utilisé pour connaître l'état du routeur voisin.

Conditions préalables

Conditions requises

Ce document exige que vous comprenez la configuration de base du protocole de routage de Protocole OSPF (Open Shortest Path First).

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Routeurs de Cisco 2500

  • Exécution de version de logiciel 12.2(24a) de Ý de Cisco IOS sur des Routeurs

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Diagramme du réseau

Est ci-dessous le schéma de réseau utilisé dans les exemples de configuration dans ce document.

/image/gif/paws/13690/18a_01.gif

Configurations pour NBMA (utilisant la diffusion du type de réseau)

Router1
interface Loopback0
      ip address 3.3.3.3 255.255.255.255
     !
     !
     interface Serial2
      ip address 1.1.1.2 255.255.255.0
      encapsulation frame-relay
      ip ospf network broadcast
      no keepalive
      frame-relay map ip 1.1.1.1 16 broadcast
     !
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0

Router2
interface Loopback0
      ip address 2.2.2.2 255.255.255.255
     !
     interface Serial1/0
      ip address 1.1.1.1 255.255.255.0
      encapsulation frame-relay
      ip ospf network broadcast
      no keepalive
      clockrate 2000000
      frame-relay map ip 1.1.1.2 16 broadcast
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
     !

Conseils de vérification

Est ci-dessous la sortie de commande show pour Router1.

Router1# show ip ospf neighbor
      
     Neighbor ID     Pri   State           Dead Time   Address         Interface
     2.2.2.2           1   FULL/BDR        00:00:37    1.1.1.1         Serial2
     
Router1# show ip ospf interface s2
     Serial2 is up, line protocol is up 
       Internet Address 1.1.1.2/24, Area 0 
       Process ID 1, Router ID 3.3.3.3, Network Type BROADCAST, Cost: 64
       Transmit Delay is 1 sec, State DR, Priority 1 
       Designated Router (ID) 3.3.3.3, Interface address 1.1.1.2
       Backup Designated router (ID) 2.2.2.2, Interface address 1.1.1.1
       Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
         Hello due in 00:00:00
       Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 1, maximum is 2
       Last flood scan time is 0 msec, maximum is 4 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 2.2.2.2  (Backup Designated Router)
       Suppress hello for 0 neighbor(s)

Et la sortie pour le Router2 est comme suit.

Router2# show ip ospf neighbor
      
     Neighbor ID     Pri   State           Dead Time   Address         Interface
     3.3.3.3           1   FULL/DR         00:00:38     1.1.1.2         Serial1/0
     
Router2# show ip ospf interface s1/0
     Serial1/0 is up, line protocol is up 
       Internet Address 1.1.1.1/24, Area 0 
       Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 64
       Transmit Delay is 1 sec, State BDR, Priority 1 
       Designated Router (ID) 3.3.3.3, Interface address 1.1.1.2
       Backup Designated router (ID) 2.2.2.2, Interface address 1.1.1.1
       Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
         Hello due in 00:00:03
       Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 1, maximum is 2
       Last flood scan time is 0 msec, maximum is 4 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 3.3.3.3  (Designated Router)
       Suppress hello for 0 neighbor(s)

Configurations pour NBMA (utilisant des déclarations de voisinage)

Router1
interface Loopback0
      ip address 3.3.3.3 255.255.255.255
     !
     interface Serial2
      ip address 1.1.1.2 255.255.255.0
      encapsulation frame-relay
      ip ospf priority 2
      no keepalive
      frame-relay map ip 1.1.1.1 16
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
      neighbor 1.1.1.1
     !

Router2
interface Loopback0
      ip address 2.2.2.2 255.255.255.255
     !
     interface Serial1/0
      ip address 1.1.1.1 255.255.255.0
      encapsulation frame-relay
      no keepalive
      clockrate 2000000
      frame-relay map ip 1.1.1.2 16
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
      neighbor 1.1.1.2
     !

Remarque:  Dans les configurations affichées ci-dessus, la commande de l'ip ospf priority 2 sur Router1 fixe une priorité d'interface plus élevée que la valeur prioritaire par défaut de 1, qui lui fait un DR et le Router2 le BDR pour le réseau NBMA. Si nécessaire, vous pouvez placer la valeur prioritaire à 0 pour configurer un routeur pour ne jamais devenir un DR/BDR. C'est nécessaire dans des réseaux de hub and spoke où le hub devrait être configuré pour devenir le DR, où comme rais ne devrait ni être le DR ni le BDR. Bien que configurer la déclaration de voisinage sur une extrémité soit suffisant pour former la contiguïté, l'il est conseillé de l'ont configurée sur les les deux les extrémités comme affichées. En outre, les commandes de carte de Relais de trames n'ont pas besoin d'avoir le paramètre d'émission parce que les paquets OSPF unicasted avec la déclaration de voisinage.

Conseils de vérification

Est ci-dessous la sortie de commande show pour Router1.

Router1# show ip ospf neighbors
      
     Neighbor ID     Pri   State           Dead Time   Address         Interface
     2.2.2.2           1   FULL/BDR        00:01:39    1.1.1.1         Serial2
     
Router1# show ip ospf interface s2
     Serial2 is up, line protocol is up 
       Internet Address 1.1.1.2/24, Area 0 
       Process ID 1, Router ID 3.3.3.3, Network Type NON_BROADCAST, Cost: 64
       Transmit Delay is 1 sec, State DR, Priority 1 
       Designated Router (ID) 3.3.3.3, Interface address 1.1.1.2
       Backup Designated router (ID) 2.2.2.2, Interface address 1.1.1.1
       Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
         Hello due in 00:00:19
       Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 2, maximum is 2
       Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 2.2.2.2  (Backup Designated Router)
       Suppress hello for 0 neighbor(s)

Et la sortie pour le Router2 est comme suit.

Router2# show ip ospf neighbor
      
     Neighbor ID     Pri   State           Dead Time   Address         Interface
     3.3.3.3           1   FULL/DR         00:01:49     1.1.1.2         Serial1/0
     
Router2# show ip ospf interface s1/0
     Serial1/0 is up, line protocol is up 
       Internet Address 1.1.1.1/24, Area 0 
       Process ID 1, Router ID 2.2.2.2, Network Type NON_BROADCAST, Cost: 64
       Transmit Delay is 1 sec, State BDR, Priority 1 
       Designated Router (ID) 3.3.3.3, Interface address 1.1.1.2
       Backup Designated router (ID) 2.2.2.2, Interface address 1.1.1.1
       Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
         Hello due in 00:00:01
       Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 2, maximum is 2
       Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 3.3.3.3  (Designated Router)
       Suppress hello for 0 neighbor(s)

Configurations pour point-à-multipoint

Router1
interface Loopback0
      ip address 3.3.3.3 255.255.255.255
     !
     interface Serial2
      ip address 1.1.1.2 255.255.255.0
      encapsulation frame-relay
      ip ospf network point-to-multipoint
      no keepalive
      frame-relay map ip 1.1.1.1 16 broadcast
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0
     !

Router2
interface Loopback0
      ip address 2.2.2.2 255.255.255.255
     !
     interface Serial1/0
      ip address 1.1.1.1 255.255.255.0
      encapsulation frame-relay
      ip ospf network point-to-multipoint
      no keepalive
      clockrate 2000000
      frame-relay map ip 1.1.1.2 16 broadcast
     !
     router ospf 1
      network 1.1.1.0 0.0.0.255 area 0

Conseils de vérification

Est ci-dessous la sortie de commande show pour Router1.

Router1# show ip ospf neighbors
      
     Neighbor ID     Pri   State           Dead Time   Address         Interface
     2.2.2.2           1   FULL/  -        00:01:53    1.1.1.1         Serial2
     
Router1# show ip ospf interface s2
     Serial2 is up, line protocol is up 
       Internet Address 1.1.1.2/24, Area 0 
       Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_MULTIPOINT, Cost: 64
       Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
       Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
         Hello due in 00:00:18
       Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 1, maximum is 1
       Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 2.2.2.2
       Suppress hello for 0 neighbor(s)

Et la sortie pour le Router2 est comme suit.

Router2# show ip ospf neighbor
      
     Neighbor ID     Pri   State           Dead Time   Address         Interface
     3.3.3.3           1   FULL/  -        00:01:58     1.1.1.2         Serial1/0

Router2# show ip ospf interface s1/0
     Serial1/0 is up, line protocol is up 
       Internet Address 1.1.1.1/24, Area 0 
       Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_MULTIPOINT, Cost: 64
       Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
       Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
         Hello due in 00:00:18
       Index 1/1, flood queue length 0
       Next 0x0(0)/0x0(0)
       Last flood scan length is 1, maximum is 1
       Last flood scan time is 0 msec, maximum is 0 msec
       Neighbor Count is 1, Adjacent neighbor count is 1 
         Adjacent with neighbor 3.3.3.3
       Suppress hello for 0 neighbor(s)

Remarque: Il n'y a aucun DR et BDR a élu quand le réseau NBMA est aussi point-à-multipoint configuré suivant les indications des sorties, puisqu'il est traité comme collection de liens point par point.

Le pour en savoir plus, voient configurer l'OSPF au-dessus de différents réseaux physiques.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 13690