IP : Protocole OSPF (Open Shortest Path First)

Configurations initiales d'OSPF sur liaison point à point

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Sur les liaisons point-à-point, telles que le High-Level Data Link Control (HDLC) et le protocole point-à-point (PPP), Open Shortest Path First (OSPF) fonctionne comme un type de réseau point-à-point. Ce type de réseau est activé par défaut. Ce document propose des exemples de configuration pour OSPF sur une liaison point-à-point. Les autres types de réseau que l’OSPF prend en charge sont les réseaux point-à-multipoint, de diffusion et de non-diffusion. Afin de vérifier le type de réseau d’une interface qui exécute OSPF, exécutez la commande show ip ospf interface.

Les exemples expliqués dans ce document fonctionnent avec le HDLC et les encapsulations PPP.

Conditions préalables

Conditions requises

Les lecteurs de ce document devraient avoir une certaine connaissance de base de protocole de routage OSPF. Pour plus d'informations sur le protocole de routage OSPF, référez-vous à la documentation de protocole OSPF.

Composants utilisés

Les informations dans ce document appliquent aux ces le logiciel et les versions de matériel.

  • Routeurs de Cisco 2500

  • Version de logiciel 12.2(27) de Ý de Cisco IOS qui fonctionne sur des Routeurs

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

OSPF au-dessus d'un lien point par point avec des adresses IP sur des interfaces série

Cette section vous présente avec les informations que vous pouvez employer pour configurer les Routeurs qui exécutent l'OSPF et sont connectés par une liaison série point par point avec l'utilisation de l'encapsulation HDLC avec des adresses IP configurées sur des interfaces série.

Remarque: Afin de trouver des informations complémentaires sur les commandes que ce document utilise, veuillez utiliser le Command Lookup Tool (clients enregistrés seulement).

Diagramme du réseau

/image/gif/paws/13687/15a.gif

Configurations

Cette section utilise ces configurations.

Router1
Router1
!
interface Loopback0
Ý ip address 3.3.3.3 255.255.255.255
!
interface Serial0
Ýip address 1.1.1.2 255.255.255.0
!
router ospf 1
network 1.1.1.0 0.0.0.255 area 0

!--- Configures the Serial Interface S0 under OSPF area 0.

!

Router2
Router2
!
interface Loopback0
Ýip address 2.2.2.2 255.255.255.255
!
interface Serial0
Ýip address 1.1.1.1 255.255.255.0
Ýclockrate 2000000
!
router ospf 1
network 1.1.1.0 0.0.0.255 area 0

!--- Configures the Serial Interface S0 under OSPF area 0..

OSPF au-dessus d'un lien point par point avec des interfaces non numérotées

Cette section vous présente avec les informations que vous pouvez employer pour configurer les Routeurs qui exécutent l'OSPF comme protocole de routage et sont connectés par une liaison série point par point avec l'encapsulation PPP et avec les interfaces série non-numérotées. Les interfaces série non-numérotées sont des interfaces qui n'ont pas leur propre adresse IP. Ces interfaces empruntent l'adresse IP à une autre interface sur le routeur qui fait configurer une adresse IP. Pour plus d'informations sur les interfaces série non-numérotées, référez-vous à comprendre et à configurer la commande d'ip unnumbered.

Remarque: Afin de trouver des informations complémentaires sur les commandes que ce document utilise, veuillez utiliser le Command Lookup Tool (clients enregistrés seulement).

Diagramme du réseau

/image/gif/paws/13687/15b.gif

Configurations

Cette section utilise ces configurations.

Router1
!

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Serial0
 ip unnumbered loopback 0

!--- Configures Serial 0 as an unnumbered interface.

 encapsulation ppp

!--- Configures the Encapsulation on the interface as PPP.

!
router ospf 1
  network 3.3.3.0 0.0.0.255 area 0

!--- Configures the Loopback Interface L0 under OSPF area 0.

!

Router2
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0
 ip unnumbered loopback 0

!--- Configures Serial 0 as an unnumbered interface.

 encapsulation ppp

!--- Configures the Encapsulation on the interface as PPP.

!
router ospf 1
  network 2.2.2.0 0.0.0.255 area 0

!--- Configures the Loopback Interface L0 under OSPF area 0..

!

Vérifiez

Cette section fournit des informations que vous pouvez employer pour confirmer votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Vérifiez la configuration de l'OSPF avec des adresses IP sur des interfaces série

C'est la sortie de commande de show ip ospf neighbor émise sur Router1.

Router1#show ip ospf neighbor
   Neighbor ID   Pri   State       Dead Time       Address        Interface
     2.2.2.2      1   FULL/ -       00:00:32       1.1.1.1         Serial 0

Cette sortie prouve que Router1 a un voisin avec un ID de routeur de 2.2.2.2, et a formé la pleine contiguïté avec ce voisin. L'adresse 1.1.1.1 est l'adresse IP de l'interface Serial0 sur le Router2.

Pour des informations supplémentaires sur la commande de show ip ospf neighbor, référez-vous à ce qui fait la commande de show ip ospf neighbor indique ?

C'est la sortie de la commande de l'interface série 0 de show ip ospf interface sur Router1. Cette sortie affiche le type de réseau OSPF pour l'interface Serial0 comme Point à point.

Router1# show ip ospf interface serial 0 
   Serial0 is up, line protocol is up 
   Internet Address 1.1.1.2/24, Area 0 
   Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_POINT, Cost: 64
   Transmit Delay is 1 sec, State POINT_TO_POINT,
   Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
   Hello due in 00:00:05
   Index 1/1, flood queue length 0
   Next 0x0(0)/0x0(0)
   Last flood scan length is 1, maximum is 1
   Last flood scan time is 0 msec, maximum is 0 msec
   Neighbor Count is 1, Adjacent neighbor count is 1 
   Adjacent with neighbor 2.2.2.2
   Suppress hello for 0 neighbor(s)

De même, cet exemple affiche la sortie pour le show ip ospf neighbor et les commandes de show ip ospf interface sur le Router2.

Router2# show ip ospf neighbor
   Neighbor ID     Pri    State     Dead Time     Address      Interface
    3.3.3.3         1     FULL/ -    00:00:32      1.1.1.2      Serial0

Router2# show ip ospf interface serial 0
   Serial0 is up, line protocol is up 
   Internet Address 1.1.1.1/24, Area 0 
   Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 64
   Transmit Delay is 1 sec, State POINT_TO_POINT,
   Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:05
   Index 1/1, flood queue length 0
   Next 0x0(0)/0x0(0)
   Last flood scan length is 1, maximum is 1
   Last flood scan time is 0 msec, maximum is 0 msec
   Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 3.3.3.3
   Suppress hello for 0 neighbor(s)

Vérifiez la configuration de l'OSPF avec des interfaces non numérotées

La commande de show ip ospf neighbor sur Router1 et Router2 confirme la pleine contiguïté. Cette sortie affiche le type de réseau OSPF pour l'interface Serial0 comme Point à point. Vous pouvez également voir que l'internet address est 0.0.0.0 pour l'interface série sur les deux Routeurs. C'est parce qu'une adresse IP est empruntée à l'interface de bouclage (dans ce cas) en vertu de la commande d'ip unnumbered.

Router1#show ip ospf neighbor
      Neighbor ID  Pri   State    Dead Time    Address      Interface
      2.2.2.2      1   FULL/ -    00:00:37    2.2.2.2       Serial0

Router1# show ip ospf interface serial 0
Serial0 is up, line protocol is up
  Internet Address 0.0.0.0/24, Area 0
  Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:08
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 2.2.2.2
  Suppress hello for 0 neighbor(s)

Cet exemple affiche la sortie du show ip ospf neighbor et des commandes de l'interface série 0 de show ip ospf interface sur le Router2.

Router2#show ip ospf neighbor
      Neighbor ID   Pri   State   Dead Time   Address   Interface
      3.3.3.3        1   FULL/ -  00:00:30    3.3.3.3    Serial0

Router2# show ip ospf interface serial 0
Serial0 is up, line protocol is up
  Internet Address 0.0.0.0/24, Area 0
  Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:08
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 3.3.3.3
  Suppress hello for 0 neighbor(s)

Cet exemple affiche la sortie de la commande de show ip route sur Router1 avec l'encapsulation ppp et l'utilisation des interfaces non numérotées.

Router1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Serial0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0

Cet exemple affiche la sortie de la commande de show ip route sur le Router2 avec l'encapsulation ppp et l'utilisation des interfaces non numérotées.

Router2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Serial0

Cet exemple affiche la sortie de la commande de show ip route sur Router1 avec l'encapsulation HDLC et l'utilisation des interfaces non numérotées.

Router1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 2.2.2.2, 00:00:08, Serial0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0

Cet exemple affiche la sortie de la commande de show ip route sur le Router2 avec l'encapsulation HDLC et l'utilisation des interfaces non numérotées.

Router1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

        2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/65] via 3.3.3.3, 00:01:28, Serial0

Remarque: La sortie de la commande de show ip route pourrait différer entre les encapsulations de PPP et HDLC quand la configuration d'ip unnumbered est utilisée sur des interfaces série. Le PPP installe une route hôte sur l'adresse IP qui est utilisée sur l'interface série à l'autre extrémité comme directement réseau connecté. Si le même préfixe est également appris par l'OSPF comme dans cette configuration, il affiche seulement comme route connectée (pendant que cette sortie de show ip route affiche). C'est parce que les routes connectées ont une distance administrative inférieure que l'OSPF et est plus préféré. Vous pouvez changer ce comportement quand vous n'émettez l'aucune commande de voisin-artère de pair sous les interfaces série qui empêche une route hôte d'être installé et la traitez comme artère OSPF.

Ce n'est pas le cas avec le HDLC parce qu'il n'installe pas une route hôte. Le HDLC installe une artère OSPF pour l'adresse sur l'autre extrémité quand l'ip unnumbered est utilisé.

Dépannez

Pour les informations sur la façon dont dépanner des questions OSPF, référez-vous dépannage derrière l'OSPF.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 13687