IP : Protocole OSPF (Open Shortest Path First)

Problème de routage courant avec l'adresse de transfert OSPF

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Il décrit les concepts et les problèmes associés à l'adresse de transfert Open Shortest Path First (OSPF). Reportez-vous au document Pourquoi certaines routes OSPF figurent-elles dans la base de données mais pas dans la table de routage ? pour plus d'informations sur le dépannage d'OSPF.

Le problème expliqué dans ce document est seulement observable avec des versions logicielles de ½ du ¿  de Cisco IOSï plus tôt que 12.1(3). Le comportement de la redistribution a changé dans le Logiciel Cisco IOS version 12.1(3) et plus tard. Pour plus de détails, référez-vous à l'ID de bogue Cisco CSCdp72526 (clients enregistrés seulement). Cette bogue a la liste de versions logicielles de Cisco IOS affectées et des versions corrigées. Référez-vous également à redistribuer des réseaux connectés dans l'OSPF où le changement du comportement de Cisco IOS est expliqué.

Conditions préalables

Conditions requises

Les lecteurs de ce document devraient avoir connaissance des sujets suivants :

  • Routage IP général.

  • Concepts et termes de protocole de routage OSPF.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Routeur Cisco 2503

  • Exécution de version de logiciel 12.2(24a) de ½ du ¿  de Cisco IOSï sur tous les Routeurs

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Description de l'adresse de transfert OSPF

Le concept de l'adresse de transfert OSPF a été introduit pour éviter des sauts supplémentaires quand le trafic est conduit à un système autonome (AS) externe, suivant les indications de cette figure.

/image/gif/paws/13682/10a.gif

Dans la figure, il y a deux Routeurs dans le domaine OSPF qui se connectent au domaine externe. Cependant, seulement le routeur 1 permute les informations de routage avec le routeur 100. Le routeur 1 redistribue les informations apprises du routeur 100 dans l'OSPF et annonce les informations au reste du domaine OSPF. En faisant ceci, le routeur 1 devient le prochain saut (ou adresse de transfert) pour les informations qu'elle redistribue au domaine OSPF. Quand le Router2 reçoit un paquet du domaine OSPF destiné pour une adresse dans le domaine externe, il en avant le paquet au routeur 1 du routeur 1. puis en avant il au routeur 100. Le concept d'adresse de transfert permet ce saut supplémentaire à éviter parce qu'il permet au routeur 1 de spécifier l'adresse IP d'un autre routeur comme adresse de transfert. Dans la figure, le routeur 1 peut spécifier le routeur 100 comme adresse de transfert pour information les informations externes que le routeur 1 redistribue dans le domaine OSPF. Quand le Router2 reçoit un paquet du domaine OSPF destiné pour une adresse dans le domaine externe, il en avant le paquet au routeur 100. Le résultat est que le saut supplémentaire est évité par le routeur 1.

La valeur de l'adresse de transfert spécifiée par le routeur ASBR (Autonomous System Boundary Router) (routeur 1 dans la figure précédente) peut être 0.0.0.0 ou différente de zéro. L'adresse de 0.0.0.0 indique que le routeur d'origine (l'ASBR) est le prochain saut. L'adresse de transfert est déterminée par ces conditions :

  • L'adresse de transfert est placée à 0.0.0.0 si l'ASBR redistribue des artères et l'OSPF n'est pas activé sur la prochaine interface du saut pour ces artères. C'est vrai dans la figure si le routeur 1 n'a pas l'OSPF activé sur l'interface Ethernet.

  • Ces conditions ont placé la zone adresse d'adresse de transfert à une adresse différente de zéro :

    • L'OSPF est activé sur la prochaine interface du saut de l'ASBR ET

    • La prochaine interface du saut de l'ASBR est non-passive sous l'OSPF ET

    • La prochaine interface du saut de l'ASBR n'est pas point par point ET

    • La prochaine interface du saut de l'ASBR n'est pas point-à-multipoint ET

    • Les chutes suivantes d'adresse de l'interface du saut de l'ASBR sous la plage de réseau spécifiée dans le router ospf commandent.

  • Toutes les autres conditions sans compter que ces derniers ont placé l'adresse de transfert à 0.0.0.0.

Pour les informations sur la façon dont l'adresse de transfert est réglée et la sélection de chemin d'affects référez-vous aux effets de l'adresse de transfert sur la sélection de chemin LSA du type 5.

Problème commun de routage OSPF lié à l'adresse de transfert

/image/gif/paws/13682/10b_01.gif

Le routeur R2513, qui exécute seulement le RIP (et peut être connecté à un réseau réservé à la RIP), est ajouté au réseau Token Ring dans la figure. Quand les artères apprises de R2513 sont redistribuées dans l'OSPF par l'ASBR (R2515), certaines des artères ne sont pas installées dans la table de routage de certains des Routeurs. Les informations de configuration appropriées de chacun des Routeurs sont fournies dans ces tables.

adresse Internet R2504
interface Serial0
ip address 1.1.1.2 255.255.255.0
         
interface TokenRing0
ip address 3.3.4.2 255.255.255.0
         
router ospf 1
network 1.1.1.0 0.0.0.255 area 0
network 3.0.0.0 0.255.255.255 area 1
area 1 range 3.0.0.0 255.0.0.0

adresse Internet R2507
interface Serial0
ip address 1.1.1.1 255.255.255.0
         
interface Serial1
ip address 7.7.7.1 255.255.255.0
         
router ospf 1
network 1.1.1.1 0.0.0.0 area 0
default- information originate metric 20
         
ip route 0.0.0.0 0.0.0.0 Serial1 

adresse Internet R2513
interface TokenRing0
ip address 3.3.4.4 255.255.255.0
       
interface ethernet 0
ip address 200.1.1.4 255.255.255.0
       
router rip
network 3.0.0.0
network 200.1.1.0

adresse Internet R2515
interface TokenRing0
ip address 3.3.4.3 255.255.255.0
       
interface ethernet 0
ip address 3.44.66.3 255.255.255.0
       
interface ethernet 1
ip address 3.22.88.3 255.255.255.0
       
router ospf 1
redistribute rip metric 20 subnets
network 0.0.0.0 255.255.255.255 area 1
       
router rip
network 3.0.0.0

passive-interface ethernet 0
passive-interface ethernet 1

Les configurations dans les tables prouvent que R2515 redistribue le RIP dans l'OSPF et que R2504 (le routeur de cadre de zone [ABR]) crée un réseau récapitulé 3.0.0.0/8.

Ce sont les tables de routage pour chacun des routeurs activés OSPF :

R2507# 
show ip route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0
         1.0.0.0/ 24 is subnetted, 1 subnets
C          1.1.1.0 is directly connected, Serial0
         3.0.0.0/ 8 is variably subnetted, 4 subnets, 2 masks
O IA        3.0.0.0/ 8 [110/ 70] via 1.1.1.2, 00: 15: 37, Serial0
O E2        3.3.4.0/ 24 [110/ 20] via 1.1.1.2, 00: 06: 37, Serial0
O E2        3.22.88.0/ 24 [110/ 20] via 1.1.1.2, 00: 06: 37, Serial0
O E2        3.44.66.0/ 24 [110/ 20] via 1.1.1.2, 00: 06: 37, Serial0
          7.0.0.0/ 24 is subnetted, 1 subnets
C           7.7.7.0 is directly connected, Serial1
S*     0.0.0.0/ 0 is directly connected, Serial1


R2504# show ip route
Gateway of last resort is 1.1.1.1 to network 0.0.0.0
            1.0.0.0/ 24 is subnetted, 1 subnets
C             1.1.1.0 is directly connected, Serial0
            3.0.0.0/ 8 is variably subnetted, 4 subnets, 2 masks
S             3.0.0.0/ 8 is directly connected, Null0
C             3.3.4.0/ 24 is directly connected, TokenRing0
O             3.22.88.0/ 24 [110/ 11117] via 3.3.4.3, 00: 15: 16, TokenRing0
O             3.44.66.0/ 24 [110/ 11117] via 3.3.4.3, 00: 15: 16, TokenRing0
O  E2 200.1.1.0/ 24 [110/ 20] via 3.3.4.4, 00: 06: 16, TokenRing0
O* E2 0.0.0.0/ 0 [110/ 20] via 1.1.1.1, 00: 15: 16, Serial0

R2515# show ip route
 Gateway of last resort is 3.3.4.2 to network 0.0.0.0
            1.0.0.0/ 24 is subnetted, 1 subnets
 O IA         1.1.1.0 [110/ 70] via 3.3.4.2, 00: 10: 28, TokenRing0
            3.0.0.0/ 24 is subnetted, 3 subnets
 C            3.3.4.0 is directly connected, TokenRing0
 R          200.1.1.0/ 24 [120/ 1] via 3.3.4.4, 00: 00: 10, TokenRing0
 O* E2 0.0.0.0/ 0 [110/ 20] via 3.3.4.2, 00: 10: 28, TokenRing0

Disparus de réseau du Tableau de routage

R2515 a une artère dérivée par (r) de RIP pour le réseau 200.1.1.0/24. R2515 est l'ASBR et redistribue le protocole RIP dans l'OSPF. R2504 se renseigne sur le réseau 200.1.1.0/24 de R2515 et l'installe dans sa table de routage pendant qu'une artère externe du type-2 OSPF (E2). Le problème est que R2507 n'a pas le réseau 200.1.1.0/24 dans sa table de routage.

R2507 a les artères externes pour les réseaux 3.3.4.0/24, 3.22.88.0/24 et 3.44.66.0/24, quoique tous ces réseaux devraient être inclus dans le résumé de 3.0.0.0/8.

La raison que ces artères externes révèlent est que l'ASBR, qui redistribue le RIP dans l'OSPF, a l'exécution de RIP sur ces trois sous-réseaux. Il redistribue donc les sous-réseaux en tant qu'artères externes dans l'OSPF. Puisque ces sous-réseaux sont les artères externes, ils ne sont pas récapitulés par l'ABR (R2504). Des artères externes OSPF peuvent seulement être récapitulées par l'ASBR. Dans ce cas, R2515. L'ABR récapitule seulement les artères internes OSPF de la zone 1 dans la zone 0.

Remarque: Avec la difficulté de l'ID de bogue Cisco CSCdp72526 (clients enregistrés seulement), l'OSPF ne génère pas une publicité de l'état de lien type-5 (LSA) d'un réseau externe superposé. R2507 a seulement une route inter-zone récapitulative de 3.0.0.0/8. Puis, R2507 installe 200.1.1.0/24 car l'adresse de transfert et lui est accessible par l'intermédiaire de la route inter-zone 3.0.0.0/8. C'est conformément à RFC 2328leavingcisco.com .

Cette sortie affiche le LSA externe pour le réseau 200.1.1.0/24 dans la base de données OSPF de R2507 :

R2507# 
show ip ospf data external 200.1.1.0

       OSPF Router with ID (7.7.7.1) (Process ID 1)
       Type- 5 AS External Link States
       LS age: 72
       Options: (No TOS- capability, DC)
       LS Type: AS External Link
       Link State ID: 200.1.1.0 (External Network Number )
       Advertising Router: 3.44.66.3
       LS Seq Number: 80000001
       Checksum: 0xF161
       Length: 36
       Network Mask: /24
                   Metric Type: 2 (Larger than any link state path)
                   TOS: 0
                   Metric: 20
                   Forward Address: 3.3.4.4
                   External Route Tag: 0

L'OSPF permet à l'ASBR pour spécifier un autre routeur comme adresse de transfert aux artères externes. Dans ce cas, l'ASBR (R2515) a spécifié 3.3.4.4 comme adresse de transfert pour le réseau externe 200.1.1.0.

RFC 2328leavingcisco.com , section 16.4 (calculant EN TANT QU'artères externes), états :

« Si l'adresse de transfert est différente de zéro, consultation l'adresse de transfert dans la table de routage. L'entrée de table assortie de routage doit spécifier une intra-zone ou un chemin d'inter-zone ; si aucun un tel chemin n'existe, ne faites rien avec le LSA et considérez le prochain dans la liste. »

Dans cet exemple, l'artère à l'adresse de transfert 3.3.4.4 est affichée ici :

R2507# 
show ip route 3.3.4.4

       Routing entry for 3.3.4.0/ 24
           Known via "ospf 1", distance 110, metric 20,type extern 2, forward metric 70
           Redistributing via ospf 1
           Last update from 1.1.1.2 on Serial0, 00: 00: 40 ago
           Routing Descriptor Blocks:
           * 1.1.1.2, from 3.44.66.3, 00: 00: 40 ago, via Serial0
              Route metric is 20, traffic share count is 1

L'adresse de transfert de 3.3.4.4 est appariée par l'artère externe 3.3.4.0/24 au lieu de la route récapitulative 3.0.0.0/8 d'inter-zone due à la règle de correspondance plus longue. Puisque le routeur n'a pas une artère interne OSPF à l'adresse de transfert, elle n'installe pas l'artère externe 200.1.1.0/24 dans la table de routage. L'utilisation d'une artère externe d'atteindre une autre artère externe peut mener aux boucles. Par conséquent l'OSPF ne le permet pas.

Ne récapitulez pas sur l'ABR

Comment pouvez-vous s'assurer que l'adresse de transfert différente de zéro existe dans la table de routage comme intra-zone ou route inter-zone ?

La première solution n'est pas de récapituler sur l'ABR.

La deuxième solution n'est pas de ne configurer aucun type 3 LSA filtrant. Si des artères du type 3 sont filtrées, l'adresse de transfert qui apparaît sur la sortie de la commande externe de show ip ospf database n'est pas accessible. Ceci rend le réseau externe inaccessible. Dans ce cas, R2504. Ceci fait avoir des Routeurs dans la zone 0 des routes inter-zone (au lieu des artères externes) pour tous les sous-réseaux spécifiques dans d'autres zones.

Utilisez ces commandes de retirer la récapitulation sur l'ABR :

R2504(config)# 
router ospf 1

R2504(config- router)# no area 1 range 3.0.0.0 255.0.0.0

Les résultats de cette commande dans la table de routage sur R2507 sont affichés ici :

R2507# show ip route
       Gateway of last resort is 0.0.0.0 to network 0.0.0.0
                 1.0.0.0/ 24 is subnetted,        1 subnets
       C            1.1.1.0        is directly connected, Serial0
                 3.0.0.0/ 24 is subnetted,        3 subnets
       O IA      3.3.4.0 [110/ 70] via 1.1.1.2, 00: 00:        48, Serial0
       O IA      3.22.88.0 [110/ 80] via 1.1.1.2, 00:        00: 48, Serial0
       O IA      3.44.66.0 [110/ 80] via 1.1.1.2, 00:        00: 48, Serial0
                 7.0.0.0/ 24 is subnetted,        1 subnets
       C           7.7.7.0 is        directly connected, Serial1
       O E2 200.1.1.0/ 24 [110/ 20] via 1.1.1.2, 00: 00: 48, Serial0
       S*     0.0.0.0/ 0 is directly connected, Serial1
	   
	  R2507# show ip route 3.3.4.4
     Routing entry for 3.3.4.0/24
      Known via "ospf 1", distance 110, metric 70, type inter area
      Last update from 1.1.1.2 on Serial1, 00:03:52 ago
      Routing Descriptor Blocks:
      * 1.1.1.2, from 3.3.4.2, 00:03:52 ago, via Serial1
          Route metric is 74, traffic share count is 1

De la sortie, vous pouvez voir que l'adresse 3.3.4.4 est accessible par une route inter-zone au réseau 3.3.4.0/24. Le routeur R2507 apprend l'artère à ce réseau par un LSA LSA Type-5 et Type-3, après que la récapitulation sur l'ABR R2504 soit retirée. Puisque l'OSPF préfère une route inter-zone au-dessus d'une artère externe au même réseau, il l'installe comme route inter-zone. L'onde sinusoïdale R2507 a maintenant une route inter-zone à l'adresse de transfert 3.3.4,4, le réseau externe 200.1.1.0/24 est également installée dans sa table de routage.

Remarque: Si le NSSA (zone pas aussi tronquée) est utilisé et si le filtrage LSA du type 3 est fait sur l'ABR NSSA, alors la même adresse de transfert de question inaccessible existera.

Empêchez le sous-réseau d'être redistribué dans l'OSPF comme artère externe

Une autre solution est d'empêcher le sous-réseau 3.3.4.0 d'être redistribué dans l'OSPF comme artère externe, puisque l'OSPF fonctionne là-dessus. Ces commandes de configuration dans l'ASBR (R2515) créent un route-map. Ceci est utilisé par la commande de redistribuer de permettre seulement le réseau 200.1.1.0/24 à redistribuer dans l'OSPF. L'ABR (R2504) récapitule toujours les artères internes OSPF de la zone 1 dans la zone 0.

R2515# configure terminal
R2515(config)# router ospf 1
R2515(config-router)# redistribute rip metric 20 subnets route-map rip_to_ospf_filter
R2515(config-router)# exit
   
R2515(config)# 
access-list 28 permit 200.1.1.0 0.0.0.255
   
R2515(config)# 
route-map rip_to_ospf_filter permit 10
R2515(config-route-map)# 
match ip address 28

Les résultats de cette commande dans la table de routage sur R2507 sont affichés ici :

R2507# show ip route
       Gateway of last resort is 0.0.0.0 to network 0.0.0.0
                 1.0.0.0/ 24 is subnetted,        1 subnets
       C            1.1.1.0        is directly connected, Serial0
       O IA  3.0.0.0/ 8 [110/ 70] via 1.1.1.2, 00: 07: 05, Serial0
                 7.0.0.0/ 24 is subnetted,        1 subnets
       C            7.7.7.0        is directly connected, Ethernet0
       O E2  200.1.1.0/ 24 [110/ 20] via 1.1.1.2, 00: 00: 21, Serial0
       S*      0.0.0.0/ 0 is directly connected, Ethernet0

La seule artère externe dans la table de routage est 200.1.1.0/24. Ce réseau est dans la table de routage parce que l'adresse de transfert de ce réseau externe (3.3.4.1) est couverte par la route récapitulative 3.0.0.0/8, qui est une route inter-zone.


Informations connexes


Document ID: 13682