IP : Protocole EIGPR (Enhanced Interior Gateway Routing Protocol)

Que signifient les messages EIGRP « Not On Common Subnet » ?

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document explique pourquoi un routeur de ½ du ¿  de Cisco IOSï peut éprouver a pas sur le message d'erreur de sous-réseau commun quand le routeur est configuré avec le Protocole EIGPR (Enhanced Interior Gateway Routing Protocol).

L'EIGRP utilise des paquets HELLO multicasts afin de communiquer à d'autres voisins EIGRP. Si l'EIGRP reçoit bonjour un paquet qui est originaire d'une adresse IP sur un sous-réseau qui n'est pas configuré sur l'EIGRP recevant l'interface, l'EIGRP génère ce message d'erreur :

timestamp: IP-EIGRP: Neighbor neighbor_IP_address not on common subnet for interface

Conditions préalables

Conditions requises

Ce document exige une compréhension de base des protocoles de Routage IP et de protocole de routage EIGRP en général. Afin d'en savoir plus sur les protocoles de routage IP et sur EIGRP, consultez les documents suivants :

Composants utilisés

Les informations dans ce document sont basées sur la version du logiciel Cisco IOS 12.2(10b) sur le Routeurs de la gamme Cisco 2500.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Cisco recommande que vous configuriez tous les Routeurs sur un segment de réseau avec les adresses IP primaires sur le même sous-réseau. Cet exemple affiche une configuration commune EIGRP :

/image/gif/paws/13674/15a1.gif

Configurations

Ce document utilise les configurations suivantes :

R1
hostname R1
!
interface Ethernet0
ip address 10.1.1.1 255.255.255.0
!
router eigrp 1
network 10.0.0.0
!
end

R2
hostname R2
!
interface Ethernet0
ip address 10.1.1.2 255.255.255.0
!
router eigrp 1
network 10.0.0.0
!
end

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Émettez la commande neighbor de show ip eigrp afin de vérifier que les deux Routeurs se voient.

R1#show ip eigrp neighbor

IP-EIGRP neighbors for process 1

H   Address                 Interface   Hold Uptime   SRTT   RTO  Q  Seq

                                        (sec)         (ms)       Cnt Num

0   10.1.1.2                Et0           12 00:00:16    0  3000  0  23
R2#show ip eigrp neighbor

IP-EIGRP neighbors for process 1

H   Address                 Interface   Hold Uptime   SRTT   RTO  Q  Seq

                                        (sec)         (ms)       Cnt Num

0   10.1.1.1                Et0           14 00:01:19   12   200  0  11

Dépannez

Utilisez cette section pour dépanner votre configuration.

Plus voisins

Si tout est configuré correctement, vous voyez une forme voisine de relations EIGRP. Changez la configuration de R2. Placez l'interface R2 Ethernet0 dans un différent sous-réseau.

R2#configure terminal

R2(config)#interface ethernet0

R2(config-if)#ip address 10.1.2.2 255.255.255.0

R2(config-if)#end

Regardez la configuration R2 maintenant :

hostname R2
!
interface Ethernet0
ip address 10.1.2.2 255.255.255.0
!
router eigrp 1
network 10.0.0.0
!
end

Maintenant vous commencez à recevoir des messages d'erreur à la réception d'un paquet HELLO EIGRP. Dans ce cas, les messages se produisent approximativement toutes les 15 secondes, sur R1 et R2 :

R1

3w0d: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 

01:05:01: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:05:15: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:05:30: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:05:44: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
R2

3w0d: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 

00:48:40: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 (10.1.)
00:48:54: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 (10.1.)
00:49:08: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 (10.1.)
00:49:22: IP-EIGRP: Neighbor 10.1.1.1 not on common subnet for Ethernet0 (10.1.)

En dépit des messages d'erreur, l'EIGRP fonctionne correctement avec tous autres voisins R1 ou R2. La sortie mise à jour de commande neighbor de show ip eigrp prouve que le message d'erreur indique un sérieux problème entre R1 et R2. Les Routeurs ne sont plus des voisins et ne permutent plus les informations de routage.

R1

R1#show ip eigrp neighbor
IP-EIGRP neighbors for process 1
R2

R2#show ip eigrp neighbor
IP-EIGRP neighbors for process 1

Adresse IP secondaire

Vous pouvez également voir ce problème dans les réseaux qui utilisent les adresses IP secondaires, si les réseaux ne sont pas correctement configurés. Ajoutez une adresse secondaire à R2 :

R2

R2#configure terminal

R2(config)#interface ethernet0

R2(config-if)#ip address 10.1.1.2 255.255.255.0 secondary

R2(config-if)#end

La configuration R2 ressemble à maintenant ceci :

hostname R2
!
interface Ethernet0
ip address 10.1.2.2 255.255.255.0


ip address 10.1.1.2 255.255.255.0 secondary
!
router eigrp 1
network 10.0.0.0
!
end

Puisque R2 identifie maintenant 10.1.1.0/24 comme sous-réseau valide pour l'interface Ethernet0, vous ne voyez plus pas en fonction le message d'erreur de sous-réseau commun sur R2. R2 affiche R1 en tant que voisin EIGRP, et R2 reçoit et reçoit bonjour les paquets R1.

Router2#show ip eigrp neighbor
IP-EIGRP neighbors for process 1
H   Address                 Interface   Hold Uptime   SRTT   RTO  Q  Seq Type
                                        (sec)         (ms)       Cnt Num
0   10.1.1.1                Et0           12 00:00:35    1  5000  1  0

Cependant, R1 n'affiche pas R2 en tant que voisin, et R1 ne reçoit pas des mises à jour de routage de R2. Ceci signifie que R2 remet à l'état initial continuellement sa contiguïté de voisinage avec R1. Sur R1, vous continuez à voir pas en fonction le message d'erreur de sous-réseau commun, et vous ne voyez pas R2 répertorié dans la table voisine EIGRP.

R1#show ip eigrp neighbor

IP-EIGRP neighbors for process

01:20:54: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:21:08: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:21:22: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)
01:21:36: IP-EIGRP: Neighbor 10.1.2.2 not on common subnet for Ethernet0 (10.1.)

Ceci se produit parce que les mises à jour EIGRP utilisent toujours l'adresse IP primaire de l'interface sortante comme adresse source. Changez l'adresse principale sur R1 pour apparier le sous-réseau R2 primaire, qui est 10.1.2.1/24 dans cet exemple.

Vous pouvez configurer quelques réseaux avec deux sous-réseaux distincts sur le même segment physique. Dans ce cas, les Routeurs EIGRP sur un sous-réseau peuvent ne pas pouvoir communiquer avec des Routeurs EIGRP sur l'autre sous-réseau. Si vous exécutez le Logiciel Cisco IOS version 11.3, 12.0, ou plus tard, vous pouvez désactiver pas en fonction les messages d'erreur de sous-réseau commun avec l'utilisation de l'aucune commande d'eigrp log-neighbor-warnings.

Remarque: Cisco ne recommande pas généralement l'utilisation de l'aucune commande d'eigrp log-neighbor-warnings. La commande désactive pas en fonction les messages d'erreur de sous-réseau commun sur toutes les interfaces que le processus EIGRP utilise. Utilisez la commande avec la discrétion.

Ne configurez l'aucun eigrp log-neighbor-warnings commandent dans le mode de configuration du routeur EIGRP.

Router#configure terminal

Router(config)#router eigrp 1

Router(config-router)#no eigrp	log-neighbor-warnings

Cause générale pour le message d'erreur

L'EIGRP utilise des paquets HELLO multicasts afin de communiquer à d'autres voisins EIGRP. L'EIGRP génère pas en fonction le message d'erreur de sous-réseau commun quand il reçoit un paquet HELLO EIGRP originaire d'une adresse IP sur un sous-réseau qui n'est pas configuré sur son interface de réception.

Ce sont la cause générale pour ce message d'erreur :

  • Mauvaise configuration des interfaces ou les ports de commutateur ou le problème de câblage.

  • Non-concordance d'adresses IP primaires/secondaires sur l'interface voisine.

  • Un commutateur/hub coule des paquets de multidiffusion à d'autres ports.

  • Si à l'aide d'un commutateur de RÉSEAU LOCAL, les VLAN ont pu avoir joint des Routeurs ensemble.

  • Un autre routeur utilise la publicité EIGRP sur le même sous-réseau/VLAN que ce routeur et misconfigured avec un numéro de système autonome incorrect.

Afin de dépanner cette question, vérifiez ces éléments :

  • Vérifiez que le câble est connecté correctement.

  • Revérifiez la configuration d'interface pour les adresses IP misconfigured sur les gens du pays et les routeurs voisins.

  • Vérifiez que l'adresse principale de l'interface est dans le même sous-réseau que l'adresse principale du routeur voisin.

  • Si la connexion voisine EIGRP est jointe par l'intermédiaire d'un hub de RÉSEAU LOCAL, utilisez les Concentrateurs distincts afin de casser le domaine d'émission pour chaque segment logique de RÉSEAU LOCAL, ou ne configurez aucun eigrp log-neighbor-warnings d'éliminer les erreurs.

  • S'il y a un commutateur impliqué, vérifiez la configuration de commutateur pour s'assurer que différents segments de RÉSEAU LOCAL ne sont pas configurés pour être dans le même VLAN qui partagent le même domaine d'émission.


Informations connexes


Document ID: 13674