Ethernet longue portée (LRE) et ligne numérique d'abonné (xDSL) : Ligne d'abonné numérique à débit asymétrique (ADSL)

Configuration et dépannage d'un routeur Cisco 1700 avec WIC Ethernet en tant que client PPPoE avec NAT

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (12 novembre 2015) | Commentaires


Contenu


Introduction

Ce document montre comment configurer un périphérique Cisco 1700 utilisant la carte d'interface de réseau étendu Ethernet (WIC-1ENET) en tant que client de protocole point à point sur Ethernet (PPPoE) avec la traduction d'adresses réseau (NAT).

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Version de logiciel 12.1(3) prendre en charge XT1 de ½ du ¿  de Cisco IOSï ou plus tard Cisco 1700 WIC-1ENET.

  • Pour cette configuration d'échantillon, le processeur d'artère de Concentrateur-noeud d'accès universel de Cisco 6400 (UAC-NRP) exécutait la version du logiciel Cisco IOS 12.1(3)DC1.

Pour prendre en charge le PPPoE, vous devez avoir l'ensemble de caractéristiques ADSL+PLUS. L'ensemble de caractéristiques réservé à l'ADSL ne prend en charge pas le PPPoE sur Cisco 1700.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Théorie générale

Le WIC-1ENET est une carte 10BaseT développée pour les Routeurs de gamme Cisco 1700. Le WIC-1ENET fournit une deuxième interface Ethernet pour Cisco 1700, qui aide à utiliser la fonctionnalité riche du logiciel de Cisco IOS avec n'importe quelle ligne d'abonné numérique (DSL) ou modem câble.

La caractéristique de PPPoE Client permet la fonctionnalité de PPPoE à déplacer au routeur. Des PC de multiple peuvent être installés derrière le port Fast Ethernet de Cisco 1700 et, avant que leur trafic soit envoyé à la session de PPPoE, elle peut être chiffrée, filtré, et ainsi de suite, et passage NAT de boîte. Le PPPoE courant sur le routeur enlève le besoin d'utiliser le logiciel de PPPoE Client sur les PC.

Conditions requises de processeur

La révision B5 du microprocesseur MPC 860 est exigée. Ce processeur est utilisé dans toute la gamme Cisco 1700 que les Routeurs ont expédié après novembre 21, 1999. Cisco 1700 numéros de série commençant par ont été fabriqués avec le microprocesseur de la révision B5 du modèle MPC860.

Le code de date est établi dans le numéro de série. Le format est LLLYYWWSSSS, où :

  • LLL est l'emplacement auquel l'unité a été établie.

  • Le YY est l'année que l'unité a été établie (1997=01, 1998=02, 1999=03, 2000=04).

  • WW est la semaine de travail de l'année que l'unité a été établie.

  • SSSS est le numéro de série.

Les informations de version de processeur sont affichées au démarrage. Vous pouvez également vérifier la révision de processeur en émettant la commande de show version à l'invite Router-.

Configurations requises en matière de mémoire

Pour diriger Cisco 1700 images IOS qui prennent en charge Cisco WIC-1ENET, le routeur doivent avoir un minimum de mémoire flash et de mémoire vive dynamique. Pour des détails sur les mémoires réquises pour chaque image, référez-vous aux notes en version pour les Routeurs de gamme Cisco 1700 pour la Cisco IOS version 12.1(3)XT1.

Restrictions et fonctions non prises en charge WIC-1ENET

  • WIC-1ENET n'est pas pris en charge dans des Plateformes autres que Cisco 1700.

  • Seulement une connexion de RJ-45 de paire torsadée est prise en charge ; il n'y a aucune interface de raccordement à l'unité (AUI) ou support d'interface BNC.

  • Il n'y a aucune négociation automatique (détection automatique) entre bidirectionnel-alterné et les modes bidirectionnels simultanés.

  • WIC-1ENET ne peut pas être utilisé pour le téléchargement de fichier TFTP tandis que l'hôte est dans ROMMON.

  • WIC-1ENET n'est pas identifié par Cisco 1700 quand il est en mode ROMMON.

  • Supports logiciels en cours de Cisco IOS le WIC-1ENET seulement dans l'emplacement 0 de Cisco 1700.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Le PPPoE Client est configuré sur Cisco 1700 avec les commandes de Réseau privé virtuel à accès commuté (VPDN). (Les commandes VPDN ne sont pas nécessaires pour Logiciel Cisco IOS version 12.2(13)T ou plus tard.) Assurez-vous que vous configurez ces commandes d'abord.

Remarque: Pour des informations sur changer la taille du Maximum Transmission Unit (MTU), référez-vous à la taille de MTU de dépannage dans la Connectivité de Dialin de PPPoE.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/12956/wic_1enet.gif

Configurations

Ce document utilise les configurations suivantes :

Cisco 1700
! 
vpdn enable 
no vpdn logging
! 
vpdn-group pppoe 
�request-dialin�� 

!--- The PPPoE client requests to establish�� 
!--- a session with the aggregation unit (6400 NRP).
!--- These VPDN commands are not needed with 
!--- Cisco IOS Software Release 12.2(13)T or later.

��protocol pppoe 
! 
int Dialer1
 ip address negotiated
 encapsulation ppp
 ip mtu 1492

!--- The Ethernet MTU is 1500 by default 
!--- (1492 + PPPoE headers = 1500).

 ip nat outside
 dialer pool 1

!--- This ties to interface Ethernet0.

 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname <username>
ppp chap password <password>
!

!--- The ISP instructs you regarding 
!--- the type of authentication to use.
!--- To change from PPP Challenge Handshake Authentication 
!--- Protocol(CHAP) to PPP Password Authentication Protocol (PAP),
!--- replace these three lines:
!--- ppp authentication chap callin
!--- ppp chap hostname 
!--- ppp chap password 
!--- with these two lines:
!--- ppp authentication pap callin.

ppp pap sent-username <username> password <password>�

!
dialer-list 1 protocol ip permit
!

!--- This is the internal Ethernet network.

interface FastEthernet0
 ip address 10.0.0.1 255.255.255.0
 ip nat inside
!
interface Ethernet0
 pppoe enable
 pppoe-client dial-pool-number 1

!--- The PPPoE client code ties into a dialer 
!--- interface upon which a virtual-access 
!--- interface is cloned.

!

!--- For NAT, you overload on the 
!--- Dialer1 interface and add a default route
!--- out of the Dialer1 interface because
!--- the IP address can change.


ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 dialer1
no ip http server
!
dialer-list 1 protocol ip permit
access-list 1 permit 10.0.0.0 0.0.0.255

!--- This is for NAT.

!

Cisco 6400
*** local ppp user 

!--- Or, you can use AAA.

username <username> password <password>

!--- Begin with the VPDN commands. 
!--- Notice that you are binding the PPPoE here to 
!--- a virtual-template instead of on the ATM interface. 
!--- You cannot (at this time) use more than one 
!--- virtual-template (or VPDN group) for PPPoE� 
!--- beginning with the VPDN commands.

vpdn enable 
no vpdn logging 
! 
vpdn-group pppoe 
�accept-dialin 

!--- This is PPPoE server mode.

�protocol pppoe 
�virtual-template 1 
! 
! 
interface ATM0/0/0 
�no ip address 
�no atm ilmi-keepalive 
�hold-queue 500 in 

!--- The binding to the virtual-template 
!--- interface is configured in the VPDN group.

! 
interface ATM0/0/0.182 point-to-point 
�pvc 1/82 
��encapsulation aal5snap

!--- You need the command on the server side. 

� protocol pppoe 
�! 
! 

!--- Virtual-template is used instead of dialer interface. 

! 
interface Virtual-Template1 
�ip unnumbered Loopback10 
�ip mtu 1492 
�peer default ip address pool ippool 
�ppp authentication chap 
! 
! 
interface Loopback10 
�ip address 8.8.8.1 255.255.255.0 
! 
ip local pool ippool 9.9.9.1 9.9.9.5

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Débogage du PPPoE Client

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Pour mettre au point Cisco 1700 (PPPoE Client), vous devez considérer la pile de protocoles.

  • Couche 4 - Couche de PPP

  • Couche 3 - Couche Ethernet

  • Couche 2 - Couche atmosphère

  • Couche 1 - Couche physique DSL

Vous pourriez dépanner le début au bas. Puisque les couches DSL et atmosphère se produisent à la CPE DSL (CPE), vous devez dépanner les couches seulement d'Ethernets et de PPP pour Cisco 1700, comme affiché ci-dessous.

Couche Ethernet

Les trames Ethernet complètes sont dans les paquets (INSTANTANÉS) de protocole d'accès de sous-réseau de l'adaptation ATM de couche 5 (AAL5). Il y a aucun mettent au point la commande de paquet Ethernet, mais vous devriez exécuter un certain VPDN met au point (le PPPoE met au point pour Logiciel Cisco IOS version 12.2(13)T ou plus tard) pour voir les trames de PPPoE.

Pour la référence, une trame Ethernet qui est une trame de PPPoE contient l'un de deux Ethertypes :

  • 0x8863 Ethertype = paquet de contrôle de PPPoE (manipule la session de PPPoE)

  • 0x8864 Ethertype = paquet de données de PPPoE (contient des paquets PPP)

L'une information importante est qu'il y a deux sessions dans le PPPoE : la session de PPPoE qui est un perçage d'un tunnel Protocol (session de la couche deux VPDN L2TP)-type, et la session PPP. Ainsi, pour établir le PPPoE, il y a une phase d'établissement de session de PPPoE et une phase d'établissement de session PPP.

L'arrêt implique habituellement une phase de terminaison de PPP et une phase de terminaison de PPPoE.

La phase d'établissement de PPPoE se compose identifier les adresses MAC du PPPoE Client et du serveur et assigner un ID de session. Ensuite c'est complet, l'établissement normal de PPP se produit juste comme n'importe quelle autre connexion PPP.

Pour mettre au point, vous pouvez utiliser le PPPoE VPDN met au point (le PPPoE met au point pour Logiciel Cisco IOS version 12.2(13)T ou plus tard) pour déterminer si le PPPoE connectent la phase est réussi.

# debug vpdn pppoe-events (debug pppoe events)

06:17:58: Sending PADI: vc=1/1

!--- A broadcast Ethernet frame (in this case, encapsulated in ATM) 
!--- requests a PPPoE server, "Are there any PPPoE servers out there?" 


06:18:00:  PPPOE: we've got our pado and the pado timer went off 

!--- This is a unicast reply from a PPPoE server (very similar to 
!--- a DHCP offer).


06:18:00: OUT PADR from PPPoE tunnel

!--- This is a unicast reply accepting the offer.


06:18:00: IN PADS from PPPoE tunnel

!--- This is a confirmation that completes the establishment.

L'établissement de PPP commence maintenant, comme dans n'importe quelle autre initiation de PPP. Après que la session de PPPoE soit établie, vous pouvez émettre des commandes de show vpdn d'obtenir l'état.

# show vpdn (show pppoe session)
%No active L2TP tunnels 
%No active L2F tunnels 

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Tunnel Information

Session count: 1

PPPoE Session Information
SID        RemMAC          LocMAC       Intf    VASt   OIntf    VC 
1       0050.7359.35b7  0001.96a4.84ac  Vi1     UP     AT0    1    1

Vous pouvez obtenir les informations de compte de paquets utilisant le show vpdn session toute la (show pppoe session tout) commande.

show vpdn session all (show pppoe session all)
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Session Information Total tunnels 1 sessions 1

session id: 1
local MAC address: 0001.96a4.84ac, remote MAC address: 0050.7359.35b7 
virtual access interface: Vi1, outgoing interface: AT0, vc: 1/1 
    1656 packets sent, 1655 received, 24516 bytes sent, 24486 received

D'autres commandes de débogage :

  • debug vpdn pppoe-data (données de debug pppoe)

  • mettez au point les PPPoE-erreurs (les erreurs de debug pppoe)

  • mettez au point les PPPoE-paquets (les paquets de debug pppoe)

Couche de PPP

Après que la session de PPPoE ait été établie, le PPP met au point sont identique que pour n'importe quel autre établissement de PPP.

Le mêmes debug ppp negotiation et commandes de debug ppp authentication sont utilisés. Voici un exemple de sortie :

Remarque: Dans cet échantillon, le nom d'hôte est "client1", et le nom du Cisco 6400 distant est « nrp-b ».

06:36:03: Vi1 PPP: Treating connection as a callout
06:36:03: Vi1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]
06:36:03: Vi1 PPP: No remote authentication for call-out
06:36:03: Vi1 LCP: O CONFREQ [Closed] id 1 len 10
06:36:03: Vi1 LCP:��� MagicNumber 0x03013D43 (0x050603013D43) 
06:36:03: Vi1 LCP: I CONFACK [REQsent] id 1 len 10
06:36:03: Vi1 LCP:��� MagicNumber 0x03013D43 (0x050603013D43) 
06:36:05: Vi1 LCP: I CONFREQ [ACKrcvd] id 2 len 15
06:36:05: Vi1 LCP:� ��AuthProto CHAP (0x0305C22305)
06:36:05: Vi1 LCP:��� MagicNumber 0x65E315E5 (0x050665E315E5) 
06:36:05: Vi1 LCP: O CONFACK [ACKrcvd] id 2 len 15
06:36:05: Vi1 LCP:��� AuthProto CHAP (0x0305C22305)
06:36:05: Vi1 LCP:��� MagicNumber 0x65E315E5 (0x050665E315E5) 
06:36:05: Vi1 LCP: State is Open
06:36:05: Vi1 PPP: Phase is AUTHENTICATING, by the peer [0 sess, 1 load]
06:36:05: Vi1 CHAP: I CHALLENGE id 9 len 26 from "nrp-b" 
06:36:05: Vi1 CHAP: Using alternate hostname client1
06:36:05: Vi1 CHAP: Username nrp-b not found
06:36:05: Vi1 CHAP: Using default password
06:36:05: Vi1 CHAP: O RESPONSE id 9 len 28 from "client1"
06:36:05: Vi1 CHAP: I SUCCESS id 9 len 4
06:36:05: Vi1 PPP: Phase is FORWARDING [0 sess, 1 load]
06:36:05: Vi1 PPP: Phase is AUTHENTICATING [0 sess, 1 load]
06:36:05: Vi1 PPP: Phase is UP [0 sess, 1 load]
06:36:05: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10
06:36:05: Vi1 IPCP:��� Address 0.0.0.0 (0x030600000000)
06:36:05: Vi1 CDPCP: O CONFREQ [Closed] id 1 len 4
06:36:05: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 10
06:36:05: Vi1 IPCP:��� Address 8.8.8.1 (0x030608080801)
06:36:05: Vi1 IPCP:��� Address 8.8.8.1 (0x030608080801)
06:36:05: Vi1 IPCP:��� Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 IPCP: O CONFREQ [ACKsent] id 2 len 10
06:36:05: Vi1 IPCP:� ��Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 LCP: I PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 
06:36:05: Vi1 CDPCP: State is Closed
06:36:05: Vi1 IPCP: I CONFACK [ACKsent] id 2 len 10
06:36:05: Vi1 IPCP:��� Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 IPCP: State is Open
06:36:05: Di1 IPCP: Install negotiated IP interface address 9.9.9.2
06:36:05: Di1 IPCP: Install route to 8.8.8.1
06:36:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed 
 state to up

Débogage du serveur de PPPoE

Pour mettre au point le Cisco 6400 (le serveur de PPPoE), vous pouvez utiliser la même procédure d'approche par le bas utilisée pour Cisco 1700 (le PPPoE Client).

  • Couche 4 - Couche de PPP

  • Couche 3 - Couche Ethernet

  • Couche 2 - Couche atmosphère

  • Couche 1 - Couche physique DSL

La différence est que maintenant vous dépannez la couche DSL sur le multiplicateur d'accès de ligne d'abonné numérique (DSLAM) et la couche atmosphère sur le Cisco 6400, comme affiché ci-dessous.

Couche physique DSL

Pour vérifier la couche physique DSL, vous devez voir les statistiques DSL sur le DSLAM. Pour des DSLAM Cisco, la commande d'interface de l'exposition DSL peut être utilisée.

Couche atmosphère

Du côté de Cisco 6400, vous pouvez également utiliser la commande de paquet atmosphère de débogage et activer le Cisco 6400 pour un PVC de particularité.

debug atm packet interface atm 0/0/0.182 vc 1/82 

Vous devriez voir la sortie semblable au suivant, avec les mêmes champs de type, de SAP, CTL, et OUI prouvant que le paquet ATM entrant est le SNAP AAL5.

4d04h: ATM0/0/0.182(I):
VCD:0x3 VPI:0x1 VCI:0x52 Type:0x900 SAP:AAAA CTL:03 OUI:0080C2 TYPE:0007 Length:0x30
4d04h: 0000 0001 96A4 84AC 0050 7359 35B7 8864 1100 0001 000E C021 0A2E 000C 65E3
4d04h: 15E5 0000 0000

Remarque: Vous ne voyez pas les paquets sortants avec cette commande en raison de la manière dont les paquets sont traité.

Couche Ethernet

Les mêmes commandes d'exposition et de débogage VPDN utilisées sur Cisco 1700 peuvent être utilisées sur le Cisco 6400 pour regarder l'établissement de PPPoE.

# debug vpdn pppoe-events (debug pppoe events)

4d04h: IN PADI from PPPoE tunnel

4d04h: OUT PADO from PPPoE tunnel

4d04h: IN PADR from PPPoE tunnel

4d04h: PPPoE: Create session
4d04h: PPPoE: VPN session created.

4d04h: OUT PADS from PPPoE tunnel


# show vpdn (show pppoe session)
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Tunnel Information

Session count: 1
PPPoE Session Information
SID        RemMAC          LocMAC       Intf    VASt   OIntf    VC
1       0001.96a4.84ac  0050.7359.35b7  Vi4     UP     AT0/0/0 1   82


nrp-b# 
show vpdn session all (show pppoe session all)
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Session Information Total tunnels 1 sessions 1
 
session id: 1
local MAC address: 0050.7359.35b7, remote MAC address: 0001.96a4.84ac
virtual access interface: Vi4, outgoing interface: AT0/0/0, vc: 1/82
    30 packets sent, 28 received, 422 bytes sent, 395 received

Ce sont d'autres commandes de débogage :

  • debug vpdn pppoe-data (données de debug pppoe)

  • mettez au point les PPPoE-erreurs (les données de debug pppoe)

  • mettez au point les PPPoE-paquets (les paquets de debug pppoe)

Couche de PPP

C'est une sortie de débogage de PPP du Cisco 6400 qui correspond au plus tôt mettent au point de Cisco 1700 :

debug ppp negotiation and debug ppp authentication

4d04h: Vi2 PPP: Treating connection as a dedicated line 
4d04h: Vi2 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load] 
4d04h: Vi2 LCP: O CONFREQ [Closed] id 1 len 15 
4d04h: Vi2 LCP:��� AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:��� MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: I CONFREQ [REQsent] id 1 len 10 
4d04h: Vi2 LCP:��� MagicNumber 0x03144FF9 (0x050603144FF9) 
4d04h: Vi2 LCP: O CONFACK [REQsent] id 1 len 10 
4d04h: Vi2 LCP:� ��MagicNumber 0x03144FF9 (0x050603144FF9) 
4d04h: Vi3 LCP: I ECHOREQ [Open] id 60 len 8 magic 0xA60C0000 
4d04h: Vi3 LCP: O ECHOREP [Open] id 60 len 8 magic 0x51A0BEF6 
4d04h: Vi2 LCP: TIMEout: State ACKsent 
4d04h: Vi2 LCP: O CONFREQ [ACKsent] id 2 len 15 
4d04h: Vi2 LCP:��� AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:��� MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: I CONFACK [ACKsent] id 2 len 15 
4d04h: Vi2 LCP:��� AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:��� MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: State is Open 
4d04h: Vi2 PPP: Phase is AUTHENTICATING, by this end [0 sess, 1 load] 
4d04h: Vi2 CHAP: O CHALLENGE id 10 len 26 from "nrp-b" 
4d04h: Vi2 CHAP: I RESPONSE id 10 len 28 from "client1" 
4d04h: Vi2 PPP: Phase is FORWARDING [0 sess, 1 load] 
4d04h: Vi2 PPP: Phase is AUTHENTICATING [0 sess, 1 load] 
4d04h: Vi2 CHAP: O SUCCESS id 10 len 4 
4d04h: Vi2 PPP: Phase is UP [0 sess, 1 load] 
4d04h: Vi2 IPCP: O CONFREQ [Closed] id 1 len 10 
4d04h: Vi2 IPCP:��� Address 8.8.8.1 (0x030608080801) 
4d04h: Vi2 IPCP: I CONFREQ [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:��� Address 0.0.0.0 (0x030600000000) 
4d04h: Vi2 IPCP: Pool returned 9.9.9.2 
4d04h: Vi2 IPCP: O CONFNAK [REQsent] id 1 len 10 
4d04h: Vi2 IPCP: ���Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 CDPCP: I CONFREQ [Not negotiated] id 1 len 4 
4d04h: Vi2 LCP: O PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 
4d04h: Vi2 IPCP: I CONFACK [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:��� Address 8.8.8.1 (0x030608080801) 
4d04h: Vi2 IPCP: I CONFREQ [ACKrcvd] id 2 len 10 
4d04h: Vi2 IPCP:��� Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 IPCP: O CONFACK [ACKrcvd] id 2 len 10 
4d04h: Vi2 IPCP:��� Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 IPCP: State is Open 
4d04h: Vi2 IPCP: Install route to 9.9.9.2 
4d04h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed 
 state to up

Informations connexes


Document ID: 12956