Routeurs : Routeurs de la gamme Cisco SOHO 70

Configuration d'un routeur Cisco SOHO77 en tant que client PPPoE avec NAT

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Dans la version de logiciel 12.1(3)XG de ½ du ¿  de Cisco IOSïÂ, une fonctionnalité client de Protocole PPPoE (PPP sur Ethernet) a été introduite pour petit Home Office de bureau de Cisco/(SOHO) 77. Cette caractéristique permet la fonctionnalité de PPPoE à déplacer au routeur. Des PC de multiple peuvent être installés derrière Cisco SOHO77, et avant que leur trafic soit envoyé à la session de PPPoE, les données peuvent être chiffrés et filtrés, et le Traduction d'adresses de réseau (NAT) peut fonctionner.

Ce document affiche un PPPoE Client configuré sur l'interface de Mode de transfert asynchrone (ATM) (l'interface DSL) de Cisco SOHO77. Cette configuration peut également être utilisée sur Cisco 1700 avec une carte d'interface WAN de Ligne d'abonné numérique à débit asymétrique (ADSL) (WIC).

La configuration sur le processeur d'artère de noeud de Cisco 6400 (NRP) peut également être utilisée sur un autre routeur utilisé en tant qu'agrégateur et avec une interface ATM.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Version de logiciel d'IOS Software du matériel de sites du client de Cisco SOHO77 (CPE) 12.1(3)XP2

  • Version de logiciel d'IOS Software du Cisco 6400 UAC-NRP 12.1(3)DC1

  • Version de logiciel d'IOS Software du Cisco 6400 UAC-NSP 12.1(3)DB

  • Version de logiciel d'IOS Software du Cisco 6130 DSLAM-NI2 12.1(5)DA

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/12925/soho77pppoe_client.gif

Configurations

Ce document utilise les configurations suivantes :

  • Cisco SOHO77

  • Cisco 6400

Le PPPoE est configuré sur Cisco SOHO77 avec des commandes de Réseau privé virtuel à accès commuté (VPDN). Veillez-vous pour configurer ces commandes d'abord.

Cisco SOHO77
! 
vpdn enable 
no vpdn logging

!--- Default.

! 
vpdn-group pppoe 
 request-dialin     
 
!--- The PPPoE client requests a session with the aggregation unit (6400 NRP).

  protocol pppoe 
! 


!--- Internal Ethernet network. 

! 
interface Ethernet0 
 ip address 10.92.1.182 255.255.255.0 
 ip nat inside 
  


!--- DSL interface. 

! 
interface ATM0 
 no ip address 
 no atm ilmi-keepalive
 bundle-enable
 dsl operating-mode auto
 hold-queue 224 in
 !--- all defaults
  


!--- PPPoE runs on top of AAL5SNAP, but the encap aal5snap command is not used.  

! 
interface ATM0.1 point-to-point 
 pvc 1/1 
  pppoe-client dial-pool-number 1 
  
!--- pvc 1/1 is an example value that you must change to match the value 
  !--- used by the Internet Service Provider (ISP). 

 ! 


!--- The PPPoE client code ties into a dialer interface, upon  
!--- which a virtual-access interface is cloned.  

! 
interface Dialer1 
 ip address negotiated 
 ip mtu 1492
 
!--- Ethernet MTU is 1500 by default. In other words, 1492 + PPPoE headers = 1500.

 ip nat outside 
 encapsulation ppp 
 dialer pool 1
 
!--- Ties to ATM interface.  

 ppp authentication chap callin 
 ppp chap hostname <hostname>
 ppp chap password <password>
! 

!--- The ISP instructs you about the type of authentication to use. 
!--- To change from PPP CHAP to PPP PAP, replace the following three lines:             
!--- ppp authentication chap callin 
!--- ppp chap hostname <hostname>
!--- ppp chap password <password>
!--- with the following two lines:
!--- ppp authentication pap callin
!--- ppp pap sent-username <username> password <password>
!--- For NAT we are going to overload on the Dialer1 interface 
!--- Then add a default route out since dialer IP address can change.  
 
ip nat inside source list 1 interface Dialer1 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 dialer1 
no ip http server 
! 
access-list 1 permit 10.92.1.0 0.0.0.255

!--- For NAT.

! 

Cisco 6400
*** local ppp user 

!--- You can also use AAA.


username <username> password <password>



!--- Begin with the VPDN commands.
!--- Note the PPPoE binding to a virtual-template instead of on the ATM interface. 
!--- You cannot (at this time) use more than one virtual-template (or VPDN group) 
!--- for PPPoE beginning with the VPDN commands. 

vpdn enable 
no vpdn logging 
! 
vpdn-group pppoe 
 accept-dialin
 
!--- PPPoE server mode. 

  protocol pppoe 
  virtual-template 1 
! 
! 
interface ATM0/0/0 
 no ip address 
 no atm ilmi-keepalive 
 hold-queue 500 in 



!--- The binding to the virtual-template interface is configured in the VPDN group.     

! 
interface ATM0/0/0.182 point-to-point 
 pvc 1/82 
  encapsulation aal5snap
  
!--- The command is needed on the server side. 

  protocol pppoe 
 ! 
! 



!--- Virtual-template is used instead of dialer interface. 

! 
interface Virtual-Template1 
 ip unnumbered Loopback10 
 ip mtu 1492 
 peer default ip address pool ippool 
 ppp authentication chap 
! 
! 
interface Loopback10 
 ip address 8.8.8.1 255.255.255.0 
! 
ip local pool ippool 9.9.9.1 9.9.9.5 

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Cette section fournit des informations que vous pouvez employer pour dépanner et mettre au point votre configuration.

Pour mettre au point le PPPoE Client sur Cisco SOHO77 ou Cisco 6400, vous devez considérer la pile de protocoles. Dépannez le début à la couche de protocole inférieure.

  1. Couche physique DSL

  2. Couche atmosphère

  3. Couche Ethernet

  4. Couche de PPP

Couche physique DSL

Assurez-vous que la ligne est en hausse et exercée.

Sélectionnez les commandes show comme indiqué dans cet exemple. La sortie résultante indique le statut de la ligne.

show int atm0 

ATM0 is up, line protocol is up 
  Hardware is PQUICC_SAR (with Alcatel ADSL Module) 
 
show dsl interface atm0 

!--- Look for "Showtime" in the first few lines.


                ATU-R (DS)                      ATU-C (US) 
Modem Status:   Showtime (DMTDSL_SHOWTIME) 

Couche atmosphère

Si l'interface ATM est en hausse, vous pouvez utiliser les paquets atmosphère de débogage commandez de voir si quelque chose entre de l'ISP.

Remarque: Vous ne verrez pas que des paquets sortants avec cette commande en raison de la manière les paquets sont traités.

Entrez dans les paquets atmosphère de débogage commandent suivant les indications de cet exemple.

debug atm packet 
03:21:32: ATM0(I): 
VCD:0x2 VPI:0x1 VCI:0x1 Type:0x0 SAP:AAAA CTL:03 OUI:0080C2 TYPE:0007 
Length:0x30 
03:21:32: 0000 0050 7359 35B7 0001 96A4 84AC 8864 1100 0001 000E C021 09AB 
000C 0235 
03:21:32: 279F 0000 0000 
03:21:32:

La sortie comme affichée ci-dessus, doit contenir les mêmes champs de type, de SAP, CTL, et OUI pour indiquer que le paquet ATM entrant est AAL5SNAP.

Couche Ethernet

Les trames Ethernet complètes sont dans les paquets AAL5SNAP. Il y a aucun mettent au point la commande de paquet Ethernet, mais vous devez exécuter un certain VPDN mettez au point des exécutions pour visualiser les trames de PPPoE.

Pour la référence, une trame Ethernet qui est une trame de PPPoE contient un de deux ethertypes :

  • 0x8863 Ethertype = paquet de contrôle de PPPoE (manipule la session de PPPoE).

  • 0x8864 Ethertype = paquet de données de PPPoE (contient des paquets PPP).

L'une information importante est qu'il y a deux sessions dans le PPPoE. La session de PPPoE qui est une session de type VPDN L2TP et la session PPP. Ainsi, pour établir le PPPoE nous avons une phase d'établissement de session de PPPoE et une phase d'établissement de session PPP.

L'arrêt implique habituellement une phase de terminaison de PPP et une phase de terminaison de PPPoE.

La phase d'établissement de PPPoE se compose de deux étapes :

  • Étape 1 : Identifiez le PPPoE Client et le serveur (les adresses MAC).

  • Étape 2 : Assignez un ID de session.

Après que ce soit complet, l'établissement normal de PPP se produit juste comme n'importe quelle autre connexion PPP.

Pour mettre au point, le PPPoE de l'utilisation VPDN met au point pour déterminer si le PPPoE connectent la phase est réussi.

  1. Sélectionnez une commande de débogage suivant les indications de cet exemple :

    #debug vpdn pppoe-events
    
    06:17:58: Sending PADI: vc=1/1
    
    !--- A broadcast Ethernet frame (here, encapsulated in ATM) requests 
    !--- a PPPoE server with the message, "Is there a PPPoE server out there?" 
    
    
    06:18:00:  PPPOE: we have got our pado, and the pado timer went off 
    
    !--- This is a unicast reply from a PPPoE server (similar to a DHCP offer).
    
    
    06:18:00: OUT PADR from PPPoE tunnel
    
    !--- This is a unicast reply to accept the offer.
    
    
    06:18:00: IN PADS from PPPoE tunnel
    
    !--- This is a confirmation that completes the establishment.
    
    
  2. Initiez la connexion PPP. L'établissement de PPP commencera maintenant comme dans n'importe quelle autre initiation de PPP. Après que la session de PPPoE soit établie, vous pouvez utiliser des commandes de show vpdn d'obtenir l'état, comme affiché ici :

    #show vpdn
    %No active L2TP tunnels 
    %No active L2F tunnels 
    
    PPPoE Tunnel and Session Information Total tunnels 1 sessions 1
    
    PPPoE Tunnel Information
    
    Session count: 1
    
    PPPoE Session Information
    SID        RemMAC          LocMAC       Intf    VASt   OIntf    VC 
    1       0050.7359.35b7  0001.96a4.84ac  Vi1     UP     AT0     1       1
  3. Obtenez les informations de compte de paquets avec le show vpdn session toute la commande, comme affiché ici :

    show vpdn session all
    %No active L2TP tunnels
    %No active L2F tunnels
    
    PPPoE Session Information Total tunnels 1 sessions 1
    
    session id: 1
    local MAC address: 0001.96a4.84ac, remote MAC address: 0050.7359.35b7 
    virtual access interface: Vi1, outgoing interface: AT0, vc: 1/1 
        1656 packets sent, 1655 received, 24516 bytes sent, 24486 received

    D'autres commandes de débogage potentiellement utiles incluent des debug vpdn pppoe-data, mettent au point des PPPoE-erreurs, et mettent au point des PPPoE-paquets.

Couche de PPP

Après que la session de PPPoE ait été établie, le PPP met au point sont identique que pour n'importe quel autre établissement de PPP. Le mêmes debug ppp negotiation et commandes de debug ppp authentication sont utilisés.

Remarque: Dans l'échantillon suivant, l'adresse Internet est "client1" et le nom du Cisco 6400 distant est « nrp-b ».

Lancez la négociation PPP ou l'authentification de PPP de la ligne de commande. La sortie résultante ressemblera à ceci :

06:36:03: Vi1 PPP: Treating connection as a callout
06:36:03: Vi1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]
06:36:03: Vi1 PPP: No remote authentication for call-out
06:36:03: Vi1 LCP: O CONFREQ [Closed] id 1 len 10
06:36:03: Vi1 LCP:    MagicNumber 0x03013D43 (0x050603013D43) 
06:36:03: Vi1 LCP: I CONFACK [REQsent] id 1 len 10
06:36:03: Vi1 LCP:    MagicNumber 0x03013D43 (0x050603013D43) 
06:36:05: Vi1 LCP: I CONFREQ [ACKrcvd] id 2 len 15
06:36:05: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
06:36:05: Vi1 LCP:    MagicNumber 0x65E315E5 (0x050665E315E5) 
06:36:05: Vi1 LCP: O CONFACK [ACKrcvd] id 2 len 15
06:36:05: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
06:36:05: Vi1 LCP:    MagicNumber 0x65E315E5 (0x050665E315E5) 
06:36:05: Vi1 LCP: State is Open
06:36:05: Vi1 PPP: Phase is AUTHENTICATING, by the peer [0 sess, 1 load]
06:36:05: Vi1 CHAP: I CHALLENGE id 9 len 26 from "nrp-b" 
06:36:05: Vi1 CHAP: Using alternate hostname client1
06:36:05: Vi1 CHAP: Username nrp-b not found
06:36:05: Vi1 CHAP: Using default password
06:36:05: Vi1 CHAP: O RESPONSE id 9 len 28 from "client1"
06:36:05: Vi1 CHAP: I SUCCESS id 9 len 4
06:36:05: Vi1 PPP: Phase is FORWARDING [0 sess, 1 load]
06:36:05: Vi1 PPP: Phase is AUTHENTICATING [0 sess, 1 load]
06:36:05: Vi1 PPP: Phase is UP [0 sess, 1 load]
06:36:05: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10
06:36:05: Vi1 IPCP:    Address 0.0.0.0 (0x030600000000)
06:36:05: Vi1 CDPCP: O CONFREQ [Closed] id 1 len 4
06:36:05: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 10
06:36:05: Vi1 IPCP:    Address 8.8.8.1 (0x030608080801)
06:36:05: Vi1 IPCP:    Address 8.8.8.1 (0x030608080801)
06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 IPCP: O CONFREQ [ACKsent] id 2 len 10
06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 LCP: I PROTREJ [Open] id 3 len 10 protocol 
CDPCP (0x820701010004) 
06:36:05: Vi1 CDPCP: State is Closed
06:36:05: Vi1 IPCP: I CONFACK [ACKsent] id 2 len 10
06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
06:36:05: Vi1 IPCP: State is Open
06:36:05: Di1 IPCP: Install negotiated IP interface address 9.9.9.2
06:36:05: Di1 IPCP: Install route to 8.8.8.1
06:36:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, 
changed state to up

Debug

Pour mettre au point le Cisco 6400 (le serveur de PPPoE), vous pouvez utiliser la même procédure d'approche par le bas utilisée pour Cisco SOHO77 (le client). La différence est dans la couche physique DSL, où vous devez vérifier le DSLAM.

  1. Couche physique DSL

  2. Couche atmosphère

  3. Couche Ethernet

  4. Couche de PPP

Couche physique DSL

Pour vérifier la couche physique DSL, vous devez voir les statistiques DSL sur le DSLAM. Pour des DSLAM Cisco, utilisez la commande d'interface de l'exposition DSL.

Couche atmosphère

Du côté de Cisco 6400, vous pouvez également utiliser une commande de paquet atmosphère de débogage, et activez le Cisco 6400 pour un PVC de particularité.

Enter mettent au point le paquet atmosphère avec des paramètres appropriés de la ligne de commande, comme suit :

debug atm packet interface atm 0/0/0.182 vc 1/82

La sortie résultante ressemble à ceci :

4d04h: ATM0/0/0.182(I):
VCD:0x3 VPI:0x1 VCI:0x52 Type:0x900 SAP:AAAA CTL:03 OUI:0080C2 TYPE:0007 Length:0x30
4d04h: 0000 0001 96A4 84AC 0050 7359 35B7 8864 1100 0001 000E C021 0A2E 000C 65E3
4d04h: 15E5 0000 0000

Remarque: Vous ne verrez pas que des paquets sortants avec cette commande en raison de la manière les paquets sont traités.

Couche Ethernet

Les mêmes commandes show VPDN et met au point utilisé sur Cisco SOHO77 peuvent être utilisées sur le Cisco 6400 pour regarder l'établissement de PPPoE.

Les échantillons suivants illustrent des commandes d'exposition et de débogage dans le contexte, avec leur sortie. Utilisez ces commandes au besoin.

#debug vpdn pppoe-events

4d04h: IN PADI from PPPoE tunnel

4d04h: OUT PADO from PPPoE tunnel

4d04h: IN PADR from PPPoE tunnel

4d04h: PPPoE: Create session
4d04h: PPPoE: VPN session created.

4d04h: OUT PADS from PPPoE tunnel

#show vpdn
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Tunnel Information

Session count: 1
PPPoE Session Information
SID        RemMAC          LocMAC       Intf    VASt   OIntf    VC
1       0001.96a4.84ac  0050.7359.35b7  Vi4     UP     AT0/0/0 1    82



#show vpdn session all


nrp-b#show vpdn session all
%No active L2TP tunnels
%No active L2F tunnels

PPPoE Session Information Total tunnels 1 sessions 1
 
session id: 1
local MAC address: 0050.7359.35b7, remote MAC address: 0001.96a4.84ac
virtual access interface: Vi4, outgoing interface: AT0/0/0, vc: 1/82
    30 packets sent, 28 received, 422 bytes sent, 395 received

D'autres commandes de débogage incluent des debug vpdn pppoe-data, mettent au point des PPPoE-erreurs, et mettent au point des PPPoE-paquets.

Couche de PPP

Être suit sortie de débogage de PPP du Cisco 6400 qui correspond au plus tôt mettent au point de Cisco SOHO77.

Sélectionnez cette commande de l'interface de ligne de commande :

debug ppp negotiation and debug ppp authentication

La sortie résultante ressemble à ceci :

4d04h: Vi2 PPP: Treating connection as a dedicated line 
4d04h: Vi2 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load] 
4d04h: Vi2 LCP: O CONFREQ [Closed] id 1 len 15 
4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: I CONFREQ [REQsent] id 1 len 10 
4d04h: Vi2 LCP:    MagicNumber 0x03144FF9 (0x050603144FF9) 
4d04h: Vi2 LCP: O CONFACK [REQsent] id 1 len 10 
4d04h: Vi2 LCP:    MagicNumber 0x03144FF9 (0x050603144FF9) 
4d04h: Vi3 LCP: I ECHOREQ [Open] id 60 len 8 magic 0xA60C0000 
4d04h: Vi3 LCP: O ECHOREP [Open] id 60 len 8 magic 0x51A0BEF6 
4d04h: Vi2 LCP: TIMEout: State ACKsent 
4d04h: Vi2 LCP: O CONFREQ [ACKsent] id 2 len 15 
4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: I CONFACK [ACKsent] id 2 len 15 
4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 
4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 
4d04h: Vi2 LCP: State is Open 
4d04h: Vi2 PPP: Phase is AUTHENTICATING, by this end [0 sess, 1 load] 
4d04h: Vi2 CHAP: O CHALLENGE id 10 len 26 from "nrp-b" 
4d04h: Vi2 CHAP: I RESPONSE id 10 len 28 from "client1" 
4d04h: Vi2 PPP: Phase is FORWARDING [0 sess, 1 load] 
4d04h: Vi2 PPP: Phase is AUTHENTICATING [0 sess, 1 load] 
4d04h: Vi2 CHAP: O SUCCESS id 10 len 4 
4d04h: Vi2 PPP: Phase is UP [0 sess, 1 load] 
4d04h: Vi2 IPCP: O CONFREQ [Closed] id 1 len 10 
4d04h: Vi2 IPCP:    Address 8.8.8.1 (0x030608080801) 
4d04h: Vi2 IPCP: I CONFREQ [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:    Address 0.0.0.0 (0x030600000000) 
4d04h: Vi2 IPCP: Pool returned 9.9.9.2 
4d04h: Vi2 IPCP: O CONFNAK [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 CDPCP: I CONFREQ [Not negotiated] id 1 len 4 
4d04h: Vi2 LCP: O PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 
4d04h: Vi2 IPCP: I CONFACK [REQsent] id 1 len 10 
4d04h: Vi2 IPCP:    Address 8.8.8.1 (0x030608080801) 
4d04h: Vi2 IPCP: I CONFREQ [ACKrcvd] id 2 len 10 
4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 IPCP: O CONFACK [ACKrcvd] id 2 len 10 
4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 
4d04h: Vi2 IPCP: State is Open 
4d04h: Vi2 IPCP: Install route to 9.9.9.2 
4d04h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2,
changed state to up 

Informations connexes


Document ID: 12925