Commutateurs : Cisco 6130 IP DSL Switch

Configuration d'un routeur Cisco 827 avec une adresse IP unique, DHCP et PPPoA

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (11 novembre 2015) | Commentaires


Contenu


Introduction

Cette configuration d'échantillon affiche un routeur de la ligne d'abonné numérique de Cisco 827 (DSL) se connectant à un multiplexeur d'accès de ligne d'abonné numérique de Cisco 6130 (DSLAM) et se terminant sur un concentrateur d'accès universel de Cisco 6400 (UAC). Le routeur de Cisco 827 a été configuré en tant que serveur du protocole DHCP (DHCP) avec le protocole point-à-point au-dessus de l'atmosphère (PPPoA).

Avant de commencer

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Conditions préalables

Aucune condition préalable spécifique n'est requise pour ce document.

Composants utilisés

Les informations dans ce document sont basées sur les versions de logiciel et de matériel ci-dessous.

  • Version de logiciel 12.1(1)XB de ½ du ¿  du matériel de sites du client de Cisco 827-4V (CPE) IOSïÂ

  • Version de logiciel d'IOS Software du processeur d'artère d'UAC-noeud de Cisco 6400 (NRP) 12.0(7)DC

  • Version de logiciel d'IOS Software du processeur de commutateur d'UAC-noeud de Cisco 6400 (NSP) 12.0(4)DB

  • Version de logiciel d'IOS Software du Cisco 6130 DSLAM-NI2 12.1(1)DA

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Informations générales

Dans ce cas, le fournisseur de services Internet (ISP) a donné à l'abonné une adresse IP simple (172.18.0.1) pour la connexion Internet, mais l'abonné a un petit réseau des PC et veut avoir l'accès Internet pour tous les périphériques.

La solution affichée ici implémente le Traduction d'adresses de réseau (NAT) sur le routeur de Cisco 827. NAT est conçu pour la simplification et l'économie d'adresse IP ; il active les interréseaux privés IP qui emploient les adresses IP nonregistered pour se connecter à l'Internet. NAT traite un routeur, habituellement connectant deux réseaux, et traduit (dans ce cas les adresses privées du réseau de 10.0.0.0) dans le réseau interne (dans ce cas, 172.18.0.1) aux adresses juridiques avant que des paquets soient expédiés à un autre réseau. En tant qu'élément de cette fonctionnalité, NAT peut être configuré pour annoncer seulement une adresse (172.18.0.1) pour le tout le réseau. Ceci fournit la Sécurité supplémentaire, masquant efficacement le réseau interne entier derrière une adresse IP simple.

NAT atteint les doubles objectifs de la Sécurité et de la conservation d'adresses, et est typiquement mis en application dans des environnements d'Accès à distance. Dans cet exemple, une adresse IP de 10.0.0.1 est manuellement configurée sur l'interface Ethernet du routeur de Cisco 827. Le routeur de Cisco 827 est configuré pour agir en tant que serveur DHCP, et loue des adresses IP aux périphériques LAN locaux reliés à son réseau Ethernet.

La configuration suivante affiche NAT configuré pour les Ethernets et les interfaces ATM. L'interface Ethernet (indiquée Ethernet0 dans le schéma de réseau ci-dessous) a une adresse IP de 10.0.0.1, avec un masque de sous-réseau de 255.0.0.0. NAT est configuré pour à l'intérieur, ainsi il signifie que l'interface est connectée au réseau intérieur qui est sujet à la traduction NAT. L'interface ATM (indiquée Dialer0 dans le schéma de réseau ci-dessous) a une adresse IP de 172.18.0.1 et un masque de sous-réseau de 255.255.0.0. NAT sur Dialer0 est configuré pour dehors, ainsi il signifie que l'interface est connectée à un réseau extérieur tel que l'Internet. Pour plus d'informations sur l'architecture asynchrone de bout en bout de PPPoA de la ligne d'abonné numérique (ADSL), référez-vous à l'architecture de référence de PPPoA.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

/image/gif/paws/12880/827dhcp_1ip2.gif

Configuration

Ce document utilise la configuration illustrée ci-dessous.

Routeur de Cisco 827
! 
version 12.1
service timestamps debug datetime msec 
service timestamps datetime msec 
! 
hostname R1 
! 
ip subnet-zero 
! 
ip dhcp excluded-address 10.0.0.1

!--- The DHCP pool does not lease this address; 
!--- it is used by interface E0.

!
ip dhcp pool <pool name>
network 10.0.0.0 255.0.0.0
 default-router 10.0.0.1

!--- The default gateway is assigned to local devices.

! 
interface Ethernet0 
 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 ip nat inside
 no ip mroute-cache
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive
 pvc 1/150 
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 !
 hold-queue 224 in 
! 
interface Dialer0 
  ip address 172.18.0.1 255.255.0.0    
  ip nat outside     
  no ip directed-broadcast 
  encapsulation ppp 
  dialer pool 1 
  dialer-group 2 
  ppp pap sent-username <username> password <password>
! 
ip nat inside source list 1  interface Dialer0 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 Dialer0 
no ip http server 
! 
access-list 1 permit 10.0.0.0 0.255.255.255 
dialer-list 2 protocol ip permit
! 
voice-port 1 
 timing hookflash-in 0
!
voice-port 2
 timing hookflash-in 0 
! 
voice-port 3
 timing hookflash-in 0 
!
voice-port 4 
 timing hookflash-in 0 
! 
end

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.


Informations connexes


Document ID: 12880