Ethernet longue portée (LRE) et ligne numérique d'abonné (xDSL) : Ligne d'abonné numérique à débit asymétrique (ADSL)

Exemples de configuration de l'agrégation large bande pour Cisco 7200

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (9 novembre 2015) | Commentaires


Contenu


Introduction

Ce document présente une description générale des composantes de la ligne d'abonné numérique (DSL) et de leur façon de s'intégrer à la mise en place d'une DSL de base. Les exemples de configurations présentées dans ce document montrent les réseaux DSL les plus fréquemment utilisés actuellement. Vous pouvez vous référer à ces configurations afin de concevoir la mise en place d'une agrégation de bande passante. Cependant, ces configurations ne doivent pas être considérées comme des solutions permettant d'éviter les cookies. Chaque client et chaque exigence sont différents et il existe plusieurs façons d'atteindre les mêmes objectifs de conception.

Tandis que les configurations dans ce document sont aussi complètes comme possible, le document donne seulement les lignes essentielles. Le document suppose que l'utilisateur a une compréhension de base de configuration de périphérique Cisco et omet plusieurs des lignes de commande de base. Employez ces configurations seulement comme un point de début pour concevoir votre propre implémentation.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Fermeture de session PPPoA : xDSL à 7200

Diagramme du réseau

Cette section utilise cette configuration du réseau :

7200_bdaggreg1.gif

Configurations

Cet exemple décrit comment connecter Cisco 677, ou toute autre CPE DSL (CPE), à un Cisco 7200 par l'intermédiaire du PPP au-dessus de l'atmosphère (PPPoA). La configuration inclut un commutateur ATM de Cisco Lightstream 1010 (LS1010), qui est un composant facultatif. Les résultats sont identiques si vous connectez directement le multiplicateur d'accès DSL (DSLAM) au Cisco 7200.

Dans cet exemple, vous établissez la session PPP sur Cisco 677 et vous terminez sur le Cisco 7200. Après l'arrêt de la session, les passages traditionnels IP trafiquent au fournisseur de service réseau (NSP) ou à l'Internet.

Le CPE a une configuration pour exécuter la traduction d'adresses du Traduction d'adresses de réseau (NAT) /Port (PAT). Le CPE implémente également un serveur DHCP pour assigner des adresses IP aux stations Ethernet.

Cette section utilise ces configurations :

Configuration de PC pour PPPoA
  1. Placez l'adressage IP pour obtenir automatiquement une adresse IP.
  2. Définissez WINS pour utiliser DHCP pour la résolution de WINS.
  3. Assurez-vous qu'aucune passerelle par défaut n'est placée.

Remarque: Si le DHCP ne peut pas passer ces informations, vous devez placer un nom de domaine.

Configuration de Cisco CPE pour PPPoA
cbos> enable
Password:

cbos# set nat enable
NAT is now enabled
You must use "write" then reboot for changes to take effect.

cbos# set ppp wan0-0 login 
User name for wan0-0 has been set to testcpe.

cbos# set ppp wan0-0 password 
Password for wan0-0 has been set to cisco.

cbos# set ppp wan0-0 ipcp 0.0.0.0
PPP wan0-0 IPCP Address set to 0.0.0.0

cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# set int eth0 address 172.22.10.254
eth0 ip address changed from 10.0.0.1 to 172.22.10.254

cbos# set int eth0 netmask 255.255.255.0
eth0 netmask changed from 255.255.255.0 to 255.255.255.0

cbos# set dhcp server enable
DHCP Server enabled

cbos# set dhcp server pool 0 ip 172.22.10.0
Pool 0 IP parameter is now 172.22.10.0

cbos# set dhcp server pool 0 netmask 255.255.255.0
Pool 0 netmask parameter is now 255.255.255.0

cbos# set dhcp server pool 0 gateway 172.22.10.254
Pool 0 gateway parameter is now 172.22.10.254

cbos# set password exec 
Exec Password Change Successful! 

cbos# set password enable 
Enable Password Change Successful! 

cbos# write
NVRAM written.

Configuration de DSLAM Cisco pour PPPoA
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 atm pvc 1 32 interface atm0/1 1 35

Configuration de Cisco LS1010 pour PPPoA
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Configuration de Cisco 7200 pour PPPoA
aaa new-model
AAA authentication ppp default local
!
!
username password 
!
!
interface ATM 2/0.1 multipoint
 no ip directed-broadcast
 PVC 1/35 
  encapsulation aal5mux ppp Virtual-Template 2
!
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template 2
 ip unnumbered FastEthernet 4/0
 no ip directed-broadcast
 peer default ip address pool <pool name>
 ppp authentication pap
!
!
ip local pool <pool name> 172.22.40.10 172.22.40.25

Pontage RFC1483 : xDSL à 7200

Diagramme du réseau

Cette section utilise cette configuration du réseau :

7200_bdaggreg2.gif

Configurations

Cet exemple décrit comment connecter Cisco 677, ou l'autre CPE DSL, à un Cisco 7200 par l'intermédiaire de RFC 1483 a jeté un pont sur l'encapsulation. Cette configuration inclut un commutateur ATM de Cisco LS1010, qui est un composant facultatif. Les résultats sont identiques si vous connectez directement le DSLAM au Cisco 7200.

Dans cet exemple, vous établissez la session traversière sur Cisco 677 et vous terminez sur le Cisco 7200. Après les passerelles de session au Cisco 7200, les passages traditionnels IP trafiquent au NSP ou à l'Internet. Un serveur DHCP avec la configuration dans les 7200 assigne une adresse IP au poste de travail de client.

Cette configuration utilise le Routage et mise en parallèle intégrés (IRB). Pour dissiper l'évolutivité et les problèmes de sécurité avec IRB, considérez l'encapsulation traversière conduite (RBE).

Cette section utilise ces configurations :

Configuration de PC pour le RFC 1483
  1. Placez l'adressage IP pour obtenir automatiquement une adresse IP.
  2. Définissez WINS pour utiliser DHCP pour la résolution de WINS.
  3. Assurez-vous qu'aucune passerelle par défaut n'est placée.

Remarque: Si le DHCP ne peut pas passer ces informations, vous devez placer un nom de domaine.

Configuration CPE de Cisco 677 pour le RFC 1483
cbos# set bridging rfc1483 enabled

!--- Use write, then reboot for the changes to take effect.


cbos# set bridging management enable

cbos# set int eth0 address 172.22.40.25

!--- You use this IP address for management purposes only.


cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# write
NVRAM written.

cbos# reboot

Configuration de DSLAM Cisco pour le RFC 1483
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 ATM PVC 1 32 interface atm0/1 1 35

Configuration de Cisco LS1010 pour le RFC 1483
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Configuration de Cisco 7200 pour le RFC 1483
ip dhcp excluded-address 172.22.40.1 172.22.40.25
!
!
ip dhcp pool 0
   network 172.22.40.0 255.255.255.0
   default-router 172.22.40.9 
   dns-server  
   netbios-name-server 
!         
!
bridge irb
!
!
interface ATM 2/0
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
!
!
interface ATM 2/0.1 point-to-point
 no ip directed-broadcast
 PVC 1/35 
  encapsulation aal5snap
 bridge-group 1
!
!
interface ATM 2/0.2 point-to-point
 no ip directed-broadcast
 PVC 1/36 
  encapsulation aal5snap
 bridge-group 1!
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface BVI 1
 ip address 172.22.40.9 255.255.255.0
 no ip directed-broadcast
!
!
bridge 1 protocol ieee
 bridge 1 route ip

RBE : xDSL à 7200

Diagramme du réseau

Cette section utilise cette configuration du réseau :

7200_bdaggreg2.gif

Configurations

RBE est actuellement la configuration du choix pour la plupart des nouvelles installations DSL. RBE aborde la Sécurité et les problèmes d'évolutivité de la transition dans l'environnement d'abonné haut débit.

Un serveur DHCP avec la configuration dans les 7200 assigne une adresse IP au poste de travail de client.

Important : Le DHCP ne peut pas fonctionner sur le routeur avec l'atmosphère non-numérotée à moins que quand vous utilisez la version de logiciel 12.1(2)T ou ultérieures de ½ du ¿  de Cisco IOSïÂ.

Cette section utilise ces configurations :

Configuration de PC pour RBE
  1. Placez l'adressage IP pour obtenir automatiquement une adresse IP.
  2. Définissez WINS pour utiliser DHCP pour la résolution de WINS.
  3. Assurez-vous qu'aucune passerelle par défaut n'est placée.

Remarque: Si le DHCP ne peut pas passer ces informations, vous devez placer un nom de domaine.

Configuration de Cisco CPE pour RBE
cbos# set bridging rfc1483 enabled

!--- Use write, then reboot for the changes to take effect.


cbos# set bridging management enable

cbos# set int eth0 address 172.22.40.25

!--- You use this IP address for management purposes only.


cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# write
NVRAM written.

cbos# reboot

Configuration de DSLAM Cisco pour RBE
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 ATM PVC 1 32 interface atm0/1 1 35

Configuration de Cisco LS1010 pour RBE
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Configuration de Cisco 7200 pour RBE
ip dhcp excluded-address 172.22.40.1 172.22.40.25
!
!
ip dhcp pool 0
   network 172.22.40.0 255.255.255.0
   default-router 172.22.40.9 
   dns-server  
   netbios-name-server 
!
!
interface Loopback0
 ip address 172.22.40.9 255.255.255.0
!
!
interface ATM 2/0
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
!
!
interface ATM 2/0.1 point-to-point
 ip unnumbered Loopback0
 no ip directed-broadcast
 ATM route-bridged ip
 PVC 1/35 
  encapsulation aal5snap
!
!
interface ATM 2/0.2 point-to-point
 ip unnumbered Loopback0
 no ip directed-broadcast
 ATM route-bridged ip
 PVC 1/36 
  encapsulation aal5snap
!
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!

PPPoE : xDSL à 7200

Diagramme du réseau

Cette section utilise cette configuration du réseau :

7200_bdaggreg3.gif

Configurations

Le PPP au-dessus des Ethernets (PPPoE) étend la session PPP du routeur au client d'extrémité. Le logiciel de PPP et d'authentification fonctionnent habituellement sur le client dans le système d'exploitation ou dans une application autonome. Le CPE agit en jetant un pont sur le mode pour jeter un pont sur la session PPP au-dessus de la connexion DSL. Mais le CPE ne peut pas agir en tant que serveur DHCP dans ce scénario.

Les configurations pour le CPE, le DSLAM, et le commutateur ATM sont identiques que les configurations pour la transition RFC 1483. Vous pouvez configurer le routeur d'agrégation de Cisco 7200 pour l'authentification locale, comme indiqué dans cet exemple. Ou vous pouvez configurer les 7200 avec l'authentification de RAYON d'Authentification, autorisation et comptabilité (AAA).

Cette section utilise ces configurations :

Configuration de PC pour le PPPoE
  1. Placez l'adressage IP pour obtenir automatiquement une adresse IP.
  2. Définissez WINS pour utiliser DHCP pour la résolution de WINS.
  3. Assurez-vous qu'aucune passerelle par défaut n'est placée.

Remarque: Si le DHCP ne peut pas passer ces informations, vous devez placer un nom de domaine.

Remarque: La station d'extrémité doit pouvoir établir une connexion PPP au routeur. Le logiciel client spécifique pour l'authentification et l'accès peut être nécessaire.

Configuration CPE de Cisco 677 pour le PPPoE
cbos# set bridging rfc1483 enabled

!--- Use write, then reboot for the changes to take effect.


cbos# set bridging management enable

cbos# set int eth0 address 172.22.40.25

!--- You use this IP address for management purposes only.


cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# write
NVRAM written.

cbos# reboot

Configuration de DSLAM Cisco pour le PPPoE
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 ATM PVC 1 32 interface atm0/1 1 35

Configuration de Cisco LS1010 pour le PPPoE
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Configuration de Cisco 7200 pour le PPPoE
!
username <username> password <password>
!
vpdn enable
!
vpdn-group 1
 accept-dialin
  protocol pppoe
  virtual-template 1
  pppoe limit per-mac 100
  pppoe limit per-vc 100
!
ip cef
!
interface atm2/0
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
!
!
interface ATM 2/0.1 point-to-point
 no ip directed-broadcast
 PVC 1/35 
  encapsulation aal5snap
  protocol pppoe
!
!
interface ATM 2/0.2 point-to-point
 no ip directed-broadcast
 PVC 1/36 
  encapsulation aal5snap
  protocol pppoe
!
interface Virtual-Template1
 ip unnumbered FastEthernet 4/0
 no ip directed-broadcast
 peer default ip address pool <pool name>
 ppp authentication pap
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
ip local pool <pool name> 172.22.32.20 172.22.32.100

L2TP : xDSL à 7200 par l'intermédiaire de L2TP

Diagramme du réseau

Cette section utilise cette configuration du réseau :

7200_bdaggreg4.gif

Configurations

Le protocol (L2TP) de perçage d'un tunnel de la couche deux fournit des moyens de terminer la connexion PPP de l'utilisateur final à un emplacement et de transporter les paquets de données L2 à un autre emplacement. L2TP débarque une grande partie de la fonctionnalité IP du périphérique d'agrégation et permet des conceptions de réseaux plus centralisées. Un serveur de RAYON fournit l'AAA.

Les configurations pour tous les périphériques excepté le Cisco 7200 sont identiques que les configurations pour l'exemple RFC 1483.

Cette section utilise ces configurations :

Configuration de PC pour L2TP
  1. Placez l'adressage IP pour obtenir automatiquement une adresse IP.
  2. Définissez WINS pour utiliser DHCP pour la résolution de WINS.
  3. Assurez-vous qu'aucune passerelle par défaut n'est placée.

Remarque: Si le DHCP ne peut pas passer ces informations, vous devez placer un nom de domaine.

Configuration CPE de Cisco 677 pour L2TP
cbos> enable
Password:

cbos# set nat enable
NAT is now enabled
You must use "write" then reboot for changes to take effect.

cbos# set ppp wan0-0 login 
User name for wan0-0 has been set to testcpe.

cbos# set ppp wan0-0 password 
Password for wan0-0 has been set to cisco.

cbos# set ppp wan0-0 ipcp 0.0.0.0
PPP wan0-0 IPCP Address set to 0.0.0.0

cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# set int eth0 address 172.22.10.254
eth0 ip address changed from 10.0.0.1 to 172.22.10.254

cbos# set int eth0 netmask 255.255.255.0
eth0 netmask changed from 255.255.255.0 to 255.255.255.0

cbos# set dhcp server enable
DHCP Server enabled

cbos# set dhcp server pool 0 ip 172.22.10.0
Pool 0 IP parameter is now 172.22.10.0

cbos# set dhcp server pool 0 netmask 255.255.255.0
Pool 0 netmask parameter is now 255.255.255.0

cbos# set dhcp server pool 0 gateway 172.22.10.254
Pool 0 gateway parameter is now 172.22.10.254

cbos# set password exec 
Exec Password Change Successful! 

cbos# set password enable 
Enable Password Change Successful! 

cbos# write
NVRAM written.

Configuration de DSLAM Cisco pour L2TP
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 ATM PVC 1 32 interface atm0/1 1 35

Configuration de Cisco LS1010 pour L2TP
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Configuration LAC de Cisco 7200 pour L2TP
!
AAA new-model
AAA authentication login default none
AAA authentication ppp default local group radius
AAA authorization network default local group radius none
AAA accounting network default wait-start group radius
!  
vpdn-group 4
 request-dialin
  protocol l2tp
  domain cisco.com
 initiate-to ip 172.22.32.27 priority 1
 local name cisco-tunnel      
!
interface ATM 2/0
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
!
!
interface ATM 2/0.1 point-to-point
 no ip directed-broadcast
 PVC 1/35 
  encapsulation aal5mux ppp Virtual-Template1
!
!
interface ATM 2/0.2 point-to-point
 no ip directed-broadcast
 PVC 1/36 
  encapsulation aal5mux ppp Virtual-Template1
!
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template1
 ip unnumbered FastEthernet4/0
 no ip directed-broadcast
 ppp authentication pap
!
!
radius-server host 172.22.32.20 auth-port 1645 acct-port 1646
radius-server key cisco

Configuration du Cisco 7200 LNS pour L2TP
!
AAA new-model
AAA authentication login default none
AAA authentication ppp default local group radius
AAA authorization network default local group radius none
AAA accounting network default wait-start group radius
!
vpdn-group 1
 accept-dialin
  protocol any
  virtual-template 1
 terminate-from hostname cisco-tunnel
 local name tunnel-gate
!
radius-server host 172.22.32.20 auth-port 1645 acct-port 1646
radius-server key cisco

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.


Informations connexes


Document ID: 12868