Ethernet longue portée (LRE) et ligne numérique d'abonné (xDSL) : Ligne d'abonné numérique à débit asymétrique (ADSL)

Fermeture de session PPPoA en utilisant des routes statiques : xDSL vers un UAC Cisco 6400 en utilisant aal5ciscoppp

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (11 novembre 2015) | Commentaires


Contenu


Introduction

Cette configuration d'échantillon active un PC connecté à un routeur de Ligne d'abonné numérique à débit asymétrique (ADSL) de Cisco 677 pour se connecter par l'intermédiaire d'un multiplexeur d'accès de ligne d'abonné numérique avancé par Cisco 6130 (ADSLAM) à des concentrateurs simples ou plusieurs d'accès universel de Cisco (UAC). Le matériel spécifique que cette configuration utilise n'est pas exigé. Par exemple, vous pouvez remplacer Cisco 677 par Cisco 678.

Cette configuration d'échantillon a quelques caractéristiques activées sur Cisco 677 qui sont communes à un lancement ADSL. Ces caractéristiques sont Traduction d'adresses de réseau (NAT), translation d'adresses d'adresse du port (PAT), et protocole DHCP (DHCP). Ces caractéristiques tiennent compte d'un lancement de coupeur de Témoin. Puisque toutes les cases ont la même configuration, il y ont un coût réduit significatif pour le lancement et la documentation.

Vous pouvez copier et coller le code pour le processeur basé sur d'artère de noeud de ½ du ¿  de Cisco IOSï (NRP) et le processeur de commutateur de noeud (NSP) à vos configurations. Cependant, Cisco 677 utilise le système d'exploitation large bande de Cisco (CBOS) et vous ne pouvez pas copier et coller ce code. Les commandes que vous utilisez pour configurer Cisco 677 sont également incluses dans cette configuration d'échantillon.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

Matériel

  • PC ou poste de travail

  • CPE de Cisco 677 ADSL (CPE)

  • Service ADSL de votre compagnie de téléphone locale

  • Cisco 6130 ADSLAM avec NI-2, DMT-II ATU-C

  • UAC Cisco 6400 avec 1 x NRP et 1 NSP x

Logiciel

  • Version du logiciel Cisco IOS 12.0.7-DC pour l'UAC Cisco 6400 NRP

  • Version du logiciel Cisco IOS 12.0.7-DB pour le NSP d'UAC Cisco 6400

  • Release 2.3.0.012 CBOS pour le Routeur Cisco 677 ADSL

  • Version du logiciel Cisco IOS 12.0.8-DA1 pour le Cisco 6130 ADSLAM

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Dans cette section, vous êtes présenté avec les informations que vous pouvez employer pour configurer les caractéristiques décrites dans ce document.

Remarque: Afin de trouver les informations complémentaires sur les commandes utilisées dans ce document, référez-vous au Command Lookup Tool (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/12851/6400dsl_pppoa_stat.gif

Configurations

Notes de configuration

Vous devez configurer une connexion virtuelle permanente (PVC) sur le Cisco 6130 qui permet à l'abonné de test pour se connecter. Quand vous configurez le PVP sur le NSP et terminez la session PPP sur le NRP, la configuration d'identifiant de chemin virtuel/indentifiant de canal virtuel (VPI/VCI) doit être enregistrée sur le Cisco 6400.

Cette configuration d'échantillon affiche un chemin virtuel sur le NSP. Ce chemin permet au Cisco 6400 pour traverser les cellules de l'ADSLAM au routeur de terminaison, ou à un autre commutateur ATM. Voici que vous pouvez placer un PVP pour commuter les cellules atmosphère à un réseau d'entreprise ou un ISP sans arrêt de la session PPP au Cisco 6400 situé dans le bureau central.

Cette configuration d'échantillon permet à des utilisateurs distants l'accès transparent à leurs réseaux d'entreprise (s'ils sont connectés) pour le courrier électronique, au fichier partagé/à copie, à l'intranet d'entreprise, et à l'Internet pour la navigation web, et ainsi de suite. sans utilisation de la connexion Internet entreprise.

Quand plusieurs PVCs sont configurés sur Cisco 677, il est possible de conduire le trafic par l'intermédiaire de chaque PVC. La configuration de l'ADSLAM et des artères UAC-NSP/commute ces PVCs à la destination appropriée, à l'ISP/ASP ou à l'entreprise, où le PPP peut se terminer. Cette configuration réduit le trafic, et de ce fait augmente la bande passante disponible sur le réseau d'entreprise et emploie un compte ISP de courant afin de porter le trafic web.

Ce document utilise les configurations suivantes :

Configuration de PC
Placez l'adressage IP de sorte qu'il obtienne une adresse IP automatiquement. Placez les WINS de sorte qu'il utilise le DHCP pour la résolution de WINS. Assurez-vous qu'aucune passerelle par défaut n'est placée. Il peut être nécessaire de placer un nom de domaine parce que le DHCP ne peut pas passer ces informations.

CPE de Cisco 67x (exposition exécutée)
[[ IP Routing = Section Start ]]
IP NAT = enabled
IP Port Address = 00, 172.22.10.254
IP Default Route for Unnumbered Links = 002, 01, 0
IP Static Route Table Entries for Unnumbered Links = 172.22.32.0, 001, 255.255.2
55.0, 1, 0;
[[ CBOS = Section Start ]]
NSOS Maximum Number of VCs = 2
NSOS Root Password = <
root password
>
NSOS Enable Password = <
enable password
>
[[ PPP Device Driver = Section Start ]]
PPP Port User Name = 00, <
username for wan0-0
>
PPP Port User Password = 00, <
password for wan0-0
>
PPP Port User Name = 01, <
username for wan0-1
>
PPP Port User Password = 01, <
password for wan0-1
>
PPP Port Option = 01, IPCP,IP Address,3,Auto,Negotiation Not Required,Negotiable
,IP,0.0.0.0
[[ DHCP = Section Start ]]
DHCP Server = enabled
DHCP Server Pool IP = 00, 172.22.10.0
DHCP Server Pool Gateway = 00, 172.22.10.254
[[ ATM WAN Device Driver = Section Start ]]
ATM WAN Virtual Connection Parms = 00, 1, 32, 0
ATM WAN Virtual Connection Parms = 01, 2, 63, 0

Commandes de fournir à Cisco 67x le CPE
cbos#set nat enabled
NAT is now enabled
You must use "write" then reboot for changes to take effect.

cbos#set int wan0 maxvcs 2
You must use "write" and reboot for changes to take effect.

cbos#write
NVRAM written.

cbos#reboot
 Hello! Expanding CBOS image...
CBOS v2.3.5.012 - Release Software
User Access Verification
Password:<
root password
>

cbos>en
Password:<
enable password
>

cbos#set ppp wan0-0 login <username for wan0-0>
User name for wan0-0 has been set to router.

cbos#set ppp wan0-0 password <password for wan0-0>
Password for wan0-0 has been set to <password for wan0-0>

cbos#set ppp wan0-1 login <username for wan0-1>
Password for wan0-1 has been set to <username for wan0-1>

cbos#set ppp wan0-1 password <password for wan0-1>
Password for wan0-1 has been set to <password for wan0-1>

cbos#set ppp wan0-0 ipcp 0.0.0.0
PPP wan0-0 IPCP Address set to 0.0.0.0

cbos#set ppp wan0-1 ipcp 0.0.0.0
PPP wan0-1 IPCP Address set to 0.0.0.0

cbos#set int eth0 address 172.22.10.254
eth0 ip address changed from 10.0.0.1 to 172.22.10.254

cbos#set int eth0 netmask 255.255.255.0
eth0 netmask changed from 255.255.255.0 to 255.255.255.0
You must use "write" then reboot for changes to take effect

cbos#set dhcp server enable
DHCP Server enabled

cbos#set dhcp server pool 0 ip 172.22.10.0
Pool 0 IP parameter is now 172.22.10.0

cbos#set dhcp server pool 0 netmask 255.255.255.0
Pool 0 netmask parameter is now 255.255.255.0
Size of pool 0 is automatically changed to max size 252

cbos#set dhcp server pool 0 gateway 172.22.10.254
Pool 0 gateway parameter is now 172.22.10.254

cbos#set password exec <root password>
Exec Password Change Successful! 

cbos#set password enable <enable password>
Enable Password Change Successful! 

cbos#set route default wan0-1
Default Route set

cbos#set route add ip 172.22.32.0 mask 255.255.255.0 gw wan0-0
Route added
cbos#set int wan0-0 close
Closing connection wan0-0

cbos#set int wan0-1 close
Closing connection wan0-1

cbos#set int wan0-0 vpi 1
Change completed.

cbos#set int wan0-0 vc1 32
Change completed.

cbos#set int wan0-1 vpi 2
Change completed.

cbos#set int wan0-1 vci 63
Change completed.

cbos#set int wan0-0 open
Opening connection wan0-0

cbos#set int wan0-1 open
Opening connection wan0-1

cbos#write
NVRAM written

cbos#reboot

61xx ADSLAM
interface ATM 1/1
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc 1 32 int atm 0/1 40 40
 pvc 2 63 int atm 0/1 50 51

NSP 6400 (emplacement 8)
interface ATM 8/0/1
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 atm pvp 40 interface ATM 1/0/0 40
 atm pvp 50 interface ATM 2/0/0 50

6400 NRP (emplacement 1)
aaa new-model
aaa authentication ppp default local
!
!
username <username for wan0-0> password <password for wan0-0>
!
!
interface ATM 0/0/0.200 multipoint
 no ip directed-broadcast
 pvc 40/40 
  encapsulation aal5ciscoppp Virtual-Template 2
!
!
interface FastEthernet 0/0/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template 2
 ip unnumbered FastEthernet 0/0/0
 no ip directed-broadcast
 peer default ip address pool <pool name A>
 ppp authentication pap
!
!
ip local pool <pool name A> 172.22.40.25 172.22.40.50

6400 NRP (emplacement 2)
aaa new-model
aaa authentication ppp default local
!
!
username <username for wan0-1> password <password for wan0-1>
!
!
interface ATM 0/0/0.300 multipoint
 no ip directed-broadcast
 pvc 50/51 
  encapsulation aal5ciscoppp Virtual-Template 21
!
!
interface FastEthernet 0/0/0
 ip address 172.16.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template 21
 ip unnumbered FastEthernet 0/0/0
 no ip directed-broadcast
 peer default ip address pool <pool name B>
 ppp authentication pap
!
!
ip local pool <pool name B> 172.16.100.10 172.16.100.25

Vérifiez

Cette section fournit des informations qui vous permettront de vérifier que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Utilisez ces commandes sur la CPE Cisco 675 :

  • affichez l'interface wan0 — Les expositions se sont exercées vers le haut de la vitesse pour la liaison ADSL.

  • affichez l'interface wan0-0 — Les informations de session PPP d'expositions sur wan0-0.

  • affichez l'interface wan0-1 — Les informations de session PPP d'expositions sur wan0-1.

  • groupe 0 de serveur de show dhcp — Les informations DHCP d'expositions au site client.

Utilisez cette commande sur l'UAC Cisco 6400 :

  • show atm pvc — Affiche si le PVC correct est établi.

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Utilisez ces commandes sur l'UAC Cisco 6400 :

  • debug ppp negotiation — Messages de débogage de négociation PPP d'expositions.

  • debug ppp authentication — Affiche si un client passe l'authentification.

  • debug ppp error — Les erreurs de protocole et les statistiques sur les erreurs d'affichages ont associé avec la négociation et l'exécution de connexion PPP.

Avant que vous tentiez des commandes de débogage l'unes des, référez-vous aux informations importantes sur des commandes de debug.


Informations connexes


Document ID: 12851