Services de mise en réseau d'applications : Cisco LocalDirector de la gamme 400

Configuration de l'équilibrage de charge multinœud dans LocalDirector

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Cisco a annoncé la fin de la commercialisation de Cisco LocalDirector. Le pour en savoir plus, se rapportent aux bulletins de fin de commercialisation de gamme 400 de LocalDirector.


Contenu


Introduction

LocalDirector emploie l'architecture du serveur d'appareils de Cisco (MAISON) pour exister dans l'environnement de l'Équilibrage de charge de MultiNode (MNLB). Dans l'environnement MNLB, LocalDirector a une configuration de gestionnaire de services. Les Routeurs de Cisco ont des configurations de transitaire. Le gestionnaire de services détermine l'Équilibrage de charge pour les transitaires. Le gestionnaire de services base cette détermination sur les informations de vrais serveurs. Cette installation augmente l'efficacité et l'évolutivité de réseau, et ajoute également l'équilibrage application-averti.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Cette configuration a été développée et testée avec l'utilisation des ces le logiciel et les versions de matériel :

  • Version de logiciel 3.1.3 de LocalDirector

  • Version de logiciel 12.0 de ½ du ¿  de Cisco IOSïÂ

  • LocalDirector 430

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

config_mnlb-01.gif

Configurations

Ce document utilise les configurations suivantes :

Configuration de gestionnaire de services (LocalDirector)
: Saved

: LocalDirector 430 Version 3.1.3 
syslog output 20.3 
no syslog console 
hostname cisco-ld 
no shutdown ethernet 0 
shutdown ethernet 1 
shutdown ethernet 2 
no shutdown ethernet 3 
interface ethernet 0 100full 
interface ethernet 1 auto 
interface ethernet 2 auto 
interface ethernet 3 100full 
mtu 0 1500 
mtu 1 1500 
mtu 2 1500 
mtu 3 1500 
multiring all 
no secure 0 
no secure 1 
no secure 2 
no secure 3 
no ping-allow 0 
no ping-allow 1 
no ping-allow 2 
ping-allow 3 
ip address 172.16.9.25 255.255.255.0 
route 172.16.10.0 255.255.255.0 172.16.9.5 1 
route 172.16.8.7 255.255.255.255 172.16.9.7 1 
route 172.16.8.8 255.255.255.255 172.16.9.8 1 
route 0.0.0.0 0.0.0.0 172.16.9.1 1 
no rip passive 
failover ip address 172.16.9.26 
failover 
telnet 172.16.0.0 255.255.0.0 
virtual 10.10.10.100:0:0:tcp is 
virtual 10.10.10.110:0:0:tcp is 
redirection 10.10.10.100:0:0:
tcp dispatched casa wildcard-ttl 60 fixed-ttl 60 igmp 224.0.1.2 port 1637 
redirection 10.10.10.110:0:0:
tcp dispatched casa wildcard-ttl 60 fixed-ttl 60 igmp 224.0.1.2 port 1637 
real 172.16.10.3:0:0:tcp is 
real 172.16.10.4:0:0:tcp is 
real 172.16.10.5:0:0:tcp is 
real 172.16.10.6:0:0:tcp is 
bind 10.10.10.100:0:0:tcp 172.16.10.3:0:0:tcp 
bind 10.10.10.100:0:0:tcp 172.16.10.5:0:0:tcp 
bind 10.10.10.110:0:0:tcp 172.16.10.4:0:0:tcp 
bind 10.10.10.110:0:0:tcp 172.16.10.6:0:0:tcp 

Configuration de transitaire (routeur de Cisco)
Building configuration... 

Current configuration: 

! 
version 12.0 
service timestamps debug uptime 
service timestamps log uptime 
service password-encryption 
! 
hostname router-a 
! 
ip subnet-zero 
no ip domain-lookup 
! 
ip cef distributed 
ip casa 172.16.8.7 224.0.1.2 
 forwarding-agent 1637 
! 
! 
process-max-time 200 
! 
interface Channel0/0 
 description RD0713 DE10 SYSF 9910 SYSJ 
 ip address 172.16.10.1 255.255.255.0 
 ip directed-broadcast 
 ip route-cache same-interface 
 no keepalive 
 claw DD10 00 172.16.10.3 TCPIP CIPTCP TCPIP TCPIP 
 claw DE10 00 172.16.10.5 TCPIP CIPTCP TCPIP TCPIP 
 claw DF10 00 172.16.10.4 TCPIP CIPTCP TCPIP TCPIP 
 claw DG20 00 172.16.10.6 TCPIP CIPTCP TCPIP TCPIP 
! 
interface Channel0/2 
 no ip address 
 no ip directed-broadcast 
 no keepalive 
 shutdown 
! 
interface FastEthernet1/0/0 
 ip address 172.16.9.7 255.255.255.0 
 no ip redirects 
 no ip directed-broadcast 
 ip route-cache flow 
 no ip route-cache distributed 
 ip igmp join-group 224.0.1.2 
 no ip mroute-cache 
 full-duplex 
 no mop enabled 
 standby use-bia 
 standby priority 105 preempt 
 standby ip 172.16.9.6 
 standby track Channel0/0 
! 
router rip 
 version 2 
 redistribute static 
 network 172.16.0.0 
! 
no ip classless 
ip route 0.0.0.0 0.0.0.0 172.16.9.1 
no ip http server 
! 
line con 0 
line aux 0 
line vty 0 4 
! 
end

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Dépannage des commandes

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Remarque: Avant que vous émettiez les commandes de débogage, référez-vous aux informations importantes sur des commandes de debug.

  • debug ip casa affinities — Les enables met au point pour des affinités de MAISON.

  • debug ip casa packets — Les enables met au point pour des paquets de MAISON.

  • debug ip casa wildcards — Les enables met au point pour des masques de MAISON.

  • show ip casa affinities — Affiche des statistiques au sujet des affinités.

  • show ip casa oper — Affiche les informations opérationnelles.

  • show ip casa stats — Affiche les informations statistiques.

  • show ip casa wildcard — Affiche des informations au sujet des affinités de masque.

Pour plus d'informations sur le MNLB commande sur LocalDirector, se rapportent à l'ensemble de caractéristiques MNLB pour le LD : Référence de commandes.

Exemple de sortie de débogage

Cette sortie est de la commande de debug ip casa affinities :

Router# debug ip casa affinities
16:15:36:Adding fixed affinity:
16:15:36:    10.10.1.1:54787 -> 10.10.10.10:23 proto = 6
16:15:36:Updating fixed affinity:
16:15:36:    10.10.1.1:54787 -> 10.10.10.10:23 proto = 6
16:15:36:    flags = 0x2, appl addr = 10.10.3.2, interest = 0x5/0x100
16:15:36:    int ip:port = 10.10.2.2:1638, sequence delta = 0/0/0/0
16:15:36:Adding fixed affinity:
16:15:36:    10.10.10.10:23 -> 10.10.1.1:54787 proto = 6
16:15:36:Updating fixed affinity:
16:15:36:    10.10.10.10:23 -> 10.10.1.1:54787 proto = 6
16:15:36:    flags = 0x2, appl addr = 0.0.0.0, interest = 0x3/0x104
16:15:36:    int ip:port = 10.10.2.2:1638, sequence delta = 0/0/0/0

Informations connexes


Document ID: 12616