Interfaces et modules Cisco : Module de commutation de contenu Cisco

Configuration de l'équilibrage de charge de serveurs FTP à l'aide de la fonction SLB d'IOS

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit une configuration d'échantillon pour l'Équilibrage de charge serveur ftp avec l'aide de l'Équilibrage de charge de serveur (SLB) Cisco IOS.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Version de logiciel 12.1(8)E de ½ du ¿  de Cisco IOSï de Supervisor de la famille du Catalyst 6000 pour l'engine 1 de superviseur avec MSFC1 (c6sup11-jsv-mz.121-8a.E)

  • Serveurs de FTP de Microsoft Windows 2000/IIS

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

La caractéristique du Cisco IOS SLB est une solution basée sur IOS de Cisco qui fournit l'équilibrage de charge du serveur. Cette caractéristique te permet pour définir un serveur virtuel qui représente une batterie de vrais serveurs, connu sous le nom de batterie de serveur. Quand un client initie une connexion au serveur virtuel, l'IOS SLB équilibrent la charge la connexion à un vrai serveur choisi, selon configuré équilibrez la charge l'algorithme ou le predictor.

Quand vous utilisez IOS SLB, vous devez configurer l'Équilibrage de charge serveur ftp pour opérer en mode de répartition. En ce mode, l'adresse virtuelle est connue aux serveurs de FTP. Vous devez configurer chacun des serveurs de FTP avec des adresses de bouclage pour leur seule interface de bouclage. Cette étape est nécessaire pour donner à chaque ordinateur dans le ftp server dans la batterie la même adresse IP que l'adresse virtuelle. Le ftp server peut alors répondre directement aux clients avec l'adresse de bouclage, juste comme le serveur répondrait pour sa propre adresse IP. IOS SLB réoriente des paquets au vrai serveur à la couche 2 à la couche de Contrôle d'accès au support (MAC). L'adresse IP de serveur virtuel n'est pas modifiée en mode acheminé. Par conséquent, les vrais serveurs doivent être la couche 2-adjacent à IOS SLB. Autrement, les routeurs intermédiaires ne peuvent pas conduire au vrai serveur choisi.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/12577/config_ftpserver_lb.gif

Configurations

Ce document utilise la configuration suivante :

  • Configuration de FTP IOS SLB utilisant le Catalyst 5509

Configuration de FTP IOS SLB utilisant le Catalyst 5509
Current configuration: 
! 
version 12.1 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname cat 
! 
boot buffersize 126968 
boot system flash slot0:c6sup11-jsv-mz.121-8a.E.bin 
! 
redundancy 
 main-cpu 
  auto-sync standard 
ip subnet-zero 
! 

!--- FTP Serverfarm configuration.
 
ip slb serverfarm FTPFARM 
 real 10.1.1.3 
  inservice 
 !  
 real 10.1.1.4 
  inservice 
! 

!--- FTP Virtual configuration. 
!--- Important: Config Loopback address on FTP Server's with Virtual address.
 
ip slb vserver FTPSERVER 
 virtual 172.17.63.241 tcp ftp service ftp 
 serverfarm FTPFARM 
 inservice 
! 
interface GigabitEthernet1/1 
 no ip address 
 shutdown 
! 
interface GigabitEthernet1/2 
 no ip address 
 shutdown 
! 
interface FastEthernet2/1 
 description "Uplink to the Default Gateway" 
 no ip address 
 switchport 
 switchport access vlan 100 
! 
interface FastEthernet2/2 
 no ip address 
 shutdown 
! 
interface FastEthernet2/3 
 description "Connection to FTP server" 
 no ip address 
 switchport 
 switchport access vlan 200 
! 
interface FastEthernet2/4 
 description "Connection to FTP server" 
 no ip address 
 switchport 
 switchport access vlan 200 
! 
interface FastEthernet2/5 
 no ip address 
 shutdown 
! 
interface FastEthernet2/48 
 no ip address 
 shutdown 
! 
interface Vlan1 
 no ip address 
 shutdown 
! 

!--- Client Side Vlan. 

interface Vlan100 
 ip address 172.17.63.240 255.255.255.192 
! 

!--- FTP Server Vlan. 
!--- Important: Configure the default gateway of the FTP Server to this address.

interface Vlan200 
 ip address 10.1.1.250 255.255.255.0 
! 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.17.63.193 
no ip http server 
! 
line con 0 
line vty 0 4 
 login 
! 
end

Remarque: En plus d'IOS SLB, le module de commutation de contenu est également disponible pour la gamme Cisco Catalyst 6500 commutent et le routeur de gamme Cisco 7600. Ce module fournit les connexions performantes entre les batteries de serveur de périphériques de réseau sur la base des brochures d'information d'une couche 4 à 7. Pour d'autres détails, référez-vous au Module de commutation de contenu Cisco.

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

  • vserver de slb de show ip — Affiche les informations de serveur virtuel. Voici un exemple qui affiche l'état du serveur virtuel et du nombre de connexions :

    cat#show ip slb vserver 
    
    slb vserver    protocal   virtual                 state         conns 
    ----------------------------------------------------------------------
    FTPSERVER      TCP        172.17.63.241/32:21     OPERATIONAL    4
  • show ip slb reals — Affiche les informations de ferme de serveur. Cette commande montre le predictor utilisé pour l'Équilibrage de charge. Cet exemple utilise la recherche séquentielle (par défaut). « Aucun » n'apparaît sous NAT parce que le périphérique est en mode acheminé.

    cat#show ip slb serverfarm 
    
    server farm     predictor       nat        reals        bind id 
    ----------------------------------------------------------------- 
    FTPFARM         ROUNDROBIN      none          2           0

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

attention Attention : La sortie de débogage est assignée la haute priorité dans le cpu process. Par conséquent, le débogage peut rendre le système inutilisable. Pour cette raison, commandes de débogage d'utilisation de dépanner seulement des problèmes spécifiques ou pendant les sessions de dépannage avec le personnel de support technique de Cisco. Cisco recommande que vous utilisiez des commandes de débogage au cours des périodes des flux de réseau inférieurs et de moins utilisateurs. L'élimination des imperfections au cours de ces périodes réduit l'effet de ces commandes sur d'autres utilisateurs sur le système.

Dépannage des commandes

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Remarque: Référez-vous aux informations importantes sur les commandes de débogage avant d'utiliser les commandes de débogage.

  • debug ip slb {conns | reals | vservers | tous} — messages de débogage d'affichages. Utilisez le forme no de cette commande afin de désactiver l'élimination des imperfections. Voici la description de syntaxe :

    Syntaxe Description
    conn. Affiche des messages de débogage pour toutes les connexions qu'IOS SLB manipule actuellement.
    vservers Affiche des messages de débogage pour tous les serveurs virtuels définis à IOS SLB.
    reals Affiche des messages de débogage pour tous les vrais serveurs définis à IOS SLB.
    tous Affiche tous les messages de débogage pour IOS SLB.

    Les sessions de FTP se composent de deux connexions entre le client FTP et le ftp server, à savoir, le contrôle et les données.

  • connexions de debug ip slb

    Voici un exemple qui utilise le FTP passif. En termes les plus simples, c'est comment le FTP passif fonctionne :

    • Une connexion pour la connexion initiale de contrôle de FTP, que le client initie au serveur :

      2d22h: SLB_CONN_DEBUG: TCP event= SYN_CLIENT,
       state= INIT -> SYNCLIENT 
      2d22h:  v_ip= 172.17.63.241:21 (  5), real= 10.1.1.4 
      2d22h:  client= 171.70.24.233:35006 
      2d22h: SLB_CONN_DEBUG: TCP event= SYNACK_SERVER,
       state= SYNCLIENT -> ESTAB 
      2d22h:  v_ip= 172.17.63.241:21 (  5), real= 10.1.1.4 
      2d22h:  client= 171.70.24.233:35006 
    • L'autre connexion pour la connexion de données de FTP, qui est initiée du client au serveur :

      2d21h: SLB_CONN_DEBUG: TCP event= DATA_CLIENT,
       state= ESTAB -> ESTAB 
      2d21h:  v_ip= 172.17.63.241:21 (  5), real= 10.1.1.4 
      2d21h:  client= 171.70.24.233:34999 
      2d21h: SLB_CONN_DEBUG: TCP event= DATA_SERVER,
       state= ESTAB -> ESTAB 
      2d21h:  v_ip= 172.17.63.241:21 (  5), real= 10.1.1.4 
      2d21h:  client= 171.70.24.233:34999

Notez que dans le FTP passif, le client initie la connexion de contrôle et la connexion de données. Le mode passif se rapporte à l'état de serveurs, parce que le serveur reçoit passivement les deux connexions. En mode passif, les ports de destination et de source sont les ports « éphémères » (plus considérablement que 1023). Le client conduit les modes, comme dans chaque cas le client doit émettre la commande passive, ou la commande de port, d'initier l'installation de la connexion de données. Dans chaque cas le destinataire de la connexion de données (serveur pour le mode passif, client pour le mode actif) doit fournir le numéro de port sur lequel ils écoutent cette connexion spécifique. Ce n'est pas TOUJOURS le port 20 pour la connexion de données, même dans le FTP de mode actif. Rien dans les RFC ne spécifie que les ports à utiliser sont 20 et 21, il est juste convention. Beaucoup de serveurs utilisent les ports éphémères pour la connexion de données.

% ne peuvent pas activer le serveur nat parce que le [chars] de vserver a le FTP activé

Ce message d'erreur est affiché parce que l'IOS SLB ne prend en charge pas le FTP dans le mode NAT. Le contournement est d'utiliser le mode et les bouclages de répartition sur les serveurs. Le pour en savoir plus, voient la section acheminée de bouclage de mode.

Bouclage acheminé de mode

Après que vous ayez configuré la caractéristique de serverfarm et de Vserver de FTP sur le Catalyst 6500, vous devez configurer chaque vrai serveur avec un périphérique ou une interface de bouclage. Configurez l'adresse IP du serveur virtuel comme adresse IP de bouclage, avec un netmask de 255.0.0.0.

Route Table 
     =========================================================================== 
     Interface List 
     0x1 ........................... MS TCP Loopback interface 
     0x2 ...00 60 b0 87 dc 1a ...... AMD PCNET Family Ethernet Adapter 
     0x1000004 ...02 00 4c 4f 4f 50 ...... MS LoopBack Driver 
     =========================================================================== 
     Active Routes: 
        Network         Destination     Netmask       Gateway   Interface Metric 
        0.0.0.0         0.0.0.0         10.1.1.250    10.1.1.3      1 
        10.1.1.0        255.255.255.0   10.1.1.3      10.1.1.3      1 
        10.1.1.3        255.255.255.255 127.0.0.1     127.0.0.1     1 
        10.255.255.255  255.255.255.255 10.1.1.3      10.1.1.3      1 
        127.0.0.0       255.0.0.0       127.0.0.1     127.0.0.1     1 
        172.17.63.241   255.255.255.255 127.0.0.1     127.0.0.1     1 
        224.0.0.0       224.0.0.0       10.1.1.3      10.1.1.3      1 
        224.0.0.0       224.0.0.0       172.17.63.241 172.17.63.241 1 
        255.255.255.255 255.255.255.255 10.1.1.3      10.1.1.3      1 
     ===========================================================================

Examinez l'adresse réseau dans chaque ligne de la table, où vous voyez que l'adresse de bouclage apparaît. Pour que les serveurs communiquent correctement, vous avez besoin d'une référence à une adresse réseau connue multicast. C'est dans le huitième ligne dans l'exemple, ainsi vous devez supprimer le default-route supplémentaire. C'est celui dont l'adresse réseau commence par le même premier chiffre que l'adresse de batterie, et est suivi par trois zéros. Dans cet exemple, l'artère supplémentaire est dans la deuxième ligne.

Ce sont des adresses réseau connues multicasts :

224.0.0.0      224.0.0.0    172.17.63.241      172.17.63.241       1

Voici les default route automatique-installés retirés de la table dans l'exemple :

0.0.0.0          0.0.0.0    172.17.63.193   172.17.63.241          1

Vous devez supprimer l'artère supplémentaire pour permettre la bonne communication avec le serveur virtuel SLB.


Informations connexes


Document ID: 12577