Services de mise en réseau d'applications : Moteurs de contenu Cisco de la gamme 500

Comment éviter Content Engine avec des listes d'accès de routeurs

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document explique comment employer une configuration de routeur simple avec le Listes de contrôle d'accès (ACL) afin de permettre ou refuser le trafic au Cisco Content Engine.

Dans ce scénario, n'importe quel trafic qui provient de C1 (172.18.124.193) et de C2 (10.27.3.4) et est destiné à n'importe quel hôte saute le moteur de cache comme spécifié par l'ACL. Tout autre trafic est expédié.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Moteur de cache 505 de Cisco dans un environnement de travaux pratiques avec des configurations effacées

  • Routeur de Cisco 2611

  • Version de logiciel 12.1(3)T de½ du¿Â du Cisco IOSïÂ

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Conventions

Référez-vous au Conventions relatives aux conseils techniques Cisco pour les informations sur des conventions de document.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'Outil de recherche de commande (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/12561/ce_acl-A.gif

Configurations

Ce document utilise la configuration suivante :

Comment sauter l'engine satisfaite avec le routeur ACLs


!--- Your command lines should appear similar to the following: 

router# configure terminal
router(config)# ip wccp web-cache redirect-list 120
router(config)# access-list 120 deny ip host 172.18.124.193 any
router(config)# access-list 120 deny ip host 10.27.3.4 any
router(config)# access-list 120 permit ip any any

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Employez l'OIT afin d'afficher une analyse de la sortie de la commande show.

  • show version - Affiche le logiciel qui fonctionne sur le routeur, aussi bien que quelques autres composants comme disponibilité système (telle qu'où le code a été précédemment amorcé, et la date où il a été compilé).

         33-ns-gateway#show version
         Cisco Internetwork Operating System Software
         IOS (tm) C2600 Software (C2600-I-M), Version 12.1(3)T,  RELEASE SOFTWARE (fc1)
         Copyright (c) 1986-2000 by cisco Systems, Inc.
         Compiled Wed 19-Jul-00 16:02 by ccai
         Image text-base: 0x80008088, data-base: 0x808A9264
          
         ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)
          
         33-Ns-gateway uptime is 1 day, 1 hour, 1 minute
         System returned to ROM by reload
         System restarted at 11:03:21 UTC Thu May 17 2001
         System image file is "flash:c2600-i-mz.121-3.T"
          
         cisco 2610 (MPC860) processor (revision 0x203) with 
            44032K/5120K bytes of memory.
         Processor board ID JAD04330MR6 (3648101504)
         M860 processor: part number 0, mask 49
         Bridging software.
         X.25 software, Version 3.0.0.
         5 Ethernet/IEEE 802.3 interface(s)
         32K bytes of non-volatile configuration memory.
         16384K bytes of processor board System flash (Read/Write)
          
         Configuration register is 0x2102
  • show running-config - Affiche la configuration en cours sur le routeur.

         33-Ns-gateway#show running-config
         Building configuration...
         Current configuration:
         !
         ! Last configuration change at 12:04:57 UTC Fri May 18 2001
         ! NVRAM config last updated at 11:01:10 UTC Fri May 18 2001
         !
         version 12.1
         service timestamps debug datetime msec
         service timestamps log datetime msec
         no service password-encryption
         !
         hostname 33-Ns-gateway
         !
         logging buffered 64000 debugging
         enable secret 5 $1$IWJr$nI.NcIr/b9DN7jEQQC17R/
         !
         !
         !
         !
         !
         ip subnet-zero
         ip wccp web-cache redirect-list 120
         ip cef
         no ip domain-lookup
         ip domain-name cisco.com
         ip name-server 161.44.11.21
         ip name-server 161.44.11.206
         !
         !
         !
         !
         interface Ethernet0/0
          ip address 10.1.3.50 255.255.255.0
          no ip route-cache cef
         !
         interface Ethernet1/0
          description interface to the CE .5
          bandwidth 100
          ip address 10.27.2.1 255.255.255.0
          full-duplex
         !
         interface Ethernet1/1
          description inter to DMZ
          ip address 172.18.124.211 255.255.255.0
          ip wccp web-cache redirect out
          no ip route-cache cef
          no ip route-cache
          no ip mroute-cache
         !
         interface Ethernet1/2
          description Preconfigured for recreates 10.27.3.0/24 net
          ip address 10.27.3.1 255.255.255.0
          no ip route-cache cef
         !
         interface Ethernet1/3
          no ip address
          shutdown
         !
         ip classless
         ip route 0.0.0.0 0.0.0.0 172.18.124.1
         no ip http server
         !
         access-list 120 deny   ip host 172.18.124.193 any log-input
         access-list 120 deny   ip host 10.27.3.4 any log-input
         access-list 120 permit ip any any log
         !
         line con 0
          exec-timeout 0 0
          transport input none
         line aux 0
          exec-timeout 0 0
         line vty 0 4
          exec-timeout 0 0
          password ww
          login
         !
         no scheduler allocate
         end
  • show access-lists - Répertorie les déclarations de commande access-list en configuration de routeur. Cette commande répertorie également un nombre de hits qui indique que le nombre de fois où un élément a été apparié quand une recherche de commande access-list est émise.

         2.33-ns-gateway#show access-lists 120
         Extended IP access list 120
         deny ip host 172.18.124.193 any log-input (114 matches)
         deny ip host 10.27.3.4 any log-input (30 matches)
         permit ip any any log
  • show log - Affiche le login d'erreur système le routeur.

         3.33-ns-gateway#show log
         Syslog logging: enabled (0 messages dropped, 0 flushes, 0 overruns)
         Console logging: level debugging, 906 messages logged
         Monitor logging: level debugging, 165 messages logged
         Buffer logging: level debugging, 267 messages logged
         Trap logging: level informational, 114 message lines logged 
         Log Buffer (64000 bytes):
         May 18 09:57:00.837: %CLEAR-5-COUNTERS: 
            Clear counter on all interfaces by vty2 
         (172.18.124.193)
         May 18 10:24:53.218: %SEC-6-IPACCESSLOGP: 
            list 120 denied tcp 172.18.124.193(0) 
         -> 216.4.77.193(0), 1 packet
         May 18 10:28:44.890: %SEC-6-IPACCESSLOGP: 
            list 120 denied tcp 10.27.3.4(0) 
         -> 64.224.45.130(0), 1 packet
         May 18 10:29:08.861: %SEC-6-IPACCESSLOGP: 
            list 120 denied tcp 172.18.124.193(0) 
         -> 212.20.160.80(0), 1 packet
         May 18 10:29:53.563: %SEC-6-IPACCESSLOGP: 
            list 120 denied tcp 172.18.124.193(0) 
         -> 216.4.77.193(0), 19 packets
         May 18 10:33:53.672: %SEC-6-IPACCESSLOGP: 
            list 120 denied tcp 10.27.3.4(0) 
         -> 216.4.77.193(0), 1 packet

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.


Informations connexes


Document ID: 12561