Technologies IBM : Data-Link Switching (DLSw) et Data-Link Switching Plus (DLSw+)

Configurations DLSw de base

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Le Data-Link Switching (DLSw) est un protocole de commutateur à commutateur qui est utilisé pour transporter le Systems Network Architecture IBM (SNA) et le trafic IBM Netbios au-dessus d'un réseau IP. Ce protocole ne fournit pas le plein routage, mais fournit à la place la commutation à la couche liaison de données SNA et l'encapsulation dans le TCP/IP pour le transport au-dessus de l'Internet.

Avant de commencer

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Conditions préalables

Aucune condition préalable spécifique n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Informations générales

DLSw+ est l'implémentation de Cisco de DLSw. En plus de la norme de DLSw, DLSw+ inclut les caractéristiques suivantes :

  • Choix de l'option de transport, y compris le TCP, le FST (transport rapide-ordonnancé), et l'encapsulation directe.

  • Améliorations de l'évolutivité : groupes de homologues, pairs sur demande, pare-feux d'exploration, et apprendre d'emplacement.

  • Conversion de medias entre les réseaux locaux locaux et distants et le SDLC ou les Ethernets.

Queest-ce que le DLSw est standard ?

Pour un plus grand détail sur la norme de DLSw, référez-vous à RFC 1795 (RFC 1434 a été rendu Désuet(e) par RFC 1795). En résumé, RFC 1795 décrit le protocole de commutateur à commutateur (SSP) utilisé entre les Routeurs pour établir des connexions de DLSw, localise des ressources, des données en avant, le contrôle de flux de traitement, et la correction d'erreur. Il décrit également comment terminer des connexions du contrôle de liaison de données (DLC) localement et tracer DLC les connexions à un DLSw font le tour.

En terminant des connexions DLC localement, DLSw aborde les problèmes suivants :

  • Minuteries DLC

  • Accusés de réception DLC au-dessus du WAN

  • Écoulement et contrôle d'encombrement

  • Contrôle d'émission des paquets de recherche

  • Le par la source pont le saut compte des limites

Remarque: Des améliorations à RFC 1795 peuvent être trouvées dans RFC 2166. Ces améliorations adressent des problèmes d'évolutivité dans DLSw et des clarifications à RFC 1795. RFC 2166, cependant, fait pas 1795 Désuet(e) et devrait être utilisé en même temps que 1795.

Exemples de configuration

Les configurations représentées ici sont des configurations partielles ; ils dépeignent seulement la partie de la configuration priée pour le support DLSw+, et rien l'IP ou tout autre support de protocole. Puisque DLSw+ se fonde sur le TCP/IP (à moins que quand vous utilisez FST ou dirigez), la supposition est que le réseau IP est déjà en service.

1. Anneau à jeton à l'Anneau à jeton au-dessus du WAN

/image/gif/paws/12411/ringwan.gif

Router A

!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning

 
!--- Allows the router to forward single route explorer frames.

Router B

!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface TokenRing0
 ip address 150.150.20.2 255.255.255.0
 ring-speed 16
 source-bridge 2 1 2000
 source-bridge spanning

 
!--- Allows the router to forward single route explorer frames.

Dans cet exemple, nous prenons une sonnerie virtuelle, le ring number 2000, pour établir facilement des relations entre les deux groupes. Le champ des informations de routage (RIF), cependant, est terminé au routeur DLSw+. Vous pouvez choisir un numéro de boucle virtuelle différent pour chaque routeur. Faites attention en choisissant le ring number ; vous devriez suivre les mêmes règles qui s'appliquent au pont en par la source. Actuellement, Cisco prend en charge seulement une sonnerie virtuelle par routeur.

La commande de dlsw local-peer est utilisée de définir votre propre adresse IP DLSw+ pour le routeur local. Dans l'exemple ci-dessus, l'adresse IP de l'interface de bouclage est utilisée de sorte que DLSw+ ne doive pas se fonder sur la vraie interface physique étant jusqu'au travail.

L'ordre de distant-pair de dlsw définit l'adresse IP du routeur distant. Le numéro 0 qui suit le mot clé de distant-pair est le numéro dans la liste d'anneaux. Généralement, si vous voulez entièrement un réseau maillé, utilisez le numéro 0. Le numéro dans la liste d'anneaux est utilisé pour contrôler l'inondation des trames d'exploration en permettant le réseau à segmenter (voir l'exemple deux pour une démonstration de sonnerie-liste).

2. Anneau à jeton à l'Anneau à jeton avec la Sonnerie-liste

/image/gif/paws/12411/ringlist.gif

Router A

!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2000
 source-bridge spanning 

 
!--- Allows the router to forward single route explorer frames.

Router B
!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 1 tcp 150.150.1.1
dlsw ring-list 1 rings 1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface TokenRing0
 ip address 150.150.20.2 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning 

 
!--- Allows the router to forward single route explorer frames.

!
interface TokenRing1
ip address 150.150.30.1 255.255.255.0
ring-speed 16
source-bridge 2 1 2000
source bridge spanning 


!--- Allows the router to forward single route explorer frames.

Dans cet exemple, toutes les stations de travail sur la sonnerie 3 peuvent seulement établir les sessions avec des stations sur la sonnerie 1, mais pas la sonnerie 2, et vice versa. Les stations sur la sonnerie 1 peuvent encore parler aux stations sur la sonnerie 2 parce qu'elles sont localement reliées au routeur B.

Ceci signifie qu'il n'y aura aucune émission de la sonnerie 2 qui sera fournie au routeur A. Utilisant le dlsw ring-list, le port-list, et les déclarations de groupe B-liste est très utile quand vous voulez contrôler le trafic d'émission au-dessus du WAN.

3. Anneau à jeton aux Ethernets au-dessus du WAN

/image/gif/paws/12411/ringether.gif

Dans cet exemple, les périphériques se trouvent sur des medias mélangés ainsi nous avons besoin de bitswap l'adresse MAC d'hôte avant qu'elle soit codée sur le périphérique secondaire qui initie le paquet de test d'explorateur. Voyez également la compréhension et dépannage du pontage SR/TLB.

Router A

!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning 

!--- Allows the router to forward single route explorer frames.


Dans l'exemple suivant, on permet à la la station sur le segment d'Ethernets pour parler aux stations sur le segment Token Ring. Le routeur DLSw+ prendra soin de la conversion du format Ethernet dans le format d'Anneau à jeton. La commande de dlsw bridge-group est utilisée d'attacher le segment d'Ethernets au processus DLSw+ juste comme l'instruction de pont source attache le segment Token Ring au DLSw+ par le groupe d'anneau virtuel. Vous n'avez pas besoin de configurer SRT/LB à moins que vous ayez une interface Token Ring sur le routeur B, et la transmission entre les stations sur cet Anneau à jeton et les Ethernets est exigée. Voir l'exemple 6.

Remarque:  le source-bridge ring-group sur le routeur B n'est pas nécessaire.

Router B
!
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface Ethernet0
 ip address 150.150.30.1 255.255.255.0
 bridge-group 1
!
bridge 1 protocol dec
!

4. Ethernets aux Ethernets au-dessus du WAN

/image/gif/paws/12411/etherwan.gif

Router A
!
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface Ethernet0
 ip address 150.150.30.1 255.255.255.0
 bridge-group 1
!
bridge 1 protocol dec
!
Router B
!
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface Ethernet0
 ip address 150.150.40.1 255.255.255.0
 bridge-group 1
!
bridge 1 protocol dec

Remarque:  le source-bridge ring-group n'est pas prié sur l'un ou l'autre de routeur.

5. Anneau à jeton aux Ethernets dans le même routeur

/image/gif/paws/12411/tokenether.gif

Si vous devez connecter des stations entre les Ethernets et l'Anneau à jeton qui sont locaux au routeur, vous devez utiliser SR/TLB (pontage translationnel). Des gens du pays DLSw entre les Ethernets et l'Anneau à jeton ne sont pas pris en charge.

Router A

source-bridge ring-group 2000
source-bridge transparent 2000 1000 1 1

interface Ethernet0
 ip address 150.150.40.1 255.255.255.0
 bridge-group 1
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning

!--- Allows the router to forward single route explorer frames.

!
bridge 1 protocol ieee

Pour le source-bridge transparent 2000 de commande 1000 1 1 nous avons :

  • 2000 est le numéro de boucle virtuelle configuré par le source-bridge ring-group 2000.

  • 1000 est le nombre de pseudo anneau donné au domaine d'Ethernets.

  • 1 est le numéro de pont de la passerelle que cela mène au domaine de Pontage transparent.

  • 1 est nombre du passerelle-groupe transparent que vous voulez attacher dans votre domaine de pont avec routage par la source.

Remarque: Des adresses IP sur les interfaces ne sont pas exigées pour SRT/LB.

6. SR/TLB et DLSw+

srtlb.gif

Router A
source-bridge ring-group 2000
source-bridge transparent 2000 1000 1 1
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Ethernet0
 ip address 150.150.40.1 255.255.255.0
 bridge-group 1
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning

!--- Allows the router to forward single route explorer frames.

!
bridge 1 protocol dec
Router B
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.11.1  255.255.255.0
 ring-speed 16
 source-bridge 2 1 2000
 source-bridge spanning 

!--- Allows the router to forward single route explorer frames.

Dans l'exemple ci-dessus, DLSw et SRT/LB sont configurés. SRT/LB est seulement exigé quand les stations sur l'Anneau à jeton doivent parler aux stations sur les Ethernets sur le même routeur, routeur A. Si la seule condition requise est pour des stations Ethernet sur le routeur A à parler aux stations Token Ring distantes sur le routeur B, alors le dlsw bridge-group 1 prend soin de cela.

7. Anneau à jeton au SDLC au-dessus du WAN

/image/gif/paws/12411/tokensdlc.gif

Router A
!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
!
interface TokenRing0
 ip address 150.150.10.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2000
 source-bridge spanning

!--- Allows the router to forward single route explorer frames.


Router B

dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.2 255.255.255.0
!
interface Serial 1
 no ip address
 encapsulation sdlc
 no keepalive
 clockrate 9600
 sdlc role primary

 !--- Assumes SDLC station role secondary for the controller.

 sdlc vmac 4000.9999.0100 

 
!--- Virtual MAC address given to the controller which will 
 !--- have sdlc address (01) appended to it.

 sdlc address 01          

 
!--- SDLC address, obtained from controller configuration.

 sdlc xid 01 05D20001     

 
 !--- 01 is the SDLC address and IDBLK/IDNUM should match that 
 !--- in SMN on the host.

 sdlc partner 4000.1020.1000 01 

 
 !--- 4000.1020.1000 is the MAC address of the host
 !--- and 01 is the SDLC address.
 
 sdlc dlsw 1
!

Remarque: La connexion de circuit de DLSw sera entre 4000.9999.0101 et 4000.1020.1000. En outre, l'exemple ci-dessus suppose un contrôleur PU2.0. Pour d'autres types unité centrale, référez-vous au guide de dépannage SDLC de DLSw.

Les exemples ci-dessus de configuration sont quelques scénarios de réseau commun. Vous pouvez faire beaucoup plus avec DLSw+, mais ces configurations te fournissent certains des fondements. Maintenez dans l'esprit que DLSw+ est RSRB amélioré avec la capacité supplémentaire de l'Interopérabilité avec d'autres Routeurs qui sont conformément à RFC 1795 et 2166.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 12411