IP : Tunnel série (STUN)

Configuration du point à point BSTUN avec accusé de réception local sur relais de trame

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Le soutien d'enables de caractéristique du tunnel sériel BISYNC (BSTUN) des périphériques qui utilisent le protocole de liaison de données BISYNC. Ce protocole permet à des entreprises de transporter le trafic BISYNC au-dessus du même réseau qui prend en charge leur Systems Network Architecture (SNA) et trafic multiprotocole, qui élimine le besoin d'équipements distincts BISYNC. Avec le Relais de trames, vous pouvez employer la caractéristique d'accusé de réception local pour fournir la terminaison locale de la session sur le pair BSTUN.

Dans cet exemple, le Point à point BSTUN est configuré avec des gens du pays Ackowledgement au-dessus de Relais de trames. Les états appropriés dans la sortie de commande de show bstun sont mis en valeur dans le ce document.

Remarque: Bien que le paquet/événement de bstun de débogage et mettent au point des commandes de paquet/événement BSC ne devrait pas entraîner l'utilisation excessive CPU, la commande de logging buffered est utilisé pour copier la sortie sur le fichier journal.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations dans ce document sont basées sur la version de logiciel 12.1(5) de Cisco IOSÝ.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

bstun_p2p_localack_over_fr-01.gif

Configurations

Ce document utilise les configurations suivantes :

Kilcot
Building configuration 
!
version 12.1
service timestamps debug datetime msec
!
hostname kilcot
!
! 
bstun peer-name 100.1.1.1
bstun protocol-group 72 bsc-local-ack
!
! 
interface Loopback0
ip address 100.1.1.1 255.0.0.0
!
interface Serial0/0
ip address 10.1.1.1 255.0.0.0
encapsulation frame-relay
no ip mroute-cache
frame-relay interface-dlci 16
frame-relay lmi-type ansi
!
interface Serial1/0
no ip address
ip directed-broadcast
encapsulation bstun
no ip mroute-cache
no keepalive
full-duplex
clockrate 9600
bstun group 72
bsc secondary
bstun route all tcp 200.2.2.2
!
!
router rip
network 10.0.0.0
network 100.0.0.0
!
end

Interlocuteur
Building configuration...

version 12.1
! 
service timestamps debug datetime msec
!
hostname party
!
bstun peer-name 200.2.2.2
bstun protocol-group 72 bsc-local-ack
!
!
interface Loopback0
ip address 200.2.2.2 255.255.255.0
! 
interface Serial0
no ip address
encapsulation bstun
load-interval 30
no keepalive
full-duplex
clockrate 9600
bstun group 72
bsc primary
bstun route all tcp 100.1.1.1
!
interface Serial1
ip address 10.1.1.2 255.0.0.0
encapsulation frame-relay IETF
no ip mroute-cache
frame-relay interface-dlci 17
frame-relay lmi-type ansi
!
!
router rip
network 10.0.0.0
network 200.2.2.0
!
end

Vérifiez

Cette section fournit des informations qui vous permettront de vérifier que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • show bstun

  • show bsc

kilcot#show bsc
BSC local-ack on Serial1/0:
secondary state is CU_Idle.
Control units on this interface:
 
   Poll address: 40. Select address: 60 *CURRENT-CU*
   State is Initializing.
   Tx Counts: 0 frames(total). 0 frames(data). 0 bytes.
   Rx Counts: 3 frames(total). 0 frames(data). 15 bytes.
 
Total Tx Counts: 0 frames(total). 0 frames(data). 0 bytes.
Total Rx Counts: 19 frames(total). 0 frames(data). 59 bytes.

kilcot#show bstun
This peer: 100.1.1.1
 
*Serial1/0  (group 72 [bsc-local-ack])
route transport address         dlci lsap state      rx_pkts tx_pkts   drops
all   TCP       200.2.2.2                 open         1       3        0

party#show bsc
BSC local-ack on Serial0:
primary state is TCU_Polled.
Control units on this interface:
 
   Poll address: 40. Select address: 60 *CURRENT-CU*
   State is Inactive.
   Tx Counts: 126 frames(total). 0 frames(data). 378 bytes.
   Rx Counts: 0 frames(total). 0 frames(data). 0 bytes.
 
Total Tx Counts: 126 frames(total). 0 frames(data). 378 bytes.
Total Rx Counts: 0 frames(total). 0 frames(data). 0 bytes.
 
party#show bstun
This peer: 200.2.2.2
 
*Serial0  (group 72 [bsc-local-ack])
route transport address         dlci lsap state      rx_pkts tx_pkts   drops
all   TCP       100.1.1.1                 open          3       2        0

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Dépannage des commandes

Le paquet/événement de bstun de débogage et mettent au point le paquet BSC/sortie d'événement a été copié sur le fichier journal. Quand vous interprétez cette sortie de débogage :

  • Données en série entrantes (SDI) — Paquets reçus de l'interface de Protocole SDLC (Synchronous Data Link Control).

  • Données de réseau entrantes (NDI) — Paquets De-encapsulés du WAN.

Remarque: Avant d'émettre des commandes debug, reportez-vous aux Informations importantes sur les commandes de débogage.

kilcot#show log
Syslog logging: enabled (0 messages dropped, 0 flushes, 0 overruns)
    Console logging: disabled
    Monitor logging: level debugging, 0 messages logged
    Buffer logging: level debugging, 5088 messages logged
    Trap logging: level informational, 70 message lines logged
          
Log Buffer (100000 bytes):

Dec 28 09:43:21.748: BSC: Serial1/0: POLLEE-FSM event:  E_LineUp old_state: CU_Down.  new_state: CU_Idle.
Dec 28 09:43:21.756: BSC: Serial1/0: SDI-rx: Data (5 bytes):   40407F7F2D
Dec 28 09:43:36.756: BSTUN bsc-local-ack: Serial1/0 SDI:   Data:   401100
Dec 28 09:43:36.756: BSTUN: Change state for peer  (all[72])200.2.2.2/1976 (closed->opening)
Dec 28 09:43:36.756: BSC: Serial1/0: POLLEE-FSM  event: E_RxEnq 
Dec 28 09:43:36.760: BSTUN: Change state for peer   (all[72])200.2.2.2/1976 (opening->open wait)
Dec 28 09:43:36.764: %BSTUN-6-OPENING: CONN:  opening peer (all[72])200.2.2.2/1976, 3
Dec 28 09:43:36.792: bsttcpd_connect:  Refreshing tcp_encaps for group 72
Dec 28 09:43:36.792: %BSTUN-6-OPENED: CONN:  peer (all[72])200.2.2.2/1976 opened, [previous state open wait]
Dec 28 09:43:36.792: BSTUN: Change state for  peer (all[72])200.2.2.2/1976 (open wait->open)
Dec 28 09:43:36.844: BSTUN bsc-local-ack:  Serial1/0 NDI: Data:   401400
Dec 28 09:43:36.848: BSC: Serial1/0: NDI-rx:  Data (3 bytes):  401400
Dec 28 09:43:37.640: %SYS-5-CONFIG_I:  Configured from console by vty0

party#show log
Syslog logging: enabled (0 messages 
   dropped, 0 flushes, 0 overruns)
    Console logging: disabled
    Monitor logging: level debugging, 114 messages logged
        Logging to: vty2(114)
    Buffer logging: level debugging, 5199 messages logged
    Trap logging: level informational, 79 message lines logged
          
Log Buffer (100000 bytes):

ec 28 09:48:09.816: %BSTUN-6-PASSIVEOPEN:   passive open 100.1.1.1(11017) -> 1976
Dec 28 09:48:09.836: %BSTUN-6-OPENED: PHDR:  peer (all[72])100.1.1.1/1976 opened, [previous state closed]
Dec 28 09:48:09.836: BSTUN: Change state for  peer (all[72])100.1.1.1/1976 (closed->open)
Dec 28 09:48:09.836: BSTUN bsc-local-ack:  Serial0 NDI: Data:   401100
Dec 28 09:48:09.836: BSC: Serial0: NDI-rx:  Data (3 bytes):  401100
Dec 28 09:48:09.836: BSTUN bsc-local-ack:  Serial0 SDI: Data:   401400
Dec 28 09:48:09.836: BSC: Serial0: SDI-tx:  Data (10 bytes):  37FF32323240407F7F2D

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 12347