Technologies IBM : Data-Link Switching (DLSw) et Data-Link Switching Plus (DLSw+)

Exemple de configuration de la redondance Ethernet DLSw

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Cette configuration d'échantillon implémente la fonctionnalité de redondance Ethernet de logiciel de Cisco IOSÝ sur un réseau de Data-Link Switching (DLSw). Également incluses dans ce document sont des techniques pour mettre au point cette caractéristique. La fonctionnalité de redondance Ethernet a été ajoutée dans le Logiciel Cisco IOS version 12.0(5)T.

Cette configuration d'échantillon affiche comment implémenter la fonctionnalité de redondance Ethernet et les commandes utilisées pour surveiller le statut des connexions. On simule trois scénarios dans lesquels la panne se produit tandis que les commandes de débogage s'exécutent afin d'afficher le comportement de chaque routeur.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/12345/8-a.gif

Notes de configuration

  • Le contrôleur A est configuré pour établir deux sessions de Contrôle de la liaison logique (LLC) avec l'hôte ; il utilise une valeur locale de point d'accès services (LSAP) de 0x04 et de 0x08, respectivement. Les tentatives du contrôleur B d'établir seulement une session LLC, et l'hôte utilise une valeur de LSAP de 0x04.

  • Pour cette configuration d'échantillon, quand les deux Routeurs de DLSw sont, le contrôleur A se connecte à l'hôte au routeur Avimimus, et le contrôleur B se connecte à l'hôte au routeur Turbo. L'Équilibrage de charge fait quand les deux Routeurs sont hauts et travail correctement.

  • Voici les adresses MAC des contrôleurs et des configurations :

    • Contrôleur A

      smac = 0000.2222.0000 (cann), dmac = 0000.6666.0000 (cann)
      lsap = 0x04 and lsap = 0x08, dsap = 0x04 for both connections

      Pour une consultation plus facile, ce sont les valeurs de rotation de bits de cette adresse MAC :

      smac = 0000.4444.0000 (non-cann), dmac = 0000.6666.0000 (non-cann)
    • Contrôleur B

      smac = 0000.1111.0000 (cann), dmac = 0000.7777.0000 (cann)
      lsap = 0x08, dsap = 0x04

      Pour une consultation plus facile, ce sont les valeurs de rotation de bits de cette adresse MAC :

      smac = 0000.8888.0000 (non-cann), dmac = 0000.EEEE.0000 (non-can)
  • L'hôte a cette adresse MAC :

    smac = 4000.3745.0000 (non-can) 
    lsap = 0x04

    Pour une consultation plus facile, c'est la valeur de rotation de bits de l'adresse MAC de l'hôte :

    smac = 0200.eca2.0000 (cann)
    
  • Avimimus est configuré pour être le routeur principal de DLSw, et Turbo est configuré pour être le routeur slave de DLSw. Avimimus est assigné une valeur prioritaire plus basse pour réaliser cette configuration. La priorité par défaut est 100. Répertoriées ici sont les commandes utilisées pour spécifier la valeur prioritaire pour chaque routeur :

    • Avimimus — maître-priorité 10 du dlsw transparent redundancy-enable 9999.9999.9999

    • Turbo — dlsw transparent redundancy-enable 9999.9999.9999

    Les deux Routeurs doivent être configurés pour utiliser la même adresse MAC de Multidiffusion pour la transmission (9999.9999.9999).

  • Avimimus a cette adresse MAC configurée :

    Ethernet 0:
    smac = 0000.3333.0000 (cann), 0000.CCCC.0000 (non-cann)
  • Turbo a cette adresse MAC configurée :

    Ethernet 0:
    smac = 0000.5555.0000 (cann), 0000.AAAA.0000 (non-cann)
  • Avimimus est configuré pour faire ce mappage d'adresse MAC :

    local mac: 0000.6666.0000 --> remote mac: 0200.ECA2.0000 (cann)

    Pour une consultation plus facile, ce sont les valeurs de rotation de bits de cette adresse MAC :

    local mac: 0000.6666.0000 --> remote mac: 4000.3745.0000 (non-can)
  • Turbo est configuré pour faire ce mappage d'adresse MAC :

    local mac: 0000.7777.0000 --> remote mac: 0200.ECA2.0000 (cann)

    Pour une consultation plus facile, ce sont les valeurs de rotation de bits de l'adresse MAC :

    local mac: 0000.EEEE.0000 --> remote mac: 4000.3745.0000 (non-can)
  • Répertoriées ici sont les commandes de spécifier le mappage d'adresse MAC aux Routeurs de DLSw :

    • Avimimus — voisin 0000.5555.0000 du distant-MAC 0200.eca2.0000 du gens du pays-MAC 0000.6666.0000 de dlsw transparent map

    • Turbo — voisin 0000.3333.0000 du distant-MAC 0200.eca2.0000 du gens du pays-MAC 0000.7777.0000 de dlsw transparent map

    Remarque: Toutes les adresses MAC configurées dans ces commandes doivent être dans le format canonique. La valeur de « gens du pays-MAC » représente le MAC de destination (DMAC) auquel les Ethernets finissent le point de stations (0000.6666.0000 et 0000.7777.0000, dans ce cas). La valeur de « distant-MAC » est la représentation canonique du serveur distant que vous tentez d'accéder par DLSw. La valeur « voisine » représente l'adresse MAC de l'interface Ethernet de l'autre routeur redondant de DLSw.

Configurations

Ce document utilise les configurations suivantes :

Routeur redondant principal DLSw
avimimus# show run
Building configuration...
!
hostname avimimus
! 
dlsw local-peer peer-id 1.1.1.1
dlsw remote-peer 0 tcp 3.3.3.1
dlsw transparent switch-support
!
!
interface Ethernet0
 mac-address 0000.3333.0000
 ip address 5.5.5.3 255.255.255.0
 no ip redirects
 no ip directed-broadcast
 media-type 10BaseT
 standby timers 3 10
 standby priority 150 preempt
 standby mac-address 0000.3333.3333
 standby ip 5.5.5.4
 dlsw transparent redundancy-enable 9999.9999.9999 master-priority 10

!--- This is the command used to specify the priority value of Avimimus.

 dlsw transparent map local-mac 0000.6666.0000 remote-mac 0200.eca2.0000 neighbor 0000.5555.0000

!--- This is the command used to specify the MAC address mapping at the DLSw router.

!
interface Serial0
 ip address 1.1.1.1 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
 clockrate 4000000
!
end

Routeur redondant slave de DLSw
turbo# show run
Building configuration...
!
hostname turbo
!
dlsw local-peer peer-id 2.2.2.1
dlsw remote-peer 0 tcp 3.3.3.1
dlsw transparent switch-support
!
interface Ethernet0
 mac-address 0000.5555.0000
 ip address 5.5.5.1 255.255.255.0
 no ip redirects
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 standby timers 3 10
 standby priority 100
 standby mac-address 0000.3333.3333
 standby ip 5.5.5.4
dlsw transparent redundancy-enable 9999.9999.9999

!--- This is the command used to specify the priority value of Turbo.

dlsw transparent map local-mac 0000.7777.0000 remote-mac 0200.eca2.0000 neighbor 0000.3333.0000

!--- This is the command used to specify the MAC address mapping at the DLSw router.

!
interface Serial1
 ip address 2.2.2.1 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
end

Routeur de DLSw d'Anneau à jeton
limno# show run 
!
hostname limno
!
source-bridge ring-group 100
!
dlsw local-peer peer-id 3.3.3.1
dlsw remote-peer 0 tcp 2.2.2.1
dlsw remote-peer 0 tcp 1.1.1.1
!
interface TokenRing0
 ring-speed 16
 source-bridge 10 1 100
 source-bridge spanning 
!
interface Serial0
 ip address 1.1.1.2 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
!
interface Serial1
 ip address 2.2.2.2 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 clockrate 4000000
!
end

Vérifiez

Cette section fournit des informations qui vous permettront de vérifier que votre configuration fonctionne correctement. Toute les sortie de commande show de cette configuration est présentée. Il y a commentaire avec la sortie de commande pour vous aider à localiser d'importantes sections.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Cette section est divisée en ces paragraphes :

show dlsw circuits et sortie de commande LLC d'exposition

Dans cette section, le show dlsw circuits et la sortie de commande LLC d'exposition est présenté.

Routeur redondant principal DLSw
avimimus# show dlsw circuits
Index     local addr(lsap)   remote addr(dsap)  state     uptime
738197594 0000.4444.0000(04) 4000.3745.0000(04) CONNECTED 3d02h
335544411 0000.4444.0000(08) 4000.3745.0000(04) CONNECTED 3d02h
Total number of circuits connected: 2 

Les circuits de DLSw sont établis entre le MAC de station d'extrémité (0000.4444.0000) et le MAC hôte. La station d'extrémité n'indique pas réellement 4000.3745.0000, mais le routeur fait le mappage d'adresse MAC spécifié dans la commande de dlsw transparent map.

Routeur redondant principal DLSw
avimimus# show llc brief
LLC2 Connections: total of 3 connections
Et0 NORMAL 0000.aaaa.0000 0000.cccc.0000 94 94
Et0 NORMAL 0000.4444.0000 0000.6666.0000 04 04
Et0 NORMAL 0000.4444.0000 0000.6666.0000 04 08

La première session LLC est établie entre les Routeurs redondants d'Ethernets de DLSw utilisant une valeur de SAP de 0x94. Les adresses MAC pour les Routeurs de DLSw apparaissent dans le format non standard. Le pour en savoir plus, se rapportent à la section transparente de sortie de commande de dlsw d'exposition de ce document.

Les deux autres sessions LLC se rapportent quand les périphériques d'extrémité communiquent avec l'adresse MAC configurée dans le routeur. C'est-à-dire, 0000.6666.0000 est l'adresse DMAC configurée dans les stations d'extrémité. Toutes les sessions LLC semblent provenir des Ethernet 0 d'interface (Et0) ; cependant, les adresses MAC répertoriées après sont affichées dans le format non standard. Ils sont répertoriés cette manière pour une consultation plus facile aux commandes de dlsw d'exposition, qui affichent toutes les adresses MAC dans le format non standard.

Routeur redondant principal DLSw
avimimus# show llc 
LLC2 Connections: total of 3 connections
Ethernet0 DTE: 0000.aaaa.0000 0000.cccc.0000 94 94 state NORMAL
V(S)=5, V(R)=7, Last N(R)=5, Local window=7, Remote Window=127
akmax=3, n2=8, 
xid-retry timer 0/0 ack timer 0/1000 
p timer 0/1000 idle timer 9480/10000 
rej timer 0/3200 busy timer 0/9600 
akdelay timer 0/100 txQ count 0/200


Ethernet0 DTE: 0000.4444.0000 0000.6666.0000 04 04 state NORMAL
V(S)=1, V(R)=1, Last N(R)=1, Local window=7, Remote Window=127
akmax=3, n2=8, 
xid-retry timer 0/0 ack timer 0/1000 
p timer 0/1000 idle timer 8920/10000 
rej timer 0/3200 busy timer 0/9600 
akdelay timer 0/100 txQ count 0/200


Ethernet0 DTE: 0000.4444.0000 0000.6666.0000 04 08 state NORMAL
V(S)=1, V(R)=1, Last N(R)=1, Local window=7, Remote Window=127
akmax=3, n2=8, 
xid-retry timer 0/0 ack timer 0/1000 
p timer 0/1000 idle timer 9100/10000 
rej timer 0/3200 busy timer 0/9600 
akdelay timer 0/100 txQ count 0/200

Routeur redondant slave de DLSw
turbo# show dlsw circuits
Index      local addr(lsap)   remote addr(dsap)  state     uptime
2634022913 0000.8888.0000(08) 4000.3745.0000(04) CONNECTED 4d00h
Total number of circuits connected: 1


turbo# show llc brief
LLC2 Connections: total of 2 connections
Et0 NORMAL 0000.cccc.0000 0000.aaaa.0000 94 94
Et0 NORMAL 0000.8888.0000 0000.eeee.0000 04 08


turbo# show llc
LLC2 Connections: total of 2 connections
Ethernet0 DTE: 0000.cccc.0000 0000.aaaa.0000 94 94 state NORMAL
V(S)=7, V(R)=5, Last N(R)=7, Local window=7, Remote Window=127
akmax=3, n2=8, 
xid-retry timer 0/0 ack timer 0/1000 
p timer 0/1000 idle timer 7480/10000 
rej timer 0/3200 busy timer 0/9600 
akdelay timer 0/100 txQ count 0/200


Ethernet0 DTE: 0000.8888.0000 0000.eeee.0000 04 08 state NORMAL
V(S)=1, V(R)=1, Last N(R)=1, Local window=7, Remote Window=127
akmax=3, n2=8, 
xid-retry timer 0/0 ack timer 0/1000 
p timer 0/1000 idle timer 2410/10000 
rej timer 0/3200 busy timer 0/9600 
akdelay timer 0/100 txQ count 0/200

affichez à dlsw la sortie de commande transparente

Dans cette section, la sortie de commande transparente de dlsw d'exposition est présentée.

Routeur redondant principal DLSw
avimimus# show dlsw transparent neighbor
Interface Ethernet0
0000.cccc.0000 SELF Master
0000.aaaa.0000 Rcvd Master-Accepted VALID

La commande de show dlsw transparent neighbor affiche les voisins de DLSw dans un domaine partagé transparent. Toutes les adresses MAC répertoriées sont affichées dans le format non standard. Cependant, quand vous configurez le routeur voisin (avec la commande de dlsw transparent map), utilisez le format canonique. Le routeur Avimimus a la priorité la plus basse et ainsi est le routeur principal.

Routeur redondant principal DLSw
avimimus# show dlsw transparent cache

Interface Ethernet0
Circuit Cache

local addr(lsap)   remote addr(dsap)  state    Owner
0000.4444.0000(04) 4000.3745.0000(04) POSITIVE SELF
0000.4444.0000(08) 4000.3745.0000(04) POSITIVE SELF
0000.8888.0000(08) 4000.3745.0000(04) NEGATIVE 0000.aaaa.0000
Total number of circuits in the Cache: 3

La commande de show dlsw transparent cache affiche le cache du circuit principal pour le domaine d'émission. Ce routeur se rend compte de la connexion qui est établie sur le deuxième routeur ; ceci correspond à l'entrée identifiée par un état NÉGATIF.

Routeur redondant principal DLSw
avimimus# show dlsw transparent map 

Interface Ethernet0
LOCAL Mac      REMOTE MAC     BACKUP
---------      ----------     ------
0000.6666.0000 4000.3745.0000 0000.aaaa.0000 STATIC
0000.eeee.0000 4000.3745.0000 0000.aaaa.0000 DYNAMIC(Passive)

Dans la sortie précédente, le routeur se rend compte de la traduction spécifiée dans sa configuration (voir la CHARGE STATIQUE marquée par entrée) et également de l'entrée qui est configurée dans le deuxième routeur (DYNAMIQUE marqué d'entrée). L'adresse MAC LOCALE est l'adresse MAC qui doit être vers la fin les stations utilisées comme DMAC.

Le routeur exécute alors la traduction aux adresses MAC qui apparaissent sous la colonne REMOTE MAC. Le MAC DISTANT doit apparier la véritable adresse MAC de la destination distante à laquelle DLSw fournit la Connectivité.

La deuxième entrée est sur un état passif, ainsi il signifie que le deuxième routeur est actif et fournit sa propre traduction. Dans le cas d'une panne, Avimimus assure cette responsabilité.

Routeur redondant slave de DLSw
turbo# show dlsw transparent neighbor 

Interface Ethernet0
0000.aaaa.0000 SELF      Slave
0000.cccc.0000 Connected MASTER.



turbo# show dlsw transparent cache 

Interface Ethernet0
Circuit Cache 

local addr(lsap)   remote addr(dsap)     state    Owner
0000.8888.0000(08) 4000.3745.0000(04)    POSITIVE SELF
Total number of circuits in the Cache: 1


turbo# show dlsw transparent map 

Interface Ethernet0
LOCAL Mac      REMOTE Mac     BACKUP
---------      ----------     ------
0000.eeee.0000 4000.3745.0000 0000.cccc.0000 STATIC
0000.6666.0000 4000.3745.0000 0000.cccc.0000 DYNAMIC(Passive)

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Dépannage des commandes

Cette section présente le tout les mettent au point la sortie de commande de cette configuration. Le commentaire est inclus avec la sortie de commande pour vous aider à localiser d'importantes sections.

Remarque: Avant d'émettre des commandes de débogage, référez-vous aux informations importantes sur des commandes de debug.

Cette section est divisée en ces paragraphes :

sortie de commande transparente de debug dlsw pendant la panne simulée du routeur principal

Cette section présente au debug dlsw la sortie de commande transparente qui est générée pendant des pannes simulées du routeur principal.

  • maître transparent de debug dlsw — Affiche des messages de débogage liés aux événements maître-esclave.

  • circuits transparents de debug dlsw — Affiche des messages de débogage liés au cache du circuit principal pour le domaine partagé transparent.

  • adresse-MAP transparente de debug dlsw — Les messages de débogage d'affichages ont associé aux mappages d'adresse MAC sur le routeur local et à tous les mappages pour lesquels le routeur local agit en tant que sauvegarde pour un pair voisin.

Routeur redondant principal DLSw
avimimus# show debug
DLSw:
DLSw Ethernet Redundancy - Master debugging is on
DLSw Ethernet Redundancy - Circuits debugging is on
DLSw Ethernet Redundancy - Address Map debugging is on

Mar 5 18:07:10.039: DLSW-ER: Sending MP Frame
Mar 5 18:07:30.039: DLSW-ER: Sending MP Frame
Mar 5 18:07:40.039: DLSW-ER: Sending MP Frame
Mar 5 18:07:50.039: DLSW-ER: Sending MP Frame
Mar 5 18:08:00.047: DLSW-ER: Sending MP Frame
Mar 5 18:08:10.051: DLSW-ER: Sending MP Frame
Mar 5 18:08:20.051: DLSW-ER: Sending MP Frame
Mar 5 18:08:30.051: DLSW-ER: Sending MP Frame
Mar 5 18:08:40.051: DLSW-ER: Sending MP Frame
Mar 5 18:08:50.051: DLSW-ER: Sending MP Frame

Le routeur redondant principal DLSw envoie à une trame actuelle principale (de député britannique) toutes les 10 secondes.

Ici, une panne est introduite quand l'interface Ethernet est arrêtée :

Routeur redondant principal DLSw
avimimus# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
avimimus(config)# interface ethernet0
avimimus(config-if)# shut


Mar 5 18:09:00.951: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Active -> Init
Mar 5 18:09:02.951: %LINK-5-CHANGED: Interface Ethernet0, changed state to administratively down
Mar 5 18:09:02.951: DLSW-ER:dm_action_b: LLC2 session dead freeing neighbor 0000.aaaa.0000
Mar 5 18:09:02.951: DLSW-ER:Sourcing a TestFrame 0000.6666.0000 --> 0000.aaaa.0000 on Ethernet0
Mar 5 18:09:02.951: DLSW-ER:Sourcing a TestFrame 0000.eeee.0000 --> 0000.aaaa.0000 on Ethernet0
Mar 5 18:09:02.971: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:09:02.979: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:09:03.951: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed 
 state to down

Voici met au point pris du routeur asservi pendant la panne :

Routeur redondant slave de DLSw
turbo#
Mar 5 18:09:10.251: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Standby -> Active
Mar 5 18:09:10.583: DLSW-ER:dm_action_r: LLC2 session dead to neighbor 0000.cccc.0000 
Mar 5 18:09:10.587: DLSW-ER:Sourcing a TestFrame 0000.eeee.0000 --> 0000.cccc.0000 on Ethernet0
Mar 5 18:09:10.591: DLSW-ER:Sourcing a TestFrame 0000.6666.0000 --> 0000.cccc.0000 on Ethernet0
Mar 5 18:09:10.595: DLSW-ER: Sending MP Frame
Mar 5 18:09:10.595: DLSW-ER:dm_action_u: Freeing current master 0000.cccc.0000
Mar 5 18:09:10.599: DLSW-ER:dm_action_u: Changing state to Master
Mar 5 18:09:20.595: DLSW-ER: Sending MP Frame
Mar 5 18:09:30.595: DLSW-ER: Sending MP Frame

Dans la syntaxe précédente, Turbo va bien au routeur principal et assure également la traduction qui a été configurée dans le routeur d'Avimimus.

Voici met au point sur Turbo quand les stations d'extrémité qui sont connectées par le reattempt d'Avimimus la connexion à l'hôte :

Routeur redondant slave de DLSw
turbo#
Mar 5 18:09:40.595: DLSW-ER: Sending MP Frame
Mar 5 18:09:40.927: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:40.939: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:40.995: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:40.995: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:09:40.999: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.4444.0000:4

Dans la syntaxe précédente, vous voyez que Turbo remplit les traductions exigées (qu'ont été précédemment possédés par Avimimus) pour installer la première session LLC du contrôleur R. Cette session utilise le LSAP 0x04 et RSAP 0x04.

Routeur redondant slave de DLSw
Mar 5 18:09:41.963: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:41.975: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:41.979: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:09:41.983: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.4444.0000:8

Dans la syntaxe précédente, vous voyez que Turbo remplit les traductions exigées (qu'ont été précédemment possédés par Avimimus) pour installer la deuxième session LLC du contrôleur R. Cette session utilise le LSAP 0x08 et RSAP 0x04.

Routeur redondant slave de DLSw
Mar 5 18:09:41.991: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:41.995: DLSW-ER:CSM->MS: C_INQ:PENDING: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:09:41.999: DLSW-ER:MS->CSM:UGotIt 4000.3745.0000:4 0000.4444.0000:4

Le premier circuit de DLSw a été établi, indiqué par l'expression d'UGotIt.

Routeur redondant slave de DLSw
Mar 5 18:09:42.003: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 ---> 
 0000.6666.0000
Mar 5 18:09:42.971: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:42.975: DLSW-ER:CSM->MS: C_INQ:PENDING: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:09:42.983: DLSW-ER:MS->CSM:UGotIt 4000.3745.0000:4 0000.4444.0000:8

Le deuxième circuit de DLSw est terminé.

Routeur redondant slave de DLSw
Mar 5 18:09:42.987: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 ---> 
 0000.6666.0000
Mar 5 18:09:50.595: DLSW-ER: Sending MP Frame

Voici toutes les commandes de DLSw qui indiquent que Turbo a succédé Avimimus et que tous les circuits sont connectés par Turbo :

Routeur redondant slave de DLSw
turbo# show dlsw transparent cache
Interface Ethernet0
Circuit Cache
local addr(lsap)   remote addr(dsap)  state    Owner
0000.4444.0000(04) 4000.3745.0000(04) POSITIVE SELF
0000.4444.0000(08) 4000.3745.0000(04) POSITIVE SELF
0000.8888.0000(08) 4000.3745.0000(04) POSITIVE SELF
Total number of circuits in the Cache: 3

turbo# show dlsw transparent map 

Interface Ethernet0
LOCAL Mac      REMOTE Mac     BACKUP
---------      ----------     ------
0000.eeee.0000 4000.3745.0000 0000.cccc.0000 STATIC
0000.6666.0000 4000.3745.0000 0000.cccc.0000 DYNAMIC(Active)

Dans la syntaxe précédente, vous pouvez voir que le statut de la deuxième traduction est maintenant DYNAMIC(Active), qui indique qu'Avimimus doit être vers le bas.

Routeur redondant slave de DLSw
turbo# show dlsw circuits
Index       local addr(lsap)    remote addr(dsap)   state     uptime
4009754676  0000.4444.0000(04) 4000.3745.0000(04) CONNECTED  00:01:05
1610612789  0000.4444.0000(08) 4000.3745.0000(04) CONNECTED  00:01:04
2634022913  0000.8888.0000(08) 4000.3745.0000(04) CONNECTED  4d01h
Total number of circuits connected: 3

sortie de commande transparente de debug dlsw pendant la reprise du routeur principal

Cette section présente au debug dlsw la sortie de commande transparente qui est générée pendant la reprise du routeur principal.

Routeur redondant principal DLSw
avimimus# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
avimimus(config)# interface ethernet0
avimimus(config-if)# no shut

Mar 5 18:12:00.087: DLSW-ER: Sending MP Frame
Mar 5 18:12:03.127: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up
Mar 5 18:12:03.595: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Listen -> Active
Mar 5 18:12:04.127: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed 
 state to up
Mar 5 18:12:10.087: DLSW-ER: Sending MP Frame
Mar 5 18:12:10.599: DLSW-ER: New neighbor: master 0000.cccc.0000, neighbor 0000.aaaa.0000
Mar 5 18:12:10.599: DLSW-ER:dm_action_a: Rcvd MP with worse priority from 0000.aaaa.0000
Mar 5 18:12:10.607: DLSW-ER:dm_action_l: LLC2 up for neighbor 0000.aaaa.0000
Mar 5 18:12:10.607: DLSW-ER: Sending MC to 0000.aaaa.0000
Mar 5 18:12:10.615: DLSW-ER:dm_action_d: Received MA from neighbor 0000.aaaa.0000 

Dans la syntaxe précédente, Avimimus a reçu un maître reçoivent le message (mA) de Turbo, qui confirme cet Avimimus est maintenant le nouveau maître.

Ici, les deux Routeurs permutent BACKMEUP_REQ pour les mappages pour lesquels ils sont configurés. Chaque demande doit être suivie par un ACK.

Routeur redondant slave de DLSw
Mar 5 18:12:10.615: DLSW-ER: Sending BACKMEUP_REQ 0000.6666.0000 --> 4000.3745.0000 to 
 neighbor 0000.aaaa.0000 (617321C8)
Mar 5 18:12:10.615: DLSW-ER: Sending DN to 0000.aaaa.0000
Mar 5 18:12:10.623: DLSW-ER:Rcvd BACKMEUP_REQ from 0000.aaaa.0000 for map entry 0000.eeee.0000 
 --> 4000.3745.0000
Mar 5 18:12:10.623: DLSW-ER: Sending BACKMEUP_ACK 0000.eeee.0000 --> 4000.3745.0000 to 
 neighbor 0000.aaaa.0000 (617321C8)
Mar 5 18:12:10.651: DLSW-ER:dm_action_f: Rcvd CO from 0000.aaaa.0000
Mar 5 18:12:10.667: DLSW-ER:Rcvd BACKMEUP_REQ from 0000.aaaa.0000 for mapentry 0000.eeee.0000 
 --> 4000.3745.0000
Mar 5 18:12:10.667: DLSW-ER: Sending BACKMEUP_ACK 0000.eeee.0000 --> 4000.3745.0000 to 
 neighbor 0000.aaaa.0000 (617321C8)
Mar 5 18:12:19.731: DLSW-ER:dm_action_h: Rcvd CG <- 
 0000.aaaa.0000 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:12:19.735: DLSW-ER:dm_action_h: Rcvd CG <- 
 0000.aaaa.0000 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:12:20.087: DLSW-ER: Sending MP Frame
Mar 5 18:12:20.647: DLSW-ER:Rcvd BACKMEUP_ACK from 0000.aaaa.0000 for mapentry 0000.6666.0000 
 --> 4000.3745.0000
Mar 5 18:12:20.647: DLSW-ER:Sourcing a TestFrame 0000.6666.0000 --> 0000.aaaa.0000 on Ethernet0
Mar 5 18:12:30.087: DLSW-ER: Sending MP Frame

Voici met au point pris de Turbo quand le routeur principal Avimimus monte :

Routeur redondant slave de DLSw
turbo#
Mar 5 18:12:00.595: DLSW-ER: Sending MP Frame
Mar 5 18:12:03.603: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Active -> Speak
Mar 5 18:12:10.087: DLSW-ER: New neighbor: master 0000.aaaa.0000, neighbor 0000.cccc.0000
Mar 5 18:12:10.091: DLSW-ER:dm_action_o: Rcvd MP with better priority: 0000.cccc.0000
Mar 5 18:12:10.595: DLSW-ER: Sending MP Frame
Mar 5 18:12:10.611: DLSW-ER:dm_action_l: LLC2 up for neighbor 0000.cccc.0000
Mar 5 18:12:10.611: DLSW-ER: Sending MA to 0000.cccc.0000

Turbo reconnaît le message d'Avimimus, et alors Turbo devient l'esclave.

Routeur redondant slave de DLSw
Mar 5 18:12:10.615: DLSW-ER: Sending BACKMEUP_REQ 0000.eeee.0000 --> 4000.3745.0000 
 to neighbor 0000.cccc.0000 (45B47C)
Mar 5 18:12:10.623: DLSW-ER:dm_action_c: Rcvd MC with better priority from 0000.cccc.0000
Mar 5 18:12:10.627: DLSW-ER:dm_action_c: Changing state: Master to Slave

Turbo va bien au routeur asservi.

Routeur redondant slave de DLSw
Mar 5 18:12:10.627: DLSW-ER:Rcvd BACKMEUP_REQ from 0000.cccc.0000 for mapentry 0000.6666.0000 
 --> 4000.3745.0000
Mar 5 18:12:10.635: DLSW-ER:calling admin_stop for ckt(0000.4444.0000(4) 4000.3745.0000(4)) with 
 lmac 0000.6666.0000
Mar 5 18:12:10.643: DLSW-ER:calling admin_stop for ckt(0000.4444.0000(8) 4000.3745.0000(4)) with 
 lmac 0000.6666.0000

Dans la syntaxe précédente, Turbo termine les circuits de DLSw qui doivent être possédés par Avimimus. (Les circuits doivent être déchirés en bas de quand le maître se réactive.) Cet arrêt se produit après que Turbo reçoive le BACKMEUP_REQ d'Avimimus.

Routeur redondant slave de DLSw
Mar 5 18:12:10.643: DLSW-ER: dm_action_n: Rcvd DN frame from 0000.cccc.0000
Mar 5 18:12:10.647: DLSW-ER:Sending CO frame # 0 to 0000.cccc.0000
Mar 5 18:12:10.651: DLSW-ER:Rcvd BACKMEUP_ACK from 0000.cccc.0000 for mapentry 0000.eeee.0000 
 --> 4000.3745.0000
Mar 5 18:12:10.655: DLSW-ER:Sourcing a TestFrame 0000.eeee.0000 --> 0000.cccc.0000 on Ethernet0
Mar 5 18:12:10.659: DLSW-ER:dm_action_s: LLC2 session up to neighbor 0000.cccc.0000
Mar 5 18:12:10.659: DLSW-ER: Sending BACKMEUP_REQ 0000.eeee.0000 --> 4000.3745.0000 
 to neighbor 0000.cccc.0000 (45B47C)
Mar 5 18:12:10.671: DLSW-ER:Rcvd BACKMEUP_ACK from 0000.cccc.0000 for mapentry 0000.eeee.0000 
 --> 4000.3745.0000
Mar 5 18:12:10.675: DLSW-ER:Sourcing a TestFrame 0000.eeee.0000 --> 0000.cccc.0000 on Ethernet0
Mar 5 18:12:13.603: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Speak -> Standby
Mar 5 18:12:19.723: DLSW-ER:CG -> 0000.cccc.0000: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:12:19.727: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:12:19.731: DLSW-ER:CG -> 0000.cccc.0000: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:12:19.735: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:12:20.643: DLSW-ER: Sending BACKMEUP_ACK 0000.6666.0000 --> 4000.3745.0000 
 to neighbor 0000.cccc.0000 (45B47C)

turbo# show dlsw circuits
Index        local addr(lsap)    remote addr(dsap)   state     uptime
2634022913  0000.8888.0000(08)   4000.3745.0000(04) CONNECTED  4d01h
Total number of circuits connected: 1

Sont présentés dans la syntaxe ici met au point qui se produisent quand l'essai de stations d'extrémité pour rétablir la connexion. Avimimus est sauvegardent pour servir de routeur principal.

Routeur redondant principal DLSw
avimimus#
Mar 5 18:12:40.071: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:12:40.071: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:12:40.079: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:12:40.079: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:12:40.079: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:12:40.087: DLSW-ER: Sending MP Frame
Mar 5 18:12:41.071: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:12:41.075: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:12:41.075: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:12:41.075: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:12:41.079: DLSW-ER:MS->CSM:UGotIt 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:12:41.079: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 ---> 
 0000.6666.0000
Mar 5 18:12:42.075: DLSW-ER:MS->CSM:UGotIt 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:12:42.075: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 ---> 
 0000.6666.0000


avimimus# show dlsw circuits
Index        local addr(lsap)    remote addr(dsap)   state     uptime
3070230625  0000.4444.0000(04)  4000.3745.0000(04) CONNECTED  00:00:08
4194304098  0000.4444.0000(08)  4000.3745.0000(04) CONNECTED  00:00:08
Total number of circuits connected: 2

sortie de commande transparente de debug dlsw pendant l'établissement de circuit de DLSw de routeur asservi

Cette section présente au debug dlsw la sortie de commande transparente qui est générée quand le routeur asservi tente d'évoquer un circuit de DLSw.

Il est utile d'examiner la transmission entre l'esclave et le maître avant que l'esclave reçoive l'autorisation de recevoir le circuit.

Le scénario est simulé quand le circuit existant de DLSw est effacé sur le routeur asservi.

Routeur redondant slave de DLSw
turbo# show dlsw circuits
Index        local addr(lsap)    remote addr(dsap)   state     uptime
2634022913  0000.8888.0000(08)  4000.3745.0000(04) CONNECTED   4d02h
Total number of circuits connected: 1


turbo# clear dlsw circuits 2634022913
turbo#
Mar 5 20:02:37.426: DLSW-ER:CG -> 0000.cccc.0000: 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:02:37.430: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.8888.0000:8 

Turbo indique le routeur principal effacer son entrée de cache pour le circuit juste-effacé.

Routeur redondant slave de DLSw
Mar 5 20:03:07.398: DLSW-ER:Replacing dmac 0000.eeee.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 20:03:07.462: DLSW-ER:Replacing dmac 0000.eeee.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 20:03:07.466: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:03:07.470: DLSW-ER:IW -> 0000.cccc.0000: 4000.3745.0000:4 0000.8888.0000:8

Turbo reçoit une demande en entrée du périphérique d'extrémité de se connecter à l'hôte d'extrémité. À 20:03:07.470, Turbo informe le routeur principal de cette demande.

Routeur redondant slave de DLSw
Mar 5 20:03:07.474: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:03:08.458: DLSW-ER:Replacing dmac 0000.eeee.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 20:03:08.462: DLSW-ER:CSM->MS: C_INQ:PENDING: 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:03:08.474: DLSW-ER:dm_action_k: Rcvd UG for 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:03:08.478: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 ---> 
 0000.eeee.0000

Turbo obtient un ug de son maître, et le circuit est évoqué.

Routeur redondant slave de DLSw
turbo# show dlsw circuits
Index        local addr(lsap)    remote addr(dsap)   state     uptime
385876023   0000.8888.0000(08)  4000.3745.0000(04) CONNECTED  00:00:33
Total number of circuits connected: 1

Voici les données prises au routeur principal lorsque les tentatives d'esclave d'évoquer le circuit.

Routeur redondant principal DLSw
avimimus# show dlsw circuits
Index        local addr(lsap)    remote addr(dsap)   state     uptime
3070230625  0000.4444.0000(04)  4000.3745.0000(04) CONNECTED  01:49:13
4194304098  0000.4444.0000(08)  4000.3745.0000(04) CONNECTED  01:49:13
Total number of circuits connected: 2


avimimus# show dlsw transparent cache
Interface Ethernet0
Circuit Cache

local addr(lsap)        remote addr(dsap)     state     Owner
0000.4444.0000(04)     4000.3745.0000(04)   POSITIVE    SELF
0000.4444.0000(08)     4000.3745.0000(04)   POSITIVE    SELF
0000.8888.0000(08)     4000.3745.0000(04)   NEGATIVE    0000.aaaa.0000
Total number of circuits in the Cache: 3

Mar 5 20:02:37.433: DLSW-ER:dm_action_h: Rcvd CG <- 
 0000.aaaa.0000 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:02:41.409: DLSW-ER: Sending MP Frame
Mar 5 20:02:51.409: DLSW-ER: Sending MP Frame
Mar 5 20:03:01.417: DLSW-ER: Sending MP Frame
Mar 5 20:03:07.473: DLSW-ER:dm_action_j: Rcvd IW <- 
 0000.aaaa.0000 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:03:08.473: DLSW-ER:UG -> 0000.aaaa.0000: 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:03:11.421: DLSW-ER: Sending MP Frame
Mar 5 20:03:21.421: DLSW-ER: Sending MP Frame
Mar 5 20:03:31.421: DLSW-ER: Sending MP Frame
Mar 5 20:03:41.421: DLSW-ER: Sending MP Frame
Mar 5 20:03:51.421: DLSW-ER: Sending MP Frame
avimimus#un all

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 12345