Interfaces et modules Cisco : Processeurs d'interface à attachement canal Cisco

Exécution d'OROUTED pour l'échange de mises à jour de routage RIP

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document donne un exemple de la configuration exigée sur le routeur et sur le mainframe pour permuter des mises à jour de routage de RIP par le recours à la procédure OROUTED. OROUTED est une procédure qui fonctionne sur le mainframe et qui remplit essentiellement la même fonction que quand vous exécutez le démon CONDUIT sur un hôte UNIX. Passages OROUTED de l'espace d'adressage d'OpenEdition/plusieurs mémoire virtuelle (OMVS) ou comme tâche commencée.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Cette configuration a été développée et testée avec les versions de logiciel et de matériel suivantes :

  • Version de logiciel 12.1(2) de Ý de Cisco IOS avec le microcode xcpa27-7 de l'adaptateur de port de la Manche de mainframe (XCPA).

    C'était la dernière version du code libérée alors, mais ces caractéristiques devraient être prises en charge dans toutes les versions majeures actuellement mises à jour de code.

  • Le routeur est un Cisco 7206 avec un PCPA (adaptateur de port de canal parallèle).

OROUTED exige ces deux fichiers de configuration sur le mainframe dans l'espace d'adressage OMVS, avec les variables d'environnement qui indiquent leur emplacement :

  • exportation ROUTED_PROFILE=/etc/orouted.profile

  • exportation RESOLVER_CONF=/etc/resolv.conf

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

Afin de commencer OROUTED, émettez ces commandes d'OMVS :

cd /usr/lpp/tcpip/sbin

orouted

Sur la console MVS, vous pouvez émettre cette commande afin de trouver le nombre de processus du processus OROUTED :

d omvs,u=p390

Remarque:  p390 est l'identification de connexion sous laquelle OROUTED a été commencé.

Vous pouvez également commencer le processus OROUTED par le langage de commandes (JCL), comme une tâche commencée. Si vous le commencez à partir d'OMVS, changez le port 520 dans l'ensemble de données de profil TCP/IP à OMVS.

Ce sont des exemples des ensembles de données :

/etc/orouted.profile
RIP_SUPPLY_CONTROL: RIP1
RIP_RECEIVE_CONTROL: ANY
RIP2_AUTHENTICATION_KEY:
/etc/resolv.conf
TCPIPJobName TCPIP
DomainOrigin cisco.com
domain cisco.com
Datasetprefix TCPIP
HostName P390
Messagecase mixed

TCP/IP profile dataset configuration changes
--------------------------------------------

; ----------------------------------------------------------------------- ;

;
orouted Routing Information
;
; if you are using orouted, comment out the GATEWAY statement and
; update the BSDROUTINGPARMS statement to reflect your installation
; configuration and remove the semicolon
;
;    Link     Maxmtu   Metric   Subnet Mask      Dest Addr
BSDROUTINGPARMS false
LDIPTG         1500       0     255.255.255.240  10.64.3.33
VIPALINK       1500       0     255.255.255.240  0
ENDBSDROUTINGPARMS
; -----------------------------------------------------------------------
RIP

Configuration

Routeur du processeur d'interface à attachement canal (CIP)
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname diplodocus
!
boot system flash slot1:c7200-a3js-mz.121-2.bin
!
!
!
!
!
microcode pcpa slot1:xcpa27-9
microcode reload
!
interface Channel2/0
ip address 10.64.3.33 255.255.255.240
no keepalive
csna 0100 41
csna 0100 42
cmpc 0100 24 DIPTG READ
cmpc 0100 25 DIPTG WRITE
lan TokenRing 0
source-bridge 4 1 1
adapter 0 4000.0000.0001
adapter 1 4000.0000.0002
adapter 2 4000.0000.0003
adapter 3 4000.0000.0004
adapter 4 4000.0000.0005
lan TokenRing 1
source-bridge 5 1 1
adapter 7 4000.0000.0001
tn3270-server
pu PU1	    01712444 10.64.3.35      token-adapter 1  04 rmac
4000.0000.0001   lu-seed DIPL###
pu PU2	    01712555 10.64.3.36      token-adapter 1  08 rmac
4000.0000.0001   lu-seed DIPL2##
tg DIPTG    ip 10.64.3.34 10.64.3.33 broadcast
!
!
router eigrp 1
redistribute rip
passive-interface Channel2/0
network 10.0.0.0
passive-interface Ethernet6/1
passive-interface Ethernet6/3
network 10.0.0.0
!
no auto-summary
!
router rip
redistribute eigrp 1
passive-interface Serial1/3
  
 passive-interface TokenRing5/0

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 12258