Interfaces et modules Cisco : Processeurs d'interface à attachement canal Cisco

Configuration d'OMPROUTE pour une exécution sur l'ordinateur central

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document trace les grandes lignes de l'hôte et des configurations de routeur d'échantillon pour exécuter la procédure OMPROUTE sur le mainframe pour permuter des mises à jour de routage avec le reste du réseau TCP/IP. OMPROUTE est employé souvent, comme indiqué dans cet exemple, en même temps qu'une adresse IP virtuelle (VIPA), qui permet l'adresse IP du mainframe configuré dans les clients pour être indépendant de n'importe quelle une interface à attachement canal. Ceci fournit la Redondance pour le canal. Initialement, l'implémentation TCP/IP du mainframe d'IBM a seulement pris en charge le Protocole RIP (Routing Information Protocol) comme protocole de routage, avec le recours à la procédure OROUTED. L'OMPROUTE plus nouvel prend en charge le RIP V1 ou le V2 et le Protocole OSPF (Open Shortest Path First). IBM recommande qu'OMPROUTE soit utilisé plutôt qu'OROUTED, et IBM enlèvera par la suite le soutien d'OROUTED.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

La version logicielle de Cisco IOSÝ qui a été utilisée pour cette configuration était 12.1(3a)T2 avec le microcode 27-9 de xCPA, qui était le plus tardif alors ceci a été testée. Si vous utilisez la GRIFFE, cependant, ceci devrait fonctionner avec n'importe quelle version de logiciel de Cisco IOS. L'utilisation de CMPC+ exige un minimum de version du logiciel Cisco IOS 12.1T.

Le routeur était un Cisco 7206 avec un adaptateur de port de xCPA. Alternativement, un routeur de Cisco 7500 avec une carte CIP pourrait être utilisé avec des modifications mineures dans la configuration, comme remarquable plus tard dans ce document.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurations

Configuration de mainframe - Fichiers OMPROUTE

La configuration d'OMPROUTE sur le mainframe est très semblable à la configuration d'OROUTED. OMPROUTE utilise également un minimum de deux fichiers de configuration. Vous devez indiquer l'emplacement de ces fichiers de configuration, dans l'espace d'adressage OMVS, avec ces deux variables d'environnement :

  • exportation resolver_conf=/etc/resolv.conf

  • exportation omproute_file=/etc/omproute.conf

C'est un exemple du contenu du resolver_conf :

TCPJobName TCPIP
DomainOrigin cisco.com
domain cisco.com
Datasetprefix TCPIP
HostName P390
Messagecase mixed

L'omproute_file dépendra de si le RIP ou l'OSPF est utilisé. C'est un exemple de configuration pour le RIP :

;
Originate_RIP_Default Condition=Always Cost=1
;
RIP_Interface IP_Address=10.64.3.34
Name=LDIPTG
Subnet_Mask=255.255.255.240
Receive_Dynamic_Nets=YES
Receive_Dynamic_Subnets=YES
MTU=1470
Destination_Addr=10.64.3.33
;
RIP_Interface IP_Address=10.64.3.17
Name=VIPALINK
Subnet_Mask=255.255.255.240
MTU=1470
;

Pour l'OSPF, il y a plus d'options de configuration disponibles, qui incluent la capacité de faire le mainframe agir en tant que zone d'extrémité. Ceci peut de manière significative réduire les mises à jour de routage de chargement qui sont placées sur le canal quand beaucoup de partitions logiques (LPARs) se connectent au-dessus du même canal. Voici un exemple :

Area Area_Number=0.0.0.0 Authentication_Type=None Stub_Area=NO
;
Comparison=Type2
;
AS_Boundary_Routing Import_Subnet_Routes=YES
Import_Direct_Routes=YES
;
OSPF_Interface IP_Address=10.64.3.34
Name=LDIPTG
Subnet_Mask=255.255.255.240
Attaches_To_Area=0.0.0.0
MTU=1470
Destination_Addr=10.64.3.33
Hello_Interval=30
Dead_Router_Interval=120
;
OSPF_Interface IP_Address=10.64.3.17
Name=VIPALINK
Subnet_Mask=255.255.255.240

Configuration de mainframe - Pile TCP/IP

L'ensemble de données de profil TCP/IP n'exige aucune configuration spéciale pour OMPROUTE, autre que le fait que vous devez commenter toute les configuration de charge statique et de default route et la section BSDROUTINGPARMS (qui est seulement utilisée par OROUTED). Cet extrait affiche seulement ce qui doit être commenté et les paramètres auxquels les fichiers de configuration OMPROUTE se réfèrent :

TCPIP Profile dataset
---------------------
 -----------------------------------------------------------------------
; Hardware definitions:
 -----------------------------------------------------------------------
; NOTE: To use these device and link statements, update the statements
; to reflect your installation configuration and remove the semicolon
;
DEVICE DIPTG MPCPTP
LINK LDIPTG MPCPTP DIPTG
DEVICE VIPADEV VIRTUAL 0
LINK VIPALINK VIRTUAL 0 VIPADEV
;
;
; -----------------------------------------------------------------------
;
; HOME Internet (IP) addresses of each link in the host.
;
; NOTE: To use this home statement, update the ipaddress and linknames 
; to reflect your installation configuration and remove the semicolon
;
HOME
10.64.3.17    VIPALINK
10.64.3.34    LDIPTG
; -----------------------------------------------------------------------
;
; IP routing information for the host.	All static IP routes should
; be added here.
;
; NOTE: To use this GATEWAY statement, update the addresses and links
; to reflect your installation configuration and remove the semicolon
;
; GATEWAY
;
; Direct Routes - Routes that are directly connected to my interfaces.
;
; Network  First Hop  Link Name Packet Size  Subnet Mask  Subnet Value
; 10           =       CIS1      1500       0.255.255.0    0.101.1
; 10           =       LDIPTG    1500       0.255.255.240  0.64.3.32
; 9            =       LIS1      1500       0.255.255.0    0.117.56.0
; 130.50       =       TR1       2000       0.0.255.0      0.0.10.0
; 193.5.2      =       ETH1      1500       0
; 9            =       FDDI1     4000       0.255.255.0    0.67.43.0
; 193.7.2.2    =       SNA1      2000       HOST
;
; Indirect Routes - Routes that are reachable through routers on my
;		    network.
;
; Network     First Hop   Link Name Packet Size  Subnet Mask  Subnet Value
; DEFAULTNET  10.64.3.33  LDIPTG    DEFAULTSIZE  0
; 193.12.2    130.50.10.1 TR1       2000         0
; 10.5.6.4    193.5.2.10  ETH1      1500         HOST
;
; Default Route - All packets to an unknown destination are routed
;		  through this route.
;
; Network     First Hop   Link Name Packet Size  Subnet Mask  Subnet Value
; DEFAULTNET  9.67.43.1   FDDI1     DEFAULTSIZE  0
;
; -----------------------------------------------------------------------
;
; orouted Routing Information
;
; if you are using orouted, comment out the GATEWAY statement and
; update the BSDROUTINGPARMS statement to reflect your installation
; configuration and remove the semicolon
;
;    Link     Maxmtu   Metric   Subnet Mask     Dest Addr
; BSDROUTINGPARMS false
; LDIPTG       1500       0     255.255.255.240 10.64.3.33
; VIPALINK     1500       0     255.255.255.240 0
;    TR1       2000       0     255.255.255.0   0
;    ETH1      1500       0     255.255.255.0   0
;    FDDI1  DEFAULTSIZE   0     255.255.255.0   0
; ENDBSDROUTINGPARMS

!--- Note that all of the last two sections have been commented out.

Configuration de mainframe - TCP/IP de définitions et de commencer vtam

L'acheminement des mises à jour peut être permuté au-dessus des connexions de GRIFFE ou CMPC+. Si vous utilisez la GRIFFE, aucune configuration supplémentaire n'est exigée sur le mainframe. Cet exemple utilise le CMPC, qui exige une entrée de la liste de ressource en transport vtam (circuit de logique à couplage transistor-résistance). C'est le membre vtam :

DIPTGTRL VBUILD TYPE=TRL
*
*
DIPTG	 TRLE  LNCTL=MPC,MAXBFRU=16,READ=(E24),WRITE=(E25)
*

Le circuit de logique à couplage transistor-résistance doit être lancé avant la tâche commencée par TCPIP est commencé. Exemple :

V NET,ACT,ID=DIPTRL1,UPDATE=ALL
IST097I VARY ACCEPTED
ISTTRL ACTIVE

Puis, lancez la tâche commencée par TCP/IP avec la commande de console S TCPIP MVS. Une fois que la tâche commencée par TCP/IP s'exécute, la procédure OMPROUTE peut être commencée, l'un ou l'autre par l'utilisation du langage de commandes (JCL) comme tâche commencée ou de l'espace d'adressage OMVS. Pour commencer dans OMVS, émettez ces commandes :

cd /usr/lpp/tcpip/sbin

omproute &

Pour vérifier qu'OMPROUTE s'exécute, émettez cette commande de console, où p390 est l'user-id sous lequel le démon OMPROUTE a été commencé :

d omvs,u=p390

Configuration du routeur

La GRIFFE et le CMPC doivent être spécifiquement configurés pour envoyer des émissions au-dessus du canal, avec le mot clé broadcast. Par exemple, pour la GRIFFE :

claw 0100 20 10.101.1.10 P390D C7000D TCPIP TCPIP broadcast

Dans cet exemple, CMPC+ est en service, ainsi ce sont les éléments pertinents de la configuration de routeur :

!
interface Channel2/0
 ip address 10.64.3.33 255.255.255.240
 ip ospf network point-to-multipoint
 no keepalive
 cmpc 0100 24 DIPTG READ
 cmpc 0100 25 DIPTG WRITE
 tg DIPTG    ip 10.64.3.34 10.64.3.33 broadcast
 router ospf 1
  network 10.0.0.0 0.255.255.255 area 0
!

Si c'avait été un routeur de Cisco 7500 avec une carte CIP au lieu des 7200 avec un adaptateur de port de xCPA, la déclaration tg aurait été configurée sous l'interface virtuelle de /2. Notez la commande point-à-multipoint d'ip ospf network, qui est exigée pour que l'OSPF fonctionne correctement. L'interface à attachement canal est considérée une interface multipoint tout comme le Relais de trames. Si vous ne souhaitez pas exécuter l'OSPF dans tout votre réseau, vous pouvez l'exécuter seulement sur l'interface à attachement canal elle-même et utiliser la redistribution entre d'autres protocoles de routage. Exemple :

!
router eigrp 1
 redistribute ospf 1
 passive-interface Channel2/0
 network 10.0.0.0
 no eigrp log-neighbor-changes
!
router ospf 1
 log-adjacency-changes
 redistribute eigrp 1
 network 10.64.3.33 0.0.0.0 area 0
!

Affichages sur le routeur

diplodocus# show extended channel 2/0 status

Path: 0100  -- ESTABLISHED
       Command    Selective   System     Device    CU
Dev    Connects    Retries    Cancels    Reset    Reset    Errors    Busy
24        30         21          1         0        0        0        0
25        29         0           1         0        0        0        0
Blocks         Bytes         Dropped Blk         Memd
Dev-Lnk    Read    Write    Read    Write    Read    Write    wait    Con
24-00       29       6      3484     789      0        0       0       Y
25-00        9      29       801    3920      0        0       0       Y
Path 0100
Total:      38      35      4285    4709      0        0       0
Last statistics 0 seconds old, next in 10 seconds

diplodocus# show extended channel 2/0 cmpc

Path    Dv    TGName    Dir    Bfrs     Status
CMPC   0100     24     DIPTG  READ  16  Active+
CMPC   0100     25     DIPTG  WRITE 16  Active+

diplodocus# show ip ospf i

Channel2/0 is up, line protocol is up
Internet Address 10.64.3.33/28, Area 0
Process ID 1, Router ID 200.100.100.9, Network Type POINT_TO_MULTIPOINT,
Cost: 4
Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
Hello due in 00:00:10
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 10.64.3.17
Suppress hello for 0 neighbor(s)

diplodocus# show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address       Interface
10.64.3.17       1    FULL/  -        00:01:35
Neighbor is up for 00:04:01           10.64.3.34  Channel2/0

diplodocus# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 10.64.3.1 to network 0.0.0.0
1.0.0.0/27 is subnetted, 1 subnets
C	1.1.1.0 is directly connected, Loopback1
200.100.100.0/29 is subnetted, 1 subnets
C	200.100.100.8 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 9 subnets, 3 masks
D	10.0.0.0/8 is a summary, 00:06:40, Null0
C	10.64.3.0/28 is directly connected, Ethernet6/0
O E2	10.64.3.17/32 [110/1] via 10.64.3.34, 00:03:57, Channel2/0
O	10.64.3.16/28 [110/5] via 10.64.3.34, 00:03:57, Channel2/0
C	10.64.3.32/28 is directly connected, Channel2/0
S	10.64.3.34/32 [1/0] via 10.64.3.34, Channel2/0
S	10.64.3.37/32 [1/0] via 10.64.3.37, Channel2/0
C	10.64.3.48/28 is directly connected, Serial1/3.1
C	10.64.3.128/28 is directly connected, Serial1/3.2
S*   0.0.0.0/0 [1/0] via 10.64.3.1

Affichages sur le mainframe

Affichages vtam sur la console système

D NET,TRL

IST097I DISPLAY ACCEPTED
ST350I DISPLAY TYPE = TRL 042
IST1314I TRLE = DIPTG	  STATUS = ACTIV       CONTROL = MPC
IST1454I 1 TRLE(S) DISPLAYED
IST314I END

D NET,TRL,TRLE=DIPTG

IST097I DISPLAY ACCEPTED
IST075I NAME = DIPTG, TYPE = TRLE 045
IST486I STATUS= ACTIV, DESIRED STATE= ACTIV
IST087I TYPE = LEASED		  , CONTROL = MPC , HPDT = YES
IST1715I MPCLEVEL = HPDT       MPCUSAGE = SHARE
IST1577I HEADER SIZE = 4092 DATA SIZE = 60 STORAGE = ***NA***
IST1221I WRITE DEV = 0E25 STATUS = ACTIVE     STATE = ONLINE
IST1577I HEADER SIZE = 4092 DATA SIZE = 60 STORAGE = DATASPACE
IST1221I READ  DEV = 0E24 STATUS = ACTIVE     STATE = ONLINE
IST314I END

Les affichages d'informations de routage sous la TSO du netstat commandent

l'artère de netstat affiche la table de routage. Exemple :

===> netstat route

EZZ2350I MVS TCP/IP NETSTAT CS V2R7       TCPIP NAME: TCPIP       15:56:33
EZZ2755I Destination       Gateway       Flags  Refcnt  Interface
EZZ2756I -----------       -------       -----  ------  ---------
EZZ2757I 10.0.0.0          10.64.3.33    UG     000000  LDIPTG
EZZ2757I 10.64.3.32        0.0.0.0       U      000000  LDIPTG
EZZ2757I 10.64.3.33        0.0.0.0       UH     000000  LDIPTG

le périphérique de netstat affiche le statut et ainsi de suite de tous les périphériques connectés ou liens. Exemple :

===> netstat device

EZZ2350I MVS TCP/IP NETSTAT CS V2R7	  TCPIP NAME: TCPIP	   15:58:04
EZZ2760I DevName: LOOPBACK	    DevType: LOOPBACK  DevNum: 0000
EZZ2761I   LnkName: LOOPBACK	      LnkType: LOOPBACK    Status: Ready
EZZ2762I     NetNum: 0	 QueSize: 0   ByteIn: 0000004278   ByteOut: 0000004278
EZZ2768I   BSD Routing Parameters:
EZZ2769I     MTU Size: 00000		 Metric: 00
EZZ2770I     DestAddr: 0.0.0.0		 SubnetMask: 0.0.0.0
EZZ2810I   Multicast Specific:
EZZ2811I     Multicast Capability: No
EZZ2760I DevName: DIPTG 	    DevType: MPC       DevNum: 0000
EZZ2761I   LnkName: LDIPTG	      LnkType: MPC	   Status: Ready
EZZ2762I     NetNum: 0	 QueSize: 0   ByteIn: 0000001848   ByteOut: 0000001936
EZZ2768I   BSD Routing Parameters:
EZZ2769I     MTU Size: 01470		 Metric: 01
EZZ2770I     DestAddr: 0.0.0.0		 SubnetMask: 255.255.255.240
EZZ2810I   Multicast Specific:
EZZ2811I     Multicast Capability: Yes
EZZ2812I     Group            RefCnt
EZZ2813I     -----            ------
EZZ2814I     224.0.0.5        0000000001
EZZ2814I     224.0.0.1        0000000001
EZZ2760I DevName: VIPADEV	    DevType: VIPA      DevNum: 0000
EZZ2761I   LnkName: VIPALINK	      LnkType: VIPA	   Status: Ready
EZZ2762I     NetNum: 0	 QueSize: 0   ByteIn: 0000000000   ByteOut: 0000000000
EZZ2768I   BSD Routing Parameters:
EZZ2769I     MTU Size: 01470		 Metric: 01
EZZ2770I     DestAddr: 0.0.0.0		 SubnetMask: 255.255.255.240
EZZ2810I   Multicast Specific:
EZZ2811I     Multicast Capability: No

Il y a beaucoup plus d'options disponibles avec le netstat. Vous pouvez émettre le netstat ? commande de les afficher tous.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 12257