Technologies IBM : Commutateur SNA (SNASw)

Configuration des services de commutation SNA sur DLSw

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document décrit comment configurer un routeur et un mainframe pour utiliser des services de commutation de Systems Network Architecture (SNASw) au-dessus de Data-Link Switching (DLSw), pour connecter l'en amont au mainframe et l'en aval à un noeud 2.0 existant de l'unité physique (unité centrale). Dans ce document ? ? ? l'exemple s, la connexion en amont au mainframe est par un processeur d'interface à attachement canal (CIP), et le noeud unité centrale 2.0 se connecte au mainframe au-dessus du canal d'Unité logique dépendante demandeur (DLUR) établi par SNASw.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • SNASw 4700 avec le Cisco IOS ? ? Version de logiciel 12.1(7)

  • CIP 7507 avec le Logiciel Cisco IOS version 12.1(7)

  • Équipement de connexion de base (DSPU) 4700 avec le Logiciel Cisco IOS version 12.0(10)

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/12253/dlsw_snasw.gif

Le DSPU est seulement utilisé pour apporter une unité centrale sur l'Anneau à jeton. Notez que le MAC distant (le rmac) auquel il se connecte est l'adresse MAC qui est spécifiée sur le port du contrôle de liaison de données virtuel (VDLC) qui est défini à SNASw sur Brachio.

Configurations

Ce document utilise les configurations suivantes :

Une déclaration de lien est exigée seulement pour la connexion en amont, et seulement une définition de port VDLC est nécessaire par l'en amont et les connexions en aval.

Brachio ? ? ? Configuration de routeur de SNASwitch
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname brachio
!
no logging buffered
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
cns event-service server
!
source-bridge ring-group 2
dlsw local-peer peer-id 10.64.3.195
dlsw remote-peer 0 tcp 10.64.3.194
dlsw remote-peer 0 tcp 192.168.25.18
!
!
interface TokenRing0
ip address 10.64.3.195 255.255.255.240
ip ospf authentication-key mypasswo
ring-speed 16
!
interface TokenRing1
ip address 192.168.25.19 255.255.255.240
ring-speed 16
source-bridge 200 1 2
!
snasw cpname P390.BRACHIO
snasw dlus P390.P390SSCP
snasw port PVDLC vdlc 2 mac 4000.0000.1234
snasw link LVDLC port PVDLC rmac 4000.0000.0001
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip classless
no ip http server
!
!
!
line con 0
exec-timeout 0 0
transport input none                                                  
line aux 0
line vty 0 4
login
!
end

FEP ? ? ? Configuration du routeur de carte CIP
!
version 12.1
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname FEP
!
boot system flash slot0:rsp-a3jsv-mz.121-7.bin
logging buffered 64000 debugging
!
!
!
microcode CIP flash slot0:cip27-17
microcode reload

!
source-bridge ring-group 60
dlsw local-peer peer-id 10.64.3.194
dlsw remote-peer 0 tcp 10.64.3.195
!
!
interface TokenRing0/0
ip address 10.64.3.194 255.255.255.240
ip nat inside
ip ospf authentication-key pass
no ip mroute-cache
ethernet-transit-oui 90-compatible
ring-speed 16
multiring all
source-bridge 100 1 60
source-bridge spanning
llc2 local-window 127
!
!
interface Channel5/0
no ip address
no keepalive
csna 0100 40
!
interface Channel5/1
no ip address
no keepalive
shutdown
!
interface Channel5/2
no keepalive
lan TokenRing 0
source-bridge 600 1 60
adapter 0 4000.0000.0001
!
!
router ospf 1
log-adjacency-changes
redistribute static
network 0.0.0.0 255.255.255.255 area 0                                
default-information originate
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
password cisco
login
!

Para ? ? ? Configuration de routeur DSPU
!
version 12.0
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname para
!
enable secret 5 $1$py25$yYt4gnt.YlmsBH00wQW3G1
enable password parra
!
ip subnet-zero
!
source-bridge ring-group 300
dlsw local-peer peer-id 192.168.25.18
dlsw remote-peer 0 tcp 10.64.3.195
!
!
dspu vdlc 300 4000.0000.5678
dspu vdlc enable-host lsap 12
!
dspu host DPU4 xid-snd 01700004 rmac 4000.0000.1234 rsap 4 lsap 12    
!
dspu vdlc start DPU4
!
!
interface TokenRing0
ip address 192.168.25.18 255.255.255.240
no ip directed-broadcast
ring-speed 16
source-bridge 200 1 300
source-bridge spanning
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
!
ip classless
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
password parra
login
!
end

Mainframe ? ? ? Configuration vtam
Noeud principal XCA
XCAE40R VBUILD TYPE=XCA
*/*
XPE40R    PORT CUADDR=E40,ADAPNO=0,SAPADDR=4,MEDIUM=RING,   -
DELAY=0,TIMER=30
*/*
*/* --------------------------------------- XCAE40R PERIPHERAL NODES
*/* ----------------------------------------------------------------
*/*
XGE40R   GROUP DIAL=YES,CALL=IN,ANSWER=ON,ISTATUS=ACTIVE
XGRL00    LINE
XGRP00      PU
*/*
XGRL01    LINE
XGRP01      PU
*/*
XGRL02    LINE
XGRP02      PU
*/*
XGRL03    LINE
XGRP03      PU
*/*
XGRL04    LINE
XGRP04      PU
*/*
XGRL05    LINE
XGRP05      PU
*/*
XGRL06    LINE
XGRP06      PU
Noeud principal commuté pour le point de contrôle de SNASwitch
VBUILD TYPE=SWNET
*
*
BRACHPU  PU    ADDR=01,      NOT USED                   X
DISCNT=NO,                 WHEN TO DISCONNECT           X
ANS=CONTINUE,                                           X
ISTATUS=ACTIVE,                                         X
NETID=P390,                                             X
CPCP=YES,                                               X
CONNTYPE=APPN,                                          X
CPNAME=BRACHIO,                                         X
HPR=YES,                                                X
PUTYPE=2
*
Noeud principal commuté pour les périphériques PU2.0 connectés par l'intermédiaire du canal de DLUR
VBUILD TYPE=SWNET,         INCREASE # IF MORE PU        X
MAXGRP=19,                 MAX NO OF PATH GROUPS        X
MAXNO=19                   MAX NO OF 'TEL' NOS
*
*
DPU4     PU    ADDR=01,      NOT USED                   X
DISCNT=NO,                 WHEN TO DISCONNECT           X
IDBLK=017,                 **  MUST MATCH 'PU' CUST     X
IDNUM=00004,  MUST MATCH 'PU' CUST (LAST 5 OF TR ADDR!) X
IRETRY=YES,                REPOLL ON IDLE DETECT T/O  ? X
LOGAPPL=A06TSO,            INITIAL LOGON                X
MAXDATA=265,               PIU SIZE (FIXED FOR DCA CS)  X
MAXOUT=7,                  NO OF PIUS BEFORE RESPONSE ? X
MAXPATH=1,                 MAX NO OF 'DIALOUT' PATHS    X
PASSLIM=7,                 MAX NO OF CONTIG PIUS SENT ? X
USSTAB=USSS,                                            X
MODETAB=ISTINCLM,                                       X
DLOGMOD=M2782,                                          X
SSCPFM=USSSCS,                                          X
PUTYPE=2
*
*
DLU42    LU    LOCADDR=2
DLU43    LU    LOCADDR=3
DLU44    LU    LOCADDR=4
DLU45    LU    LOCADDR=5
DLU46    LU    LOCADDR=6
DLU47    LU    LOCADDR=7
*

Vérifiez

Cette section présente les informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Ces exemples de sortie de commande show affichent les informations d'état pour les Routeurs dans la configuration d'échantillon :

para# show dspu

dspu host DPU4 Vdlc  PU STATUS Active
FRAMES RECEIVED 7 FRAMES SENT 7
LUs USED BY DSPU 0 LUs ACTIVE 0
LUs USED BY API 0 LUs ACTIVE 0
LUs ACTIVATED BY HOST BUT NOT USED 6

brachio# show snasw link

Number of links 2
SNA Links                                                            HPR
Link Name     State    Port Name   Adjacent CP Name  Node Type     Sess  Sup
---------    --------  ---------   ----------------  ------------  ----  ---
1> @I000003   Active    PVDLC      P390.DPU4         LEN Node         7  No
2> LVDLC      Active    PVDLC      P390.P390SSCP     Network Node     2  Yes

brachio# show snasw dlus

Number of Dependent LU Servers 1
SNA Dependent LU Servers
DLUS Name          Default?  Backup?  Pipe State         PUs
-----------------  --------  -------  ----------------  -------
1> P390.P390SSCP      Yes       No       Active            1

brachio# show snasw pu

Number of DLUR PUs 1
SNA DLUR PUs
PU Name    PU ID     State       DLUS Name
--------  --------  --------  -----------------
1> DPU4    01700004  Active    P390.P390SSCP

Ces exemples de sortie de commande d'affichage affichent le statut du Virtual Telecommunications Access Method (vtam) :

D NET,ID=SNASW1,E

IST097I DISPLAY ACCEPTED
IST075I NAME = SNASW1, TYPE = SW SNA MAJ NODE 231
IST486I STATUS= ACTIV, DESIRED STATE= ACTIV
IST1656I VTAMTOPO = REPORT, NODE REPORTED - YES
IST084I NETWORK RESOURCES:
IST089I BRACHPU  TYPE = PU_T2.1          , ACTIV--L--
IST1500I STATE TRACE = OFF
IST314I END

D NET,ID=XCAE40R,E

IST097I DISPLAY ACCEPTED
IST075I NAME = XCAE40R, TYPE = XCA MAJOR NODE 234
IST486I STATUS= ACTIV, DESIRED STATE= ACTIV
IST1021I MEDIUM=RING,ADAPNO= 0,CUA=0E40,SNA SAP= 4
IST654I I/O TRACE = OFF, BUFFER TRACE = OFF
IST1656I VTAMTOPO = REPORT, NODE REPORTED - YES
IST170I LINES:
IST232I XGRL00   ACTIV
IST232I XGRL01   ACTIV
IST232I XGRL02   ACTIV
IST232I XGRL03   ACTIV
IST232I XGRL04   ACTIV
IST232I XGRL05   ACTIV
IST232I XGRL06   ACTIV
IST314I END

D NET,ID=CISCOPU4,E

IST097I DISPLAY ACCEPTED
IST075I NAME = CISCOPU4, TYPE = SW SNA MAJ NODE 237
IST486I STATUS= ACTIV, DESIRED STATE= ACTIV
IST1656I VTAMTOPO = REPORT, NODE REPORTED - YES
IST084I NETWORK RESOURCES:
IST089I DPU4     TYPE = PU_T2.1          , ACTIV
IST089I DLU42    TYPE = LOGICAL UNIT     , ACTIV
IST089I DLU43    TYPE = LOGICAL UNIT     , ACTIV
IST089I DLU44    TYPE = LOGICAL UNIT     , ACTIV
IST089I DLU45    TYPE = LOGICAL UNIT     , ACTIV
IST089I DLU46    TYPE = LOGICAL UNIT     , ACTIV
IST089I DLU47    TYPE = LOGICAL UNIT     , ACTIV
IST314I END

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 12253