Technologies IBM : Data-Link Switching (DLSw) et Data-Link Switching Plus (DLSw+)

DLSw+ (Data Link Switching Plus)

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Le Data-Link Switching (DLSw) est une norme mise en application par IBM qui prend en charge le transport du Contrôle de la liaison logique (LLC) au-dessus des WAN. DLSw est une forme plus élaborée de Technologie Remote Source-Route Bridging (RSRB) et est plus spécifique quant à ce qu'il peut ou ne peut pas jeter un pont sur. DLSw a besoin de que le routeur transporte une session LLC2 valide ou une session de Netbios.

Les Routeurs de Cisco implémentent RFC 1795 (norme de DSLw) et 2166 (version de DLSw 2). En outre, DLSw implémente plus de caractéristiques pour le contrôle d'émission et transporte moins d'informations à travers le WAN que d'autres méthodes.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Commandes générales

Cette section couvre d'importantes commandes de DLSw, commandes pour configurer DLSw, et commandes pour dépanner DLSw.

source-bridge ring-group

La première étape en configurant DLSw est d'ajouter l'ordre de source-bridge ring-group. Ceci connecte les interfaces Token Ring exécutant le pont en par la source (SRB).

Tâche Commande
Définissez un groupe d'anneau. groupe d'anneau de source-bridge ring-group [adresse MAC virtuelle]

Remarque: En exécutant DLSw sur un routeur qui a seulement des interfaces Ethernet, il n'y a aucun besoin d'installer un groupe d'anneau.

Définissez l'identification d'homologue local

La prochaine option est de définir l'identification d'homologue local. C'est une adresse IP dans la même case. Ceci commence fondamentalement DLSw dans le routeur.

Tâche Commande
Définissez l'homologue local DLSw+. dlsw local-peer [[biu-segment] de taille] d'IP address] de pair-id [groupe de groupe] [cadre] [coût coûté] [LF [secondes de keepalive] [passif] [promiscueux]

L'option la plus fondamentale en configurant DLSw est d'établir l'IP address local de pair-id. Ce sont des descriptions des paramètres de commande :

  • groupe et cadre — Ces commandes sont émises ensemble de créer des homologues de périphérie dans le réseau.

  • coût — Cette commande est émise quand il y a des plusieurs chemins au même emplacement. Cette commande indique au routeur comment atteindre ces sites distants utilisant le chemin le moins coûteux d'abord.

  • LF — Cette commande détermine la plus grande taille de trame que ce pair peut manipuler. Les tailles de trame peuvent être :

    • 516-516 taille de trame maximale d'octet

    • 1470-1470 taille de trame maximale d'octet

    • 1500-1500 taille de trame maximale d'octet

    • 2052-2052 taille de trame maximale d'octet

    • 4472-4472 taille de trame maximale d'octet

    • 8144-8144 taille de trame maximale d'octet

    • 11407-11407 taille de trame maximale d'octet

    • 11454-11454 taille de trame maximale d'octet

    • 17800-17800 taille de trame maximale d'octet

  • keepalive — Cette commande définit les paquets keepalive intermédiaires d'intervalle. L'intervalle peut s'étendre de 0 à 1200 secondes. Il est habituellement placé à 0 en configurant DLSw pour le Routage à établissement de connexion à la demande (DDR).

  • passif — Cette commande configure le routeur pour ne pas initier un startup de pair du routeur.

  • promiscueux — Cette commande signifie que le routeur reçoit des connexions de n'importe quel pair distant demandant un startup de pair. Cette commande est utile dans les grands sites qui ont beaucoup de pairs, parce que vous ne devez pas définir tout le routeur distant de pairs au centre.

  • biu-segment — Cette commande est une option pour DLSw qui permet à DLSw pour contrôler la taille de segment plus élevée dans les couches du Network Architecture de système (SNA). Ce commandes enables que les stations d'extrémité croient qu'elles peuvent envoyer de plus grandes quantités de données.

Définissez le pair distant

Après avoir défini l'homologue local, vous définissez le pair distant. Vous pouvez définir trois types de pairs : Le TCP, le transport Rapide-ordonnancé (FST), et dirigent le contrôle de liaison de haut niveau (HDLC) et le Relais de trames. Ce sont des explications des commandes émises pour définir le pair distant :

Tâche Commande
Encapsulation directe au-dessus de Relais de trames dlci-nombre de numéro de série d'interface de Relais de trames de numéro de liste de distant-pair de dlsw [IP address de backup peer] [octet-liste-nom d'octet-Netbios-] [coût coûté] [mac-address de DEST-MAC] [access-list-number de dmac-sortie-liste] [hôte-liste-nom d'hôte-Netbios-] [secondes de keepalive] [taille LF] [s'attardent les minutes] [la liste de lsap-sortie-liste] [passage-à travers]
Encapsulation directe au-dessus de HDLC numéro de série d'interface de numéro de liste de distant-pair de dlsw [IP address de backup peer] [octet-liste-nom d'octet-Netbios-] [coût coûté] [mac-address de DEST-MAC] [access-list-number de dmac-sortie-liste] [hôte-liste-nom d'hôte-Netbios-] [secondes de keepalive] [taille LF] [s'attardent les minutes] [la liste de lsap-sortie-liste] [passage-à travers]
FST IP address de fst de numéro de liste de distant-pair de dlsw [IP address de backup peer] [octet-liste-nom d'octet-Netbios-] [coût coûté] [mac-address de DEST-MAC] [access-list-number de dmac-sortie-liste] [hôte-liste-nom d'hôte-Netbios-] [secondes de keepalive] [taille LF] [s'attardent les minutes] [la liste de lsap-sortie-liste] [passage-à travers]
TCP IP address de TCP de numéro de liste de distant-pair de dlsw [IP address de backup peer] [octet-liste-nom d'octet-Netbios-] [mac-address de DEST-MAC] [access-list-number de dmac-sortie-liste] [dynamique] [hôte-liste-nom d'hôte-Netbios- coûté [par coût]] [minutes d'inactivité] [secondes de keepalive] [taille LF] [s'attardent les minutes] [liste de lsap-sortie-liste] [minutes NO--LLC] [priorité] [taille TCP-file d'attente-maximum] [délai d'attente seconds][v2-single-tcp]

Ce sont les descriptions des options de commande :

  • backup peer — Cette option de commande définit le pair qui sauvegarde ce pair au cas où le premier pair échouerait.

  • coût — Cette option de commande définit le coût de ce pair. Cette commande est utilisée quand il y a des plusieurs chemins à une destination et quand vous avez besoin d'un scénario préférer-capable.

  • DEST-MAC, dynamique, NO--LLC et inactivité — ces options de commande sont discutées dans section de sauvegarde/coûtée de pair de ce document.

  • dmac-sortie-liste — Cette option de commande est émise de définir une liste d'accès qui indique le routeur quel MAC de destination distant s'adresse à vous autorisation, ou refuse, le trafic d'exploration.

  • hôte-Netbios- — Cette option de commande est émise d'appliquer des noms du filtre d'hôte de Netbios.

  • keepalive — Cette option de commande est émise de déterminer l'intervalle en quelques secondes entre le Keepalives. Il est utilisé en grande partie pour des installations DDR.

  • LF — Cette option de commande spécifie la plus grande taille permise pour le pair.

  • attardez-vous — Cette option de commande spécifie la durée que le routeur laisse le backup peer ouvert qui devient actif (en raison de la panne primaire) après que la liaison principale devienne active de nouveau.

  • priorité — Cette option de commande crée des plusieurs homologues pour la hiérarchisation du trafic de DLSw.

  • TCP-file d'attente-maximum — Cette option de commande change la valeur par défaut de 200 pour les files d'attente de TCP.

  • délai d'attente — Cette option de commande est le nombre de secondes que le TCP attend un accusé de réception avant de démolir la connexion.

  • V2-single-tcpM — Cette option de commande est conçue pour l'usage dans des environnements de Traduction d'adresses de réseau (NAT). Chaque pair pense qu'il a l'adresse IP plus élevée pour empêcher chaque pair de démolir une des connexions TCP.

Temporisateurs utilisés dans DLSw

Ce sont des explications des temporisateurs utilisés dans DLSw :

Paramètre Description
icannotreach-bloc-temps Cachez la vie de la ressource inaccessible, l'où recherche cette ressource sont bloqués. La plage valide est de 1 à 86400 secondes. Le par défaut est 0 (désactivé)
Netbios-cache-délai d'attente Vie de cache d'emplacement de nom NetBIOS pour les gens du pays et le cache d'accessibilité à distance. La plage valide est de 1 à 86400 secondes. Le par défaut est de 16 minutes.
Netbios-explorateur-délai d'attente Durée que le logiciel IOSÝ attend une réponse d'exploration avant de marquer une ressource inaccessible (LAN et WAN). La plage valide est de 1 à 86400 secondes. Le par défaut est de 6 secondes.
Netbios-relance-intervalle Retry interval d'explorateur de Netbios (RÉSEAU LOCAL seulement). La plage valide est de 1 à 86400 secondes. Le par défaut est 1 seconde.
Netbios-vérifier-intervalle Intervalle entre la création d'une entrée de cache et quand l'entrée est marquée en tant qu'éventé. Si une demande de recherche entre pour une entrée éventée de cache, dirigé vérifient la requête est envoyé pour s'assurer qu'il existe toujours. La plage valide est de 1 à 86400 secondes. Le par défaut est de 4 minutes.
SNA-cache-délai d'attente Durée qu'une entrée de cache d'emplacement de point d'accès services MAC/SNA (SAP) existe avant qu'elle soit jetée (les gens du pays et le distant). La plage valide est de 1 à 86400 secondes. Le par défaut est de 16 minutes.
SNA-explorateur-délai d'attente Durée que le logiciel IOS attend une réponse d'exploration avant de marquer une ressource inaccessible (LAN et WAN). La plage valide est de 1 à 86400 secondes. Le par défaut est de 3 minutes.
SNA-relance-intervalle Intervalle entre les relances d'explorateur SNA (RÉSEAU LOCAL). La plage valide est de 1 à 86400 secondes. Le par défaut est de 30 secondes.
SNA-vérifier-intervalle Intervalle entre la création d'une entrée de cache et quand l'entrée est marquée en tant qu'éventé. Si une demande de recherche entre pour une entrée éventée de cache, dirigé vérifient la requête est envoyé pour s'assurer qu'il existe toujours. La plage valide est de 1 à 86400 secondes. Le par défaut est de 4 minutes.
explorateur-attente-temps Chronométrez, en quelques secondes, que le routeur attend tous les explorateurs pour retourner avant de déterminer quel pair à l'utiliser.

Ces paramètres sont très utiles. Par exemple, vous pouvez changer l'intervalle en quelques secondes que le routeur envoie un explorateur. Ceci aide à réduire la quantité d'explorateurs dans le réseau en augmentant le temps entre eux. En outre, vous pouvez changer les valeurs auxquelles le routeur chronomètre le cache entries.

Commandes supplémentaires de DLSw

Ce sont d'importantes commandes supplémentaires de DLSw :

  • dlsw allroute-sna/Netbios — Cette commande est émise de changer le comportement de DLSw de sorte que tous les explorateurs d'artère soient utilisés au lieu des explorateurs de route unique.

  • dlsw bridge-group — Cette commande est émise d'attacher d'une manière transparente des domaines pontés avec DLSw. Il est utilisé intensivement en configurant Netbios avec des Ethernets.

  • dlsw explorerq-depth — Cette commande place la valeur de la file d'attente d'exploration de DLSw. Cette commande est émise après la commande régulière de file d'attente d'exploration de source-bridge, mais elle se rapporte à toutes les trames CANUREACH (CABOT) qui doivent être traitées. Cette commande est importante parce qu'elle couvre les paquets des Ethernets, quoiqu'elle ne soit pas couverte dans la commande de source-bridge explorerq-depth. Référez-vous en comprenant et dépannage du par la source pont pour plus d'informations sur cette commande.

Commandes show

Les commandes show et les sorties décrites dans cette section sont pour le dépannage utile DLSw.

affichez le pair de dlsw

Cette commande fournit des informations au sujet des pairs. Chaque pair distant configuré est affiché ici, y compris la quantité de paquets transmis et reçus.

Peers:                state     pkts_rx   pkts_tx  type  drops ckts TCP   uptime
 TCP 5.5.5.1         CONNECT          2         2  conf      0    0   0 00:00:06

Ce sont les états possibles :

  • CONNECTEZ — Cet état signifie que le pair de DLSw est en service.

  • DÉCONNECTEZ cet état signifie que le pair vers le bas ou n'est pas connecté.

  • CAP_EXG — Cet état signifie que DLSw est dans l'échange de capacités avec le pair distant.

  • WAIT_RD — Cet état est la dernière étape en commençant vers le haut du pair. Ce pair attend le pair distant pour ouvrir le port lu. Référez-vous à la section de mise au point de ce document pour plus d'informations sur quand le pair démarre et émettant l'ordre de pair de debug dlsw.

  • WAN_BUSY — Cet état signifie que la file d'attente sortante de TCP est pleine, et le paquet ne peut pas être transmis.

L'ordre de pair de dlsw d'exposition affiche également le nombre de baisses, la quantité de circuits à travers le pair spécifique, la file d'attente de TCP, et la disponibilité. Les augmentations de compteur de baisse pour ces raisons :

  • L'interface WAN n'est pas en hausse pour un pair direct.

  • Essais de DLSw pour envoyer un paquet avant que le pair soit entièrement connecté (attendant l'événement de TCP ou l'événement de capacités). File d'attente sortante de TCP complètement.

  • Non-concordance de compte de numéro de séquence FST.

  • Ne peut pas obtenir la mémoire tampon pour ralentir le paquet du commutateur FST.

  • Panne de contrôleur de CiscoBus sur haut de gamme ; ne peut pas déplacer le paquet du du réception la mémoire tampon pour transmettre la mémoire tampon, ou vice versa.

  • L'adresse IP de destination du paquet FST n'apparie pas l'ID d'homologue local.

  • Interface WAN pas pour un pair FST.

  • Aucune commande de cache d'artère SRB configurée.

  • La mémoire tampon de sonnerie de Madge est pleine sur les systèmes bas de gamme : RÉSEAU LOCAL de alimentation BLÊME trop rapide.

show dlsw capabilities

DLSw: Capabilities for peer 5.5.5.1(2065)
  vendor id (OUI)         : '00C' (cisco)
  version number          : 1
  release number          : 0
  init pacing window      : 20
  unsupported saps        : none
  num of tcp sessions     : 1
  loop prevent support    : no
  icanreach mac-exclusive : no
  icanreach netbios-excl. : no
  reachable mac addresses : none
  reachable netbios names : none
  cisco version number    : 1
  peer group number       : 0
  border peer capable     : no
  peer cost               : 3
  biu-segment configured  : no
  local-ack configured    : yes
  priority configured     : no
  version string          :
Cisco Internetwork Operating System Software
IOS (tm) 4500 Software (C4500-J-M), Version 10.3(13), RELEASE SOFTWARE (fc2)
Copyright (c) 1986-1996 by cisco Systems, Inc.

show dlsw reachability

DLSw MAC address reachability cache list
Mac Addr        status     Loc.    peer/port            rif
0800.5a0a.c51d  FOUND      LOCAL   TokenRing3/0     06B0.0021.00F0
0800.5a49.1e38  FOUND      LOCAL   TokenRing3/0     06B0.0021.00F0
0800.5a95.3a13  FOUND      REMOTE  5.5.5.1(2065)
 
DLSw NetBIOS Name reachability cache list
NetBIOS Name    status     Loc.    peer/port            rif
PIN-PIN         FOUND      LOCAL   TokenRing3/0     06B0.0021.00F0
QUENEPA         FOUND      LOCAL   TokenRing3/0     06B0.0021.00F0
WIN95           FOUND      REMOTE  5.5.5.1(2065)

La zone STATUS est la plupart de partie importante de la commande de portée de dlsw d'exposition. Ce sont les états possibles :

  • TROUVÉ — Le routeur a localisé le périphérique.

  • RECHERCHER — Le routeur recherche la ressource.

  • NOT_FOUND — La mise en cache négative est allumée, et la station n'a pas répondu aux requêtes.

  • NON CONFIRMÉ — La station est configurée, mais DLSw ne l'a pas vérifiée.

  • VÉRIFIEZ — Vérifier les informations de cache parce que le cache est aller éventé, ou la configuration utilisateur est vérifié.

affichez le circuit de dlsw

Index           local addr(lsap)    remote addr(dsap)  state
1622193728      4001.68ff.0001(04)  4000.0000.0001(04) CONNECTED
        PCEP: 60A545B4   UCEP: 60B0B640
        Port:To3/0          peer 5.5.5.1(2065)
        Flow-Control-Tx CW:20, Permitted:32; Rx CW:20, Granted:32
        RIF = 06B0.0021.00F0

En émettant la commande de circuit de dlsw d'exposition, prêtez l'attention au contrôle de flux. Le contrôle de flux existe à une base de par-circuit. C'est une transmission qui se produit tandis que les deux pairs de DLSw assignent au circuit une fenêtre de transfert possible. Cette valeur augmente et diminue selon le niveau de trafic par lequel le circuit essaye de se déplacer. La valeur peut changer selon l'encombrement du nuage.

La commande de circuit de dlsw d'exposition est plus étendue en date d'IOS 11.1. La commande te permet maintenant pour regarder le circuit de DLSw sur une valeur de point d'accès services (SAP) ou une valeur de MAC, qui simplifient localiser le pour le dépannage de circuits. Voici est un exemple de sortie :

ibu-7206#sh dlsw cir
Index           local addr(lsap)    remote addr(dsap)  state
1622193728      4001.68ff.0001(04)  4000.0000.0001(04) CONNECTED
ibu-7206#sh dls cir det ?
  <0-4294967295>  Circuit ID for a specific remote circuit
  mac-address     Display all remote circuits using a specific MAC
  sap-value       Display all remote circuits using a specific SAP
  <cr>
 
ibu-7206#show dlsw circuit detail mac 4000.0000.0001
Index           local addr(lsap)    remote addr(dsap)  state
1622193728      4001.68ff.0001(04)  4000.0000.0001(04) CONNECTED
        PCEP: 60A545B4   UCEP: 60B0B640
        Port:To3/0          peer 5.5.5.1(2065)
        Flow-Control-Tx CW:20, Permitted:29; Rx CW:20, Granted:29
        RIF = 06B0.0021.00F0
241-00  4000.0000.0001(04)  4001.68ff.0000(04) CONNECTED
        Port:To0          peer 5.5.7.1(2065)
        Flow-Control-Tx CW:20, Permitted:27; Rx CW:20, Granted:27
        RIF = 0630.00F1.0010
s5e#sh cls
DLU user: DLSWDLU
      SSap:0x63       type:  llc0   class:0
        DTE:0800.5a95.3a13 0800.5a0a.c51d F0 F0
        T1 timer:0      T2 timer:0      Inact timer:0
        max out:0       max in:0        retry count:0
        XID retry:0     XID timer:0     I-Frame:0
 
        DTE:4000.0000.0001 4001.68ff.0000 04 04
        T1 timer:0      T2 timer:0      Inact timer:0
        max out:0       max in:0        retry count:0
        XID retry:0     XID timer:0     I-Frame:0
TokenRing0 DTE: 4000.0000.0001 4001.68ff.0000 04 04 state NORMAL
   V(S)=23, V(R)=23, Last N(R)=22, Local window=7, Remote Window=127
   akmax=3, n2=8, Next timer in 1240
   xid-retry timer      0/0       ack timer    1240/1000
   p timer              0/1000    idle timer  10224/10000
   rej timer            0/3200    busy timer      0/9600
   akdelay timer        0/100     txQ count       0/200

Dépannage

Par défaut, DLSw termine des sessions LLC aux Routeurs (gens du pays-ACK). En outre, parce qu'il termine le champ des informations de routage (RIF), il y a d'autres questions de conception à considérer. Les problèmes de DLSw les plus communs sont décrits dans cette section.

Boucles

Une des la plupart des choses importantes à se souvenir au sujet de DLSw est arrêt de RIF. C'est une question parce que des boucles importantes dans le réseau peuvent facilement être créées. Ce diagramme explique une boucle :

/image/gif/paws/12249/dlsw_1.gif

Dans ce cas, puisque DLSw termine le RIF, le paquet circule indéfiniment. C'est parce que chaque fois qu'une trame CUR est envoyée du pair pour scruter, le pair de réception crée un nouvel explorateur (AUCUN RIF) et l'envoie. Les étapes de l'explorateur sont décrites :

  1. Les 3174 dans la sonnerie 11 envoie un explorateur pour atteindre l'hôte.

  2. SF1 et la passerelle copient la trame.

  3. SF1 crée une trame CUR à LA1 (son pair) pour indiquer à LA1 que les 3174 veut atteindre l'HÔTE.

  4. SF2 reçoit le paquet et fait la même chose.

  5. Maintenant LA1 et LA2 créent l'explorateur et l'envoient à la sonnerie.

  6. LA1 et LA2 reçoivent un explorateur qu'a créé.

  7. Il y a maintenant un dilemme, parce que chaque côté croit que les 3174 est localement reliés.

  8. Chaque routeur a les 3174, les gens du pays et le distant.

  9. Maintenant ils envoient une trame d'Icanreach à SF1 et à SF2, respectivement, qui crée une réponse de l'hôte vers les 3174.

  10. SF1 et SF2 mettent la réponse d'exploration sur l'Anneau à jeton et chacun apprend que l'adresse MAC de l'hôte est accessible localement et à distance.

  11. De DLSw d'accessibilité Pare-feu efficacement contre l'explorateur faisant une boucle indéfiniment. Cependant, avec des trames des informations non numérotées (UI), ceci peut faire une boucle, puis pilote CPU et ligne utilisation jusqu'à 100%.

Si ceci se produit, vérifiez que la sonnerie virtuelle dans les Routeurs sont exactement identique de chaque côté du nuage, comme présenté dans ce diagramme :

/image/gif/paws/12249/dlsw_2.gif

Les Routeurs de chaque côté de ce nuage ont le précis le même numéro de boucle virtuelle. Ceci s'assure qu'un des Routeurs envoie un explorateur qui a déjà traversé la sonnerie, alors le routeur la relâche. Quand LA1 génère un explorateur pour une trame CUR reçue par SF1, LA2 le relâche parce que l'explorateur a déjà traversé la sonnerie 1. Dans ce scénario, il est important que le routeur fasse configurer une passerelle différente si le paquet est dirigé pour le même anneau, qui est le cas du côté de LA du réseau.

Dans un Ethernet version du même scénario, vous devez désactiver un pair. Un exemple est affiché dans ce diagramme :

dlsw_3.gif

Puisqu'un paquet sur les Ethernets n'a pas un RIF, le routeur ne peut pas déterminer si l'émission, créée par l'autre routeur sur le RÉSEAU LOCAL, est de l'autre routeur ou d'une station d'origine. Avec la SNA, le paquet est localement lancé ou distant. Puisque les explorateurs d'un environnement Token Ring ont en effet des adresses de source et de MAC de destination, ils ne sont pas une émission sur les Ethernets, mais une trame dirigée à une station des autres.

Ce qui se produit dans le diagramme précédent est expliqué dans ces étapes :

  1. Un explorateur est envoyé des 3174 à l'hôte.

  2. Cet explorateur est reçu par SF1 et SF2.

  3. SF1 et SF2 chacun génèrent un CABOT à l'autre côté LA1 et LA2.

  4. Ceux-ci génèrent un explorateur au lequel l'hôte répond ; parce que c'est un explorateur de route unique, il est répondu à avec un explorateur de tout-artère.

  5. LA1 et LA2 créent une trame CUR à SF1 et à SF2, qui créent le paquet pour les 3174.

  6. SF1 entend l'adresse MAC de l'HÔTE provenant les Ethernets et croit maintenant que l'HÔTE se trouve sur le réseau local. Mais dans le cache de SF1, l'id d'HÔTE répond d'un pair distant.

  7. Ceci force le routeur pour avoir les gens du pays et le distant d'HÔTE, ainsi il signifie que DLSw est cassé.

Sauvegarde/pairs coûtés

Les backup peers ajoutent la tolérance aux pannes à DLSw au cas où un pair serait perdu. Ceci est habituellement installé dans de principaux environnements de sorte que quand un principal routeur échoue, un autre routeur puisse recevoir le routeur manquant. Les configurations et le diagramme dans cette section illustrent une installation de backup peer.

D3B
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3b
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.14.1
   cost 2 promiscuous
!
interface Loopback0
 ip address 1.1.14.1 255.255.255.0
!
interface Serial0
 ip address 1.1.6.2 255.255.255.0
 bandwidth 125000
 clockrate 125000
!
interface TokenRing0
 ip address 1.1.5.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!

D3C
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3c
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.12.1
   cost 4 promiscuous
!
interface Loopback0
 ip address 1.1.12.1 255.255.255.0
!
interface Serial0
 ip address 1.1.4.1 255.255.255.0
 bandwidth 500000
 clockrate 500000
!
interface TokenRing0
 ip address 1.1.5.2 255.255.255.0
 ring-speed 16
 source-bridge 3 2 2
 source-bridge spanning
!

D3A
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3a
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.13.1
dlsw remote-peer 0 tcp 1.1.14.1
dlsw remote-peer 0 tcp 1.1.12.1
dlsw timer explorer-wait-time 2
!
interface Loopback0
 ip address 1.1.13.1 255.255.255.0
!
interface Serial0
 ip address 1.1.6.1 255.255.255.0
 bandwidth 500000
!
interface Serial1
 ip address 1.1.4.2 255.255.255.0
 bandwidth 125000
!
interface TokenRing0
 ip address 1.1.1.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!

/image/gif/paws/12249/dlsw_8.gif

La première chose à se souvenir au sujet des pairs de coût de DLSw est que les deux pairs sont en activité. Le routeur met à jour seulement un backup peer. Il peut avoir deux alors si attardez-vous est configuré. C'est ce qui s'est produit dans le diagramme précédent :

  1. D3a reçoit un explorateur et commence le processus par envoyer une trame CUR à chaque pair distant.

  2. D3B et D3C reçoivent les trames CUR. Chacun génère un explorateur à l'hôte, qui répond de nouveau à D3B et à D3C.

  3. D3B et D3C répondent de nouveau à D3A avec Icanreach.

  4. D3A envoie la réponse d'exploration à la station d'extrémité.

  5. Le poste de travail distant met en marche le circuit de dlsw, avec l'identification d'échange (XID) pour le mode asynchrone équilibré SNA et de positionnement étendu (SABME) pour Netbios.

  6. D3A sélectionne plus peu coûteux dans l'accessibilité.

Il y a un temporisateur dans D3A qui peut être défini pour dire au routeur combien de temps attendre tous les explorateurs pour retourner à D3A. Ceci évite des problèmes avec les coûts qui peuvent se produire quand le routeur utilise le premier explorateur qui revient à lui. Émettez la commande de <seconds> d'explorateur-attente-temps de dlsw timer de placer ce temporisateur.

En outre, en exécutant des homologues de périphérie, DLSw envoie seulement une trame CUR au pair le plus peu coûteux. Il se comporte différemment qu'il fait en exécutant le coût sans homologues de périphérie.

Les backup peers fonctionnent un peu différemment. Vous spécifiez le backup peer dans le pair qui va être de sauvegarde pour le pair spécifié. Ceci signifie que le pair qui a la déclaration de sauvegarde est le backup peer lui-même.

Spécifiez l'option de retard de sorte que quand le pair primaire devient opérationnel de nouveau, les circuits ne puissent pas démolir immédiatement. C'est utile si le pair primaire varie en haut et en bas, parce que vous ne voulez pas utiliser le pair défectueux.

Ceci explique la configuration des backup peers :

D3B
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3b
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.14.1
   promiscuous
!
interface Loopback0
 ip address 1.1.14.1 255.255.255.0
!
interface Serial0
 ip address 1.1.6.2 255.255.255.0
 bandwidth 125000
 clockrate 125000
!
interface TokenRing0
 ip address 1.1.5.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!

D3C
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3c
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.12.1
   promiscuous
!
interface Loopback0
 ip address 1.1.12.1 255.255.255.0
!
interface Serial0
 ip address 1.1.4.1 255.255.255.0
 bandwidth 500000
 clockrate 500000
!
interface TokenRing0
 ip address 1.1.5.2 255.255.255.0
 ring-speed 16
 source-bridge 3 2 2
 source-bridge spanning
!

D3A
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3a
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.13.1
dlsw remote-peer 0 tcp 1.1.14.1
dlsw remote-peer 0 tcp 1.1.12.1 backup-peer 1.1.14.1 linger 5
dlsw timer explorer-wait-time 2
!
interface Loopback0
 ip address 1.1.13.1 255.255.255.0
!
interface Serial0
 ip address 1.1.6.1 255.255.255.0
 bandwidth 500000
!
interface Serial1
 ip address 1.1.4.2 255.255.255.0
 bandwidth 125000
!
interface TokenRing0
 ip address 1.1.1.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!

Le pair est déconnecté en émettant l'ordre de pair de dlsw d'exposition :

d3a#sh dls peer
Peers:                state     pkts_rx   pkts_tx  type  drops ckts TCP   uptime
 TCP 1.1.14.1        CONNECT        464      1286  conf      0    0   0 03:17:02
 TCP 1.1.12.1        DISCONN          0         0  conf      0    0   -        -

Homologues de périphérie

Les homologues de périphérie sont une importante caractéristique de DLSw parce qu'ils résolvent le problème du contrôle d'émission dans un réseau. Cet exemple montre comment des homologues de périphérie sont configurés et ce qui se produit quand une session est soulevée :

/image/gif/paws/12249/dlsw_6.gif

D3E
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3e
!
!
dlsw local-peer peer-id 1.1.11.1 group 1
   border promiscuous
dlsw remote-peer 0 tcp 1.1.12.1
!
interface Loopback0
 ip address 1.1.11.1 255.255.255.0
!
interface Serial0
 ip address 1.1.3.1 255.255.255.0
!
interface Serial1
 ip address 1.1.2.2 255.255.255.0
 clockrate 500000
!
interface TokenRing0
 ip address 10.17.1.189 255.255.255.0
 ring-speed 16
!
router ospf 100
 network 1.0.0.0 0.255.255.255 area 0
!

D3C
Current configuration:
!
version 11.1

service udp-small-servers
service tcp-small-servers
!
hostname d3c
!
!
dlsw local-peer peer-id 1.1.12.1 group 2
   border promiscuous
dlsw remote-peer 0 tcp 1.1.11.1
!
interface Loopback0
 ip address 1.1.12.1 255.255.255.0
!
interface Serial0
 ip address 1.1.4.1 255.255.255.0
 no fair-queue
 clockrate 500000
!
interface Serial1
 ip address 1.1.3.2 255.255.255.0
 clockrate 500000
!
interface TokenRing0
 no ip address
 shutdown
 ring-speed 16
!
router ospf 100
 network 1.0.0.0 0.255.255.255 area 0
!

D3F
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3f
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.10.1 group 1
   promiscuous
dlsw remote-peer 0 tcp 1.1.11.1
dlsw peer-on-demand-defaults inactivity 1
!
interface Loopback0
 ip address 1.1.10.1 255.255.255.0
!
interface Serial0
 ip address 1.1.2.1 255.255.255.0
 no fair-queue
!!
interface TokenRing0
 ip address 1.1.1.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2
 source-bridge spanning
!
router ospf 100
 network 1.0.0.0 0.255.255.255 area 0

D3A
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3a
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.13.1 group 2
   promiscuous
dlsw remote-peer 0 tcp 1.1.12.1
dlsw peer-on-demand-defaults inactivity 1
!
interface Loopback0
 ip address 1.1.13.1 255.255.255.0
!
interface Serial0
 ip address 1.1.4.2 255.255.255.0
!
interface TokenRing0
 ip address 1.1.5.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!
router ospf 100
 network 1.0.0.0 0.255.255.255 area 0
!

La première partie de configurer des homologues de périphérie est de créer les pairs promiscueux. Les pairs promiscueux reçoivent des connexions de n'importe quel routeur de DLSw essayant d'ouvrir un pair avec ce routeur. Par exemple, dans le diagramme précédent, vous voulez que D3A ouvre un pair avec D3F. S'il n'y a pas aucun homologue de périphérie, vous devez installer les pairs statiques dans le réseau. Ceci fonctionne bien, mais quand vous avez des centaines de sites et vous utilisez les pairs statiques quand un routeur doit trouver une station à distance, le routeur doit envoyer une trame CUR à chaque pair. Ceci peut entraîner beaucoup de temps système.

D'autre part, quand vous utilisez les homologues de périphérie, dont le routeur distant a besoin pour envoyer seulement une demande à l'homologue de périphérie. Cette demande est alors propagée par les groupes, et le routeur distant ouvre un pair avec l'autre routeur distant pour mettre en marche un circuit et pour établir une connexion. Ce processus est expliqué dans ce diagramme :

/image/gif/paws/12249/dlsw_7.gif

  1. Quand D3A reçoit l'explorateur, il envoie une émission à D3C. D3C est l'homologue de périphérie auquel D3A est relié.

  2. Quand D3C reçoit la trame CUR, il envoie la trame CUR à tous les pairs dans le groupe. D3C envoie également une trame de test à toutes les interfaces locales qui sont configurées pour faire ainsi, et envoie une trame CUR aux homologues de périphérie dans l'autre groupe.

  3. D3E reçoit le CABOT de D3C dans un autre groupe. Alors D3E fait la même chose en envoyant le CABOT à tous les pairs dans le groupe et toutes les interfaces locales.

  4. D3F reçoit la trame CUR et envoie un sondage de test à l'interface locale. Si D3F a un pair indiquant un autre routeur, il ne peut pas faire écho cette trame CUR à un autre routeur.

  5. Quand le D3F reçoit une réponse pour la station d'extrémité, il renvoie la trame d'Icanreach à D3E.

  6. D3E l'envoie à D3C, qui en avant il à D3A. D3A envoie une réponse de test au périphérique.

  7. Quand la station d'extrémité commence un circuit de dlsw, avec XID pour la SNA et le SABME pour Netbios, D3A initie une connexion homologue avec D3F et commence la session.

C'est le débogage de D3C et de D3A pendant ce processus :

d3a#
DLSW Received-ctlQ : CLSI Msg : TEST_STN.Ind   dlen: 40
CSM: Received CLSI Msg : TEST_STN.Ind   dlen: 40 from TokenRing0
CSM:   smac c001.68ff.0000, dmac 4000.0000.0001, ssap 4 , dsap 0
DLSw: sending bcast to BP peer 1.1.12.1(2065)

La trame de test qui entre dans le routeur est vue. Puis, le routeur génère une trame CUR à D3C. L'activité D3C affiche cette sortie :

DLSw: Pak from peer 1.1.13.1(2065) with op DLX_MEMBER_TO_BP
DLSw: recv_member_to_border() from peer 1.1.13.1(2065)
DLSw: passing pak to core originally from 1.1.13.1 in group 2
%DLSWC-3-RECVSSP: SSP OP = 3( CUR  ) -explorer from peer 1.1.13.1(2065)
DLSw: Pak from peer 1.1.11.1(2065) with op DLX_RELAY_RSP
DLSW: relaying pak to member 1.1.13.1 in group 2

Quand D3C reçoit le paquet de D3A, il en avant le paquet au noyau. Plus tard, vous voyez la réponse du pair distant qui est transmis par relais de nouveau à D3A. Alors D3A commence la connexion (à la demande de pair) avec le pair distant que D3F en cela mettent au point :

DLSw: Pak from peer 1.1.12.1(2065) with op DLX_RELAY_RSP
DLSW: creating a peer-on-demand for 1.1.10.1
DLSw: passing pak to core originally from 1.1.10.1 in group 1
%DLSWC-3-RECVSSP: SSP OP = 4( ICR  ) -explorer from peer 1.1.10.1(2065)
DISP Sent : CLSI Msg : TEST_STN.Rsp   dlen: 44
DLSW Received-ctlQ : CLSI Msg : ID_STN.Ind   dlen: 54
CSM: Received CLSI Msg : ID_STN.Ind   dlen: 54 from TokenRing0
CSM:   smac c001.68ff.0000, dmac 4000.0000.0001, ssap 4 , dsap 4
DLSw: new_ckt_from_clsi(): TokenRing0 4001.68ff.0000:4->4000.0000.0001:4
DLSw: action_a() attempting to connect peer 1.1.10.1(2065)
DLSw: action_a(): Write pipe opened for peer 1.1.10.1(2065)
DLSw: peer 1.1.10.1(2065), old state DISCONN, new state WAIT_RD
DLSw: passive open 1.1.10.1(11003) -> 2065
DLSw: action_c(): for peer 1.1.10.1(2065)
DLSw: peer 1.1.10.1(2065), old state WAIT_RD, new state CAP_EXG
DLSw: CapExId Msg sent to peer 1.1.10.1(2065)
DLSw: Recv CapExId Msg from peer 1.1.10.1(2065)
DLSw: Pos CapExResp sent to peer 1.1.10.1(2065)
DLSw: action_e(): for peer 1.1.10.1(2065)
DLSw: Recv CapExPosRsp Msg from peer 1.1.10.1(2065)
DLSw: action_e(): for peer 1.1.10.1(2065)
DLSw: peer 1.1.10.1(2065), old state CAP_EXG, new state CONNECT
DLSw: peer_act_on_capabilities() for peer 1.1.10.1(2065)
DLSw: action_f(): for peer 1.1.10.1(2065)
DLSw: closing read pipe tcp connection for peer 1.1.10.1(2065)
DLSw: new_ckt_from_clsi(): TokenRing0 4001.68ff.0000:4->4000.0000.0001:4
DLSw: START-FSM (1474380): event:DLC-Id state:DISCONNECTED
DLSw: core: dlsw_action_a()
DISP Sent : CLSI Msg : REQ_OPNSTN.Req   dlen: 106
DLSw: END-FSM (1474380): state:DISCONNECTED->LOCAL_RESOLVE

Après que le routeur reçoive le paquet transmis par relais de l'homologue de périphérie, il ouvre un à la demande de pair avec le pair distant D3F (1.1.10.1), et met en marche le circuit.

débogage

La première étape dans n'importe quel réseau de DLSw amène les pairs. Sans pairs, il n'y a aucun échange des données. La plupart des détails de ce qui se produit entre les pairs de DLSw sont expliquées dans RFC 1795.

Remarque: Si vous parlez au matériel de non-Cisco par l'intermédiaire de DLSw, utilisez DLSw. Cependant, entre les Routeurs de Cisco, utilisation DLSw+.

Cette sortie est d'émettre des pairs de debug dlsw et d'amener les pairs entre deux Routeurs de Cisco :

DLSw: passive open 5.5.5.1(11010) -> 2065
DLSw: action_b(): opening write pipe for peer 5.5.5.1(2065)
DLSw: peer 5.5.5.1(2065), old state DISCONN, new state CAP_EXG
DLSw: CapExId Msg sent to peer 5.5.5.1(2065)
DLSw: Recv CapExId Msg from peer 5.5.5.1(2065)
DLSw: Pos CapExResp sent to peer 5.5.5.1(2065)
DLSw: action_e(): for peer 5.5.5.1(2065)
DLSw: Recv CapExPosRsp Msg from peer 5.5.5.1(2065)
DLSw: action_e(): for peer 5.5.5.1(2065)
shSw: peer 5.5.5.1(2065), old state CAP_EXG, new state CONNECT
DLSw: peer_act_on_capabilities() for peer 5.5.5.1(2065)
DLSw: action_f(): for peer 5.5.5.1(2065)
DLSw: closing read pipe tcp connection for peer 5.5.5.1(2065)

Cette sortie affiche le routeur commençant vers le haut du pair et ouvrant une session TCP avec l'autre routeur. Alors il commence à permuter des capacités. Après que positif permutez des capacités, le pair est connecté. Contrairement à RSRB, DLSw ne déplace pas le pair à un état fermé quand il n'y a aucune activité, telle que le trafic. Ils restent toujours connectés. Si les pairs sont déconnectés, émettez le pair de debug dlsw pour déterminer pourquoi ils ne sont pas capables de l'ouverture.

Pour le dépannage une session étant apportée, noyau de debug dlsw de question pour observer la panne de session et pour la vérifier si le circuit est soulevé.

C'est l'écoulement pour un contrôleur de 3174 transmissions à l'hôte par l'intermédiaire de DLSw+ :

/image/gif/paws/12249/dlsw_4.gif

La sortie de debug dlsw affiche l'écoulement de la session étant apportée correctement :

ibu-7206#debug dlsw
DLSw reachability debugging is on at event level for all protocol traffic
DLSw peer debugging is on
DLSw local circuit debugging is on
DLSw core message debugging is on
DLSw core state debugging is on
DLSw core flow control debugging is on
DLSw core xid debugging is on
ibu-7206#
DLSW Received-ctlQ : CLSI Msg : UDATA_STN.Ind   dlen: 208
CSM: Received CLSI Msg : UDATA_STN.Ind   dlen: 208 from TokenRing3/0
CSM:   smac 8800.5a49.1e38, dmac c000.0000.0080, ssap F0, dsap F0
CSM: Received frame type NETBIOS DATAGRAM from 0800.5a49.1e38, To3/0
DLSw: peer_put_bcast() to non-grouped peer 5.5.5.1(2065)
DLSw: Keepalive Request sent to peer 5.5.5.1(2065))
DLSw: Keepalive Response from peer 5.5.5.1(2065)
DLSW Received-ctlQ : CLSI Msg : TEST_STN.Ind   dlen: 41
CSM: Received CLSI Msg : TEST_STN.Ind   dlen: 41 from TokenRing3/0
CSM:   smac c001.68ff.0001, dmac 4000.0000.0001, ssap 4 , dsap 0

Notez la trame de test provenir le RÉSEAU LOCAL (localement) de la station c001.68ff.0001 à l'adresse MAC de 4000.0000.0001. Chacun. L'Ind indique qu'un paquet est livré dedans du RÉSEAU LOCAL. Quand le routeur envoie un paquet au RÉSEAU LOCAL, vous voyez un .RSP.

DLSw: peer_put_bcast() to non-grouped peer 5.5.5.1(2065)
%DLSWC-3-RECVSSP: SSP OP = 4( ICR  ) -explorer from peer 5.5.5.1(2065)
DISP Sent : CLSI Msg : TEST_STN.Rsp   dlen: 44

Maintenant vous pouvez voir l'émission envoyée au pair distant et à la réponse du débit de cellules initial (ICR) de retour. Ceci signifie que le routeur distant a identifié la station comme accessible. Le TEST_STN.Rsp est le routeur envoyant une réponse de test à la station.

DLSW Received-ctlQ : CLSI Msg : ID_STN.Ind   dlen: 54
CSM: Received CLSI Msg : ID_STN.Ind   dlen: 54 from TokenRing3/0
CSM:   smac c001.68ff.0001, dmac 4000.0000.0001, ssap 4 , dsap 4

Après que la station reçoive la réponse de test, elle envoie le premier XID. Vous pouvez noter ceci avec l'IS_STN.Ind. Maintenant le routeur doit se tenir sur cette trame temporairement jusqu'à ce qu'elle efface quelques détails entre les deux Routeurs de DLSw.

DLSw: new_ckt_from_clsi(): TokenRing3/0 4001.68ff.0001:4->4000.0000.0001:4
DLSw: START-FSM (1622182940): event:DLC-Id state:DISCONNECTED
DLSw: core: dlsw_action_a()
DISP Sent : CLSI Msg : REQ_OPNSTN.Req   dlen: 108
DLSw: END-FSM (1622182940): state:DISCONNECTED->LOCAL_RESOLVE
 
DLSW Received-ctlQ : CLSI Msg : REQ_OPNSTN.Cfm CLS_OK dlen: 108
DLSw: START-FSM (1622182940): event:DLC-ReqOpnStn.Cnf state:LOCAL_RESOLVE
DLSw: core: dlsw_action_b()
CORE: Setting lf size to 30
%DLSWC-3-SENDSSP: SSP OP = 3(CUR)  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:LOCAL_RESOLVE->CKT_START
 
%DLSWC-3-RECVSSP: SSP OP = 4(ICR)  from peer 5.5.5.1(2065)
DLSw: 1622182940 recv FCI 0 - s:0 so:0 r:0 ro:0
DLSw: recv RWO
DLSw: START-FSM (1622182940): event:WAN-ICR state:CKT_START
DLSw: core: dlsw_action_e()
DLSw: sent RWO
DLSw: 1622182940 sent FCI 80 on  ACK   - s:20 so:1 r:20 ro:1
%DLSWC-3-SENDSSP: SSP OP = 5(ACK)  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:CKT_START->CKT_ESTABLISHED

Voici que vous pouvez noter l'écoulement interne de DLSw entre les deux pairs. Ces paquets sont normaux pour chaque démarrage de session. La première phase est de se déplacer d'un état déconnecté à un état CKT_ESTABLISHED. Les deux Routeurs transmettent une trame CUR pour le circuit elle-même. Ceci s'appelle peut l'installation de circuit de portée u (CURCS). Quand le pair qui initie la trame CURCS reçoit une trame ICRCS, elle envoie un accusé de réception et se déplace à un état établi de circuit. Maintenant, les deux Routeurs de DLSw sont prêts pour le traitement XID.

DLSw: START-FSM (1622182940): event:DLC-Id state:CKT_ESTABLISHED
DLSw: core: dlsw_action_f()
DLSw: 1622182940 sent FCA on  XID
%DLSWC-3-SENDSSP: SSP OP = 7(XID)  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:CKT_ESTABLISHED->CKT_ESTABLISHED

Le routeur a reçu un XID après envoi de la réponse de test à la station. Il enregistre ce XID pendant un instant, puis le communique au pair à travers le circuit. Ceci signifie que vous leur envoyez des paquets à/de le pair avec l'ID de circuit étiqueté. De cette façon, DLSw comprend l'activité entre les deux stations. Souvenez-vous que DLSw termine le Logical Link Control, le type-2 (LLC2), session sur chaque côté du nuage.

%DLSWC-3-RECVSSP: SSP OP = 7(XID)  from peer 5.5.5.1(2065)
DLSw: 1622182940 recv FCA on  XID   - s:20 so:0 r:20 ro:0
DLSw: START-FSM (1622182940): event:WAN-XID state:CKT_ESTABLISHED
DLSw: core: dlsw_action_g()
DISP Sent : CLSI Msg : ID.Rsp   dlen: 12
DLSw: END-FSM (1622182940): state:CKT_ESTABLISHED->CKT_ESTABLISHED
 
DLSW Received-ctlQ : CLSI Msg : ID.Ind   dlen: 39
DLSw: START-FSM (1622182940): event:DLC-Id state:CKT_ESTABLISHED
DLSw: core: dlsw_action_f()
%DLSWC-3-SENDSSP: SSP OP = 7(XID)  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:CKT_ESTABLISHED->CKT_ESTABLISHED

Vous notez d'abord une réponse au premier XID qui a été envoyé déja. Dans ID.Rsp, vous voyez que le XID a été envoyé à la station, à laquelle la station répondue avec un ID.Ind. C'est un autre XID qui a été envoyé à travers au pair de DLSw.

%DLSWC-3-RECVSSP: SSP OP = 8(CONQ)  from peer 5.5.5.1(2065)
DLSw: START-FSM (1622182940): event:WAN-CONQ state:CKT_ESTABLISHED

La présente partie nous prouve que la station de l'autre côté a répondu avec un SABME (CONQ) au XID. La négociation XID s'est terminée et le routeur est prêt à commencer la session.

DLSw: core: dlsw_action_i()
DISP Sent : CLSI Msg : CONNECT.Req   dlen: 16

Ensuite, le routeur envoie le SABME à la station dans CONNECT.Req.

DLSw: END-FSM (1622182940): state:CKT_ESTABLISHED->CONTACT_PENDING
 
DLSW Received-ctlQ : CLSI Msg : CONNECT.Cfm CLS_OK dlen: 8
DLSw: START-FSM (1622182940): event:DLC-Connect.Cnf state:CONTACT_PENDING
DLSw: core: dlsw_action_j()
%DLSWC-3-SENDSSP: SSP OP = 9( CONR )  to peer 5.5.5.1(2065) success
DISP Sent : CLSI Msg : FLOW.Req   dlen: 0
DLSw: END-FSM (1622182940): state:CONTACT_PENDING->CONNECTED

Alors vous recevez l'accusé de réception non-numéroté (uA) de la station, qui est affichée dans le message CONNECT.Cfm. Ceci est envoyé au pair distant par l'intermédiaire d'un CONR. Alors le processus du taux associé (rr) est commencé par FLOW.Req.

%DLSWC-3-RECVSSP: SSP OP = 10(INFO)  from peer 5.5.5.1(2065)
DLSw: 1622182940 decr r - s:20 so:0 r:19 ro:0
DLSw: START-FSM (1622182940): event:WAN-INFO state:CONNECTED
DLSw: core: dlsw_action_m()
DISP Sent : CLSI Msg : DATA.Req   dlen: 34
DLSw: END-FSM (1622182940): state:CONNECTED->CONNECTED
 
DLSw: 1622182940 decr s - s:19 so:0 r:19 ro:0
DLSW Received-disp : CLSI Msg : DATA.Ind   dlen: 35
DLSw: sent RWO
DLSw: 1622182940 sent FCI 80 on  INFO  - s:19 so:0 r:39 ro:1
%DLSWC-3-SENDSSP: SSP OP = 10(INFO)  to peer 5.5.5.1(2065) success
%DLSWC-3-RECVSSP: SSP OP = 10(INFO)  from peer 5.5.5.1(2065)
DLSw: 1622182940 decr r - s:19 so:0 r:38 ro:1
DLSw: 1622182940 recv FCA on  INFO  - s:19 so:0 r:38 ro:0
DLSw: 1622182940 recv FCI 0 - s:19 so:0 r:38 ro:0
DLSw: recv RWO
DLSw: START-FSM (1622182940): event:WAN-INFO state:CONNECTED
DLSw: core: dlsw_action_m()
DISP Sent : CLSI Msg : DATA.Req   dlen: 28
DLSw: END-FSM (1622182940): state:CONNECTED->CONNECTED

Le DATA.Req indique que le routeur a transmis une trame I. Data.Ind indique que le routeur a reçu une trame I. Vous pouvez employer ces informations pour déterminer l'écoulement de paquet à travers les Routeurs de DLSw.

DLSW Received-ctlQ : CLSI Msg : DISCONNECT.Ind   dlen: 8
DLSw: START-FSM (1622182940): event:DLC-Disc.Ind state:CONNECTED

La présente partie contient un DISCONNECT.Ind. . L'Ind indique un paquet étant livré dedans du RÉSEAU LOCAL. Dans ce cas, la station envoie un DÉBRANCHEMENT, qui fait commencer le routeur démolir le circuit.

DLSw: core: dlsw_action_n()
%DLSWC-3-SENDSSP: SSP OP = 14( HLTQ )  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:CONNECTED->DISC_PENDING
 
%DLSWC-3-RECVSSP: SSP OP = 15( HLTR )  from peer 5.5.5.1(2065)
DLSw: START-FSM (1622182940): event:WAN-HLTR state:DISC_PENDING

Après que le routeur reçoive le DÉBRANCHEMENT, il envoie une INTERRUPTION au pair distant et attend la réponse. Tout ce qui reste est d'envoyer un uA à la station et à la fermeture le circuit, qui est affiché dans le suivant met au point avec le DISCONNECT.Rsp :

DLSw: core: dlsw_action_q()
DISP Sent : CLSI Msg : DISCONNECT.Rsp   dlen: 4
DISP Sent : CLSI Msg : CLOSE_STN.Req   dlen: 4
DLSw: END-FSM (1622182940): state:DISC_PENDING->CLOSE_PEND
 
DLSW Received-ctlQ : CLSI Msg : CLOSE_STN.Cfm CLS_OK dlen: 8
DLSw: START-FSM (1622182940): event:DLC-CloseStn.Cnf state:CLOSE_PEND
DLSw: core: dlsw_action_y()
DLSw: 1622182940 to dead queue
DLSw: END-FSM (1622182940): state:CLOSE_PEND->DISCONNECTED

La dernière chose DLSw exécute est de mettre le circuit dans la file d'attente morte. De là, des pointeurs sont nettoyés et préparent pour un nouveau circuit.

Sessions de Netbios

DLSw manipule des sessions de Netbios différemment, mais met au point sont très semblables.

/image/gif/paws/12249/dlsw_5.gif

Remarque: Souvenez-vous que XIDs ne circulent pas pour des stations de Netbios et que les trames et le nom NetBIOS du processeur de commutateur de système de requête de nom NetBIOS d'échange de Routeurs de DLSw (SSP) ont reconnu. C'est la principale différence.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 12249