Distribution de vidéo et de contenu : Routeurs d'accès par câble de la gamme Cisco uBR900

cable-modem dhcp-proxy nat sur des modems câble Cisco

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document explique comment utiliser la commande nat de cable-modem dhcp-proxy. La fonction principale de cette commande est de configurer un pool d'adresses de Traduction d'adresses de réseau (NAT) avec une adresse IP fournie par le serveur DHCP du fournisseur d'Intrernet.

Le pour en savoir plus, se rapportent au cable-modem dhcp-proxy dans des commandes IOS CMTS de câble.

attention Attention : Rendez-vous compte de l'ID de bogue Cisco CSCdt32356 (clients enregistrés seulement), qui est réparé dans des séries de versions du logiciel 12.2 de Cisco IOSÝ et plus tard. NAT dynamique utilisant la commande nat d'interface de câble de nom du pool de cable-modem dhcp-proxy ne fonctionne pas correctement. L'adresse IP ou les masques de sous-réseau et les passerelles par défaut ne sont pas assignés correctement, le cas échéant. Après que la commande soit sélectionnée, l'adresse qui est assignée au groupe NAT ne répond pas au Protocole ARP (Address Resolution Protocol). L'ip nat pool qui est créé est de la portée de modem câble, plutôt que la portée de la CPE (le CPE), ainsi lui met une adresse IP unroutable dans le groupe NAT. Notez que ce problème se produit dans les versions logicielles de Cisco IOS pour plusieurs Modems câble, particulièrement 12.1(5)T. Il est recommandé que vous utilisez la logiciel Cisco IOS série de version 12.2 sur l'uBR924 et utilisez des versions 12.2T, 12.3, et plus défuntes séries pour l'uBR905, l'uBR925, et les Modems CVA. Pour information les informations complémentaires, référez-vous à l'ID de bogue Cisco CSCdt32356 (clients enregistrés seulement).

Remarque: Rendez-vous également compte de ces considérations :

  1. Puisque les Plateformes uBR904 ne prennent en charge pas le Logiciel Cisco IOS version 12.1(1)T, il n'est pas possible de configurer la commande de cable-modem dhcp-proxy sur cette plate-forme.

  2. Pour activer la caractéristique de DHCP-proxy sur l'uBR924, on le recommande généralement que vous utilisiez la version du logiciel Cisco IOS 12.2(6j).

  3. Pour le CVA122, la commande est documentée comme DHCP-proxy de câble nat. Cette commande est identique que la commande nat de cable-modem dhcp-proxy sur les Modems câble de gamme uBR900.

    D'un CVA122, cette sortie peut être vue :

    Router(config)# interface cable 0
    
    Router(config-if)# cable?
    
    cable-modem

Conditions préalables

Conditions requises

Les lecteurs de ce document devraient avoir connaissance des sujets suivants :

  • Compréhension de base de la traduction d'adresses réseau et pourquoi elle est utilisée

  • Protocole du Data-over-Cable Service Interface Specifications (DOCSIS) 1.0

  • L'interface de ligne de commande de logiciel de Cisco IOS

Composants utilisés

Cette table affiche les versions logicielles de Cisco IOS qui prennent en charge cette commande pour chaque plate-forme de modem câble Cisco :

Libérez qu'introduit la commande de cable-modem dhcp-proxy Plate-forme
12.1(1)T uBR924
12.1(3)XL uBR905
12.2(2)XA uBR925
12.1(5)XU1 CVA122

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

NAT dynamique contre NAT statique

Avec NAT dynamique, les traductions n'existent pas dans la table de traduction NAT jusqu'à ce que le routeur reçoive le trafic qui exige la traduction. Les traductions dynamiques ont une période de minuterie, après quoi elles sont purgées de la table de traduction. Avec NAT statique, cependant, les traductions existent dans la table de traduction NAT dès que vous configurerez une commande NAT statique, et elles demeurent dans la table de traduction jusqu'à ce que vous supprimiez la commande ou les commandes NAT statique.

Le moyen le plus simple de déterminer que vous faites configurer NAT dynamique dans votre modem câble est en recherchant cette commande dans la configuration du modem câble :

ip nat inside source list 100 interface cable-modem0 overload

En indiquant la source NAT une liste d'accès, vous construisez dynamiquement la table de traduction NAT. La commande nat de cable-modem dhcp-proxy utilise cette caractéristique NAT dynamique.

Configuration utilisant la commande nat de cable-modem dhcp-proxy

En utilisant la commande nat de cable-modem dhcp-proxy, l'adresse utilisée pour le groupe NAT est automatiquement allouée du serveur DHCP du câblo-opérateur.

En utilisant cette option, incluez ces commandes de configuration NAT :

  • interface interne d'ip nat — Utilisation de configurer l'interface Ethernet comme interface de « intérieur ».

  • interface d'ip nat outside — Utilisation de configurer l'interface de câble comme interface de « extérieur ».

  • surcharge — Spécifiez cette option avec la commande de configuration globale d'IP NAT parce que le groupe NAT créé par la commande nat de cable-modem dhcp-proxy contient seulement une adresse IP.

Après avoir configuré le routeur avec la commande nat de cable-modem dhcp-proxy, redémarrez le routeur. Pendant le processus d'approvisionnement DOCSIS, le routeur envoie une demande de DHCP Client d'obtenir une adresse IP pour l'interface de câble. Le routeur envoie alors une requête DHCP de proxy au serveur DHCP utilisant l'adresse MAC de l'interface Ethernet. Le serveur DHCP répond avec une deuxième adresse IP que le routeur assigne à une interface dynamiquement configurée de bouclage qui indique un groupe NAT dynamiquement configuré de seulement une adresse.

Voyez la sortie de configuration dans ce document pour les informations qui sont automatiquement ajoutées à la configuration après que le DHCP soit traité.

Pour configurer NAT de sorte qu'il crée le groupe dynamiquement, émettez ces commandes sur votre routeur. Souvenez-vous que, afin de configurer NAT, votre routeur doit être en mode de routage.

Router# config t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)# interface ethernet 0

Router(config-if)# ip address 192.168.1.1 255.255.255.0

!--- Assign an IP address to interface Ethernet 0.

Router(config-if)# no bridge-group 59

!--- Remove bridging so that you can configure for routing.

Router(config-if)# no bridge-group 59 spanning

!--- Remove bridging spanning.

Router(config-if)# ip nat inside

!--- Enable NAT inside for the Ethernet interface.

Router(config-if)# exit

Router(config)#

Router(config)# interface cable 0

Router(config-if)# no bridge-group 59

!--- Remove bridging so that you can configure for routing.

Router(config-if)# no bridge-group 59 spanning

!--- Remove bridging spanning.

Router(config-if)# no cable compliant bridge

!--- Remove bridging so that you can configure for routing.

Router(config-if)# ip nat outside

!--- Enable NAT outside for the cable interface.

Router(config-if)# cable-modem dhcp-proxy nat TEST_POOL

!--- Define dhcp-proxy nat for the TEST_POOL pool.

Router(config-if)# exit

Router(config)#

Router(config)# ip routing

!--- Enable routing.

Router(config)# ip nat inside source list 1 pool TEST_POOL overload

!--- Configure dynamic NAT.

Router(config)# access-list 1 permit 192.168.1.0 0.0.0.255

!--- Define interesting traffic for NAT.

La configuration ressemble à ceci :

router# show run

Building configuration...
Current configuration : 953 bytes
!
version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router
!
logging rate-limit console 10 except errors
!
ip subnet-zero
no ip finger
!
ip audit notify log
ip audit PO max-events 100
no ip dhcp-client network-discovery
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 no ip mroute-cache
!
interface cable-modem0
 ip nat outside
 no ip mroute-cache
 no cable-modem compliant bridge
 cable-modem dhcp-proxy nat TEST_POOL
!
ip nat inside source list 1 pool TEST_POOL overload
ip classless
no ip http server
no ip http cable-monitor
!
access-list 1 permit 192.168.1.0 0.0.0.255
snmp-server packetsize 4096
snmp-server manager
!
voice-port 0
 input gain -2
 output attenuation 0
!
voice-port 1
 input gain -2
 output attenuation 0
!
!
line con 0
 transport input none
line vty 0 4
 login
!
end

router#

Les commandes grasses sont celles que vous avez écrites ; les autres sont les par défaut. Notez que le groupe NAT encore n'a pas été créé en ce moment. Le modem câble doit être rechargé, ou l'interface de câble doit être remise à l'état initial en émettant la commande fermée suivie de l'aucune commande fermée.

router# reload

Proceed with reload? [confirm]
133.CABLEMODEM.CISCO: 00:06:16: %SYS-5-RELOAD: Reload requested
System Bootstrap, Version 12.0(6r)T3, RELEASE SOFTWARE (fc1)
Copyright (c) 1999 by Cisco Systems, Inc.
UBR924 platform with 16384 Kbytes of main memory
program load complete, entry point: 0x80010000, size: 0x398070
Self decompressing the image : #################################
################################################################
################################################################
################################################################
################################################################
################################################################
########################################################## [OK]

!--- Output suppressed.

Press RETURN to get started!

Remarque: Dans la sortie de configuration, les informations qui sont automatiquement ajoutées à la configuration après que le DHCP soit traité sont notées avec des commentaires.

Dans ce document, un uBR7114 et un uBR924 sont utilisés comme exemples. Les versions logicielles de Cisco IOS installées sur eux sont 12.1(5)EC1 et 12.1(3a)T4, respectivement. La prochaine figure affiche la Connectivité et les adresses IP utilisées.

Figure 1 : Diagramme utilisé dans la configuration utilisant la commande nat de DHCP-proxy de câble

/image/gif/paws/12176/cable_dhcp_proxy1.gif

uBR924 — Configuration du pool d'adresses NAT avec une adresse IP fournie par le serveur DHCP du fournisseur de services
router# show run

Building configuration...
Current configuration : 1273 bytes
!
! Last configuration change at 13:12:52 - Tue Feb 29 2000
!
version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router
!
logging rate-limit console 10 except errors
!
clock timezone - -8
ip subnet-zero
no ip finger
!
ip audit notify log
ip audit PO max-events 100
no ip dhcp-client network-discovery
!
!
interface Loopback0
 ip address 111.111.111.8 255.255.255.255

!--- Lookback interface added automatically by DHCP configuration.

!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 no ip mroute-cache
!
interface cable-modem0
 ip nat outside
 no ip mroute-cache
 no cable-modem compliant bridge
 cable-modem dhcp-proxy nat TEST_POOL
 cable-modem boot admin 2
 cable-modem boot oper 5
 cable-modem downstream saved channel 525000000 37 1
!
ip nat pool TEST_POOL 111.111.111.8 111.111.111.8 netmask 255.255.255.0

!--- NAT pool added automatically by DHCP configuration.

ip nat inside source list 1 pool TEST_POOL overload
ip classless
no ip http server
no ip http cable-monitor
!
access-list 1 permit 192.168.1.0 0.0.0.255
snmp-server packetsize 4096
snmp-server manager
!
voice-port 0
 input gain -2
 output attenuation 0
!
voice-port 1
 input gain -2
 output attenuation 0
!
!
line con 0
 transport input none
line vty 0 4
 login
!
end

Vérification de configuration

Cette section décrit comment employer la sortie de commande show pour vérifier la configuration du modem câble.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Émettez la commande de show arp d'afficher les entrées dans la table ARP.

router# show arp

Protocol  Address         Age (min) Hardware Addr   Type   Interface
Internet  111.111.111.111      56   0002.b9ff.8c1c  ARPA   cable-modem0
Internet  10.4.1.1             59   0002.b9ff.8c1c  ARPA   cable-modem0

!--- IP address of the interface cable 1/0
!--- of the cable modem termination system (CMTS).

Internet  192.168.1.1           -   0030.1976.771a  ARPA   Ethernet0
Internet  192.168.1.5          34   00a0.243c.eff5  ARPA   Ethernet0

!--- IP address of the PC behind the cable modem.

Internet  10.4.1.114            -   0030.1976.771b  ARPA   cable-modem0

Le PC derrière le modem câble a l'adresse IP 192.168.1.5 statiquement configuré. Il est très facile, cependant, pour faire au modem câble un serveur DHCP qui assigne dynamiquement une adresse IP à ses hôtes de RÉSEAU LOCAL ; utilisez cette configuration :

ip dhcp excluded-address 192.168.1.1 
ip dhcp pool pool name


   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1

Pour tester que les travaux NAT, émettent une commande ping du PC s'est connecté derrière le modem câble pour essayer d'atteindre l'interface de câble.

Si vous regardez la table de traduction NAT, vous pouvez voir les traductions réussies.

router# show ip nat translations

Pro  Inside global      Inside local       Outside local    Outside global
icmp 111.111.111.8:512  192.168.1.5:512    10.4.1.114:512   10.4.1.114:512

Le pour en savoir plus, se rapportent au cable-modem dhcp-proxy dans des commandes IOS CMTS de câble.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 12176