Voix : H.323

VoIP sur frame relay avec PVCs multipoint et hiérarchisation

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document discute la formation et la hiérarchisation du trafic pour une voix sur ip (VoIP) au-dessus de réseau de Relais de trames avec la topologie de hub and spoke. La configuration du hub est telle qu'il y a deux circuits virtuels permanents (PVCs), un pour chaque rayon distant, et les deux données et Voix sont envoyées au-dessus du même PVCs. Il est important de noter que la hiérarchisation et la fragmentation discutées dans ce document s'applique non seulement à ce scénario mais également à un scénario où vous pouvez avoir un PVC avec la Voix et les données et des autres avec seulement des données. Les circuits de données PVC doivent être en forme de trafic juste comme la Voix et les circuits de données PVC. C'est dû au fait que quand un canal physique simple est partagé, dans ce cas au hub, le retard de fabrication en série affecte toutes les données.

Dans la topologie ci-dessous, New York représente le routeur de central de hub. Raleigh et San Jose représentent les Routeurs distants connectés au hub par un réseau de Relais de trames. Il y a de deux PVCs qui se connectent au routeur de New York. Dans ce cas, New York devrait ne jamais envoyer plus que les 64 Kbits/s à Raleigh et de même, il devraient ne jamais envoyer plus de 192 Kbps à San Jose parce que ceci dépasse le débit de données garanti configuré (CIR) sur les mapclass de Relais de trames.

En topologie représentée dans ce document, les Routeurs avec des configurations VoIP sont directement connectés à un nuage de Relais de trames. Dans quelques topologies, cependant, les routeurs activés par la voix peuvent exister n'importe où dans le réseau, excepté Cisco AS5300. Pour plus d'informations sur ceci, référez-vous à la note fournie. Les Routeurs de Voix peuvent être connectés par la Connectivité de RÉSEAU LOCAL à d'autres Routeurs qui sont connectés au WAN. Il est important noter ce parce que si vos Routeurs de Voix ne sont pas directement connectés à un service de Relais de trames, toutes les commandes de configuration de connectivité WAN sont configurées sur ces Routeurs qui sont connectés au WAN, et pas sur les Routeurs de Voix.

Remarque:  Des Routeurs de Cisco AS5300 avec des interfaces série à haut débit ne sont pas conçus pour prendre en charge la connexion de données à un WAN. Vous devez employer votre Cisco AS5300s en tant que Routeurs intermédiaires de RÉSEAU LOCAL avec la fonctionnalité principale pour traiter des communications voix. Vous avez besoin de Routeurs dédiés pour agir en tant que liaisons directes au WAN.

Conditions préalables

Conditions requises

Avant que vous tentiez cette configuration, assurez-vous que vous rencontrez ces conditions préalables :

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Trois Routeurs de Cisco 3640 avec la version de logiciel 12.3(5) de Cisco IOSÝ Enterprise Plus

  • Quatre téléphones analogiques se sont connectés aux ports du Foreign Exchange Station (FXS) sur des rais

  • Un PBX a connecté au t1 un contrôleur sur le routeur concentrateur

Les rais peuvent également être un Cisco 2600 ou une plate-forme 1750. Le hub peut être un Cisco 2600 ou une plate-forme 3600 dans le cas de voix numérique, mais ce peut également être une plate-forme de Cisco 1750 si seulement la Voix analogique existe au hub. Tous trafiquent la formation et les configurations appliquent à d'autres Plateformes aussi bien.

Remarque: Bien que ce document ne soit pas limité au logiciel spécifique, certaines des commandes utilisées ici ne sont pas disponibles avec toutes les versions de logiciel de Cisco IOS. Par exemple, la commande de frame-relay fragment est prise en charge avec l'IP Plus mais pas par une image IP.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurer le trafic formant et hiérarchisation pour un VoIP sur frame relay

Quand vous exécutez le VoIP sur frame relay, il est important que le trafic envoyé au-dessus de la trame reste à un niveau qui est inférieur ou égal au Relais de trames CIR. Le routeur n'envoie pas le trafic qui dépasse le CIR une fois configuré avec le Formatage du trafic de relais de trames (FRTS) comme affiché. Si vous configurez le routeur pour s'exécuter à une vitesse plus grande que le CIR, vous pouvez éprouver des problèmes de qualité voix, et la Qualité vocale n'est pas garantie quand vous exécutez PVCs au-dessus du CIR garanti.

Remarque: Il est possible de configurer la mise en forme adaptative pour permettre à un routeur d'étrangler en bas du débit de transmission à une valeur spécifiée si des paquets de relais de trame sont reçus avec le positionnement explicite arrière de bit de la notification d'encombrement (BECN). Vous êtes informé que cependant, ces débits de trafic ne sont pas de dépasser le CIR du service de Relais de trames quand des paquets vocaux sont transmis. C'est d'assurer la qualité et la livraison appropriées quand des paquets vocaux en temps réel sont envoyés à travers le réseau. La configuration où le CIR est dépassé est seulement recommandée pour les circuits de données PVC qui ne portent pas le trafic vocal.

Remarque: En outre, avant que vous puissiez configurer votre routeur pour utiliser le VoIP, il est le meilleur si vous comprenez les caractéristiques de Qualité de service (QoS) en logiciel de Cisco IOS. Pour se renseigner plus sur des caractéristiques de QoS, référez-vous à la Mise en file d'attente, le trafic formant, et filtrage et la fragmentation pour la Voix.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau affichée dans le diagramme ici :

/image/gif/paws/12162/voip_fr_mp_1.gif

Configurations

Ce document utilise les configurations suivantes :

Routeur concentrateur de New York
Current configuration:
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname newyork
!
logging buffered 50000 debugging
enable secret < password > [Choose a strong password with 
at least one capital letter, one number, and one special character.]
!
controller T1 2/0
framing esf
linecode b8zs
ds0-group 1 timeslots 1-4 type e&m-wink-start
!
!
interface Serial2/0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 frame-relay traffic-shaping

!--- This CLI command enables traffic shaping for both PVCs.

!
interface Serial2/0.1 point-to-point
description Connection to Raleigh PVC
ip address 172.16.120.2 255.255.255.0
  frame-relay interface-dlci 100
  class class-raleigh
!
interface Serial2/0.2 point-to-point
description Connection to San Jose PVC
ip address 172.16.130.2 255.255.255.0
frame-relay interface-dlci 200
  class class-sanjose
!
ip classless
!
map-class frame-relay class-raleigh
 frame-relay cir 64000
 frame-relay bc 640
 frame-relay be 0
 frame-relay mincir 64000
 no frame-relay adaptive-shaping
 frame-relay fair-queue
 frame-relay fragment 80

!--- Recommended fragment size for 10ms delay when carrying voice
!--- traffic based on the configured CIR 64000.
!--- based on the configured CIR 64000

 frame-relay ip rtp priority 16384 16383 48

!--- Two calls with g729, no CRTP, at 24 kbps/each.

 !
map-class frame-relay class-sanjose
 frame-relay cir 192000
 frame-relay bc 1920
 frame-relay be 0
 frame-relay mincir 192000
 no frame-relay adaptive-shaping
 frame-relay fair-queue
 frame-relay fragment 240

!--- This is the recommended fragment size for 10ms delay when carrying voice traffic
!--- based on the configured CIR 192000.

frame-relay ip rtp priority 16384 16383 48 

!--- Two calls with G729, no Compressed Real Time Protocol (cRTP), at 24kbpseach.

!
!
voice-port 2/0:1
!
dial-peer cor custom
!
dial-peer voice 100 pots

!--- Calls to the Public Switched Telephone Network (PSTN).

 destination-pattern 212.......
prefix 212
port 2/0:1
!
dial-peer voice 200 pots

!--- Calls to the corporate network-four digit extension forwarded.

destination-pattern 567....
 port 2/0:1
!
dial-peer voice 110 voip

!--- Calls to Raleigh.

destination-pattern 919392....
session target ipv4:172.16.120.1
 ip qos dscp cs5 media
dtmf-relay h245-alphanumeric
!
dial-peer voice 210 voip    
!--- Calls to San Jose.

destination-pattern 408527....
session target ipv4:172.16.130.1
 ip qos dscp cs5 media
dtmf-relay h245-alphanumeric
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 no login
!
end  

La commande d'ip qos dscp a été introduite dans IOS version12.2(2)T de remplacer la commande d'ip precedence (dial peer).

La commande de frame-relay ip rtp priority réserve une file d'attente prioritaire stricte pour un ensemble d'écoulements de paquet de Protocole RTP (Real-Time Protocol) qui appartient à une plage des destinations port de Protocole UDP (User Datagram Protocol).

Remarque: Puisque la commande de frame-relay ip rtp priority accorde la priorité absolue au-dessus de l'autre trafic, utilisez cette commande avec soin. En cas de l'encombrement, si le trafic dépasse la bande passante configurée, puis tout les trafic excédentaire est abandonné.

Cisco 3640 Raleigh
Current configuration:
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname raleigh3640a
!

logging buffered 50000 debugging
enable secret < password > [Choose a strong password with at 
least one capital letter, one number, and one special character.]
!
no ip subnet-zero
!
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
dial-peer voice 1 pots
 destination-pattern 9193924100
port 1/0/0
!
dial-peer voice 2 voip
 destination-pattern 2126789001
  ip qos dscp cs5 media
 dtmf-relay h245-alphanumeric
 session target ipv4: 172.16.120.2 
!

interface Loopback0
 ip address 172.16.125.1 255.255.255.255
 no ip directed-broadcast
!

interface Serial2/0
 no ip address
 encapsulation frame-relay
 frame-relay traffic-shaping
!
interface Serial2/0.1 point-to-point
description Connection to New York
 ip address 172.16.120.1 255.255.255.0

 frame-relay interface-dlci 100
  class fr_class_voip  
!
!
ip classless
no ip http server
!
!
map-class frame-relay fr_class_voip
 frame-relay cir 64000
 frame-relay bc 640
 frame-relay be 0
 frame-relay mincir 64000
 no frame-relay adaptive-shaping
 frame-relay fair-queue
 frame-relay fragment  80


!--- The recommended fragment size for 10ms delay when carrying voice traffic.


!--- based on the configured CIR 64000.


  frame-relay ip rtp priority 16384 16383 48
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 no login
!
end

Vérifiez

Cette section fournit des informations que vous pouvez employer pour confirmer vos travaux de configuration.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • show frame-relay fragment — Affiche des informations au sujet de la fragmentation de relais de trame qui a lieu sur le routeur de Cisco.

  • show traffic-shape queue — L'affiche des informations au sujet des éléments s'est alignée au niveau de l'identificateur de connexion de liaison de données de circuit virtuel (circuit virtuel) (DLCI). Cette commande est utilisée de vérifier le fonctionnement de la priorité IP RTP au-dessus du Relais de trames. Quand le lien est congestionné, des flux voix sont identifiés avec un poids de zéro. Ceci indique que le flux voix utilise la file d'attente prioritaire. Référez-vous à la sortie témoin fournie.

  • show frame-relay pvc [dlci#] — Affiche des informations telle que des paramètres de formatage du trafic, des valeurs de fragmentation, et des paquets relâchés. Référez-vous à la sortie témoin fournie ici et référez-vous également au guide complet de configurer et de dépannage de Frame Relay pour de plus amples informations.

newyork#show frame-relay fragment

interface   dlci   frag-type   frag-size   in-frag   out-frag   dropped-frag
 
Serial1/0.1 100    end-to-end    80          16        20           0 

Serial1/0.2 200    end-to-end    240         12        10           0 

newyork#show traffic-shape  serial 2/0.1
Interface Se2/0.1

     Access    Target   Byte   Sustain   Excess   Interval    Increment    Adapt
VC   List      Rate     Limit  bits/int  bits/int (ms)        (bytes)      Active

100            64000    80     640       0         10          80          -
  
newyork#show traffic-shape queue
Traffic queued in shaping queue on Serial2/0.1 dlci 100
  Queueing strategy: weighted fair
  Queueing Stats: 0/600/64/0 (size/max total/threshold/drops)
     Conversations  0/1/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 16 kilobits/sec

Traffic queued in shaping queue on Serial2/0.2 dlci 200
  Queueing strategy: weighted fair
  Queueing Stats: 0/600/64/0 (size/max total/threshold/drops)
    Conversations  0/1/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 144 kilobits/sec

newyork#show frame-relay pvc 100

PVC Statistics for interface Serial2/0 (Frame Relay DCE)

DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial2/0.1

input pkts 1078          output pkts 1078         in bytes 157792
out bytes 172284         dropped pkts 0           in pkts dropped 0
out pkts dropped 0                out bytes dropped 0
in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
out BECN pkts 0          in DE pkts 0             out DE pkts 0
out bcast pkts 28        out bcast bytes 8498
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:27:48, last time pvc status changed 00:27:48
Queueing strategy: weighted fair
Current fair queue configuration:
	Discard     Dynamic      Reserved
	threshold   queue count  queue count
		64          16           0
Output queue size 0/max total 600/drops 0
fragment type end-to-end        fragment size 80
cir 64000     bc   640       be 0         limit 80     interval 10
mincir 64000     byte increment 80    BECN response no  IF_CONG no
frags 2707      bytes 172284    frags delayed 2707      bytes delayed 172284
shaping inactive
traffic shaping drops 0
ip rtp priority parameters 16384 32767 48000

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Procédure de dépannage

Voici l'information de dépannage et les instructions concernant cette configuration :

  1. Dépannez le Relais de trames et le QoS mis en application pour la Voix et assurez son exécution correcte.

  2. Poursuivez à la panne de communication voix dépannant selon les besoins.

    Remarque: Pour l'information de dépannage plus détaillée, référez-vous au VoIP sur frame relay avec QoS (fragmentation, trafic formant, LLQ/IP RTP Priority).

Dépannage des commandes

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Remarque: Référez-vous aux informations importantes sur les commandes de débogage avant d'utiliser les commandes de débogage.

  • debug priority — Affiche des événements de Fonction Priority Queueing (PQ) et affiche si une baisse se produit dans cette file d'attente. Le pour en savoir plus, se rapportent à des suppressions de sortie de dépannage avec la file d'attente à priorité déterminée.

  • fragment de debug frame-relay — Affichages événement ou messages d'erreur liés à la fragmentation de relais de trame. Cette commande est seulement activée au niveau PVC sur l'interface sélectionnée.

    newyork#debug priority 
    Priority output queueing debugging is on
    newyork#ping 172.16.120.1
    Type escape sequence to abort. 
    Sending 5, 100-byte ICMP Echos to 172.16.120.1, timeout is 2 seconds: 
    !!!!! 
    Success rate is 100 percent (5/5), round-trip min/avg/max = 56/57/60 ms 
    newyork# 
    *Mar  1 05:11:24.746: PQ: Serial2/0 output (Pk size/Q 104/2)
    *Mar  1 05:11:24.754: PQ: Serial2/0 output (Pk size/Q 104/2) 
    *Mar  1 05:11:24.810: PQ: Serial2/0 output (Pk size/Q 104/2)
    *Mar  1 05:11:24.818: PQ: Serial2/0 output (Pk size/Q 104/2) 
    *Mar  1 05:11:24.874: PQ: Serial2/0 output (Pk size/Q 104/2) 
    *Mar  1 05:11:24.882: PQ: Serial2/0 output (Pk size/Q 13/0) 
    
    newyork#debug frame-relay fragment interface serial 2/0 100
    This may severely impact network performance.
    You are advised to enable no logging console debug. Continue?[confirm]
    Frame Relay fragment/packet debugging is on
    Displaying fragments/packets on interface Serial2/0 dlci 100 only
    
    *Mar  1 20:58:32.838: Serial1/0.1(o): dlci 100, tx-seq-num 3645, 
    B bit set, frag_hdr 03 B1 9C 3D
    *Mar  1 20:58:32.846: Serial1/0.1(o): dlci 100, tx-seq-num 3646, 
    E bit set, frag_hdr 03 B1 5C 3E
    *Mar  1 20:58:32.890: Serial1/0.1(i): dlci 100, rx-seq-num 17, 
    exp_seq-num 17,B bit set,
    	 frag_hdr 03 B1 80 11
    *Mar  1 20:58:32.894: Serial1/0.1(i): dlci 100, rx-seq-num 18, 
    exp_seq-num 18,E bit set,
    	 frag_hdr 03 B1 40 12

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 12162