Commutation LAN : EtherChannel

Exemple de configuration d'EtherChannel entre des commutateurs des gammes 3550/3560/3750 et des commutateurs Catalyst exécutant le logiciel système Cisco IOS

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (7 octobre 2015) | Commentaires


Contenu


Introduction

Ce document fournit une configuration d'échantillon pour que la façon installe un EtherChannel entre un Catalyst 3550 et un logiciel système de Ý de Cisco IOS d'exécution du Catalyst 6500/6000. En fonction de la vitesse des interfaces ou des ports utilisés pour former l’EtherChannel, il peut être appelé Fast EtherChannel ou Gigabit Channel.

Remarque: Les commandes EtherChannel appliquées à un commutateur Catalyst 3550 dans ces documents peuvent également être appliquées aux commutateurs de la gamme Catalyst 3750.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Version du logiciel Cisco IOS courante 12.1(14)EA de commutateur du Catalyst 3550

  • Version du logiciel Cisco IOS courante 12.1(13)E1 de commutateur du Catalyst 6500/6000

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Théorie générale

Dans ce document, deux interfaces Gigabit Ethernet sur un commutateur Catalyst 3550 -- (l’interface GigabitEthernet située sur le commutateur 3500 est une interface Ethernet négociée 10/100/1 000) -- ont été intégrées à Fast EtherChannel avec deux interfaces Fast Ethernet depuis un commutateur Catalyst 6500/6000 exécutant la plate-forme logicielle Cisco IOS pour former un EtherChannel couche 2 (L2).

Remarque: Dans ce document, Fast EtherChannel, Gigabit EtherChannel, canal de port et groupe de canaux renvoient tous à EtherChannel.

Dans ce document, la configuration de commutateur Catalyst s’applique à tous les commutateurs de la série Catalyst 6500/6000 ou Catalyst 4500/4000 exécutant la plate-forme logicielle Cisco IOS.

Ce document indique les fichiers de configuration des commutateurs uniquement, ainsi que la sortie de commandes « show » de l’exemple associé. Pour plus de détails sur la configuration d’un EtherChannel, reportez-vous aux documents suivants :

Remarques importantes

EtherChannel peut être configuré manuellement à l’aide des commandes adaptées. Vous pouvez également le configurer automatiquement à l’aide du protocole d’agrégation de ports (PAgP) afin que le commutateur négocie le canal avec l’autre côté. Pour plus de détails sur le protocole PAgP, reportez-vous aux documents suivants :

Les configurations indiquées dans ce document sont implémentées à l’aide du mode « desirable » (préférable). Si vous envisagez de configurer l’EtherChannel manuellement, utilisez les étapes indiquées afin de créer un canal de port. Cette opération permet d’éviter les problèmes de protocole STP (Spanning Tree Protocol) au cours du processus de configuration. Le protocole STP peut désactiver certains ports (dont l'état est « error-disabled » [errdisable]) si l’un des côtés est configuré en tant que canal avant que l’autre côté ne puisse l’être.

Exécutez les étapes suivantes pour créer un canal de port :

  1. Laissez les interfaces à utiliser dans le canal de port désactivées d’un point de vue administratif.

  2. Créez le canal de port (groupe de canaux) sur le commutateur Catalyst 6500/6000.

    Assurez-vous que vous définissez le mode du canal sur on. Par exemple, channel-group 1 mode on.

  3. Créez des canaux de port sur le commutateur Catalyst 3550, 3560 ou 3750.

    Assurez-vous que le mode du canal est défini sur on.

  4. Réactivez les interfaces précédemment désactivées sur le commutateur Catalyst 6500/6000 à l’aide de la commande no shut.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

/image/gif/paws/12033/89-a.gif

Remarque: L’interface Gigabit Ethernet du commutateur Catalyst 3550 est une interface Ethernet négociée 10/100/1 000 Mbits/s Le port Gigabit du commutateur Catalyst 3550 peut également être connecté à un port FastEthernet (100 Mbits/s) sur un commutateur Catalyst 6500/6000.

Remarque: Les commutateurs de la série Catalyst 3750 prennent en charge Cross-Stack EtherChannel, ce qui permet aux interfaces de différents commutateurs de pile de faire partie du même groupe EtherChannel. Pour plus d'informations sur le ÝEtherChannel dans l'environnement aÝstacked de commutateur, référez-vous à la section d'EtherChannel et de piles de commutateurs de configurer la documentation d'EtherChannels pour des Commutateurs de gamme Catalyst 3750.

Configurations

Ce document utilise les configurations suivantes :

Catalyst 3550
Building configuration...
Current configuration : 1610 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat3550
!
enable password ww
!
ip subnet-zero
no ip finger
!
!
!
!
!--- A logical port-channel interface is automatically created 
!--- when ports are grouped into a channel group.

interface Port-channel 1


!--- In this example, the L2 EtherChannel is configured.
!--- A Layer 3 (L3) EtherChannel can also be configured on the Catalyst 3550 switches.
!--- For more information, refer to the document Configuring EtherChannel.

switchport mode access no ip address snmp trap link-status!

!--- Note: The Gigabit Ethernet interface on the Catalyst 3550 is a 
!--- 10/100/1000 Mbps negotiated Ethernet interface. The Gigabit port on the Catalyst 3550 is 
!--- connected to a FastEthernet (100 Mbps) port on the Catalyst 6500/6000.

!--- The port is a member of channel group 1.

interface GigabitEthernet0/1
 switchport mode access
 no ip address
 snmp trap link-status
 channel-group 1 mode desirable
!


!--- The port is a member of channel group 1.

interface GigabitEthernet0/2
 switchport mode access
 no ip address
 snmp trap link-status
 channel-group 1 mode desirable
!
interface GigabitEthernet0/3
 switchport mode access
 no ip address
 snmp trap link-status
!


!--- Output suppressed.

interface GigabitEthernet0/12
 switchport mode access
 no ip address
 snmp trap link-status


!--- Interface VLAN1 is required for management purposes.

interface Vlan1
 ip address 10.1.1.1 255.255.255.0
!
ip classless
ip http server
!
!
line con 0
 transport input none
line vty 5 15
!
end

Catalyst 6500/6000
Building configuration...
  
 Current configuration : 5869 bytes
 !
 version 12.1
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname cat6500
 !
 boot buffersize 126968
 boot bootldr bootflash:c6msfc-boot-mz.121-4.E1
 enable password ww
 !
 redundancy
  main-cpu
   auto-sync standard
 ip subnet-zero
 !
 !
 no ip finger
 !
 !
 !
 !


!--- A logical port-channel interface is automatically created 
!--- when ports are grouped into a channel group.

 interface Port-channel 1
  no ip address
  switchport
  switchport mode access
 !
 interface GigabitEthernet1/1
  no ip address
  shutdown
 !
 interface GigabitEthernet1/2
  no ip address
  shutdown
 !

!--- Note: The Gigabit Ethernet interface on the Catalyst 3550 is a
!--- 10/100/1000 Mbps negotiated Ethernet interface. The Gigabit port on the Catalyst 3550 is 
!--- connected to a FastEthernet (100 Mbps) port on the Catalyst 6500/6000.

 interface FastEthernet3/1
  no ip address


!--- In this example, the L2 EtherChannel is configured.
!--- An L3 EtherChannel can also be configured on the Catalyst 6500/6000 running
!--- Cisco IOS System Software. For more details, refer to the document
!--- Configuring EtherChannel.

!--- On a Catalyst 6500/6000, you must issue the switchport
!--- command once, without any keywords, in order to configure the interface as an L2 port.
!--- By default, all the ports are router ports (L3 ports).
!--- On a Catalyst 4500/4000 switch, all ports are L2 ports by default;
!--- no additional command is required.

 switchport

!--- This command puts the interface in VLAN1, by default.

 switchport mode access

!--- The port is a member of channel group 1.

 channel-group 1 mode desirable
 !
 interface FastEthernet3/2
  no ip address

!--- On a Catalyst 6500/6000, you must issue the switchport 
!--- command once, without any keywords, in order to configure the interface as an L2 port.
!--- By default, all the ports are router ports (L3 ports).
!--- On a Catalyst 4500/4000 switch, all ports are L2 ports by default;  
!--- no additional command is required.

  switchport

!--- This command puts the interface in VLAN1, by default.

  switchport mode access

!--- The port is a member of channel group 1.

  channel-group 1 mode desirable
 !
 interface FastEthernet3/3
  no ip address
 switchport
  switchport mode access
 !


!--- Output suppressed.

 !
 interface FastEthernet3/48
  no ip address
 switchport
  switchport mode access
 !


!--- Interface VLAN1 is required for management purposes.

 interface Vlan1
  ip address 10.1.1.2 255.255.255.0
 !
 ip classless
 no ip http server
 !
 !
 !
 line con 0
  transport input none
 line vty 0 4
 !
 end

Remarque: Cet exemple de configuration illustre une configuration EtherChannel avec des liens d’accès. La même configuration s’applique aux liens de jonction EtherChannel. Utilisez la commande switchport mode trunk ou autorisez les commutateurs à négocier le mode à l’aide du mode dynamic desirable. Pour plus d’informations sur la configuration de la jonction, reportez-vous à la section Configuration des jonctions VLAN du document Configuration de VLAN.

Sous configuration d'interface de Port canalisé

Un autre exemple de la configuration du Port canalisé avec la sous interface dans la version du logiciel Cisco IOS courante de commutateur de Catalyst 3560 12.2(25).

Catalyst 3560
Building configuration...
  
Current configuration : 2480 bytes
!
version 12.2
!
interface Port-channel5
no switchport
no ip address
!
interface Port-channel5.690
!
interface Port-channel10
no switchport
no ip address
!
interface Port-channel10.1
!
interface Port-channel10.690
!
interface Port-channel11
no switchport
no ip address

Vérifiez

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Utilisez les commandes suivantes pour vérifier le canal de port sur les commutateurs Catalyst 6500/6000 et Catalyst 3500 exécutant la plateforme logicielle Cisco IOS :

Exécutez la commande suivante pour vérifier l’état du protocole STP dans les commutateurs Catalyst 6500/6000 et Catalyst 3500 exécutant la plateforme logicielle Cisco IOS :

Catalyst 3550

Cat3550#show interface port-channel 1
Port-channel1 is up, line protocol is up
Hardware is EtherChannel, address is 0002.4b28.db02 (bia 0002.4b28.db02)
MTU 1500 bytes, BW 200000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
 Full-duplex, 100Mb/s
input flow-control is off, output flow-control is off
 Members in this channel: Gi0/1 Gi0/2
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:03:27, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
26 packets input, 5344 bytes, 0 no buffer
Received 17 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
59 packets output, 5050 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

Cat3550#show spanning-tree vlan 1 detail
 
 VLAN1 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address 0002.4b28.db01
  Configured hello time 2, max age 20, forward delay 15
  We are the root of the spanning tree
  Topology change flag not set, detected flag not set
  Number of topology changes 1 last change occurred 00:00:38 ago
          from Port-channel1
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 0
 
 Port 65 (Port-channel1) of VLAN1 is forwarding
   Port path cost 12, Port priority 128, Port Identifier 128.65.
   Designated root has priority 32768, address 0002.4b28.db01
   Designated bridge has priority 32768, address 0002.4b28.db01
   Designated port id is 128.65, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 34, received 0 

Cat3550# show etherchannel 1 summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        R - Layer3      S - Layer2
        U - port-channel in use
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
1     Po1(SU)     Gi0/1(P)   Gi0/2(P)

Cat3550# ping 10.1.1.2
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

Catalyst 6500/6000

Cat6500# show interface port-channel 1
Port-channel1 is up, line protocol is up
  Hardware is EtherChannel, address is 0002.7ef1.36e1 (bia 0002.7ef1.36e1)
  MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Full-duplex, 100Mb/s
  Members in this channel: Fa3/1 Fa3/2
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/2000, 0 drops
  5 minute input rate 1000 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     407 packets input, 34994 bytes, 0 no buffer
     Received 311 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     93 packets output, 16598 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

Cat6500# show spanning-tree vlan 1 detail
 
 VLAN1 is executing the ieee compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address 00d0.024f.6001
  Configured hello time 2, max age 20, forward delay 15
  Current root has priority 32768, address 0002.4b28.db01
  Root port is 833 (Port-channel1), cost of root path is 12
  Topology change flag not set, detected flag not set
  Number of topology changes 0 last change occurred 00:02:13 ago
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 300
 
 Port 833 (Port-channel1) of VLAN1 is forwarding
   Port path cost 12, Port priority 128, Port Identifier 131.65.
   Designated root has priority 32768, address 0002.4b28.db01
   Designated bridge has priority 32768, address 0002.4b28.db01
   Designated port id is 128.65, designated path cost 0
   Timers: message age 1, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 0, received 66

Cat6500# show etherchannel 1 summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        R - Layer3      S - Layer2
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
1     Po1(SU)     Fa3/1(P)   Fa3/2(P)

Cat6500# ping 10.1.1.1
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

Dépannez

État Err-Disable

Le passage des interfaces en mode err-disable est un problème courant lors de la configuration d’EtherChannel. Cela se produit lorsque EtherChannel est placé en mode ON sur un commutateur et que l’autre commutateur n’est pas immédiatement configuré. Si l’état est conservé tel quel pendant environ une minute, le protocole STP du commutateur sur lequel EtherChannel est activé pense qu’il existe une boucle. Cela entraîne le passage des ports de canal en état err-disable . Pour plus d’informations sur la manière de déterminer si vos interfaces EtherChannel se trouvent en état err-disable reportez-vous à l’exemple suivant :

%SPANTREE-2-CHNL_MISCFG: Detected loop due to etherchannel misconfiguration of Gi0/9
%PM-4-ERR_DISABLE: channel-misconfig error detected on Po10, putting Gi0/9 in err-disable state
%PM-4-ERR_DISABLE: channel-misconfig error detected on Po10, putting Gi0/10 in err-disable state
Switch1#show etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        u - unsuitable for bundling
        U - in use      f - failed to allocate aggregator
        d - default port

Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
10     Po10(SD)         -        Gi0/9(D)    Gi0/10(D)

Switch1#show interfaces GigabitEthernet 0/9 status

Port      Name               Status       Vlan       Duplex  Speed Type
Gi0/9                        err-disabled 1            auto   auto 10/100/1000BaseTX

Switch1#show interfaces GigabitEthernet 0/10 status

Port      Name               Status       Vlan       Duplex  Speed Type
Gi0/10                       err-disabled 1            auto   auto 10/100/1000BaseTX

Le message d’erreur indique que l’interface EtherChannel a rencontré une boucle de spanning tree. Afin de résoudre le problème, placez le mode de canal à desirable des deux côtés de la connexion, et puis réactivez les interfaces :

Switch1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch1(config)#interface gi0/9
Switch1(config-if)#channel-group 10 mode desirable

Suite à cela, chaque côté forme un canal (sous réserve d’accord des deux côtés). S’ils n’acceptent pas de créer un canal, ils continuent à fonctionner comme des ports normaux.

Une fois le mode de canal défini sur desirable des deux côtés de la connexion, exécutez les commandes shutdown et no shutdown sur l’interface associée pour réactiver les ports manuellement :

Switch1(config-if)#shutdown
Switch1(config-if)#no shutdown

"La commande « speed nonegociate » ne s’affiche pas dans la configuration en cours

La commande speed nonegotiate configurée sur un canal de port ne s’affiche pas toujours dans la configuration en cours. Cela se produit car la commande nonegociate sur l’interface de canal de port dépend de celle des ports regroupés. Elle est insérée lorsque le canal de port est actif ; elle est également insérée en fonction de la configuration individuelle des ports du canal.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 12033