Commutation LAN : EtherChannel

Exemple de configuration : EtherChannel entre commutateurs Catalyst exécutant CatOS et le logiciel Cisco IOS

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (7 octobre 2015) | Commentaires


Contenu


Introduction

Ce document discute l'installation d'un EtherChannel entre un SYSTÈME D'EXPLOITATION courant de Catalyst de commutateur du Catalyst 5500/5000 (CatOS) et un commutateur du Catalyst 6500/6000 ou du Catalyst 4500/4000 exécutant le logiciel de Cisco IOSÝ. Un EtherChannel met en paquets des liaisons individuelles dans un lien logique simple qui fournit une bande passante plus élevée et la redondance entre les commutateurs ou d'autres périphériques. Vous pouvez vous référer à EtherChannel en tant que le Fast EtherChannel (FEC) ou Gigabit EtherChannel (GEC); cela dépend de la vitesse des interfaces ou des ports utilisés pour créer l'EtherChannel. Cette configuration s'applique également à un commutateur de la gamme Catalyst 4500/4000 ou 6500/6000 exécutant CatOS qui est connecté à un commutateur de la gamme Catalyst 4500/4000 ou 6500/6000 exécutant le logiciel Cisco IOS.

La configuration dans ce document empaquette deux ports de Fast Ethernet (technicien) de chacun des Commutateurs dans une FEC. Ce document emploie le terme « EtherChannel » pour se rapporter au GEC, à la FEC, au Port canalisé, au canal, et au groupe de port.

Ce document affiche seulement les fichiers de configuration des Commutateurs et la sortie des exemples de commande show relatifs. Pour plus de détails sur la configuration d’un EtherChannel, reportez-vous aux documents suivants :

Conditions préalables

Conditions requises

Avant que vous tentiez cette configuration, assurez-vous que vous avez une compréhension de base de :

  • Configuration d'EtherChannel

  • La configuration des gammes Catalyst 6500/6000 et Catalyst 5500/5000 commute avec l'interface de ligne de commande (le CLI)

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Commutateur Cisco Catalyst 5505 exécutant le logiciel de CatOS 6.4(8)

  • Logiciel Cisco IOS version 12.1(20)E courant de Commutateur Cisco Catalyst 6509

Remarque: Pour des configurations système requises d'EtherChannel sur des Commutateurs de Catalyst, référez-vous aux configurations système requises d'implémenter l'EtherChannel sur des Commutateurs de Catalyst.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques démarrés avec une configuration (par défaut) effacée. Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Théorie générale

Vous pouvez configurer l'EtherChannel sans réserve (avec le mode de canal en fonction) ou par la négociation automatique. Quand vous configurez par la négociation automatique, le commutateur est en pourparlers le canal avec l'extrémité. Pour faire ceci, il utilise le Protocole PAgP (Port Aggregation Protocol) de propriété industrielle de Cisco (avec la commande de mode desirable de canal) ou le Control Protocol d'agrégat de lien d'IEEE 802.3ad (LACP) (avec les commandes passives de mode d'active ou de canal de mode de canal). Dans ce document, la configuration d'EtherChannel utilise PAgP pour la négociation automatique.

Tout le Catalyst commute le support logiciel courant PAgP de système de CatOS. Les Commutateurs de gamme Catalyst 6500/6000 ou 4500/4000 exécutant le logiciel système de Cisco IOS prennent en charge également PAgP. Le mode recommandé pour établir un EtherChannel entre les périphériques qui prennent en charge PAgP est mode desirable. PAgP se protège contre toutes les configurations incorrectes entre les deux périphériques. Vous pouvez utiliser le mode de canal sur quand le périphérique se connectant ne prend en charge pas PAgP et vous devez installer le canal sans réserve. Vous pouvez utiliser les mots clé silents ou non-silents avec des modes automatiques et desirables de canal. Le Catalyst 6500/6000 ou 4500/4000 de Commutateurs ont le mot clé silent activé par défaut sur tous les ports. Les Commutateurs de gamme Catalyst 5500/5000 ont le mot clé silent activé par défaut sur les ports de cuivre. Pour tous les ports fibre (technicien et Gigabit Ethernet [GE]), les Commutateurs de 5500/5000 ont le mot clé non-silent activé par défaut. Utilisez le mot clé silent ou non-silent par défaut quand vous vous connectez entre les Commutateurs de Cisco.

Remarque: Pour des informations supplémentaires sur des modes channelings de PAgP et des modes de silent/non-silent, référez-vous au PAgP de utilisation pour configurer la section de (recommandé) d'EtherChannel et la section Mode de silent/non-silent du document configurant l'EtherChannel entre le Catalyst 4500/4000, 5500/5000, et 6500/6000 de Commutateurs qui exécutent le logiciel système de CatOS.

Configurez

Cette section présente les informations pour configurer les fonctionnalités décrites dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/12029/71a.gif

Instructions

Quand des liens actifs sont agrégés dans un EtherChannel, les ports momentanément laissent le spanning-tree et se joignent de retour en tant que simple, port logique. Jusqu'à ce que le spanning-tree reconverges, le trafic réseau est perturbé.

Si vous n'utilisez pas des protocoles tels que PAgP ou LACP pour la configuration de l'EtherChannel en raison d'autres considérations, assurez-vous que les paramètres exigés sont identiques sur les deux extrémités. S'ils sont différents, une extrémité du canal entrera dans le mode d'errer-débronchement. Pour récupérer les ports du mode d'errer-débronchement, référez-vous à ces derniers :

Configurations

Ce document utilise les configurations suivantes :

Remarque: Pour vérifier les capacités pour un module ou un port de commutateur que vous configurez, utilisez la commande de module de show port capabilities pour des Commutateurs exécutant CatOS. Pour des Commutateurs exécutant le logiciel de Cisco IOS, utilisez la commande de show interfaces capabilities.

Remarque: Dans les configurations, les commentaires entre les sorties apparaissent en les italiques bleu.

Catalyst 5500
cat5500 (enable) show config
This command shows non-default configurations only.
Use 'show config all' to show both default and non-default configurations.
......
................
................
..

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
# time: Wed Jan 28 2004, 09:39:55
!

# version 6.4(2) 
!
# errordetection
set errordetection portcounter enable
!
# frame distribution method
set port channel all distribution mac both
!
# vtp
set vtp domain cisco
set vlan 1 name default type ethernet mtu 1500 said 100001 state active
set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active
set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state
active stp ieee
set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state
active stp ibm
set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state
active mode srb aremaxhop 7 stemaxhop 7 backupcrf off
!
# ip

!--- This is the IP address for management.

set interface sc0 1 10.10.10.2/255.255.255.0 10.10.10.255

!
# set boot command
set boot config-register 0x2102
set boot system flash bootflash:cat5000-supg.6-4-8.bin
!
# mls
set mls nde disable
!
# port channel


!--- Ports are assigned to admin-group 200. Administrative groups 
!--- specify which ports can form an EtherChannel together. An administrative group 
!--- can contain a maximum of eight ports. This admin-group assignment happens
!--- automatically with the configuration of the port channel. You can also
!--- assign it manually, as done in this example. However, you do not need to assign 
!--- the admin-group manually. Let the switch create
!--- the admin-group automatically. 
!--- Note: This configuration sets ports 4/1 through 4/4
!--- for port channel, but only configures ports 4/1-2. This is
!--- normal behavior. You can use ports 4/3 and 4/4 for any other purpose.

set port channel 4/1-4 200
!
# default port status is enable
!
!
#module 1 : 0-port Supervisor III
!
#module 2 : 2-port MM MIC FDDI
!
#module 3 : 24-port 10/100BaseTX Ethernet
!
#module 4 : 12-port 10/100BaseTX Ethernet

!--- This enables port channeling with PAgP and configures desirable silent mode.

set port channel 4/1-2 mode desirable silent
!
#module 5 : 2-port MM OC-3 Dual-Phy ATM

!--- Output suppressed.

end

Référez-vous à la référence de commandes de famille de Catalyst 5000 (6.3 et 6.4) pour plus d'informations sur les commandes dans la configuration.

Catalyst 6500
Cat6509# show running-config
Building configuration...

Current configuration : 3852 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6509
!
!
redundancy
 main-cpu
  auto-sync standard
ip subnet-zero
!
!
interface port-channel1
 no ip address


!--- This example has configured a Layer 2 (L2) EtherChannel.
!--- You can configure a Layer 3 (L3) EtherChannel on the Catalyst
!--- 6500/6000 switches running Cisco IOS Software; however, this is not 
!--- the focus of this document. For details on the Layer 3 EtherChannel configuration,
!--- refer to the document Configuring EtherChannels.


 switchport


!--- This command puts the interface in VLAN1, by default.

switchport mode access
!
interface FastEthernet6/1
no ip address

!--- On the Catalyst 6500/6000, you must issue the switchport command once,
!--- without any keywords, to configure the interface as an L2 port.
!--- By default, all the ports are router ports (L3 ports).
!--- On a Catalyst 4500/4000 switch, all ports are L2 ports by default.
!--- You do not need an additional command.

switchport


!--- This command puts the interface in VLAN1, by default.

 switchport mode access


!--- The port is a member of channel group 1 with autonegotiation
!--- that uses PAgP and silent mode.

 channel-group 1 mode desirable
!
interface FastEthernet6/2
 no ip address


!--- On the Catalyst 6500/6000, you must issue the switchport command once,
!--- without any keywords, to configure the interface as a L2 port.
!--- By default, all the ports are router ports (L3 ports).
!--- On a Catalyst 4500/4000 switch, all ports are L2 ports by default.
!--- You do not need an additional command.

 switchport


!--- This command puts the interface in VLAN1, by default.

 switchport mode access


!--- The port is a member of channel group 1 with autonegotiation
!--- that uses PAgP and silent mode.

 channel-group 1 mode desirable
!
interface FastEthernet6/3
 no ip address
!
interface FastEthernet6/4
 no ip address
!

!--- Output suppressed.

interface FastEthernet6/45
 no ip address
 shutdown
!
interface FastEthernet6/46
 no ip address
 shutdown
!
interface FastEthernet6/47
 no ip address
 shutdown
!
interface FastEthernet6/48
 no ip address
 shutdown
!


!--- This is the IP address for management.

 ip address 10.10.10.3 255.255.255.0


!
ip classless
no ip http server
!
!
!
line con 0
line vty 0 4
!
end
Cat6509#

Pour plus d'informations sur les commandes dans la configuration, référez-vous à la référence de commandes de famille de Catalyst 5000 (6.3 et 6.4).

Remarque: Si vous affectez une interface à un VLAN qui n'existe pas, l'interface s'arrête jusqu'à ce que vous créiez le VLAN dans la base de données VLAN. Pour plus de détails, référez-vous à créer ou à modifier une section de VLAN Ethernet de configurer des VLAN.

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Pour vérifier le Port canalisé dans des Commutateurs de CatOS, émettez ces commandes :

Pour vérifier l'état du Protocole Spanning Tree (STP) dans des Commutateurs de CatOS, émettez ces commandes :

Pour vérifier le Port canalisé dans des Commutateurs de gamme Catalyst 6500/6000 ou Catalyst 4500/4000 exécutant le logiciel de Cisco IOS, émettez ces commandes :

Pour vérifier l'état STP dans des Commutateurs de gamme Catalyst 6500/6000 ou Catalyst 4500/4000 exécutant le logiciel de Cisco IOS, émettez ces commandes :

Exemple de sortie de la commande show

Commutateur de Catalyst 5500

Cette commande vérifie si le module est capable de l'acheminement. Il indique également quel groupe de ports vous pouvez empaqueter ensemble pour former l'EtherChannel. Dans cet exemple, vous pouvez grouper les deux ports 4/1-2 ou les quatre ports 4/1-4 pour former un canal :

cat5500 (enable) show port capabilities 4
Model                    WS-X5203
Port                     4/1
Type                     10/100BaseTX
Speed                    auto,10,100
Duplex                   half,full
Trunk encap type         ISL
Trunk mode               on,off,desirable,auto,nonegotiate
Channel                  4/1-2,4/1-4
Broadcast suppression    pps(0-150000),percentage(0-100)
Flow control             no
Security                 yes
Membership               static,dynamic
Fast start               yes
QOS scheduling           rx-(none),tx-(none)
CoS rewrite              no
ToS rewrite              no
Rewrite                  no
UDLD                     yes
AuxiliaryVlan            no
SPAN                     source,destination

!--- Output suppressed.

Cette commande, avec la commande de show port, vérifie le statut du Port canalisé.

cat5500 (enable) show port channel
Port  Status     Channel              Admin Ch                 
                 Mode                 Group Id
----- ---------- -------------------- ----- -----
4/1  connected  desirable silent       200   865 
4/2  connected  desirable silent       200   865
----- ---------- -------------------- ----- -----

Port  Device-ID                       Port-ID                   Platform
----- ------------------------------- ------------------------- ---------------- 
4/1  Switch                          Fa6/1                     cisco Catalyst 6000 
4/2  Switch                          Fa6/2                     cisco Catalyst 6000
----- ------------------------------- ------------------------- ----------------
cat5500 (enable)
cat5500 (enable) show port 4/1
Port  Name               Status     Vlan       Level  Duplex Speed Type
----- ------------------ ---------- ---------- ------ ------ ----- ------------ 
4/1                     connected  1          normal a-full a-100 10/100BaseTX

!--- Output suppressed.

 
Port  Status     Channel              Admin Ch                 
                 Mode                 Group Id
----- ---------- -------------------- ----- ----- 
4/1  connected  desirable silent       200   865 
4/2  connected  desirable silent       200   865
----- ---------- -------------------- ----- -----


!--- Output suppressed.


cat5500 (enable) show port 4/2
Port  Name               Status     Vlan       Level  Duplex Speed Type
----- ------------------ ---------- ---------- ------ ------ ----- ------------ 
4/2                     connected  1          normal a-full a-100 10/100BaseTX


!--- Output suppressed.


Port  Status     Channel              Admin Ch                 
                 Mode                 Group Id
----- ---------- -------------------- ----- ----- 
4/1  connected  desirable silent       200   865 
4/2  connected  desirable silent       200   865
----- ---------- -------------------- ----- -----


!--- Output suppressed.

cat5500 (enable) show port channel info
Switch Frame Distribution Method: Mac both

Port  Status     Channel              Admin Channel Speed Duplex Vlan
                 mode                 group id
----- ---------- -------------------- ----- ------- ----- ------ ---- 
4/1  connected  desirable silent       200     865 a-100 a-full    1 
4/2  connected  desirable silent       200     865 a-100 a-full    1
----- ---------- -------------------- ----- ------- ----- ------ ----
 
Port  ifIndex Oper-group Neighbor   Oper-Distribution PortSecurity/
                         Oper-group Method            Dynamic port
----- ------- ---------- ---------- ----------------- ------------- 
4/1  334              1 65537      Mac both 
4/2  334              1 65537      Mac both
----- ------- ---------- ---------- ----------------- -------------
 
Port  Device-ID                       Port-ID                   Platform
----- ------------------------------- ------------------------- ---------------- 
4/1  Switch                          Fa6/1                     cisco Catalyst 6000 
4/2  Switch                          Fa6/2                     cisco Catalyst 6000
----- ------------------------------- ------------------------- ----------------


!--- Output suppressed.

Les commandes STP vérifient si vous avez tous les ports dans un canal groupé ensemble et dans l'état d'expédition.

cat5500 (enable) show spantree 1
VLAN 1
Spanning tree enabled
Spanning tree type          IEEE

Designated Root             00-30-40-a7-a4-00
Designated Root Priority    32768
Designated Root Cost        0
Designated Root Port        1/0
Root Max Age   20 sec    Hello Time 2  sec   Forward Delay 15 sec 

Bridge ID MAC ADDR          00-30-40-a7-a4-00
Bridge ID Priority          32768
Bridge Max Age 20 sec    Hello Time 2  sec   Forward Delay 15 sec
 
Port                     Vlan Port-State    Cost  Priority Portfast   Channel_id
------------------------ ---- ------------- ----- -------- ---------- ---------- 
2/1-2                   1    not-connected    19       32 disabled   0 
3/1                     1    not-connected   100       32 disabled   0 
3/2                     1    not-connected   100       32 disabled   0 
3/3                     1    not-connected   100       32 disabled   0 
3/4                     1    not-connected   100       32 disabled   0 
3/5                     1    not-connected   100       32 disabled   0 
3/6                     1    not-connected   100       32 disabled   0 
3/7                     1    not-connected   100       32 disabled   0 
3/8                     1    not-connected   100       32 disabled   0 
3/9                     1    not-connected   100       32 disabled   0 
3/10                    1    not-connected   100       32 disabled   0 
3/11                    1    not-connected   100       32 disabled   0 
3/12                    1    not-connected   100       32 disabled   0 
3/13                    1    not-connected   100       32 disabled   0 
3/14                    1    not-connected   100       32 disabled   0 
3/15                    1    not-connected   100       32 disabled   0 
3/16                    1    not-connected   100       32 disabled   0 
3/17                    1    not-connected   100       32 disabled   0 
3/18                    1    not-connected   100       32 disabled   0 
3/19                    1    not-connected   100       32 disabled   0 
3/20                    1    not-connected   100       32 disabled   0 
3/21                    1    not-connected   100       32 disabled   0 
3/22                    1    not-connected   100       32 disabled   0 
3/23                    1    not-connected   100       32 disabled   0 
3/24                    1    not-connected   100       32 disabled   0
4/1-2                   1    forwarding       12       32 disabled   865 
4/3                     1    forwarding       19       32 disabled   0 
4/4                     1    forwarding       19       32 disabled   0 
4/5                     1    not-connected   100       32 disabled   0 
4/6                     1    not-connected   100       32 disabled   0 
4/7                     1    not-connected   100       32 disabled   0 
4/8                     1    not-connected   100       32 disabled   0 
4/9                     1    not-connected   100       32 disabled   0 
4/10                    1    not-connected   100       32 disabled   0 
4/11                    1    not-connected   100       32 disabled   0 
4/12                    1    not-connected   100       32 disabled   0
cat5500 (enable)  
cat5500 (enable) show spantree 4/1
Port                     Vlan Port-State    Cost  Priority Portfast   Channel_id
------------------------ ---- ------------- ----- -------- ---------- ----------
4/1-2                    1    forwarding       12       32 disabled   865
cat5500 (enable) show spantree 4/2
Port                     Vlan Port-State    Cost  Priority Portfast   Channel_id
------------------------ ---- ------------- ----- -------- ---------- ----------
4/1-2                    1    forwarding       12       32 disabled   865
cat5500 (enable) 

Remarque: La sortie du module/du port de show spantree pour les ports 4/1 et 4/2 affiche des résultats identiques. C'est parce qu'ils sont groupés ensemble dans un canal avec l'ID de canal de 865.

Commutateur Catalyst 6500

Cette commande vérifie si le module est capable de l'acheminement.

Cat6509# show interfaces capabilities module 6  
FastEthernet6/1
  Model:                 WS-X6348-RJ-45
  Type:                  10/100BaseTX
  Speed:                 10,100,auto
  Duplex:                half,full
  Trunk encap. type:     802.1Q,ISL
  Trunk mode:            on,off,desirable,nonegotiate
  Channel:               yes
  Broadcast suppression: percentage(0-100)
  Flowcontrol:           rx-(off,on),tx-(none)
  Membership:            static
  Fast Start:            yes
  QOS scheduling:        rx-(1q4t), tx-(2q2t)
  CoS rewrite:           yes
  ToS rewrite:           yes
  Inline power:          yes
  SPAN:                  source/destination
  UDLD                   yes
  Link Debounce:         yes
  Link Debounce Time:    no
FastEthernet6/2
  Model:                 WS-X6348-RJ-45
  Type:                  10/100BaseTX
  Speed:                 10,100,auto
  Duplex:                half,full
  Trunk encap. type:     802.1Q,ISL
  Trunk mode:            on,off,desirable,nonegotiate
  Channel:               yes
  Broadcast suppression: percentage(0-100)
  Flowcontrol:           rx-(off,on),tx-(none)
  Membership:            static
  Fast Start:            yes
  QOS scheduling:        rx-(1q4t), tx-(2q2t)
  CoS rewrite:           yes
  ToS rewrite:           yes
  Inline power:          yes
  SPAN:                  source/destination
  UDLD                   yes
  Link Debounce:         yes
  Link Debounce Time:    no
  • numéro d'interface de canal de port de show interfaces port-channel

Cette commande vérifie le statut du Port canalisé. Il t'indique également quels ports forment ce canal.

Cat6509# show interfaces port-channel 1
Port-channel1 is up, line protocol is up
  Hardware is EtherChannel, address is 0009.1267.27d9 (bia 0009.1267.27d9)
  MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255  
Encapsulation ARPA, loopback not set  
Full-duplex, 100Mb/s  
input flow-control is off, output flow-control is off  
Members in this channel: Fa6/1 Fa6/2  
ARP type: ARPA, ARP Timeout 04:00:00  
Last input never, output never, output hang never  
Last clearing of "show interface" counters never  
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0  
Queueing strategy: fifo  
Output queue :0/40 (size/max)  
5 minute input rate 0 bits/sec, 0 packets/sec  
5 minute output rate 0 bits/sec, 0 packets/sec
     126880 packets input, 10173099 bytes, 0 no buffer
     Received 126758 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     6101 packets output, 1175124 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Cat6509#

Cette commande affiche le résumé d'un-line par groupe de canaux. Dans cette sortie témoin, vous pouvez voir l'indicateur P avec les ports Fa6/1 et Fa6/2. Ceci implique que ces ports forment le Port canalisé.

Cat6509# show etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator

u - unsuitable for bundling
Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
--------- +-----------------------+ ----------------+ ---------------
1 Po1(SU) PAgP Fa6/1(P) Fa6/2(P)

Cette commande affiche les informations de Port canalisé.

Cat6509# show etherchannel port-channel


Channel-group listing:
-----------------------

Group: 1
----------
Port-channels in the group:
----------------------

Port-channel: Po1
------------

Age of the Port-channel = 00d:00h:02m:25s
Logical slot/port = 14/1 Number of ports = 2
GC = 0x00010001 HotStandBy port = null
Port state = Port-channel Ag-Inuse
Protocol = PAgP

Ports in the Port-channel:

Index Load Port EC state No of bits
------+------+------+------------------+-----------
1 55 Fa6/1 Desirable-Sl 4
0 AA Fa6/2 Desirable-Sl 4

Time since last port bundled: 00d:00h:01m:03s Fa6/1
Time since last port Un-bundled: 00d:00h:01m:05s Fa6/1

Cette commande vérifie si le canal est dans l'état d'expédition pour un VLAN particulier.

Cat6509# show spanning-tree detail

VLAN1 is executing the IEEE compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address 00d0.029a.8001
  Configured hello time 2, max age 20, forward delay 15
  Current root has priority 32768, address 0030.40a7.a400
  Root port is 833 (Port-channel1), cost of root path is 12
  Topology change flag not set, detected flag not set
  Number of topology changes 0 last change occurred 00:23:59 ago
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0, aging 300

Port 833 (Port-channel1) of VLAN1 is forwarding
   Port path cost 12, Port priority 128, Port Identifier 131.65.
   Designated root has priority 32768, address 0030.40a7.a400
   Designated bridge has priority 32768, address 0030.40a7.a400
   Designated port id is 131.97, designated path cost 0
   Timers: message age 2, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 1, received 718 

Cette commande affiche les informations de spanning-tree pour VLAN1.

Cat6509# show spanning-tree vlan 1

VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32768
Address 0030.40a7.a400
Cost 12
Port 833 (Port-channel1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32768
Address 00d0.029a.8001
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300

Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po1 Root FWD 12 128.833 P2p

Considération spéciale avec l'utilisation de sans conditions sur le mode de la Manche

Cisco recommande l'utilisation de PAgP pour la configuration de Port canalisé, car ce document décrit. Si vous configurez l'EtherChannel sans réserve (avec l'utilisation du mode de canal en fonction) pour une raison quelconque, vous devriez créer un Port canalisé. Cette section fournit la procédure. Si vous créez un Port canalisé, vous évitez des problèmes éventuels avec STP pendant le processus de configuration. La détection de boucle STP peut désactiver les ports si vous configurez un côté pendant qu'un canal devant l'autre côté devient un canal.

  1. Pour placer les ports pour le port creusant des rigoles pour désactiver le mode sur le commutateur de CatOS, émettez la commande de module/port de set port disable.

  2. Créez le Port canalisé (groupe de port) sur le commutateur de Cisco IOS, et placez le mode de canal à en fonction.

  3. Créez le Port canalisé sur le commutateur de CatOS, et placez le mode de canal à en fonction.

  4. Pour réactiver les ports que vous avez désactivés plus tôt sur le premier commutateur de CatOS, émettez la commande de module/port de set port enable.

Dépannez

Problèmes de performance avec des EtherChannels

Les problèmes de performance avec des EtherChannels sont provoqué par par plusieurs conditions. Les causes classiques incluent l'algorithme incorrect d'Équilibrage de charge et mettent en communication les questions spécifiques de couche physique.

Pour mieux comprendre et configurer l'algorithme d'Équilibrage de charge, référez-vous à ces documents :

Pour les informations sur la façon dont dépanner des questions de couche physique, référez-vous au port de commutateur de dépannage et reliez les problèmes.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 12029