Commutation LAN : Liaison inter-commutateurs (ISL)

Configuration d'une jonction ISL entre un commutateur Catalyst 2948G-L3 et des commutateurs des gammes Catalyst 2900/3500XL ou 2970

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (7 octobre 2015) | Commentaires


Contenu


Introduction

Ce document discute comment configurer un joncteur réseau de Protocol de Liaison inter-commutateurs (ISL) entre Cisco Catalyst 2948G-L3 et Catalyst 2900/3500XL ou Commutateurs de gamme 2970. Quand vous connectez un Catalyst 2948G-L3 à un commutateur, les tâches de configuration sont identiques que ceux pour connecter un routeur à un commutateur. L'exemple de configuration dans ce document utilise le Catalyst 2948G-L3 en tant que routeur et utilise le Catalyst 3500XL pendant que le commutateur de la couche 2 (L2). Vous pouvez substituer le Catalyst 2900XL ou 2970 au 3500XL, aux fins de ce document.

Pour utiliser le concept des VLAN sur le Catalyst 2948G-L3, vous devez utiliser des groupes de passerelle. Chaque groupe de passerelle est considéré un VLAN distinct. Ces groupes de passerelle correspondent au nombre VLAN du commutateur connecté.

Conditions préalables

Conditions requises

Avant que vous tentiez cette configuration, assurez-vous que vous connectez un câble croisé entre le 2900/3500XL ou le 2970 et le 2948G-L3. Typiquement, vous utilisez un câble direct entre un routeur et un commutateur ; mais avec du Catalyst 2948G-L3, vous utilisez un câble croisé pour se connecter à un autre commutateur. C'est le même câble croisé que vous utiliseriez pour une connexion de commutateur à commutateur.

Les lecteurs de ce document devraient avoir connaissance des sujets suivants :

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de logiciel suivantes :

  • Version de logiciel 12.0(25)W5(27) de ½ du ¿  de Cisco IOSï pour le commutateur de la couche 3 (L3)/routeur (CAT2948G-IN-M)

  • Logiciel Cisco IOS version 12.0(5)WC9 (C3500XL-C3H2S-M) (fc1)

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section fournit des informations pour configurer les caractéristiques décrites dans ce document.

Remarque: Pour trouver les informations complémentaires au sujet des commandes dans ce document, utilisez le Command Lookup Tool (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/12019/25.gif

Si vous voulez que chacun des trois PC puisse se cingler et avoir une passerelle par défaut, alors vous devez utiliser la transition avec le Routage et mise en parallèle intégrés (IRB).

Le Catalyst 2948G-L3 est le périphérique L3 dans ce scénario. Puisque c'est un périphérique L3, il ne peut pas avoir deux interfaces L3 dans le même sous-réseau. C'est pourquoi vous devez utiliser des groupes de passerelle sur les interfaces et les attacher ainsi qu'une interface virtuelle de passerelle (BVI), BVI 2.

L'adresse IP BVI 2 est la passerelle par défaut pour tous les PC et périphériques dans VLAN 2 ou groupe 2. de passerelle.

Configurations

Ce document utilise les configurations suivantes :

2948G-L3
Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2948G-L3
!
!
ip subnet-zero
bridge irb
!
!
!
interface FastEthernet1

!--- This interface is the ISL trunk to the switch.

 no ip address
 no ip directed-broadcast
!
interface FastEthernet1.1
 encapsulation isl 1        
 no ip redirects
 no ip directed-broadcast
 bridge-group 1

!--- Use bridge-group 1 for the trunk subinterface.
!--- You can not use an IP address here because of the subnet
!--- overlap that would occur due to BVI 1, which is in the
!--- same subnet.

!
interface FastEthernet1.2
 encapsulation isl 2
 no ip redirects
 no ip directed-broadcast
 bridge-group 2             
!
interface FastEthernet2
 no ip address
 no ip directed-broadcast
 bridge-group 2

!--- This port belongs to VLAN 2.

!
interface FastEthernet3
 no ip address
 no ip directed-broadcast
 bridge-group 2

!--- This port belongs to VLAN 2.

!
interface FastEthernet4
 no ip address
 no ip directed-broadcast
 bridge-group 1

!--- This port belongs to VLAN 1.

!
interface BVI1
 ip address 10.1.1.1 255.255.0.0

!--- This is the IP address of BVI 1.

 no ip directed-broadcast
 no ip route-cache cef
!
interface BVI2

!--- This is the IP address of BVI 2.

 ip address 10.2.2.2 255.255.0.0
 no ip directed-broadcast
 no ip route-cache cef
!
ip classless
!
bridge 1 protocol ieee

!--- Choose IEEE as the Spanning Tree Protocol.

 bridge 1 route ip

!--- Allow routing to occur for IP.

bridge 2 protocol ieee
 bridge 2 route ip
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

2900/3500XL ou 2970

!--- First, add VLAN 2 to the VLAN database for a 2900/3500XL
!--- switch:

3500XL# vlan database

3500XL(vlan)# vlan 2

VLAN 2 added:
    Name: VLAN0002

3500XL(vlan)# exit

APPLY completed.
Exiting....
3500XL#

!--- The Catalyst 2970 gives you the option to configure VLANs
!--- from the VLAN database or from global configuration mode:

2970# configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

2970(config)# vlan 2

2970(config-vlan)# end

2970#

!--- The switchport configurations on the Catalyst 2900/3500XL
!--- and on the 2970 are identical, for the purposes of this
!--- document. Remember that the Catalyst 2970 has 10/100/1000
!--- ports (1000Base-T), so the interfaces in this output
!--- would instead be labeled Gigabit Ethernet 0/1, 0/2,
!--- and so forth.

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3500XL
!
interface FastEthernet0/1
 switchport mode trunk

!--- This port is an ISL trunk.

!
interface FastEthernet0/2
 switchport access vlan 2

!--- This port is in VLAN 2.

!
interface FastEthernet0/3

!--- This port is in the default VLAN 1.

!
interface FastEthernet0/4
!
!
interface VLAN1
 ip address 10.1.1.100 255.255.0.0

!--- This is the IP address of the management interface.

 no ip directed-broadcast
 no ip route-cache
!
snmp-server engineID local 000000090200000AF484CC80
snmp-server community public RO
!
line con 0
 exec-timeout 0 0
 transport input none
 stopbits 1
line vty 0 4
 login
line vty 5 15
 login
!
end

Vérifiez

Cette section fournit des informations pour confirmer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • affichez le switchport de l'interface fa0/1 — Vérifiez l'état du joncteur réseau sur le 2900/3500XL ou le 2970 et voyez quels VLAN sont en activité.

    3500XL# show interface fa0/1 switchport
    
    Name: Fa0/1
    Switchport: Enabled
    Administrative mode: trunk
    Operational Mode: trunk
    Administrative Trunking Encapsulation: isl
    Operational Trunking Encapsulation: isl
    Negotiation of Trunking: Disabled
    Access Mode VLAN: 0 ((Inactive))
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: ALL
    Trunking VLANs Active: 1,2
    Pruning VLANs Enabled: 2-1001
    
    Priority for untagged frames: 0
    Override vlan tag priority: FALSE
    Voice VLAN: none
    Appliance trust: none
    Self Loopback: No
    3500XL#
  • VLAN d'exposition — Vérifiez que les ports sur le 2900/3500XL ou le 2970 sont assignés aux VLAN corrects.

    3500XL# show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6,
                                                    Fa0/7, Fa0/8, Fa0/9, Fa0/10,
                                                    Fa0/11, Fa0/12, Fa0/13, Fa0/14,
                                                    Fa0/15, Fa0/16, Fa0/17, Fa0/18,
                                                    Fa0/19, Fa0/20, Fa0/21, Fa0/22,
                                                    Fa0/23, Fa0/24, Gi0/1, Gi0/2
    2    VLAN0002                         active    Fa0/2
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        0      0
    2    enet  100002     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        0      0
    1003 tr    101003     1500  -      -      -        -    -        0      0
    1004 fdnet 101004     1500  -      -      -        ieee -        0      0
    1005 trnet 101005     1500  -      -      -        ibm  -        0      0
    3500XL#
  • affichez l'interface bvi 1 — Vérifiez que les interfaces BVI 2948G-L3 et la ligne protocole sont toutes deux sur le 2948G-L3.

    2948G-L3# show interface bvi 1
    
    BVI1 is up, line protocol is up
      Hardware is BVI, address is 0001.c75c.680a (bia 0000.0000.0000)
      Internet address is 10.1.1.1/16
      MTU 1500 bytes, BW 10000 Kbit, DLY 5000 usec, rely 255/255, load 1/255
      Encapsulation ARPA, loopback not set
      ARP type: ARPA, ARP Timeout 04:00:00
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue 0/0 (size/max)
    2948G-L3#
  • show bridge 1 — Vérifiez que la passerelle 1 expédie. Vous pouvez également vérifier que le Protocole Spanning Tree est activé et expédition avec une commande de show spanning-tree.

    2948G-L3# show bridge 1
    
    Total of 300 station blocks, 299 free
    Codes: P - permanent, S - self
    
    Bridge Group 1:
    
        Address       Action   Interface
    00ee.1e9f.50c0   forward   Fa1.1
    
    2948G-L3#

Dépannez

Cette section fournit les conseils et la sortie témoin pour aider à dépanner votre configuration.

  • Vérifiez que vous pouvez cingler à travers à l'autre périphérique.

  • Vérifiez que les PC peuvent cingler d'autres PC dans d'autres VLAN.

  • Assurez-vous que la passerelle par défaut est correcte. Dans ce scénario, la passerelle par défaut est le BVIs respectif sur le 2948G-L3.

2948G-L3# ping 10.1.1.100

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.100, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/12 ms

2948G-L3# show arp

Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.2.2.2                -   0030.40d6.4008  ARPA   BVI2
Internet  10.1.1.1                -   0030.40d6.400a  ARPA   BVI1
Internet  10.1.1.100              1   00ee.1e9f.50c0  ARPA   BVI1
2948G-L3#

Informations connexes


Document ID: 12019