Composition et accès : Routage à établissement de connexion à la demande (DDR)

Configuration d'une sauvegarde BRI RNIS avec Dialer Watch

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document explique l'utilisation d'une ligne d'accès de base (BRI) RNIS de sauvegarder une ligne louée, un WAN, ou une connexion série utilisant la fonctionnalité Dialer Watch. Pour plus d'informations sur les caractéristiques et le fonctionnement de la Fonction Dialer Watch, référez-vous évaluation derrière des Interfaces de sauvegarde, des Routes statiques flottantes, et de la Fonction Dialer Watch pour la sauvegarde DDR.

Avant de commencer

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Conditions préalables

Configurer la sauvegarde DDR implique deux étapes distinctes :

  1. Configurez le DDR avec le DDR hérité ou les Profils de composeur. Vérifiez que votre connexion DDR fonctionne correctement avant de mettre en application la configuration de sauvegarde. Ceci te permet pour vérifier la méthode de cadran utilisée, la négociation de Protocole point à point (PPP), et l'authentification sont réussie avant de configurer la sauvegarde.

  2. Configurez le routeur pour initier la connexion DDR de sauvegarde quand la liaison principale échoue. Cette configuration emploie la fonctionnalité Dialer Watch pour déclencher le dialout.

Pour plus d'informations sur les étapes nécessaires pour configurer la sauvegarde référez-vous au document configurant et dépannant la sauvegarde DDR.

Composants utilisés

Les informations dans ce document sont basées sur les versions de logiciel et de matériel ci-dessous.

  • Deux Cisco IOS courants de Routeurs de Cisco 2500 (DTE en relais de trame) ? ? Versions de logiciel 12.2(3) et 12.2(5).

  • Un routeur de Cisco 4500, agissant en tant que commutateur de Relais de trames (configuration non affichée).

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Théorie générale

Cet exemple utilise des Profils de composeur pour le lien de la sauvegarde BRI. Vous pouvez également utiliser le Routage à établissement de connexion à la demande (DDR) existant, qui utilise la commande de carte de numéroteur pour la connexion de la sauvegarde BRI. Pour plus d'informations sur configurer la Fonction Dialer Watch avec des Cartes de composeur, référez-vous à configurer la sauvegarde DDR utilisant BRIs et Fonction Dialer Watch.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour trouver les informations complémentaires sur les commandes utilisées dans ce document, utilisez l'utilitaire de recherche de commande

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

/image/gif/paws/11048/bri_isdn_11048.gif

Configurations

Ce document utilise les configurations présentées ci-dessous.

krimson (routeur de Cisco 2500)
krimson#show running-config
 Building configuration...

 Current configuration : 5055 bytes
 !
 version 12.2
 service timestamps debug datetime msec
 service timestamps log datetime msec
 no service password-encryption
 !
 hostname krimson
 !
 logging buffered 500000 debugging
 no logging console
 enable password <deleted>
 !
 username kevin password 0 <deleted>
 ip subnet-zero
 no ip domain-lookup
 !
 isdn switch-type basic-net3
 !
 interface Ethernet0
  ip address 10.200.16.30 255.255.255.0
  no ip route-cache
  no ip mroute-cache
  no cdp enable
          
 ! <<- Unused interface configuration omitted
 !
 interface Serial1
 
!--- Primary Link (Frame Relay)

  bandwidth 64
  no ip address
  encapsulation frame-relay
  no ip route-cache
  no ip mroute-cache
 !
 interface Serial1.1 point-to-point
 
!--- Point-to-point Frame Relay subinterface

  ip address 10.5.5.2 255.255.255.0
  no ip route-cache
  frame-relay interface-dlci 20 
 !
 interface BRI0
 
!--- Backup physical interface

   description Backup ISDN, Nr. 4420038
   no ip address
   encapsulation ppp
   no ip route-cache
   no ip mroute-cache
   load-interval 30
   no keepalive
   dialer pool-member 1
 
!--- BRI 0 is a member of dialer pool 1

   isdn switch-type basic-net3
   no fair-queue
   no cdp enable
   ppp authentication chap
 !
 interface Dialer0
 
!--- Logical interface for the backup

   ip address 10.9.9.1 255.255.255.0
 
!--- The dialer is in the same network as the remote dialer interface

   encapsulation ppp
   no ip route-cache
   no ip mroute-cache
   dialer pool 1
 
!--- Dialer pool 1. BRI 0 is a member of this pool

   dialer remote-name kevin
 
!--- Authenticated remote name of the peer.
 !--- Verify that this name exactly matches the authenticated name 
 !--- of the remote dialer

   dialer string 6120
 
!--- Number for outbound call. For inbound calls this is not needed

   dialer watch-group 1
 
!--- Enable dialer watch on this backup interface.
 !--- Watch the route specified with dialer watch-list 1


   dialer-group 1
 
!--- Apply interesting traffic defined in dialer-list 1


   no cdp enable
   ppp authentication chap
 !
 !
 router ospf 10
   log-adjacency-changes
   network 10.5.5.0 0.0.0.255 area 0
   network 10.7.7.0 0.0.0.255 area 0
   network 10.9.9.0 0.0.0.255 area 0
 !
 no ip classless
 ip route 0.0.0.0 0.0.0.0 10.200.16.1
 
!--- Default route through ethernet 0

 no ip http server
 !
 access-list 101 deny ospf any any
 
!--- Mark OSPF as uninteresting.
 !--- This will prevent OSPF hellos from keeping the link up

 access-list 101 permit ip any any
 
!--- All other IP traffic is interesting


 dialer watch-list 1 ip 10.8.8.0 255.255.255.0
 
!--- This defines the route(s) to be watched.
 !--- This exact route(including subnet mask) must exist in the routing table. 
 !--- Use the dialer watch-group 1 command to apply this list to the backup
 !--- interface (interface dialer 0)

 dialer-list 1 protocol ip list 101
 
!--- Interesting traffic is defined by access-list 101.
 !--- This is applied to BRI0 using dialer-group 1


 !
 line con 0
   exec-timeout 0 0
   privilege level 15
 line aux 0
   transport input all
 line vty 0 4
   exec-timeout 0 0
   password <deleted>
   login
  !
 end

kevin(2500)
kevin#show running-config
 version 12.2
 service timestamps debug datetime msec
 service timestamps log datetime msec
 !
 hostname kevin
 !
 username krimson password 0 <password>
 !
 isdn switch-type basic-net3
 !
 !
 interface Loopback0
  ip address 10.8.8.1 255.255.255.0
 
!--- This is the network the remote side is watching

  ip ospf network point-to-point
 !
 interface Loopback1
  ip address 172.19.0.1 255.255.255.255
 !
 interface Ethernet0
  ip address 10.200.17.26 255.255.255.0
 !
 interface Serial0
  no ip address
  encapsulation frame-relay
 !
 interface Serial0.1 point-to-point
 
!--- Primary link (Frame Relay sub-interface)

  ip address 10.5.5.1 255.255.255.0
  frame-relay interface-dlci 20 
 !
 interface BRI0
 
!--- Physical interface

  no ip address
  encapsulation ppp
  dialer pool-member 1
 
!--- Member of dialer pool 1

  isdn switch-type basic-net3
  no cdp enable
  ppp authentication chap
 !
 interface Dialer0
 
!--- Logical interface for incoming call

 ip address 10.9.9.2 255.255.255.0
 
!--- The dialer is in the same network as the remote dialer interface

 encapsulation ppp
 dialer pool 1
 
!--- Dialer pool 1. BRI 0 is a member of this pool

 dialer remote-name krimson
 
!--- Authenticated remote name of the peer.
 !--- Verify that this name exactly matches the authenticated name 
 !--- of the remote dialer.

 dialer-group 1
 
!--- Apply interesting traffic defined in dialer-list 1

 no cdp enable
 ppp authentication chap
 !
 router ospf 10
  log-adjacency-changes
  network 10.5.5.0 0.0.0.255 area 0
  network 10.8.8.0 0.0.0.255 area 0
 
!--- Advertise the network the remote router is watching

  network 10.9.9.0 0.0.0.255 area 0
 !
 ip classless
 ip route 0.0.0.0 0.0.0.0 10.200.17.1
 no ip http server
 !
 dialer-list 1 protocol ip permit
 
!--- Interesting traffic definition. All IP traffic is interesting.
 !--- This is applied to BRI0 using dialer-group 1.
 !--- Since the remote router activates and deactivates the backup, this router
 !--- does not need to restrict interesting traffic

 no cdp run
 !
 line con 0
  exec-timeout 0 0
 line aux 0
  modem InOut
 line vty 0 4
  exec-timeout 0 0
  password <password>
  login
 !
 end

Remarque:  La configuration de maui-nas-05 n'inclut aucune commande liée à la sauvegarde. Pour maui-nas-05, la liaison de sauvegarde est juste un autre client entrant. Ceci peut simplifier la configuration du lieu d'exploitation principal dans les situations où beaucoup de périphériques établissent une liaison de sauvegarde au même lieu d'exploitation principal. Dans les scénarios de sauvegarde, il est idéal d'avoir seulement un initié de côté le cadran, alors que l'autre côté reçoit seulement des appels.

Commandes de Fonction Dialer Watch

Ce qui suit est une liste des commandes disponibles pour la Fonction Dialer Watch. Certaines de ces commandes ont été incluses dans la configuration ci-dessus, alors que d'autres sont données pour la référence.

  • adresse-masque d'IP address d'IP de groupe-nombre de dialer watch-list : Définit les adresses IP ou les réseaux à observer. L'adresse ou le réseau (avec le masque correct) qui est configuré doit exister dans la table de routage. Vous pouvez également observer de plusieurs artères avec la commande de dialer watch-list. Un exemple est montré :

    dialer watch-list 1 ip 10.1.1.0 255.255.255.0
    dialer watch-list 1 ip 10.1.2.0 255.255.255.0
    dialer watch-list 1 ip 10.1.3.0 255.255.255.0
  • groupe-nombre de montre-groupe de numéroteur : Fonction Dialer Watch d'enable sur l'Interface de sauvegarde. Le nombre de groupe utilisé ici apparie le nombre de groupe de la commande de dialer watch-list définissant les artères à observer. La commande de montre-groupe de numéroteur avec un nombre de groupe particulier peut seulement être configurée sur une interface. Ceci signifie que le routeur ne peut pas employer des plusieurs interfaces pour fournir la sauvegarde pour une artère particulière. Cependant, une interface peut avoir de plusieurs commandes de montre-groupe de numéroteur, avec différents groupe-nombres. Par conséquent, une interface peut être utilisée pour fournir la sauvegarde pour de plusieurs artères.

  • secondes de dialer watch-disable : Appliquez-vous un temps de retard de débronchement à l'interface. Après que l'interface principale récupère, ce retard empêche déconnecter l'Interface de sauvegarde pour la période indiquée. Ce temporisateur de délai est démarré quand le temporisateur de veille expire, et le statut de la route primaire est vérifié et avéré. Ce retard peut assurer la stabilité, particulièrement pour les interfaces instables ou les interfaces éprouvant des changements de route fréquente.

  • secondes d'initiale d'artère-contrôle de retard de groupe-nombre de dialer watch-list : Ce les commandes enables le routeur à vérifier si la route primaire est en hausse après que le démarrage initial du routeur soit complet et le temporisateur (en quelques secondes) expire. Sans cette commande, la Fonction Dialer Watch est seulement déclenchée quand la route primaire est retirée de la table de routage. Si la liaison principale ne soulève pas pendant le démarrage initial du routeur, l'artère n'est jamais ajoutée à la table de routage et par conséquent ne peut pas être observée. Par conséquent, avec cette commande, la Fonction Dialer Watch composera la liaison de sauvegarde en cas d'une défaillance de liaison primaire pendant l'initial démarrent du routeur.

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

certaines commandes show sont prises en charge par l'outil Interpréteur de sortie, qui vous permet d'afficher une analyse de la sortie de la commande show.

  • show interfaces serial - Affiche des informations au sujet de l'identificateur de connexion de liaison de données multicast (DLCI), des DLCI utilisés sur l'interface, et du DLCI utilisé pour l'interface de gestion locale (LMI). Employez ceci pour vérifier que l'interface principale est en haut ou en bas.

  • interface dialer d'exposition - Affiche le statut de l'interface de numérotation.

  • show ip route - Entrées de table de Routage IP d'affichages. Vérifiez que le réseau observé existe dans la table de routage (quand la liaison principale est en hausse). Quand la liaison principale descend et la sauvegarde est composée la table de routage devrait reconverge et le réseau observé devrait réapparaître (avec prochain sautez à cloche-pied comme interface de numérotation).

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

La configuration de Relais de trames utilisée ici (avec des sous-interfaces point par point et le Protocole OSPF (Open Shortest Path First) d'utilisation comme protocole de routage) est spécifique à cette installation. Cependant, les étapes de dépannage indiquées ci-dessous sont plus de général et peuvent être utilisées avec différentes configurations comme les point-à-multipoints en relais de trame ou la liaison principale avec l'encapsulation de High-Level Data Link Control (HDLC) et de protocole de point-à-point (PPP), indépendamment du protocole de routage étant utilisé.

Pour vérifier la fonctionnalité de sauvegarde, nous avons placé une des interfaces sur le routeur de Cisco 4500 qui agit en tant que commutateur de Relais de trames dans l'état d'arrêt, afin de simuler des problèmes dans le réseau de Relais de trames. En conséquence, ceci mène à l'état inactif PVC étant conduit au routeur DTE par l'intermédiaire du réseau de Relais de trames, et à un événement de sous-interface de relais de trame vers le bas. La route surveillé disparaît par conséquent et la liaison de sauvegarde est lancée.

Pour les informations sur la Fonction Dialer Watch de dépannage référez-vous au document configurant et dépannant la sauvegarde DDR.

Dépannage des commandes

certaines commandes show sont prises en charge par l'outil Interpréteur de sortie, qui vous permet d'afficher une analyse de la sortie de la commande show.

Remarque: Avant d'exécuter les commandes debug, référez-vous à la section Informations importantes sur les commandes Debug.

  • debug isdn q931 - Affiche des informations au sujet de l'établissement d'appel et du démontage de la connexion réseau RNIS (couche 3) entre le routeur local (côté utilisateur) et le réseau.

  • debug backup - Débugge des événements de sauvegarde.

  • mettez au point le numéroteur - Les informations de débogage d'affichages au sujet des paquets ou des événements sur une interface de numérotation.

  • debug ppp negotiation - Entraîne la commande de debug ppp d'afficher des paquets PPP transmis pendant le startup de PPP, où des options PPP sont négociées.

  • debug ppp authentication - Entraîne la commande de debug ppp d'afficher des messages du protocole d'authentification, y compris des échanges de paquet de Protocol d'authentification de défi (CHAP) et des échanges de Password Authentication Protocol (PAP).

  • debug ip ospf events - L'affiche des informations sur des événements liés à l'OSPF, tels que des contiguïtés, les informations d'engorgement, a indiqué la sélection de routeur, et calcul de plus court chemin le premier (SPF).

  • debug frame-relay events - Les informations de débogage d'affichages au sujet du Protocole ARP (Address Resolution Protocol) de Relais de trames répondent sur les réseaux qui prennent en charge un canal multicast et utilisent l'adressage dynamique.

Sortie de dépannage d'échantillon

Dans la sortie ci-dessous, l'interface de Relais de trames est en hausse.

krimson#show ip route
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

   Gateway of last resort is 10.200.16.1 to network 0.0.0.0

   10.0.0.0/24 is subnetted, 6 subnets
   C 10.5.5.0 is directly connected, Serial1.1
   O 10.8.8.0 [110/1563] via 10.5.5.1, 00:01:31, Serial1.1 
   
!--- Initial state through the primary Frame Relay interface, 
   !--- before line failure occurred

   C 10.9.9.0 is directly connected, Dialer0
   C 10.7.7.0 is directly connected, Loopback0
   C 10.200.16.0 is directly connected, Ethernet0
   S* 0.0.0.0/0 [1/0] via 10.200.16.1

   krimson#
   *Apr 17 01:00:50.591: OSPF: Rcv hello from 172.19.0.1 area 0 
   from Serial1.1 10.5.5.1
   *Apr 17 01:00:50.595: OSPF: End of hello processing
   *Apr 17 01:00:51.127: %SYS-5-CONFIG_I: Configured from console by console
   *Apr 17 01:01:00.591: OSPF: Rcv hello from 172.19.0.1 area 0 from Serial1.1    
   10.5.5.1
   *Apr 17 01:01:00.595: OSPF: End of hello processing
   *Apr 17 01:01:05.243: %LINK-3-UPDOWN: Interface Serial1, changed state to down    
   
!--- Frame Relay failure simulated by shutting down the interface on 
   !--- the Cisco 4500 router(acting as switch)

   *Apr 17 01:01:05.251: OSPF: Interface Serial1.1 going Down
   *Apr 17 01:01:05.255: %OSPF-5-ADJCHG: Process 10, Nbr 172.19.0.1 on Serial1.1    
   from FULL to DOWN, Neighbor Down: Interface down or detached
   *Apr 17 01:01:05.399: DDR: Dialer Watch: watch-group = 1
   *Apr 17 01:01:05.403: DDR: network 10.8.8.0/255.255.255.0 DOWN,
   
!--- Watched network is down

   *Apr 17 01:01:05.407: DDR: primary DOWN
   *Apr 17 01:01:05.407: DDR: Dialer Watch: Dial Reason: Primary of group 1 DOWN
   *Apr 17 01:01:05.411: DDR: Dialer Watch: watch-group = 1, 
   *Apr 17 01:01:05.411: BR0 DDR: rotor dialout [priority]
   *Apr 17 01:01:05.411: DDR: dialing secondary by dialer string 6120 on Di0
   
!--- router dials 6120 on interface Dialer 1

   *Apr 17 01:01:05.415: BR0 DDR: Attempting to dial 6120
   *Apr 17 01:01:05.523: ISDN BR0: TX -> SETUP pd = 8 callref = 0x43
   *Apr 17 01:01:05.531: Bearer Capability i = 0x8890
   *Apr 17 01:01:05.535: Channel ID i = 0x83
   *Apr 17 01:01:05.543: Called Party Number i = 0x80, '6120', Plan:Unknown, 
   Type:Unknown
   *Apr 17 01:01:05.599: ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0xC3
   *Apr 17 01:01:05.603: Channel ID i = 0x89
   *Apr 17 01:01:05.855: ISDN BR0: RX <- CONNECT pd = 8 callref = 0xC3
   *Apr 17 01:01:05.875: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
   *Apr 17 01:01:05.875: BR0:1 DDR: Dialer Watch: resetting call in progress
   *Apr 17 01:01:05.883: %DIALER-6-BIND: Interface BR0:1 bound to profile Di0
   *Apr 17 01:01:05.891: BR0:1 PPP: Treating connection as a callout
   *Apr 17 01:01:05.895: BR0:1 PPP: Phase is ESTABLISHING, Active Open 
   [0 sess, 0 load]
   *Apr 17 01:01:05.899: BR0:1 LCP: O CONFREQ [Closed] id 54 len 15
   *Apr 17 01:01:05.903: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
   *Apr 17 01:01:05.903: BR0:1 LCP: MagicNumber 0xF24F182E (0x0506F24F182E)
   *Apr 17 01:01:05.911: ISDN BR0: TX -> CONNECT_ACK pd = 8 callref = 0x43
   *Apr 17 01:01:05.939: BR0:1 LCP: I CONFREQ [REQsent] id 88 len 15
   *Apr 17 01:01:05.943: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
   *Apr 17 01:01:05.943: BR0:1 LCP: MagicNumber 0x9B15A6B0 (0x05069B15A6B0)
   *Apr 17 01:01:05.947: BR0:1 LCP: O CONFACK [REQsent] id 88 len 15
   *Apr 17 01:01:05.951: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
   *Apr 17 01:01:05.955: BR0:1 LCP: MagicNumber 0x9B15A6B0 (0x05069B15A6B0)
   *Apr 17 01:01:05.959: BR0:1 LCP: I CONFACK [ACKsent] id 54 len 15
   *Apr 17 01:01:05.963: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
   *Apr 17 01:01:05.963: BR0:1 LCP: MagicNumber 0xF24F182E (0x0506F24F182E)
   *Apr 17 01:01:05.967: BR0:1 LCP: State is Open
   *Apr 17 01:01:05.967: BR0:1 PPP: Phase is AUTHENTICATING, by both 
   [0 sess, 0 load]
   *Apr 17 01:01:05.971: BR0:1 CHAP: O CHALLENGE id 54 len 28 from "krimson"
   *Apr 17 01:01:06.051: BR0:1 CHAP: I CHALLENGE id 56 len 26 from "kevin"
   *Apr 17 01:01:06.055: BR0:1 CHAP: O RESPONSE id 56 len 28 from "krimson"
   *Apr 17 01:01:06.151: BR0:1 CHAP: I SUCCESS id 56 len 4
   *Apr 17 01:01:06.167: BR0:1 CHAP: I RESPONSE id 54 len 26 from "kevin"
   *Apr 17 01:01:06.175: BR0:1 CHAP: O SUCCESS id 54 len 4
   *Apr 17 01:01:06.179: BR0:1 PPP: Phase is UP [0 sess, 0 load]
   *Apr 17 01:01:06.183: BR0:1 IPCP: O CONFREQ [Not negotiated] id 46 len 10
   *Apr 17 01:01:06.187: BR0:1 IPCP: Address 10.9.9.1 (0x03060A090901)
   *Apr 17 01:01:06.279: BR0:1 IPCP: I CONFREQ [REQsent] id 34 len 10
   *Apr 17 01:01:06.283: BR0:1 IPCP: Address 10.9.9.2 (0x03060A090902)
   *Apr 17 01:01:06.287: BR0:1 IPCP: O CONFACK [REQsent] id 34 len 10
   *Apr 17 01:01:06.291: BR0:1 IPCP: Address 10.9.9.2 (0x03060A090902)
   *Apr 17 01:01:06.295: BR0:1 IPCP: I CONFACK [ACKsent] id 46 len 10
   *Apr 17 01:01:06.299: BR0:1 IPCP: Address 10.9.9.1 (0x03060A090901)
   *Apr 17 01:01:06.303: BR0:1 IPCP: State is Open
   *Apr 17 01:01:06.315: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1,    
   changed state to down
   *Apr 17 01:01:06.319: BR0:1 DDR: dialer protocol up
   *Apr 17 01:01:06.327: Di0 IPCP: Install route to 10.9.9.2
   *Apr 17 01:01:07.175: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,    
   changed state to up
   
!--- Call connects

   *Apr 17 01:01:10.775: OSPF: Rcv hello from 172.19.0.1 area 0 from Dialer0 10.9.9.2
   
!--- OSPF hello from the peer

   *Apr 17 01:01:10.779: OSPF: End of hello processing
   *Apr 17 01:01:11.891: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 6120 
   
   kevin#show interface serial 1.1
   Serial1.1 is down, line protocol is down 
   
!--- Primary link is still down

   Hardware is HD64570
   Internet address is 10.5.5.2/24
   MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation FRAME-RELAY
   
   krimson#show interface dialer 0 
   
!--- Backup interface is up and active

   Dialer0 is up, line protocol is up (spoofing)
   Hardware is Unknown
   Internet address is 10.9.9.1/24
   MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation PPP, loopback not set
   DTR is pulsed for 1 seconds on reset
   Interface is bound to BR0:1
   Last input 1w6d, output never, output hang never
   Last clearing of "show interface" counters 6w5d
   Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
   Queueing strategy: weighted fair
   Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
   Conversations 0/1/16 (active/max active/max total)
   Reserved Conversations 0/0 (allocated/max allocated)
   Available Bandwidth 42 kilobits/sec
   5 minute input rate 0 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
   882 packets input, 69656 bytes
   892 packets output, 70436 bytes
   Bound to:
   BRI0:1 is up, line protocol is up 
   Hardware is BRI
   MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, 
   
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation PPP, loopback not set
   Keepalive not set
   DTR is pulsed for 1 seconds on reset
   Time to interface disconnect: idle 00:01:38
   Interface is bound to Di0 (Encapsulation PPP)
   LCP Open
   Open: IPCP
   Last input 00:00:03, output 00:00:01, output hang never
   Last clearing of "show interface" counters never
   Queueing strategy: fifo
   Output queue 0/40, 0 drops; input queue 0/75, 0 drops
   30 second input rate 0 bits/sec, 0 packets/sec
   30 second output rate 0 bits/sec, 0 packets/sec
   4213 packets input, 414529 bytes, 0 no buffer
   Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
   29 input errors, 18 CRC, 0 frame, 0 overrun, 0 ignored, 11 abort
   3922 packets output, 242959 bytes, 0 underruns
   0 output errors, 0 collisions, 27 interface resets
   0 output buffer failures, 0 output buffers swapped out
   622 carrier transitions
   
   krimson#show ip route
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route

   Gateway of last resort is 10.200.16.1 to network 0.0.0.0

   192.168.64.0/30 is subnetted, 1 subnets
   C 192.168.64.0 is directly connected, Dialer4
   10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
   C 10.9.9.2/32 is directly connected, Dialer0
   O 10.8.8.0/24 [110/1786] via 10.9.9.2, 00:00:25, Dialer0 
   
!--- New route to the same destination (through dialer 0).
   !--- Network now points to backup interface

   C 10.9.9.0/24 is directly connected, Dialer0
   C 10.7.7.0/24 is directly connected, Loopback0
   C 10.9.8.0/24 is directly connected, Dialer1
   C 10.200.16.0/24 is directly connected, Ethernet0
   S* 0.0.0.0/0 [1/0] via 10.200.16.1

Dans la sortie ci-dessous, l'interface de Relais de trames est soulevée.

*Apr 17 01:02:50.631: %LINEPROTO-5-UPDOWN: Line protocol 
   on Interface Serial1,
    changed state to up 
   
!--- Primary is UP again

   *Apr 17 01:02:50.975: OSPF: Rcv hello from 172.19.0.1 area 0 
   from Dialer0 10.9.9.2
   *Apr 17 01:02:50.979: OSPF: End of hello processing

   *Apr 17 01:03:00.975: OSPF: Rcv hello from 172.19.0.1 area 0 
   from Dialer0 10.9.9.2
   *Apr 17 01:03:00.979: OSPF: End of hello processing
   *Apr 17 01:03:05.887: BR0:1 DDR: idle timeout
   *Apr 17 01:03:05.887: DDR: Dialer Watch: watch-group = 1
   *Apr 17 01:03:05.887: DDR: network 10.8.8.0/255.255.255.0 UP, 
   
!--- Watched route is UP

   *Apr 17 01:03:05.891: DDR: primary DOWN
   *Apr 17 01:03:10.551: OSPF: Rcv hello from 172.19.0.1 area 0 
   from Serial1.1
    10.5.5.1
   *Apr 17 01:03:10.555: OSPF: End of hello processing
   *Apr 17 01:03:10.975: OSPF: Rcv hello from 172.19.0.1 area 0 
   from Dialer0 10.9.9.2
   *Apr 17 01:03:10.979: OSPF: End of hello processing
   
   krimson#show ip route
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route

   Gateway of last resort is 10.200.16.1 to network 0.0.0.0

   10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
   C 10.9.9.2/32 is directly connected, Dialer0
   C 10.5.5.0/24 is directly connected, Serial1.1
   O 10.8.8.0/24 [110/1563] via 10.5.5.1, 00:00:01, Serial1.1 
   
! -- Route entry to destination network via primary has been installed again.

   C 10.9.9.0/24 is directly connected, Dialer0
   C 10.7.7.0/24 is directly connected, Loopback0
   C 10.9.8.0/24 is directly connected, Dialer1
   C 10.200.16.0/24 is directly connected, Ethernet0
   S* 0.0.0.0/0 [1/0] via 10.200.16.1

   krimson#show isdn active
   --------------------------------------------------------------------------------
   ISDN ACTIVE CALLS
   --------------------------------------------------------------------------------
   Call  Calling Called Remote Seconds Seconds Seconds Charges
   Type  Number  Number Name   Used    Left    Idle    Units/Currency
   --------------------------------------------------------------------------------
   Out   6120           kevin  149     90      29      0 
   --------------------------------------------------------------------------------

Le champ d'inactif de secondes précise que ce plus de trafic ne passe cependant l'Interface de sauvegarde et le temps d'inactivité augmente.

krimson# show isdn active
   --------------------------------------------------------------------------------
   ISDN ACTIVE CALLS
   --------------------------------------------------------------------------------
   Call Calling Called Remote Seconds Seconds Seconds Charges
   Type Number  Number Name   Used    Left    Idle    Units/Currency
   --------------------------------------------------------------------------------
   Out          6120   kevin  165      74      45      0 
   --------------------------------------------------------------------------------
   
   krimson# show isdn active
   --------------------------------------------------------------------------------
   ISDN ACTIVE CALLS
   --------------------------------------------------------------------------------
   Call Calling Called Remote Seconds Seconds Seconds  Charges
   Type Number  Number Name   Used    Left    Idle     Units/Currency
   --------------------------------------------------------------------------------
   Out          6120   kevin   224    15      104       0 
   --------------------------------------------------------------------------------

   krimson#show isdn active
   --------------------------------------------------------------------------------
   ISDN ACTIVE CALLS
   --------------------------------------------------------------------------------
   Call Calling Called Remote Seconds Seconds Seconds Charges
   Type Number Number Name Used Left Idle Units/Currency
   --------------------------------------------------------------------------------
   --------------------------------------------------------------------------------

   krimson#show ip route
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route

   Gateway of last resort is 10.200.16.1 to network 0.0.0.0

   192.168.64.0/30 is subnetted, 1 subnets
   C 192.168.64.0 is directly connected, Dialer4
   10.0.0.0/24 is subnetted, 6 subnets
   C 10.5.5.0 is directly connected, Serial1.1
   O 10.8.8.0 [110/1563] via 10.5.5.1, 00:01:52, Serial1.1
   C 10.9.9.0 is directly connected, Dialer0
   C 10.7.7.0 is directly connected, Loopback0
   C 10.9.8.0 is directly connected, Dialer1
   C 10.200.16.0 is directly connected, Ethernet0
   S* 0.0.0.0/0 [1/0] via 10.200.16.1

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 11048