Composition et accès : Routage à établissement de connexion à la demande (DDR)

Sauvegarde BRI RNIS avec l'interface de sauvegarde

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit une configuration d'échantillon pour la sauvegarde RNIS, et fournit l'information de dépannage de base pour ce type de configuration.

Pour les informations sur les réalisations les plus communes de la sauvegarde RNIS, et des comparaisons entre ces derniers, référez-vous au document suivant : Évaluation des Interfaces de sauvegarde, des Routes statiques flottantes, et de la Fonction Dialer Watch pour la sauvegarde DDR.

Conditions préalables

Conditions requises

Aucune condition préalable spécifique n'est requise pour ce document.

Composants utilisés

Les informations dans ce document sont basées sur les versions de logiciel et de matériel ci-dessous.

  • Deux Routeurs de Cisco 2500 (matériel de terminal de données en relais de trame [DTE]) exécutant des versions de logiciel 12.2(3) et 12.2(5) de Cisco IOSÝ.

  • Un routeur de Cisco 4500 agissant en tant que commutateur de Relais de trames.

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

/image/gif/paws/11047/bri_isdn_11047.gif

Configurations

Ce document utilise les configurations présentées ci-dessous.

krimson (routeur de Cisco 2500)
krimson#show running-config
Building configuration...

!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
         
!
hostname krimson
!
!
username kevin password 0 <password> !
isdn switch-type basic-net3
!
!
interface Loopback0
ip address 10.7.7.1 255.255.255.0
ip ospf network point-to-point
!
interface Ethernet0
ip address 10.200.16.30 255.255.255.0
!
interface Serial1
bandwidth 64
no ip address
encapsulation frame-relay
no ip route-cache
no ip mroute-cache
!
interface Serial1.1 point-to-point
backup interface Dialer0
ip address 10.5.5.2 255.255.255.0
no ip route-cache
frame-relay interface-dlci 20 
!
interface BRI0
description Testanschluss ISDN(intern), Nr. 4420038
no ip address
encapsulation ppp
no ip route-cache
no ip mroute-cache
load-interval 30
no keepalive
dialer pool-member 1
isdn switch-type basic-net3
no fair-queue
no cdp enable
ppp authentication chap
!
interface Dialer0
ip address 10.9.9.1 255.255.255.0
encapsulation ppp
no ip route-cache
no ip mroute-cache
dialer pool 1
dialer remote-name kevin
dialer string 6120
dialer-group 1
no cdp enable
ppp authentication chap
!
router ospf 10
log-adjacency-changes
network 10.5.5.0 0.0.0.255 area 0
network 10.7.7.0 0.0.0.255 area 0
network 10.9.9.0 0.0.0.255 area 0
!
ip default-gateway 10.200.16.1
no ip classless
no ip http server
!
access-list 105 permit ip any host 10.7.7.1
access-list 105 permit ip any host 10.8.8.1
access-list 105 permit ip any any
dialer-list 1 protocol ip permit
!
line con 0
exec-timeout 0 0
privilege level 15
line aux 0
transport input all
line vty 0 4
exec-timeout 0 0
password <password> login
!
end

Kevin (routeur de Cisco 2500)
kevin#show running-config
Building configuration...

version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname kevin
!
!
username krimson password 0 <password> !
isdn switch-type basic-net3
!
!
interface Loopback0
ip address 10.8.8.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback1
ip address 172.19.0.1 255.255.255.255
!
interface Ethernet0
ip address 10.200.16.26 255.255.255.0
!
interface Serial0
no ip address
encapsulation frame-relay
!
interface Serial0.1 point-to-point
ip address 10.5.5.1 255.255.255.0
no cdp enable
frame-relay interface-dlci 20 
!
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
no cdp enable
ppp authentication chap
!
interface Dialer0
ip address 10.9.9.2 255.255.255.0
encapsulation ppp
dialer pool 1
dialer remote-name krimson
dialer-group 1
no cdp enable
ppp authentication chap
!
router ospf 10
log-adjacency-changes
network 10.5.5.0 0.0.0.255 area 0
network 10.8.8.0 0.0.0.255 area 0
network 10.9.9.0 0.0.0.255 area 0
!
ip default-gateway 10.200.16.1
ip classless
!
dialer-list 1 protocol ip permit
no cdp run
!        
line con 0        
exec-timeout 0 0
line aux 0
modem InOut
line vty 0 4
exec-timeout 0 0
password <password> login
!
ntp clock-period 17180102
ntp server 10.200.20.134
end

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Utilisez les commandes suivantes de vérifier votre configuration :

certaines commandes show sont prises en charge par l'outil Interpréteur de sortie, qui vous permet d'afficher une analyse de la sortie de la commande show.

  • affichez à des interfaces l'affiche des informations séquentielle au sujet de l'identificateur de connexion de liaison de données multicast (DLCI), des DLCI utilisés sur l'interface, et du DLCI utilisé pour l'interface de gestion locale (LMI).

  • affichez l'affiche des informations d'appeleur d'interface au sujet de l'interface de numérotation.

  • l'artère de show ip affiche des entrées de table de Routage IP.

   krimson#show interface serial 1.1 

   ! --- The initial state before the simulated Frame Relay network failure. 
   ! --- The primary link is up and functional. 

   
   Serial1.1 is up, line protocol is up 
   Hardware is HD64570
   Internet address is 10.5.5.2/24
   Backup interface Dialer0, failure delay 0 sec, 
   secondary disable delay 0 sec
   MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation FRAME-RELAY
   
   krimson#show int dialer 0 

   ! --- Initial state. The backup interface is in standby mode and inactive.

   Dialer0 is standby mode (spoofing), line protocol is down (spoofing)
   Hardware is Unknown
   Internet address is 10.9.9.1/24
   MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation PPP, loopback not set
   DTR is pulsed for 1 seconds on reset
   Last input 1w6d, output never, output hang never
   Last clearing of "show interface" counters 6w4d
   Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
   Queueing strategy: weighted fair
   Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
   Conversations 0/1/16 (active/max active/max total)
   Reserved Conversations 0/0 (allocated/max allocated)
   Available Bandwidth 42 kilobits/sec
   5 minute input rate 0 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
   596 packets input, 48924 bytes
   600 packets output, 49280 bytes
   
   krimson#show ip route
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route
   
   Gateway of last resort is 10.200.16.1 to network 0.0.0.0
   
   192.168.64.0/30 is subnetted, 1 subnets
   C 192.168.64.0 is directly connected, Dialer4
   10.0.0.0/24 is subnetted, 6 subnets
   O 10.9.9.0 [110/3347] via 10.5.5.1, 00:03:34, Serial1.1
   O 10.8.8.0 [110/1563] via 10.5.5.1, 00:03:34, Serial1.1 

   ! --- The route to the tested destination network points to the 
   ! --- still-active primary link.

   
   C 10.5.5.0 is directly connected, Serial1.1
   C 10.7.7.0 is directly connected, Loopback0
   C 10.9.8.0 is directly connected, Dialer1
   C 10.200.16.0 is directly connected, Ethernet0
   S* 0.0.0.0/0 [1/0] via 10.200.16.1

Ici, nous pouvons voir que l'interface de Relais de trames va vers le bas.

   krimson#
   *Apr 16 23:56:47.840: %LINK-3-UPDOWN: Interface Serial1, 
   changed state to down
   *Apr 16 23:56:47.848: OSPF: Interface Serial1.1 going Down 

   ! --- Here we have simulated a failure within the Frame Relay network.
   ! --- We can see what was conducted to the Frame Relay DTE router, 
   ! --- and the subinterface going down.

   *Apr 16 23:56:47.852: %OSPF-5-ADJCHG: Process 10, 
   Nbr 172.19.0.1 on Serial1.1    
   from FULL to DOWN, Neighbor Down: Interface down or detached
   *Apr 16 23:56:48.736: BACKUP(Serial1.1): event = primary went down
   *Apr 16 23:56:48.740: BACKUP(Serial1.1): changed state to 
   "waiting to backup"
   *Apr 16 23:56:48.744: BACKUP(Serial1.1): event = timer expired
   *Apr 16 23:56:48.748: Di0 DDR is shutdown, could not clear interface.
   *Apr 16 23:56:48.752: BACKUP(Serial1.1): 
   secondary interface (Dialer0) made active 

   ! --- The configured backup interface is active.

   *Apr 16 23:56:48.752: BACKUP(Serial1.1): changed state to "backup mode"
   *Apr 16 23:56:48.756: OSPF: Interface Dialer0 going Up
   *Apr 16 23:56:48.760: BR0 DDR: rotor dialout [priority]
   *Apr 16 23:56:48.764: BR0 DDR: Dialing cause ip (s=10.9.9.1, d=224.0.0.5) 

   ! --- OSPF packets trigger the call.

   *Apr 16 23:56:48.768: BR0 DDR: Attempting to dial 6120
   *Apr 16 23:56:48.784: ISDN BR0: TX -> SETUP pd = 8 callref = 0x3E
   *Apr 16 23:56:48.792: Bearer Capability i = 0x8890
   *Apr 16 23:56:48.796: Channel ID i = 0x83
   *Apr 16 23:56:48.804: Called Party Number i = 0x80, '6120', 
   Plan:Unknown, Type:Unknown
   *Apr 16 23:56:48.844: %LINEPROTO-5-UPDOWN: Line protocol on  
   Interface Serial1, changed state to down
   *Apr 16 23:56:48.884: ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0xBE
   *Apr 16 23:56:48.892: Channel ID i = 0x89
   *Apr 16 23:56:49.144: ISDN BR0: RX <- CONNECT pd = 8 callref = 0xBE
   *Apr 16 23:56:49.160: %LINK-3-UPDOWN: Interface BRI0:1, 
   changed state to up
   *Apr 16 23:56:49.168: %DIALER-6-BIND: 
   Interface BR0:1 bound to profile Di0
   *Apr 16 23:56:49.176: BR0:1 PPP: Treating connection as a callout
   *Apr 16 23:56:49.180: BR0:1 PPP: Phase is ESTABLISHING, Active Open 
   [0 sess, 0 load]
   *Apr 16 23:56:49.184: BR0:1 LCP: O CONFREQ [Closed] id 49 len 15
   *Apr 16 23:56:49.188: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
   *Apr 16 23:56:49.188: BR0:1 LCP: MagicNumber 0xF2143EDB (0x0506F2143EDB)
   *Apr 16 23:56:49.196: ISDN BR0: TX -> CONNECT_ACK pd = 8 callref = 0x3E
   *Apr 16 23:56:49.224: BR0:1 LCP: I CONFREQ [REQsent] id 83 len 15
   *Apr 16 23:56:49.228: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
   *Apr 16 23:56:49.232: BR0:1 LCP: MagicNumber 0x9ADACD69 (0x05069ADACD69)
   *Apr 16 23:56:49.236: BR0:1 LCP: O CONFACK [REQsent] id 83 len 15
   *Apr 16 23:56:49.236: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
   *Apr 16 23:56:49.240: BR0:1 LCP: MagicNumber 0x9ADACD69 (0x05069ADACD69)
   *Apr 16 23:56:49.244: BR0:1 LCP: I CONFACK [ACKsent] id 49 len 15
   *Apr 16 23:56:49.248: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
   *Apr 16 23:56:49.252: BR0:1 LCP: MagicNumber 0xF2143EDB (0x0506F2143EDB)
   *Apr 16 23:56:49.252: BR0:1 LCP: State is Open
   *Apr 16 23:56:49.256: BR0:1 PPP: Phase is AUTHENTICATING, by both 
   [0 sess, 0 load]
   *Apr 16 23:56:49.260: BR0:1 CHAP: O CHALLENGE id 49 len 28 from "krimson"
   *Apr 16 23:56:49.276: BR0:1 CHAP: I CHALLENGE id 51 len 26 from "kevin"
   *Apr 16 23:56:49.284: BR0:1 CHAP: O RESPONSE id 51 len 28 from "krimson"
   *Apr 16 23:56:49.332: BR0:1 CHAP: I SUCCESS id 51 len 4
   *Apr 16 23:56:49.344: BR0:1 CHAP: I RESPONSE id 49 len 26 from "kevin"
   *Apr 16 23:56:49.352: BR0:1 CHAP: O SUCCESS id 49 len 4
   *Apr 16 23:56:49.356: BR0:1 PPP: Phase is UP [0 sess, 0 load]
   *Apr 16 23:56:49.360: BR0:1 IPCP: O CONFREQ [Not negotiated] id 41 len 10
   *Apr 16 23:56:49.364: BR0:1 IPCP: Address 10.9.9.1 (0x03060A090901)
   *Apr 16 23:56:49.376: BR0:1 IPCP: I CONFREQ [REQsent] id 29 len 10
   *Apr 16 23:56:49.380: BR0:1 IPCP: Address 10.9.9.2 (0x03060A090902)
   *Apr 16 23:56:49.384: BR0:1 IPCP: O CONFACK [REQsent] id 29 len 10
   *Apr 16 23:56:49.388: BR0:1 IPCP: Address 10.9.9.2 (0x03060A090902)
   *Apr 16 23:56:49.396: BR0:1 IPCP: I CONFACK [ACKsent] id 41 len 10
   *Apr 16 23:56:49.400: BR0:1 IPCP: Address 10.9.9.1 (0x03060A090901)
   *Apr 16 23:56:49.400: BR0:1 IPCP: State is Open
   *Apr 16 23:56:49.408: BR0:1 DDR: dialer protocol up
   *Apr 16 23:56:49.416: Di0 IPCP: Install route to 10.9.9.2
   *Apr 16 23:56:49.960: OSPF: Rcv hello from 172.19.0.1 area 0 from 
   Dialer0 10.9.9.2
   *Apr 16 23:56:49.964: OSPF: End of hello processing
   *Apr 16 23:56:50.356: %LINEPROTO-5-UPDOWN: 
   Line protocol on Interface BRI0:1, changed state to up
   *Apr 16 23:56:50.748: %LINK-3-UPDOWN: Interface Dialer0, 
   changed state to up
   *Apr 16 23:56:50.752: Di0 LCP: Not allowed on a Dialer Profile
   *Apr 16 23:56:50.752: BACKUP(Dialer0): event = primary came up
   *Apr 16 23:56:55.176: %ISDN-6-CONNECT: 
   Interface BRI0:1 is now connected to 6120 kevin
   *Apr 16 23:56:58.804: OSPF: Rcv DBD from 172.19.0.1 on Dialer0 
   seq 0x988 opt 0x42 flag 0x7 len 32 mtu 1500 state INIT
   *Apr 16 23:56:58.808: OSPF: 2 Way Communication to 172.19.0.1 
   on Dialer0, state 2WAY
   
   krimson#show interface serial 1.1
   Serial1.1 is down, line protocol is down 
   
! --- The primary link is down.

   Hardware is HD64570
   Internet address is 10.5.5.2/24
   Backup interface Dialer0, failure delay 0 sec, 
   secondary disable delay 0 sec
   MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation FRAME-RELAY
   
   krimson#show interface dialer 0
   Dialer0 is up, line protocol is up (spoofing) 

   ! --- The backup interface is active and bearing traffic.

   Hardware is Unknown
   Internet address is 10.9.9.1/24
   MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation PPP, loopback not set
   DTR is pulsed for 1 seconds on reset
   Interface is bound to BR0:1
   Last input 1w6d, output never, output hang never
   Last clearing of "show interface" counters 6w4d
   Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
   Queueing strategy: weighted fair
   Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
   Conversations 0/1/16 (active/max active/max total)
   Reserved Conversations 0/0 (allocated/max allocated)
   Available Bandwidth 42 kilobits/sec
   5 minute input rate 0 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
   614 packets input, 50240 bytes
   618 packets output, 50584 bytes
   Bound to:
   BRI0:1 is up, line protocol is up 
   Hardware is BRI
   MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation PPP, loopback not set
   Keepalive not set
   DTR is pulsed for 1 seconds on reset
   Time to interface disconnect: idle 00:01:57
   Interface is bound to Di0 (Encapsulation PPP)
   LCP Open
   Open: IPCP
   Last input 00:00:01, output 00:00:02, output hang never
   Last clearing of "show interface" counters never
   Queueing strategy: fifo
   Output queue 0/40, 0 drops; input queue 0/75, 0 drops
   30 second input rate 0 bits/sec, 0 packets/sec
   30 second output rate 0 bits/sec, 0 packets/sec
   3910 packets input, 394443 bytes, 0 no buffer
   Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
   29 input errors, 18 CRC, 0 frame, 0 overrun, 0 ignored, 11 abort
   3613 packets output, 222417 bytes, 0 underruns
   0 output errors, 0 collisions, 27 interface resets
   0 output buffer failures, 0 output buffers swapped out
   607 carrier transitions
   
   krimson#show ip route
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route

Gateway of last resort is 10.200.16.1 to network 0.0.0.0
 
192.168.64.0/30 is subnetted, 1 subnets
   C 192.168.64.0 is directly connected, Dialer4
   10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
   C 10.9.9.2/32 is directly connected, Dialer0
   O 10.8.8.0/24 [110/1786] via 10.9.9.2, 00:00:53, Dialer0 
   
! --- The route entry to the destination network is now pointing to 
   ! --- the backup interface as a next hop.

   C 10.9.9.0/24 is directly connected, Dialer0
   C 10.7.7.0/24 is directly connected, Loopback0
   C 10.9.8.0/24 is directly connected, Dialer1
   C 10.200.16.0/24 is directly connected, Ethernet0
   S* 0.0.0.0/0 [1/0] via 10.200.16.1
   
   krimson#ping 10.8.8.1
   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 10.8.8.1, timeout is 2 seconds:
   !!!!!
   Success rate is 100 percent (5/5), round-trip min/avg/max = 36/36/40 ms

Ici nous pouvons voir le système revenant à son état initial une fois que la panne dans le réseau de Relais de trames a été effacée :

krimson#show interface serial 1.1
   Serial1.1 is up, line protocol is up 
   Hardware is HD64570
   Internet address is 10.5.5.2/24
   Backup interface Dialer0, failure delay 0 sec, 
   secondary disable delay 0 sec
   MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation FRAME-RELAY
   
   krimson#show interface dialer 0
   Dialer0 is standby mode (spoofing), line protocol is down (spoofing)
   Hardware is Unknown
   Internet address is 10.9.9.1/24
   MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation PPP, loopback not set
   DTR is pulsed for 1 seconds on reset
   Last input 1w6d, output never, output hang never
   Last clearing of "show interface" counters 6w5d
   Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
   Queueing strategy: weighted fair
   Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
   Conversations 0/1/16 (active/max active/max total)
   Reserved Conversations 0/0 (allocated/max allocated)
   Available Bandwidth 42 kilobits/sec
   5 minute input rate 0 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
   665 packets input, 54008 bytes
   671 packets output, 54548 bytes
   
   krimson#show ip route
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route
   Gateway of last resort is 10.200.16.1 to network 0.0.0.0
   192.168.64.0/30 is subnetted, 1 subnets
   C 192.168.64.0 is directly connected, Dialer4
   10.0.0.0/24 is subnetted, 6 subnets
   O 10.9.9.0 [110/3347] via 10.5.5.1, 00:08:39, Serial1.1
   O 10.8.8.0 [110/1563] via 10.5.5.1, 00:08:39, Serial1.1
   C 10.5.5.0 is directly connected, Serial1.1
   C 10.7.7.0 is directly connected, Loopback0
   C 10.9.8.0 is directly connected, Dialer1
   C 10.200.16.0 is directly connected, Ethernet0
   S* 0.0.0.0/0 [1/0] via 10.200.16.1
   krimson# 

Remarque: Aucune configuration spécifique n'est nécessaire du côté appelé.

La même sortie d'exposition enregistrée pendant le fonctionnement normal contient les informations suivantes :

kevin#show interface serial 0.1
   Serial0.1 is up, line protocol is up 

   ! --- The primary interface is up and running.

   Hardware is HD64570
   Internet address is 10.5.5.1/24
   MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation FRAME-RELAY
   
   kevin#show interface dialer 0
   Dialer0 is up (spoofing), line protocol is up (spoofing) 

   ! --- Note: On the called side, the dialer interface is active 
   ! --- and not in standby mode.

   Hardware is Unknown
   Internet address is 10.9.9.2/24
   MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation PPP, loopback not set
   DTR is pulsed for 1 seconds on reset
   Last input 1w6d, output never, output hang never
   Last clearing of "show interface" counters 4w2d
   Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
   Queueing strategy: weighted fair
   Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
   Conversations 0/1/16 (active/max active/max total)
   Reserved Conversations 0/0 (allocated/max allocated)
   Available Bandwidth 42 kilobits/sec
   5 minute input rate 0 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
   598 packets input, 49252 bytes
   596 packets output, 48924 bytes

   kevin#show ip route
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route
   
   Gateway of last resort is 10.200.16.1 to network 0.0.0.0
   
   172.17.0.0/32 is subnetted, 1 subnets
   S 172.17.247.195 [1/0] via 10.200.16.1
   172.19.0.0/32 is subnetted, 1 subnets
   C 172.19.0.1 is directly connected, Loopback1
   10.0.0.0/24 is subnetted, 5 subnets
   C 10.5.5.0 is directly connected, Serial0.1
   O 10.7.7.0 [110/65] via 10.5.5.2, 00:04:27, Serial0.1
   C 10.9.9.0 is directly connected, Dialer0
   C 10.8.8.0 is directly connected, Loopback0
   C 10.200.16.0 is directly connected, Ethernet0
   S* 0.0.0.0/0 [1/0] via 10.200.16.1

Voici les mêmes mêmes informations enregistrées pendant la panne :

kevin#show interface serial 0.1
   Serial0.1 is down, line protocol is down 
   Hardware is HD64570
   Internet address is 10.5.5.1/24
   MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation FRAME-RELAY
   
   kevin#show interface dialer 0
   Dialer0 is up, line protocol is up (spoofing)
   Hardware is Unknown
   Internet address is 10.9.9.2/24
   MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation PPP, loopback not set
   DTR is pulsed for 1 seconds on reset
   Interface is bound to BR0:1
   Last input 1w6d, output never, output hang never
   Last clearing of "show interface" counters 4w2d
   Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
   Queueing strategy: weighted fair
   Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
   Conversations 0/1/16 (active/max active/max total)
   Reserved Conversations 0/0 (allocated/max allocated)
   Available Bandwidth 42 kilobits/sec
   5 minute input rate 0 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
   618 packets input, 50700 bytes
   616 packets output, 50384 bytes
   Bound to:
   BRI0:1 is up, line protocol is up 
   Hardware is BRI
   MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, 
   reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation PPP, loopback not set
   Keepalive set (10 sec)
   DTR is pulsed for 1 seconds on reset
   Time to interface disconnect: idle 00:01:57
   Interface is bound to Di0 (Encapsulation PPP)
   LCP Open
   Open: IPCP
   Last input 00:00:03, output 00:00:02, output hang never
   Last clearing of "show interface" counters never
   Queueing strategy: fifo
   Output queue 0/40, 0 drops; input queue 0/75, 0 drops
   5 minute input rate 0 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
   1280 packets input, 138077 bytes, 0 no buffer
   Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
   9789 input errors, 9789 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
   1309 packets output, 138487 bytes, 0 underruns
   0 output errors, 0 collisions, 15 interface resets
   0 output buffer failures, 0 output buffers swapped out
   351 carrier transitions
   
   kevin#show ip route
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route
   Gateway of last resort is 10.200.16.1 to network 0.0.0.0
   172.17.0.0/32 is subnetted, 1 subnets
   S 172.17.247.195 [1/0] via 10.200.16.1
   172.19.0.0/32 is subnetted, 1 subnets
   C 172.19.0.1 is directly connected, Loopback1
   10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
   O 10.7.7.0/24 [110/1786] via 10.9.9.1, 00:01:21, Dialer0
   C 10.9.9.0/24 is directly connected, Dialer0
   C 10.8.8.0/24 is directly connected, Loopback0
   C 10.9.9.1/32 is directly connected, Dialer0
   C 10.200.16.0/24 is directly connected, Ethernet0
   S* 0.0.0.0/0 [1/0] via 10.200.16.1

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Les configurations de Relais de trames avec des sous-interfaces point par point et le Protocole OSPF (Open Shortest Path First) comme un protocole de routage l'a utilisé ici sont spécifiques à cette installation. Cependant, les étapes de dépannage affichées sont plus de général et peuvent être utilisées avec différentes configurations telles que des point-à-multipoints en relais de trame ou une liaison principale avec l'encapsulation de High-Level Data Link Control (HDLC) ou de protocole de point-à-point (PPP), indépendamment du protocole de routage utilisé.

Pour vérifier la fonctionnalité de sauvegarde, une des interfaces sur le routeur de Cisco 4500 qui agit en tant que commutateur de Relais de trames a été placée dans l'état d'arrêt afin de simuler le problème dans le réseau de Relais de trames. En conséquence, ceci mène à l'état inactif PVC étant conduit au routeur DTE par l'intermédiaire du réseau de Relais de trames, et à un événement de sous-interface de relais de trame vers le bas. Ceci lance l'Interface de sauvegarde.

Dépannage des commandes

Remarque: Avant d'exécuter les commandes debug, référez-vous à la section Informations importantes sur les commandes Debug.

  • debug isdn q931

  • mettez au point les événements de sauvegarde de sauvegarde de debugs.

  • mettez au point les informations de débogage d'affichages d'appeleur au sujet des paquets ou des événements sur une interface de numérotation.

  • debug ppp negotiation - Entraîne la commande de debug ppp d'afficher des paquets PPP transmis pendant le startup de PPP, où des options PPP sont négociées.

  • debug ppp authentication - Entraîne la commande de debug ppp d'afficher des messages du protocole d'authentification, y compris des échanges de paquet de Protocol d'authentification de défi (CHAP) et des échanges de Password Authentication Protocol (PAP).

  • debug ip ospf events - L'affiche des informations sur des événements liés à l'OSPF, tels que des contiguïtés, les informations d'engorgement, a indiqué la sélection de routeur, et calcul de plus court chemin le premier (SPF)

  • debug frame-relay events - Les informations de débogage d'affichages au sujet de l'ARP de Relais de trames répondent sur les réseaux qui prennent en charge un canal multicast et utilisent l'adressage dynamique.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 11047