Commutateurs : Commutateurs Cisco Catalyst, s�rie�6500

Configuration d'une adresse IP de gestion sur les commutateurs Catalyst 4500/4000, 5500/5000, 6500/6000 et les commutateurs Catalyst à configuration fixe

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (20 octobre 2015) | Commentaires


Interactif : Ce document propose une analyse personnalisée de votre périphérique Cisco.


Contenu


Introduction

Ce document décrit comment configurer un IP address de Gestion sur le Catalyst 4500/4000, 5500/5000, et les Commutateurs de gamme 6500/6000 qui exécutent le logiciel de ½ du ¿  OS (CatOS) et de Cisco IOSï de Catalyst. Ce document comporte également les commutateurs de configuration fixe de Catalyst, qui exécutent seulement le logiciel Cisco IOS et incluent les commutateurs de la gamme 2900/3500XL, 2940, 2950, 2955, 2970, 3550 et 3750. Une adresse IP est nécessaire si vous voulez gérer le commutateur depuis une station à distance de gestion à capacité TCP/IP. Un commutateur qui doit être géré par un terminal VT100 sur son port de console ne requiert pas d'adresse IP.

Conditions préalables

Conditions requises

Cisco recommande de prendre connaissance des informations contenues dans cette section.

Les commutateurs Catalyst 4500/4000, 5500/5000, 6500/6000 qui exécutent seulement CatOS sont des commutateurs de la couche 2 (L2). Les commutateurs à configuration fixe Catalyst 2900/3500XLs, 2940, 2950, 2955 et 2970 sont également des commutateurs L2. Le protocole TCP/IP sur un commutateur L2 a seulement des objectifs de gestion. Les données qui traversent le commutateur peuvent avoir des adresses de la couche 3 (L3), telles que IP, Internetwork Packet Exchange (IPX), AppleTalk et ainsi de suite. Cependant, le commutateur utilise seulement l'adresse MAC de données afin de déterminer d'où le trafic de routage est provenu et quels ports devraient recevoir les données. Les commutateurs L2 ignorent les adresses L3 quand les commutateurs transfèrent des données.

Les commutateurs des gammes Catalyst 6500/6000, 4500/4000 et 3550/3750 qui exécutent le logiciel Cisco IOS sont des routeurs de commutation ou des commutateurs L3 et peuvent utiliser n'importe quelle interface pour la gestion. Vous pouvez configurer l'interface de gestion de l'une des façons suivantes :

  • En tant qu'interface logique, comme une interface de bouclage

  • Comme port d'accès L2 dans un VLAN de gestion

  • Comme une interface L3 avec une adresse IP

    Remarque: Il s'agit de la même façon dont vous configurez l'interface sur n'importe quel routeur Cisco.

Les commutateurs Catalyst que ce document aborde ont les interfaces de gestion suivantes :

  • Les commutateurs des gammes Catalyst 5500/5000 et 6500/6000 avec les Supervisor Engines qui exécutent CatOS ont deux interfaces IP de gestion configurables :

    • L'interface intrabande (sc0)

    • L'interface du Serial Line Internet Protocol (SLIP) (sl0)

  • Les commutateurs Catalyst 4500/4000 avec les Supervisor Engines qui exécutent CatOS ont trois interfaces configurables de gestion IP. L'interface supplémentaire est appelée l'interface Ethernet de gestion (me1).

  • Les commutateurs à configuration fixe Catalyst L2 qui exécutent le logiciel Cisco IOS ont seulement une interface configurable de gestion IP qui, par défaut, est l'interface VLAN 1.

  • Les commutateurs purs de la couche 2 peuvent avoir une seule interface VLAN à la fois. Ceci est appelé la gestion VLAN (dans IOS) ou l'interface sc0 (dans CatOS). Le principal objectif de cette interface est la gestion (telnet, SNMP, etc.). Si le commutateur est un commutateur de la couche 3, vous pouvez configurer plusieurs VLAN et la route entre eux. Un commutateur L3 peut prendre en charge de multiples IP, de sorte qu'il n'y ait pas de gestion VLAN spécifique sur le commutateur.

  • Les commutateurs de la gamme Catalyst 3550/3750 qui exécutent le logiciel Cisco IOS peuvent utiliser n'importe quelle interface pour la gestion.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Interfaces de gestion Catalyst 4500/4000, 5500/5000 et 6500/6000

L'interface sc0 est une interface de gestion interne connectée à la matrice de commutation. L'interface sc0 participe à toutes les fonctions d'un port de commutation normal, qui incluent :

  • Protocole Spanning Tree (STP)

  • Cisco Discovery Protocol (CDP)

  • Appartenance à LAN virtuel (VLAN)

Les interfaces me1 et sl0 sont des interfaces d'administration hors bande qui ne sont pas connectées à la matrice de commutation et ne participent pas à l'une de ces fonctions.

Quand vous configurez l'adresse IP, masque de sous-réseau et adresse de diffusion (et, sur l'interface sc0, l'appartenance au VLAN) de l'interface sc0 ou me1, vous pouvez accéder au commutateur par Telnet ou le Protocole de gestion de réseau simple (SNMP). Quand vous configurez l'interface du SLIP (sl0), vous pouvez ouvrir une connexion point à point au commutateur à travers le port de console d'une station de travail.

Si vous disposez de la sortie d'une commande show interface pour votre périphérique Cisco, vous pouvez utiliser l'outil interpréteur des résultats (réservé aux clients inscrits) pour afficher les problèmes potentiels ainsi que les correctifs.

Le sc0 n'a pas de port externe pour la connexion directe. Cette interface existe en tant qu'interface logique à l'intérieur du commutateur et est accessible à travers n'importe lequel des ports physiques du commutateur. La figure suivante fournit une illustration :

/image/gif/paws/10594/8a.gif

me1 est en fait un port Ethernet physique sur le module du Supervisor Engine des commutateurs de la gamme Catalyst 4500/4000. Cette interface est seulement utilisée pour l'administration de réseau et ne prend pas en charge la commutation de réseau.

/image/gif/paws/10594/8d.gif

sl0 utilise le port de console RS232 en tant qu'interface physique. sl0 ne peut pas être utilisé comme console VT100 quand il est en mode SLIP. La figure suivante montre une connexion SLIP à sl0 :

8b.gif

Configurez l'interface sc0 sur les commutateurs Catalyst 4500/4000, 5500/5000 et 6500/6000 qui exécutent CatOS

Cette section décrit comment configurer une adresse IP sur l'interface intrabande sc0.

  1. Connectez un terminal aux ports de console des commutateurs.

    Pour des détails sur la façon de se connecter aux ports de console des commutateurs Catalyst, reportez-vous à Connexion d'un terminal au port de console sur des commutateurs Catalyst.

  2. Émettez la commande show interface à l'invite du commutateur afin d'afficher le statut par défaut des interfaces de gestion.

    Switch-A> (enable) show interface
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63<UP,BROADCAST,RUNNING>        
            vlan 1 inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    
    !--- Catalyst 5500/5000 and 6500/6000 series switches 
    !--- do not display the me1 interface in the output.
    
    Switch-A> (enable)
  3. Émettez la commande set interface sc0 172.16.84.17 255.255.255.0 172.16.84.255 afin de configurer une adresse IP pour sc0.

    Le message que le commutateur renvoie vous indique quels paramètres ont été modifiés.

    Remarque: Quand vous émettez la commande set interface sc0, vous ne pouvez pas introduire l'adresse de diffusion sans masque de sous-réseau de l'adresse IP.

    Switch-A> (enable) set interface sc0 172.16.84.17 255.255.255.0 172.16.84.255 
    Interface sc0 IP address, netmask, and broadcast set. 
    Switch-A> (enable)

    Émettez la commande show interface afin d'afficher les modifications.

    Switch-A> (enable) show interface 
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0 
    sc0: flags=63<UP,BROADCAST,RUNNING> 
            vlan 1 inet 172.16.84.17 netmask 255.255.255.0 broadcast 172.16.84.255
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    Switch-A> (enable)

    Si vous entrez seulement une adresse IP après la commande set interface sc0 172.16.84.17, le masque par défaut et l'adresse de diffusion de routage par défaut pour la classe d'adresses sont automatiquement configurés. Voici un exemple :

    Switch-A> (enable) set interface sc0 172.16.84.17 
    
    !--- Notice that neither the mask nor the broadcast address is specified.
    
    Interface sc0 IP address and netmask set. 
    Switch-A> (enable) 
    Switch-A> (enable) show interface 
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0 
    sc0: flags=63<UP,BROADCAST,RUNNING>
            vlan 1 inet 172.16.84.17 netmask 255.255.0.0 broadcast 172.16.255.255 
    
    !--- Notice that the switch took the default mask 
    !--- and the broadcast address of class B.
    
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    Switch-A> (enable)

    Si vous entrez l'adresse IP et le masque de sous-réseau après la commande set interface sc0, l'adresse de diffusion pour le sous-réseau spécifique est automatiquement configurée.

  4. Afin de modifier le VLAN sur l'interface sc0, émettez la commande set interface sc0 vlan# , qui spécifie le numéro VLAN.

    Remarque: Par défaut, l'interface sc0 appartient au VLAN 1.

    Si vous voulez modifier l'appartenance de sc0 au VLAN 2, émettez cette commande :

    Switch-A> (enable) set interface sc0 2 
    
    
    Interface sc0 vlan set. 
    Switch-A> (enable)

    Remarque: Assurez-vous que VLAN 2 est configuré sur le commutateur avant que vous émettiez cette commande. La configuration des VLAN sur des commutateurs Catalyst ne relève pas du champ de ce document. Pour plus d'informations, référez-vous à Création de VLAN Ethernet sur des commutateurs Catalyst.

    Émettez la commande show interface afin d'afficher les modifications.

    Switch-A> (enable) show interface
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING> 
            slip 0.0.0.0 dest 0.0.0.0 
    sc0: flags=63<UP,BROADCAST,RUNNING>
    vlan 2 inet 172.16.84.17 netmask 255.255.255.0 broadcast 172.16.84.255
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    
    Switch-A> (enable)
  5. Émettez la commande show ip route.

    Remarque:  Si vous voulez pouvoir gérer le commutateur à travers un routeur, vous devez configurer une passerelle par défaut. Le commutateur ne participe pas au routage IP. Par conséquent, le commutateur n'a aucune connaissance de la topologie L3 du réseau.

    Quand vous émettez la commande show ip route, notez que la passerelle pour le sous-réseau sc0 est attribuée à sa propre adresse.

    Switch-A> (enable) show ip route 
    Fragmentation   Redirect   Unreachable 
    -------------   --------   ----------- 
    enabled         enabled    enabled 
    
    Destination      Gateway          RouteMask    Flags    Use       Interface 
    ---------------  ---------------  ----------   -----    --------  --------- 
    172.16.84.0   172.16.84.17         0xffffff00   U        395         sc0 
    default          default          0xff000000   UH       0           sl0 
    Switch-A> (enable)
  6. Émettez la commande set ip route 0.0.0.0 172.16.84.1 ou la commande set ip route default 172.16.84.1 afin d'établir la route par défaut.

    La deuxième adresse IP est directement connectée au routeur qui sera votre chemin à travers le reste du réseau. Cette adresse IP doit faire partie du même sous-réseau IP que le commutateur. Vous pouvez définir jusqu'à trois passerelles IP par défaut. Employez le mot clé primaire avec la commande set ip route afin de faire d'une passerelle la passerelle principale. Si vous ne spécifiez pas une passerelle principale par défaut, la première passerelle qui est configurée est la passerelle principale. Si plus d'une passerelle est indiquée en tant que primaire, la dernière passerelle principale qui est configurée est la passerelle principale par défaut.

    • Switch-A> (enable) set ip route 0.0.0.0 172.16.84.1 
      Route added. 
      Switch-A> (enable)

    ou

    • Switch-A> (enable) set ip route default 172.16.84.1
      Route added. 
      Switch-A> (enable)

    Émettez la commande show ip route afin d'afficher les modifications.

    Switch-A> (enable) show ip route 
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled 
    
    The primary gateway: 172.16.84.1
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default        172.16.84.1          0x0        UG      0           sc0
    172.16.84.0      172.16.84.17     0xffffff00   U       525         sc0
    default          default          0xff000000   UH      0           sl0
    Switch-A> (enable)
  7. Si vous avez besoin d'effacer les routes de la table de routage, émettez la commande clear ip route all .

    Remarque: Si vous êtes connecté au commutateur à travers Telnet depuis un sous-réseau différent, vous perdez la connexion quand vous effacez les routes. Vous ne pouvez pas atteindre le commutateur de nouveau jusqu'à ce que quelqu'un ressaisisse l'adresse de la passerelle à travers une console raccordée ou un PC/terminal qui est sur le même sous-réseau que le commutateur.

    Switch-A> (enable) clear ip route all
    All routes deleted.
    Switch-A> (enable)

    Vous pouvez effacer une route simple si vous spécifiez seulement cette route. Émettez la commande clear ip route 0.0.0.0 172.16.84.1.

Configurez l'interface SLIP (sl0) sur les commutateurs Catalyst 4500/4000, 5500/5000 et 6500/6000 qui exécutent CatOS

Vous pouvez utiliser une connexion SLIP sur sl0 afin de contrôler ou gérer le commutateur à distance avec un périphérique doté d'une capacité TCP/IP où il n'y a aucun autre chemin de routage vers le commutateur excepté à travers le port de console.

Un administrateur réseau peut utiliser un PC distant pour accéder par ligne commutée aux commutateurs n'importe où dans le monde et gérer les commutateurs en utilisant SNMP ou Telnet sur SLIP. Vous pouvez également télécharger le logiciel système sur l'interface sl0 avec l'utilisation de TFTP. Sans SLIP, le port de console peut seulement être utilisé pour l'accès VT100 (tty) ou les transferts de fichiers Kermit. Reportez-vous à Connecter un modem au port de console sur des commutateurs Catalyst pour plus d'informations sur la façon d'activer la connectivité par ligne commutée à un commutateur Catalyst.

La figure suivante montre un exemple de la gestion d'un commutateur à travers un terminal distant avec l'utilisation de sl0. Ce type de gestion est parfois mentionné sous le nom d'administration hors bande. Hors bande signifie qu'un terminal de gestion accède au périphérique à travers un chemin qui n'inclut pas le réseau auquel le commutateur est connecté.

/image/gif/paws/10594/8c.gif

Si vous installez et activez l'interface sl0 d'un terminal de console directement raccordé, vous perdez votre connexion par console. Si le terminal que vous utilisez prend en charge SLIP, établissez une session SLIP avec le commutateur. Désactivez la connexion SLIP quand vous terminez afin de permettre la connectivité directe de console. Si vous activez SLIP et que votre terminal ne le prend pas en charge, vous devez établir une connexion Telnet au commutateur et désactiver sl0 ou mettre le commutateur sous tension puis hors tension afin de réobtenir l'accès au port de console.

Remarque: À moins que vous ayez un terminal qui peut exécuter SLIP et que vous sachiez l'utiliser, effectuez seulement ces étapes d'une connexion Telnet au commutateur.

  1. Établissez une session Telnet au commutateur.

  2. Émettez la commande set interface sl0 1.1.1.1 1.1.1.2 à l'invite de commande afin de définir l'adresse SLIP du commutateur et l'adresse IP de destination.

    Voici un exemple :

    Switch-A> (enable) set interface sl0 1.1.1.1 1.1.1.2
    Interface sl0 slip and destination address set.
    Switch-A> (enable)
  3. Émettez la commande slip attach à l'invite de commande afin d'activer le mode SLIP.

    Voici un exemple :

    Switch-A> (enable) slip attach
    Console Port now running SLIP.
    Switch-A> (enable)
  4. Émettez la commande slip detach à l'invite de commande afin de désactiver le mode SLIP.

    Voici un exemple :

    Switch-A> (enable) slip detach
    SLIP detached on Console port.
    Switch-A> (enable)

Configurez l'interface de gestion Ethernet (me1) sur un Catalyst 4500/4000 qui exécute CatOS

Cette section explique comment configurer une adresse IP sur le me1 qui est présent sur les commutateurs de la gamme Catalyst 4500/4000. Les paquets reçus sur l'interface me1 n'atteignent jamais la matrice de commutation et il n'y a aucun accès à l'interface me1 excepté par le port Ethernet sur le Supervisor Engine.

Une autre caractéristique de l'interface me1 est que, quand le commutateur est dans le moniteur ROM (ROMmon), l'interface me1 est la seule interface qui est active. Vous pouvez démarrer depuis le réseau à travers me1 ou mettre à niveau le logiciel Cisco IOS à travers me1 quand il est dans ROMmon. Cependant, vous devez être directement sur le port de console. Vous pouvez utiliser cette interface quand vous récupérez un commutateur de la gamme Catalyst 4500/4000 d'une image logicielle altérée ou absente ou d'une panne de mise à niveau. Pour ces détails, reportez-vous à la rubrique Récupération des commutateurs Catalyst 4000, Catalyst 2948G, Catalyst 2980G et Catalyst 4912G exécutant CatOS après des pannes de démarrage.

Vous configurez l'adresse IP sur l'interface me1 de façon identique à la configuration sur l'interface sc0. La seule différence est que vous ne pouvez attacher l'interface me1 à aucun VLAN parce que cette interface n'atteint pas la matrice de commutation comme le fait l'interface sc0.

Suivez ces étapes afin de configurer une adresse IP sur l'interface me1 :

  1. Connectez un terminal aux ports de console du commutateur.

  2. Émettez la commande show interface à l'invite du commutateur afin d'afficher l'état par défaut de l'interface me1.

    Voici un exemple :

    Switch-A> (enable) show interface
    sl0: flags=51<DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63<UP,BROADCAST,RUNNING>
            vlan 1 inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    me1: flags=62<DOWN,BROADCAST,RUNNING>
            inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    
    Switch-A> (enable)
  3. Émettez la commande set interface me1 10.1.1.2 255.255.255.0 10.1.1.255 afin de configurer une adresse IP pour me1.

    Le message que le commutateur renvoie vous indique quels paramètres ont été modifiés.

    Remarque: Vous devez entrer dans un masque de réseau afin de configurer une adresse de diffusion.

    Switch-A> (enable) set interface me1 10.1.1.2 255.255.255.0 10.1.1.255
    Interface me1 IP address, netmask, and broadcast set.
    Switch-A> (enable)

    Émettez la commande show interface afin d'afficher les modifications que vous avez effectuées.

    Switch-A> (enable) show interface
    sl0: flags=50 <DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63 <UP,BROADCAST,RUNNING>
            vlan 1 inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    me1: flags=63 <UP,BROADCAST,RUNNING>
            inet 10.1.1.2 netmask 255.255.255.0 broadcast 10.1.1.255
    Switch-A> (enable)

    Si vous entrez seulement une adresse IP après la commande set interface me1 10.1.1.2, le masque par défaut et l'adresse de diffusion par défaut pour la classe d'adresses que vous avez utilisée sont configurés. Voici un exemple :

    Switch-A> (enable) set interface me1 10.1.1.2 
    
    !--- Notice that neither the mask nor the broadcast address is specified.
    
    Interface sc0 IP address and netmask set. 
    Switch-A> (enable)
    
    Switch-A> (enable) show interface
    sl0: flags=50 <DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63 <UP,BROADCAST,RUNNING>
            vlan 1 inet 0.0.0.0 netmask 0.0.0.0 broadcast 0.0.0.0
    
    me1: flags=63 <UP,BROADCAST,RUNNING>
            inet 10.1.1.2 netmask 255.0.0.0 broadcast 10.255.255.255
    
    !--- Notice that the switch took the 
    !--- default mask and the broadcast address of class A.
    
    Switch-A> (enable)

    Remarque: Normalement, l'interface me1 est configurée de façon à être dans un sous-réseau différent que l'interface sc0 qui permet aux deux interfaces de rester actives. Les deux interfaces peuvent être configurées dans le même sous-réseau ou avec la même adresse IP, mais l'interface sc0 est arrêtée dans ce cas. L'interface me1 a toujours la priorité dans ce cas. Par exemple, si vous avez déjà configuré l'interface sc0 avec une adresse IP 172.16.84.17 255.255.255.0 et que vous essayez de configurer l'interface me1 dans le même sous-réseau (172.16.84.18 255.255.255.0), vous voyez ces messages :

    Switch-A> (enable) set interface me1 172.16.84.18 255.255.255.0 172.16.80.255
    This command places me1 and sc0 into the same ip subnet. 
    The sc0 interface will be automatically configured down if necessary to resolve 
    the conflict.
    Do you want to continue (y/n) [n]?y
    Interface me1 IP address, netmask, and broadcast set.
    Interface sc0 administratively down due to conflict.
    Console> (enable)
    
    !--- Check the configuration.
    
    Switch-A> (enable) show interface
    sl0: flags=50 <DOWN,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=62 <DOWN,BROADCAST,RUNNING>
            vlan 1 inet 172.16.84.17 netmask 255.255.255.0 broadcast 172.16.84.255
    me1: flags=63 <UP,BROADCAST,RUNNING>
            inet 172.16.84.18 netmask 255.255.255.0 broadcast 172.16.84.255
    Switch-A> (enable) 
  4. Si vous avez remarqué dans l'étape 3 que l'état de me1 est inactif plutôt qu'actif, émettez cette commande afin mettre l'interface en marche manuellement :

    Switch-A> (enable) set interface me1 up
    Interface me1 administratively up.
    Switch-A> (enable)
  5. Émettez la commande show ip route.

    Remarque: Si vous voulez pouvoir gérer le commutateur à travers un routeur, vous devez configurer une passerelle par défaut parce que le commutateur ne participe pas au routage IP. Par conséquent, le commutateur n'a aucune connaissance de la topologie L3 du réseau.

    Quand vous émettez la commande show ip route, notez que la passerelle pour le sous-réseau me1 est attribuée à sa propre adresse.

    Switch-A> (enable) show ip route 
    Fragmentation   Redirect   Unreachable 
    -------------   --------   ----------- 
    enabled         enabled    enabled 
    
    Destination      Gateway          RouteMask    Flags    Use       Interface 
    ---------------  ---------------  ----------   -----    --------  --------- 
    10.1.1.0         10.1.1.2         0xffffff00   U       0           me1
    Switch-A> (enable)
  6. Émettez la commande set ip route 0.0.0.0 10.1.1.3 ou la commande set ip route default 10.1.1.3 afin d'établir la route par défaut.

    La deuxième adresse IP est directement connectée au routeur qui sera votre chemin à travers le reste du réseau. Cette adresse IP doit faire partie du même sous-réseau IP que le commutateur.

    • Switch-A> (enable)set ip route 0.0.0.0 10.1.1.3
      Route added. 
      Switch-A> (enable)

    ou

    • Switch-A> (enable) set ip route default 10.1.1.3
      Route added. 
      Switch-A> (enable)

    Émettez la commande show ip route afin d'afficher les modifications.

    Switch-A> (enable) show ip route
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled 
    
    The primary gateway: 10.1.1.3
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default          10.1.1.3         0x0          UG      0           me1
    10.1.1.0         10.1.1.2         0xffffff00   U       1           me1
    Switch-A> (enable)
    
    

    Remarque: Si sc0 et me1 sont dans différents sous-réseaux, vous pouvez configurer plusieurs passerelles par défaut. Cependant, la passerelle qui est définie en premier devient la passerelle principale. Si c'est la passerelle que vous souhaitez, vous devez utiliser le mot clé primaire à la fin de la commande afin de modifier la passerelle par défaut principale. Par exemple, 172.16.84.1 est la passerelle principale dans le cas où ces deux élément sont vrais :

    • Vous avez sc0 avec l'adresse IP 172.16.84.17 255.255.255.0 configuré en premier avec la passerelle par défaut de 172.16.84.1.

    • Vous configurez me1 avec une adresse IP de 10.1.1.2 255.255.255.0 et avec la passerelle par défaut de 10.1.1.3.

    Vous pouvez émettre ces commandes afin de modifier la passerelle principale à 10.1.1.3 :

    Switch-A> (enable) show ip route
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled 
    
    The primary gateway: 172.16.80.1
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default          10.1.1.3         0x0          G       0           me1
    default          172.16.84.1      0x0          UG      11          sc0
    172.16.80.0      172.16.84.17     0xffffff00   U       38          sc0
    10.1.1.0         10.1.1.2         0xffffff00   U       4           me1
    
    !--- Notice that 172.16.84.1 is the primary default gateway.
    
    Switch-A> (enable) 
    
    !--- Change the primary default gateway to 10.1.1.3.
    
    Switch-A> (enable) set ip route default 10.1.1.3 primary
    Primary route changed
    Switch-A> (enable)
    
    !--- This message displays when the primary gateway is changed:
    
    %SYS-5-RTE_DEFGATEFROM:Default Gateway switching from 172.16.80.1
    %SYS-5-RTE_DEFGATETO:Default Gateway switching to 10.1.1.3
    
    !--- Verify the change.
    
    Switch-A> (enable) show ip route
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled 
    
    The primary gateway: 10.1.1.3
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default          10.1.1.3         0x0          UG      0         me1
    default          172.16.84.1      0x0          G       11        sc0
    172.16.80.0      172.16.84.17     0xffffff00   U       38        sc0
    10.1.1.0         10.1.1.2         0xffffff00   U       4         me1
    
    !--- Notice that now the primary default gateway is 10.1.1.3.
    
    
  7. Si vous avez besoin d'effacer les routes de la table de routage, émettez la commande clear ip route all .

    Remarque: Si vous êtes connecté au commutateur à travers Telnet depuis un sous-réseau différent, vous perdez la connexion quand vous effacez les routes. Vous ne pouvez pas atteindre le commutateur de nouveau jusqu'à ce que quelqu'un ressaisisse l'adresse de la passerelle à travers une console raccordée ou un PC/terminal sur le même sous-réseau que le commutateur.

    Switch-A> (enable) clear ip route all
    All routes deleted.
    Switch-A> (enable)

    Vous pouvez effacer une route simple si vous spécifiez seulement cette route. Émettez la commande clear ip route 0.0.0.0 10.1.1.3.

Configurez une interface de gestion pour les commutateurs de la gamme Catalyst 4500/4000 qui exécutent le logiciel Cisco IOS

Sur un Supervisor Engine III/IV du Catalyst 4500/4000 qui exécute le logiciel Cisco IOS, toute interface routable peut être utilisée pour la gestion. Il y a trois options pour configurer cette interface.

Remarque: Le port de gestion Ethernet (étiqueté 10/100 MGT) sur Supervisor Engine III (WS-X4014) ou Supervisor Engine IV (WS-X4515) est utilisé en mode ROMmon pour récupérer seulement une image logicielle du commutateur qui est manquante ou altérée. Ce port n'est pas actif pendant le fonctionnement normal d'un commutateur et ne peut pas être utilisé comme interface de gestion.

Option 1 - Configurez une interface de bouclage pour la gestion des commutateurs. L'interface de bouclage présente quelques avantages. Un bouclage est une interface virtuelle qui est toujours active. Des paquets qui sont conduits vers l'interface de bouclage sont routés de nouveau vers le commutateur L3 ou le routeur et sont traités localement. Des paquets IP qui sont conduits en dehors de l'interface de bouclage mais ne sont pas destinés à l'interface de bouclage sont déposés. Ceci signifie que l'interface de bouclage sert en tant qu'interface nulle 0 également. L'interface de bouclage sert d'ID du routeur à l'Open Shortest Path First (OSPF) et ainsi de suite. Cet exemple utilise le bouclage 0 :

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface loopback 0
Switch(config-if)#ip address 10.1.1.1 255.255.255.255

!--- The loopback interface should have a 32-bit subnet mask, which means that
!--- the 10.1.1.1 address is the only destination address in this subnet.

Switch(config-if)#end
Switch#

Vous devez également configurer un protocole de routage pour distribuer le sous-réseau qui est affecté à l'adresse de bouclage ou pour créer une route statique.

Option 2 - Configurez l'interface en tant qu'interface L3 routée avec une adresse IP. Toutes les interfaces sur un commutateur Catalyst 4500/4000 qui exécute le logiciel Cisco IOS sont L2 par défaut. Par conséquent, vous devez faire de n'importe quelle interface connectée au reste du réseau une interface routée L3. Émettez la commande no switchport et configurez l'adresse IP désirée. L'exemple fournit une illustration. Toutes les interfaces sont activées par défaut, ainsi vous n'avez pas besoin d'émettre la commande no shutdown. Cet exemple utilise Fast Ethernet 5/30 :

Switch(config)#interface fastethernet 5/30 
Switch(config-if)#no switchport
Switch(config-if)#ip address 11.1.1.1 255.0.0.0

Si vous émettez la commande show running-config interface fastethernet 5/30 , ce résultat affiche :

Building configuration... 
Current configuration : 80 bytes 
! 
interface FastEthernet5/30
no switchport
ip address 11.1.1.1 255.0.0.0
end

Option 3 - Configurez une interface L2 comme partie d'un VLAN spécifique. Émettez la commande switchport mode access et la commande switchport access vlan vlan-id et utilisez l'interface virtuelle commutée correspondante (interface SVI) avec une adresse IP.

Remarque: Vous devez comprendre la différence entre la gestion VLAN qui est utilisée pour gérer le commutateur et les données VLAN qui sont utilisés pour passer le trafic L2. La gestion VLAN est une SVI que vous créez avec l'utilisation de la commande globale interface vlan vlan-id. Ne confondez pas cette commande avec les commandes que vous utilisez pour créer des données VLAN pour passer le trafic L2. Sur les commutateurs de la gamme Catalyst 6500/6000 qui exécutent le logiciel Cisco IOS, vous pouvez configurer des données VLAN de la base de données VLAN ou vous pouvez émettre la commande globale vlan vlan-id.

Procédez comme suit :

  1. Émettez les commandes suivantes :

    Switch(config)#interface vlan 1 
    Switch(config-if)#ip address 10.1.1.1 255.0.0.0 
    Switch(config-if)#no shut
    

    Remarque: Cet exemple utilise le VLAN 1 comme VLAN de gestion. VLAN 1 est dans la base de données VLAN par défaut.

  2. Émettez la commande switchport mode access sous l'interface physique désirée si vous voulez la confirmation que l'interface est un port de commutation d'accès.

    Par défaut, toutes les interfaces sont les interfaces L2 et sont des ports de commutation d'accès dans VLAN 1. Si vous prévoyez d'utiliser VLAN 1 comme VLAN de gestion, aucune configuration n'est nécessaire sous l'interface. Mais si vous voulez la confirmation dans la configuration que l'interface est en effet un port de commutation d'accès, vous devez utiliser la commande switchport mode access.

    Cet exemple utilise Fast Ethernet 5/32 :

    Switch(config)#interface fastethernet 5/32
    Switch(config-if)#switchport mode access
    

    Si vous émettez la commande show run interface fastethernet 5/32, ce résultat affiche maintenant :

    Switch#show run interface fastethernet 5/32
    Building configuration...
    
    Current configuration : 84 bytes
    !
    interface FastEthernet5/32
    switchport mode access
    no snmp trap link-status
    end
  3. Si vous voulez modifier l'interface de gestion du VLAN 1 par défaut pour un autre VLAN, émettez la commande interface vlan vlan-id afin de créer une nouvelle SVI.

    Vous devez alors émettre la commande switchport access vlan vlan-id afin de configurer une interface L2 telle qu'une partie du nouveau VLAN. Cet exemple explique ce processus :

    Switch(config)#interface vlan 2
    Switch(config-if)#ip address 20.1.1.1 255.0.0.0
    Switch(config-if)#no shut
    
    !--- Configure an interface to access the new management VLAN.
    
    Switch(config)#interface fastethernet 5/32 
    Switch(config-if)#switchport mode access
    Switch(config-if)#switch access vlan 2
    

    Si vous émettez la commande show run interface fastethernet 5/32, ce résultat affiche maintenant :

    Building configuration... 
    Current configuration : 110 bytes
    !
    interface FastEthernet5/32 
     switchport access vlan 2 
     switchport mode access
    end

    Afin que le commutateur accède à des réseaux distants, vous devez avoir soit :

    • Une passerelle par défaut qui est définie pour le routeur du prochain saut qui est directement connectée au commutateur

    • Un protocole de routage dynamique configuré

    Si vous ne routez pas IP, émettez la commande ip default-gateway ip-address afin de configurer une adresse IP de routeur de passerelle. Afin de configurer le routage dynamique, utilisez la commande routing_protocol du routeur. Émettez la commande show ip route afin d'afficher l'état de la table de routage.

Configurez une interface de gestion pour un commutateur Catalyst 6500/6000 qui exécute le logiciel Cisco IOS

Sur un commutateur de la gamme Catalyst 6500/6000 qui exécute le logiciel Cisco IOS, n'importe quelle interface routable peut être utilisée pour la gestion. Il y a trois options pour configurer cette interface.

Option 1 - Configurez une interface de bouclage pour la gestion des commutateurs. L'interface de bouclage présente quelques avantages. Un bouclage est une interface virtuelle qui est toujours active. Des paquets qui sont conduits vers l'interface de bouclage sont routés de nouveau vers le commutateur L3 ou le routeur et sont traités localement. Des paquets IP qui sont conduits en dehors de l'interface de bouclage mais ne sont pas destinés à l'interface de bouclage sont déposés. Ceci signifie que l'interface de bouclage sert en tant qu'interface nulle 0 également. L'interface de bouclage sert d'ID du routeur pour OSPF et ainsi de suite. Cet exemple utilise le bouclage 0 :

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface loopback 0
Switch(config-if)#ip address 10.1.1.1 255.255.255.255

!--- The loopback interface should have a 32-bit subnet mask, which means that
!--- the 10.1.1.1 address is the only destination address in this subnet.

Switch(config-if)#end
Switch#

Vous devez également configurer un protocole de routage pour distribuer le sous-réseau qui est affecté à l'adresse de bouclage ou pour créer une route statique.

Option 2 - Configurez l'interface en tant qu'interface L3 routée avec une adresse IP. Toutes les interfaces sur un commutateur de Catalyst 6500/6000 qui exécute le logiciel Cisco IOS sont L3 par défaut. Toutes les interfaces sont activées par défaut, ainsi vous n'avez pas besoin d'émettre la commande no shutdown. Cet exemple utilise Fast Ethernet 5/30 :

Switch(config)#interface fastethernet 5/30 
Switch(config-if)#ip address 11.1.1.1 255.0.0.0

Si vous émettez la commande show running-config interface fastethernet 5/30 , ce résultat affiche :

Building configuration... 
Current configuration : 80 bytes 
! 
interface FastEthernet5/30
no switchport
ip address 11.1.1.1 255.0.0.0 
end

Option 3 - Configurez une interface L2 comme partie d'un VLAN spécifique. Émettez la commande switchport mode access et la commande switchport access vlan , et utilisez une interface SVI correspondante avec une adresse IP.

Remarque: Vous devez comprendre la différence entre la gestion VLAN qui est utilisée pour gérer le commutateur et les données VLAN qui sont utilisés pour passer le trafic L2. La gestion VLAN est une SVI que vous créez avec l'utilisation de la commande globale interface vlan vlan-id. Ne confondez pas cette commande avec les commandes que vous utilisez pour créer des données VLAN pour passer le trafic L2. Sur les commutateurs de la gamme Catalyst 6500/6000 qui exécutent le logiciel Cisco IOS, vous pouvez configurer des données VLAN de la base de données VLAN ou vous pouvez émettre la commande globale vlan vlan-id.

Procédez comme suit :

  1. Émettez les commandes suivantes :

    Switch(config)#interface vlan 1
    
    !--- Interface VLAN 1 is an SVI.
    
    Switch(config-if)#ip address 10.1.1.1 255.0.0.0 
    Switch(config-if)#no shut
    

    Remarque: Cet exemple utilise le VLAN 1 comme VLAN de gestion. VLAN 1 est dans la base de données VLAN par défaut.

  2. Émettez la commande switchport mode access sous l'interface physique désirée afin de faire de l'interface un L2 dans le VLAN 1 par défaut.

    Remarque: Par défaut, toutes les interfaces sont des interfaces L3.

    Cet exemple utilise Fast Ethernet 5/32 :

    Switch(config)#interface fastethernet 5/32
    Switch(config-if)#switchport mode access
    

    Si vous émettez la commande show run interface fastethernet 5/32, ce résultat affiche maintenant :

    Switch#show run interface fastethernet 5/32
    Building configuration...
    Current configuration : 84 bytes
    !
    interface FastEthernet5/32
     switchport mode access
     no snmp trap link-status
    end
  3. Si vous voulez modifier l'interface de gestion du VLAN 1 par défaut pour un autre VLAN, émettez la commande interface vlan vlan-id afin de créer une nouvelle SVI.

    Vous devez alors émettre la commande switchport access vlan vlan-id afin de configurer une interface L2 telle qu'une partie du nouveau VLAN. Cet exemple explique ce processus :

    Switch(config)#interface vlan 2
    Switch(config-if)#ip address 20.1.1.1 255.0.0.0
    Switch(config-if)#no shut
    
    !--- Configure an interface to access the new management VLAN.
    
    Switch(config)#interface fastethernet 5/32 
    Switch(config-if)#switchport mode access
    Switch(config-if)#switch access vlan 2
    

    Si vous émettez la commande show run interface fastethernet 5/32, ce résultat affiche maintenant :

    Building configuration... 
    Current configuration : 110 bytes
    !
    interface FastEthernet5/32 
     switchport access vlan 2 
     switchport mode access
    end

    Afin que le commutateur accède à des réseaux distants, vous devez avoir soit :

    • Une passerelle par défaut qui est définie pour le routeur du prochain saut qui est directement connectée au commutateur

    • Un protocole de routage dynamique configuré

    Si vous ne routez pas IP, émettez la commande ip default-gateway ip-address afin de configurer une adresse IP de routeur de passerelle. Afin de configurer le routage dynamique, utilisez la commande routing_protocol du routeur. Émettez la commande show ip route afin d'afficher l'état de la table de routage.

Configurez une interface de gestion pour des commutateurs de configuration fixe de Catalyst L2

Les commutateurs de configuration fixe de Catalyst L2 exécutent le logiciel Cisco IOS, mais ont des commutateurs avec une capacité L2 seulement. Ces commutateurs peuvent avoir seulement une interface de gestion active à la fois. L'interface de gestion par défaut est VLAN 1. Vous ne pouvez pas supprimer le VLAN 1 sur ces commutateurs. Cependant, vous pouvez créer une autre interface VLAN pour la gestion, que les exemples dans cette section expliquent.

Remarque: Vous devez comprendre la différence entre la gestion VLAN qui est utilisée pour gérer le commutateur et les données VLAN qui sont utilisées pour passer le trafic L2. La gestion VLAN est une SVI que vous créez avec l'utilisation de la commande globale interface vlan vlan-id. Ne confondez pas cette commande avec les commandes que vous utilisez pour créer des données VLAN pour passer le trafic L2. Sur des commutateurs de la gamme XL, vous pouvez seulement créer des VLAN de données avec l'utilisation de la commande vlan database. Dans les versions 12.1(9)EA1 du logiciel Cisco IOS et ultérieures pour le 2950 (et dans toutes les versions du logiciel pour les 2940, 2955 et 2970), il existe une option supplémentaire pour la configuration des données VLAN . Cette option supplémentaire est la commande globale vlan vlan-id.

Ces exemples utilisent Fast Ethernet 0/1 comme port de commutation d'accès et en tant que membre du VLAN de gestion. Aucune configuration n'est nécessaire afin de faire d'une interface un membre du VLAN 1 parce que toutes les interfaces ont des ports de commutation d'accès dans VLAN 1 par défaut.

Voici le premier exemple :

Switch(config)#interface vlan 1
Switch(config-if)#ip address 10.1.1.1 255.0.0.0
Switch(config-if)#end
Switch#

Switch#show run interface vlan 1 
Building configuration...
Current configuration: 
! 
interface VLAN1 
 ip address 10.1.1.1 255.0.0.0 
 no ip directed-broadcast 
 no ip route-cache 
end

Switch#show run interface fastethernet 0/1
Building configuration...
 
Current configuration:
!
interface FastEthernet0/1

!--- All interfaces are access switch ports in VLAN 1 by default.

end
 
Switch#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
VLAN1                      10.1.1.1        YES manual up                    up  
    
FastEthernet0/1            unassigned      YES unset  up                    up

Souvenez-vous que vous ne pouvez pas supprimer l'interface de gestion VLAN 1. Si vous voulez modifier l'interface de gestion du VLAN 1 par défaut pour un autre VLAN, émettez la commande interface vlan vlan-id afin de créer une nouvelle SVI. Vous devez alors émettre la commande switchport access vlan vlan-id afin de configurer une interface L2 telle qu'une partie du nouveau VLAN. Cet exemple explique ce processus :

Remarque: L'interface de gestion peut être dans l'état arrêté après un rechargement si l'interface de gestion n'est pas un membre de VLAN 1 et si vous avez configuré l'une de ces commandes sur le commutateur :

  • ip ftp source-interface vlan vlan-id

  • ip tftp source-interface vlan vlan-id

  • ip telnet source-interface vlan vlan-id

    Faites de l'interface de gestion un membre de VLAN 1. Alternativement, supprimez ces commandes de la configuration ou mettez à niveau le logiciel du commutateur à la dernière image afin de résoudre ce problème.

Remarque: Sur des commutateurs de la gamme XL, vous pouvez utiliser la commande de gestion facultative sous la nouvelle SVI afin d'arrêter automatiquement le VLAN 1 et transférer l'adresse IP vers le nouveau VLAN.

Switch(config)#interface vlan 2
Switch(config-if)#ip address 20.1.1.1 255.0.0.0
Switch(config-if)#no shut

!--- Configure an interface to access the new management VLAN.

Switch(config)#interface fastethernet 0/1
Switch(config-if)#switchport access vlan 2
Switch(config-if)#end

Switch#

Si vous émettez la commande show run interface fastethernet 0/1, ce résultat affiche maintenant :

Switch#show run interface fastethernet 0/1
Building configuration...
Current configuration : 85 bytes
!
interface FastEthernet 0/1
 switchport access vlan 2
 switchport mode access
end
Switch#

Pour que le commutateur accède à des réseaux distants, vous devez avoir une passerelle par défaut qui est configurée pour le routeur du prochain saut directement connecté au commutateur. Émettez la commande ip default-gateway ip-address afin de configurer une adresse IP de routeur de passerelle.

Configurez une interface de gestion pour des commutateurs de la gamme 3550 et 3750

Sur un commutateur de la gamme Catalyst 3550/3750 qui exécute le logiciel Cisco IOS, n'importe quelle interface routable peut être utilisée pour la gestion. Il y a trois options pour configurer cette interface.

Option 1 - Configurez une interface de bouclage pour la gestion des commutateurs. L'interface de bouclage présente quelques avantages. Un bouclage est une interface virtuelle qui est toujours active. Des paquets qui sont conduits vers l'interface de bouclage sont routés de nouveau vers le commutateur L3 ou le routeur et sont traités localement. Des paquets IP qui sont conduits en dehors de l'interface de bouclage mais ne sont pas destinés à l'interface de bouclage sont déposés. Ceci signifie que l'interface de bouclage sert en tant qu'interface nulle 0 également. L'interface de bouclage sert d'ID du routeur pour OSPF et ainsi de suite. Cet exemple utilise le bouclage 0 :

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface loopback 0
Switch(config-if)#ip address 10.1.1.1 255.255.255.255

!--- The loopback interface should have a 32-bit subnet mask, which means that
!--- the 10.1.1.1 address is the only destination address in this subnet.

Switch(config-if)#end
Switch#

Vous devez également configurer un protocole de routage pour distribuer le sous-réseau qui est affecté à l'adresse de bouclage ou pour créer une route statique.

Option 2 - Configurez l'interface en tant qu'interface L3 routée avec une adresse IP. Toutes les interfaces sur un commutateur de Catalyst 3550 ou 3750 qui exécute le logiciel Cisco IOS sont L2 par défaut. Afin de faire d'une interface L2 une interface L3, émettez la commande no switchport , puis configurez une adresse IP. Toutes les interfaces sont activées par défaut, ainsi vous n'avez pas besoin d'émettre la commande no shutdown. Cet exemple utilise Fast Ethernet 2/0/1 sur un Catalyst 3750 :

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface fastethernet 2/0/1
Switch(config-if)#no switchport
Switch(config-if)#ip address 11.1.1.1 255.0.0.0
Switch(config-if)#end
Switch#

Si vous émettez la commande show running-config interface fastethernet 2/0/1 , ce résultat affiche :

Switch#show running-config interface fastethernet 2/0/1
Building configuration...
Current configuration : 81 bytes
!
interface FastEthernet2/0/1
 no switchport
 ip address 11.1.1.1 255.0.0.0
end
Switch#

Option 3 - Configurez une interface L2 comme partie d'un VLAN spécifique. Émettez la commande switchport mode access et la commande switchport access vlan , et utilisez une interface SVI correspondante avec une adresse IP.

Procédez comme suit :

  1. Émettez les commandes suivantes :

    Switch(config)#interface vlan 1
    
    !--- Interface VLAN 1 is an SVI.
    
    Switch(config-if)#ip address 10.1.1.1 255.0.0.0 
    Switch(config-if)#no shut
    

    Remarque: Cet exemple utilise le VLAN 1 comme VLAN de gestion. VLAN 1 est dans la base de données VLAN par défaut.

  2. Émettez la commande switchport mode access sous l'interface physique désirée si vous voulez la confirmation que l'interface est un port de commutation d'accès.

    Par défaut, toutes les interfaces sont les interfaces L2 et sont des ports de commutation d'accès dans VLAN 1. Si vous prévoyez d'utiliser VLAN 1 comme VLAN de gestion, aucune configuration n'est nécessaire sous l'interface. Mais si vous voulez la confirmation dans la configuration que l'interface est en effet un port de commutation d'accès, vous devez utiliser la commande switchport mode access.

    Cet exemple utilise Fast Ethernet 2/0/1 :

    Switch(config)#interface fastethernet 2/0/1
    Switch(config-if)#switchport mode access
    Switch(config-if)#end
    

    Si vous émettez la commande show run interface fastethernet 2/0/1, ce résultat affiche maintenant :

    Switch#show run interface fastethernet 2/0/1
    Building configuration...
    Current configuration : 59 bytes
    !
    interface FastEthernet2/0/1
     switchport mode access
    end
    Switch#
  3. Si vous voulez modifier l'interface de gestion du VLAN 1 par défaut pour un autre VLAN, émettez la commande interface vlan vlan-id afin de créer une nouvelle SVI.

    Vous devez alors émettre la commande switchport access vlan vlan-id afin de configurer une interface L2 telle qu'une partie du nouveau VLAN. Cet exemple explique ce processus :

    Switch(config)#interface vlan 2
    Switch(config-if)#ip address 20.1.1.1 255.0.0.0
    Switch(config-if)#no shut
    
    !--- Configure an interface to access the new management VLAN.
    
    Switch(config)#interface fastethernet 2/0/1
    Switch(config-if)#switchport access vlan 2
    Switch(config-if)#end
    Switch#

    Si vous émettez la commande show run interface fastethernet 2/0/1, ce résultat affiche maintenant :

    Switch#show run interface fastethernet 2/0/1
    Building configuration...
    Current configuration : 85 bytes
    !
    interface FastEthernet2/0/1
     switchport access vlan 2
     switchport mode access
    end
    Switch#

    Afin que le commutateur accède à des réseaux distants, vous devez avoir soit :

    • Une passerelle par défaut qui est définie pour le routeur du prochain saut qui est directement connectée au commutateur

    • Un protocole de routage dynamique configuré

    Si vous ne routez pas IP, émettez la commande ip default-gateway ip-address afin de configurer une adresse IP de routeur de passerelle.

    Si vous prévoyez de configurer le routage dynamique, gardez présent à l'esprit que le routage IP est désactivé par défaut. Vous devez émettre la commande globale ip routing afin d'activer le routage IP. Le Protocole d'informations de routage (RIP) est le seul protocole de routage dynamique qui est pris en charge quand vous utilisez l'image logicielle multicouche standard (SMI). L'image logicielle multicouche améliorée (EMI) est requise pour la prise en charge d'Interior Gateway Routing Protocol (IGRP), Enhanced IGRP (EIGRP), OSPF et Border Gateway Protocol (BGP). Afin de configurer le routage dynamique, utilisez la commande routing_protocol du routeur. Émettez la commande show ip route afin d'afficher l'état de la table de routage.


Informations connexes


Document ID: 10594